Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Linux version of Anomaly Wazone Earth
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message

Joined: 11 Apr 2004
Posts: 58

PostPosted: Thu Sep 06, 2012 8:58 pm    Post subject: Linux version of Anomaly Wazone Earth Reply with quote

Has anyone got this game to work on Gentoo with ATI drivers? I get the start screen / movie, and then about when I get to the main menu screen, the screen goes black and totally locks the system.

I posted to the Anomaly site but no answers there either:

This is a native Linux port, so I would expect it to work, but with the complete system lock, I am having a hard time finding the error. Other games work fine on my machine.

Reprint from the Anomaly Warzone post:

System freeze after intro movie, yet sound still plays

On Anomaly start up, after the initial intro movie, I get the loading graphic in the bottom right of the screen. Shortly after that, the white cursor comes up on a black screen, and then shortly after that, the cursor will freeze, followed by a hard system freeze. Keyboard stops functioning, mouse stops functioning, and the whole system locks requiring one hold down the power button to power off. What is strange is the music plays in the background without issue even though the system is hard locked.

System is Gentoo with a KDE desktop.

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6500M/5600/5700 Series
OpenGL version string: 4.2.11733 Compatibility Profile Context

uname -r

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4

libva: VA-API version 0.32.0
Xlib:  extension "XFree86-DRI" missing on display ":0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib64/va/drivers/
libva: va_openDriver() returns 0
vainfo: VA-API version: 0.32 (libva 1.0.15)
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.8.0
vainfo: Supported profile and entrypoints
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

Any help would be appreciated. This is the only game I have that will not run on Linux. All others work fine.

I should also mention I tried running this in a window and it still hard locks the system.

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum