Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-qt/qtgui
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1234
Location: /mnt/Gentoo/Europe

PostPosted: Fri Sep 04, 2015 4:11 pm    Post subject: dev-qt/qtgui Reply with quote

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.4.2-r1:5/5::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-qt/qtgui-5.4.2:5[gles2] required by (dev-qt/qtdeclarative-5.4.2-r1:5/5::gentoo, installed)
                           ^^^^^
    ~dev-qt/qtgui-5.4.2[gles2,-gtkstyle,png,xcb] required by (dev-qt/qtwidgets-5.4.2:5/5::gentoo, installed)
                        ^^^^^                   
    ~dev-qt/qtgui-5.4.2[gles2] required by (dev-qt/qtopengl-5.4.2:5/5::gentoo, installed)
                        ^^^^^
    ~dev-qt/qtgui-5.4.2[gles2] required by (dev-qt/qtprintsupport-5.4.2:5/5::gentoo, installed)
                        ^^^^^


In /etc/portage/package.use I have:
Code:
>=dev-qt/qtgui-5.4.2-r1 -gles2


Code:
# equery u qtgui
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for dev-qt/qtgui-5.4.2-r1:
 U I
 - - accessibility : Add support for accessibility (eg 'at-spi' library)
 + + dbus          : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
 - - debug         : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
                     https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 - - egl           : Use EGL instead of default GLX to manage OpenGL contexts
 - - eglfs         : Compile EGL Full Screen/Single Surface support
 - - evdev         : Enable evdev input support
 + + gif           : Add GIF image support
 - + gles2         : Use GLES 2.0 or later instead of full OpenGL
 - - gtkstyle      : Build a Qt style called GTK+ that mimics the active GTK+ theme
 + + harfbuzz      : Use media-libs/harfbuzz for text shaping
 - - ibus          : Build the IBus input method plugin
 + + jpeg          : Add JPEG image support
 + + png           : Add support for libpng (PNG images)
 - - test          : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in
                     make.conf/package.use anymore
 + + udev          : Enable virtual/udev integration (device discovery, power and storage device support, etc)
 + + xcb           : Support the X C-language Binding, a replacement for Xlib
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6189

PostPosted: Sat Sep 05, 2015 4:50 am    Post subject: Reply with quote

The portage output is a bit confusing, but the most likely reason would be that 'gles2 has to be equal on qtgui and qtopengl (and likely the others too).
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1234
Location: /mnt/Gentoo/Europe

PostPosted: Sun Sep 06, 2015 10:46 am    Post subject: Reply with quote

VoidMage wrote:
The portage output is a bit confusing, but the most likely reason would be that 'gles2 has to be equal on qtgui and qtopengl (and likely the others too).


I think this remain of my probe to install kdenlive 15.08:
https://bugs.gentoo.org/show_bug.cgi?id=558356
Quote:
kde-apps/kdenlive-15.08.0 with dev-qt/qtgui[gles2] fails to emerge
Back to top
View user's profile Send private message
duryodhana
n00b
n00b


Joined: 13 Jan 2008
Posts: 66

PostPosted: Sat Sep 19, 2015 8:27 pm    Post subject: Reply with quote

Try to emerge kde-frameworks/plasma with -opengl use flag. That worked for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum