Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no ebuilds to satisfy ">=sys-apps/dbus-1.9.8[systemd]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Sun May 21, 2017 9:32 pm    Post subject: no ebuilds to satisfy ">=sys-apps/dbus-1.9.8[systemd Reply with quote

I'm installing GNOME 3.14 using GNOME/GNOME Without systemd guide and ran into this issue:

After installing layman I ran
Code:

layman  --sync-all
layman -a dantrell-gnome
layman -a dantrell-gnome-3-14
emaint sync -a
eselect profile set "dantrell-gnome:default/amd64/3.14/extended"
emerge --deep --with-bdeps=y --changed-use --update --ask --verbose @world
rc-update add dbus default
rc-update add consolekit default
rc
emerge --ask --verbose --keep-going gnome-base/gnome


I got:
Code:
All ebuilds that could satisfy ">=sys-apps/dbus-1.9.8[systemd]" have been masked.

One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.10.16-r1::gentoo (masked by: ~amd64 keyword)


to /etc/portage/package.accept_keywords, I added:
Code:
=sys-apps/dbus-1.10.16-r1 ~amd64


again ran:
Code:
emerge --ask --verbose --keep-going gnome-base/gnome


then I got:
Code:
emerge: there are no ebuilds to satisfy ">=sys-apps/dbus-1.9.8[systemd]


Before I installed layman my profile was:
Code:
default/linux/amd64/13/0/desktop/gnome


At this point I'm not sure why it's looking for a systemd ebuild. Any guidance is greatly appreciated; you'll have to let me know what further information to provide so I can resolve this issue. Thank You
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Sun May 21, 2017 10:51 pm    Post subject: Reply with quote

This was the output of emerge --deep --with-bdeps=y --changed-use --update --ask --verbose @world :

Code:
#

These are the packages that would be merged, in order:

Calculating dependencies 
 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

. ......... ..... done!
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0::dantrell-gnome-3-14 [1.50.0::gentoo] 1,278 KiB
[ebuild     U  ] dev-libs/vala-common-0.36.3::dantrell-gnome [0.34.8::gentoo] 2,774 KiB
[ebuild  N     ] dev-libs/libunistring-0.9.7:0/2::dantrell-gnome  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 3,506 KiB
[ebuild   R    ] dev-libs/npth-1.3::dantrell-gnome [1.3::gentoo] USE="-static-libs" 0 KiB
[ebuild   R    ] dev-libs/openssl-1.0.2k::gentoo  USE="asm sslv3 tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5,185 KiB
[ebuild     U *] x11-base/xorg-drivers-9999::gentoo [1.18-r1::gentoo] INPUT_DEVICES="keyboard libinput mouse -acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="amdgpu dummy fbdev intel nouveau radeon radeonsi vesa -ast -epson (-fglrx) (-freedreno) (-geode) -glint -i915% -i965% -mga -nv -nvidia (-omap) -qxl -r128 -siliconmotion -tdfx (-tegra) -via -virtualbox -vmware (-voodoo) (-apm%) (-chips%) (-cirrus%) (-i128%) (-i740%) (-mach64%) (-neomagic%) (-rendition%) (-s3%) (-s3virge%) (-savage%) (-sisusb%) (-sunbw2%) (-suncg14%) (-suncg3%) (-suncg6%) (-sunffb%) (-sunleo%) (-suntcx%) (-tga%) (-trident%) (-tseng%)" 0 KiB
[ebuild     U  ] app-admin/eselect-1.4.9::dantrell-gnome [1.4.8::gentoo] USE="-doc -emacs (-multischema) -vim-syntax" 173 KiB
[ebuild   R    ] app-eselect/eselect-pinentry-0.7::dantrell-gnome [0.7::gentoo] 0 KiB
[ebuild   R    ] dev-lang/python-3.4.5:3.4/3.4m::gentoo  USE="gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened (-libressl) -sqlite* -tk -wininst" 0 KiB
[ebuild   R    ] dev-lang/python-2.7.12:2.7::gentoo  USE="gdbm ipv6 ncurses readline ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened (-libressl) -sqlite* -tk -wininst" 0 KiB
[ebuild   R    ] media-libs/freetype-2.8:2::gentoo  USE="X adobe-cff bzip2 cleartype_hinting png -bindist* -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0::gentoo  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 595 KiB
[ebuild  N     ] x11-libs/libXinerama-1.1.3::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 272 KiB
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1::dantrell-gnome [1.25-r1::gentoo] 658 KiB
[ebuild   R    ] dev-libs/boehm-gc-7.4.2::gentoo  USE="cxx threads* -static-libs" 0 KiB
[ebuild  N     ] x11-libs/libXfont2-2.0.1::gentoo  USE="bzip2 ipv6 truetype -doc -static-libs" 462 KiB
[ebuild   R    ] www-client/w3m-0.5.3-r9::gentoo  USE="X gpm nls ssl unicode -fbcon -gtk* -imlib (-libressl) -lynxkeymap -nntp -xface" L10N="-ja" 0 KiB
[ebuild   R    ] sys-devel/gettext-0.19.8.1::dantrell-gnome [0.19.8.1::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)" 19,243 KiB
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1::dantrell-gnome [1.27-r1::gentoo] USE="nls -common-lisp -static-libs" ABI_X86="(64) -32 (-x32)" 795 KiB
[ebuild   R    ] dev-libs/libgcrypt-1.7.6:0/20::dantrell-gnome [1.7.6:0/20::gentoo] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 2,830 KiB
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1::dantrell-gnome [2.4.3-r1::gentoo] USE="-static-libs" 0 KiB
[ebuild  N     ] net-dns/libidn2-0.16-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1,460 KiB
[ebuild     U  ] net-libs/gnutls-3.5.12:0/30::gentoo [3.3.26:0/0::gentoo] USE="cxx idn%* nls openssl seccomp%* sslv3%* tls-heartbeat%* zlib -dane -doc -examples -guile -openpgp% -pkcs11 -sslv2% -static-libs {-test} (-test-full) -tools% -valgrind% (-crywrap%*)" ABI_X86="(64) -32 (-x32)" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN" 7,044 KiB
[ebuild  N     ] sys-libs/libomp-3.9.1:0/3.9::gentoo  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)" 1,984 KiB
[ebuild  N     ] sys-devel/clang-runtime-3.9.1::gentoo  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] sys-devel/llvm-3.9.1-r1:0/3.9.1::gentoo  USE="clang* libffi ncurses sanitize static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc -gold -libedit (-lldb) -multitarget -ocaml -python {-test}" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 11,911 KiB
[ebuild  N     ] sys-devel/clang-3.9.1-r100:0/3.9.1::gentoo  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB
[ebuild   R    ] media-libs/mesa-13.0.5::gentoo  USE="classic dri3 egl gallium gbm gles2 llvm nettle nptl -bindist* -d3d9 -debug -gcrypt -gles1 (-libressl) -opencl -openmax -openssl -osmesa -pax_kernel -pic (-selinux) -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 -r100 -r200 -r300 -r600 (-vc4) -vmware" 0 KiB
[ebuild  N     ] virtual/opengl-7.0-r1::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2::dantrell-gnome [2.50.3::gentoo] PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_6)" 6,839 KiB
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0:5/5.29::gentoo  USE="-doc {-test}" 296 KiB
[ebuild  N     ] media-libs/glfw-3.2.1::gentoo  USE="-examples -wayland" 640 KiB
[ebuild     U  ] x11-base/xorg-server-1.19.2:0/1.19.2::gentoo [1.18.4:0/1.18.4::gentoo] USE="glamor ipv6 suid udev xorg -debug% -dmx -doc -kdrive* (-libressl) -minimal (-selinux) -static-libs (-systemd) -tslib -unwind -wayland -xephyr -xnest -xvfb" 5,830 KiB
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.2::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216::gentoo  USE="dri sna udev -debug -dri3 -tools -uxa -xvmc" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.9.0::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0::gentoo  USE="glamor" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.8.0::gentoo  USE="glamor udev" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-nouveau-1.0.13::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-dummy-0.3.8::gentoo  USE="-dga" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-vesa-2.3.4::gentoo  0 KiB
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome [2.50.3-r1:2/2::gentoo] USE="dbus (mime) xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[blocks b      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
[ebuild  N     ] gnome-base/dconf-0.22.0::dantrell-gnome  USE="X {-test}" 385 KiB
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1::dantrell-gnome-3-14 [1.50.0::gentoo] USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="(-python2_7%) (-python3_4%*) (-python3_5%)" PYTHON_TARGETS="python2_7 (-python3_4%*) (-python3_5%)" 0 KiB
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1:0.6::dantrell-gnome [0.6.12-r1:0.6::gentoo] USE="{-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-libs/dbus-glib-0.102::gentoo  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 766 KiB
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4:2::dantrell-gnome [2.36.6:2::gentoo] USE="X introspection jpeg tiff -debug -jpeg2k {-test}" ABI_X86="(64) -32 (-x32)" 5,038 KiB
[ebuild     UD ] dev-libs/atk-2.14.0::dantrell-gnome-3-14 [2.22.0::gentoo] USE="introspection nls {-test}" ABI_X86="(64) -32 (-x32)" 680 KiB
[ebuild   R    ] sys-fs/eudev-3.1.5::gentoo  USE="hwdb introspection* kmod -rule-generator (-selinux) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] app-text/poppler-0.54.0:0/67::dantrell-gnome [0.45.0:0/62::gentoo] USE="cairo cxx introspection jpeg jpeg2k lcms png tiff utils -cjk -curl -debug -doc -nss -qt4* -qt5 (-cairo-qt%)" 1,659 KiB
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1:2::dantrell-gnome-3-14 [2.22.1:2::gentoo] USE="X introspection" ABI_X86="(64) -32 (-x32)" 446 KiB
[ebuild     UD ] x11-libs/pango-1.36.8-r1::dantrell-gnome [1.40.5::gentoo] USE="X introspection {-test}" ABI_X86="(64) -32 (-x32)" 1,010 KiB
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1:2::dantrell-gnome-3-14 [2.22.0:2::gentoo] USE="{-test}" ABI_X86="(64) -32 (-x32)" 275 KiB
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15::dantrell-gnome-3-14 [3.22.2::gentoo] 304 KiB
[ebuild  N     ] app-text/mupdf-1.11-r1:0/1.11::gentoo  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla" 39,215 KiB
[ebuild   R    ] gnome-base/librsvg-2.40.17:2::dantrell-gnome [2.40.17:2::gentoo] USE="introspection -tools -vala" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] dev-libs/libgudev-230-r1::gentoo  USE="introspection -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2::dantrell-gnome-3-14 [3.22.0-r1::gentoo] USE="branding" 17,170 KiB
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.24.0::gentoo  0 KiB
[ebuild     UD ] dev-libs/libgusb-0.2.7::dantrell-gnome [0.2.9::gentoo] USE="introspection -static-libs -vala" ABI_X86="(64) -32 (-x32)" 270 KiB
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1::gentoo  USE="X cups dbus tiff -gtk* -idn -static-libs" L10N="-de -ja -ko -zh-CN -zh-TW" 0 KiB
[ebuild     U  ] net-print/cups-filters-1.12.0::dantrell-gnome [1.5.0::gentoo] USE="dbus foomatic jpeg ldap pdf%* png postscript%* tiff -perl -static-libs -zeroconf" 1,385 KiB
[ebuild   R    ] app-crypt/libsecret-0.18.5::dantrell-gnome [0.18.5::gentoo] USE="crypt introspection -debug {-test} -vala" 0 KiB
[ebuild     U  ] sys-auth/pambase-20150213-r1::dantrell-gnome [20150213::gentoo] USE="consolekit* cracklib gnome-keyring* nullok sha512 -debug -elogind% -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux) (-systemd)" 0 KiB
[ebuild   R    ] net-misc/openssh-7.3_p1-r7::gentoo  USE="X* hpn ldap* pam pie ssl -X509 -bindist* -debug -kerberos -ldns -libedit (-libressl) -livecd -sctp (-selinux) -skey -ssh1 -static {-test}" 0 KiB
[ebuild   R    ] sys-auth/polkit-0.113::gentoo  USE="introspection nls pam -examples -gtk* -jit -kde (-selinux) (-systemd) {-test}" 0 KiB
[ebuild     UD ] sys-auth/consolekit-0.4.6::dantrell-gnome [1.1.0-r1::gentoo] USE="acl pam policykit -debug -doc (-selinux) -systemd-units% {-test} (-cgroups%) (-pm-utils%)" 370 KiB
[ebuild     UD ] x11-misc/colord-1.2.12:0/2::dantrell-gnome [1.3.4:0/2::gentoo] USE="gusb introspection policykit udev -argyllcms -examples -extra-print-profiles -scanner (-systemd) -vala" ABI_X86="(64) -32 (-x32)" 1,187 KiB
[ebuild     UD ] x11-libs/gtk+-3.14.15:3/14::dantrell-gnome-3-14 [3.22.15:3/3::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -examples {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)" 15,524 KiB
[ebuild     UD ] app-crypt/gcr-3.14.0:0/1::dantrell-gnome-3-14 [3.20.0:0/1::gentoo] USE="gtk introspection -debug {-test} -vala*" 1,310 KiB
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1::dantrell-gnome [0.9.7-r1::gentoo] USE="gnome-keyring ncurses -caps -emacs -gtk* -qt4* -qt5 -static" 0 KiB
[ebuild     U  ] app-crypt/gnupg-2.1.21::dantrell-gnome [2.1.20-r1::gentoo] USE="bzip2 gnutls ldap nls readline smartcard usb -doc (-selinux) -tofu -tools -wks-server" 6,322 KiB
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0::dantrell-gnome-3-14 [3.20.0::gentoo] USE="caps filecaps pam ssh-agent (-selinux) {-test}" 1,145 KiB
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0::dantrell-gnome [3.12.0::gentoo] USE="introspection -debug {-test} -vala" 0 KiB
[ebuild     U  ] sys-apps/openrc-0.26.2::gentoo [0.24.2::gentoo] USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs" 0 KiB
[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-9999)

Total: 76 packages (10 upgrades, 17 downgrades, 14 new, 35 reinstalls), Size of downloads: 168,218 KiB
Conflict: 2 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.19:0/1.18.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed)
    ^                     ^^^^^^^^^^^^^^                                                                                         
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed) pulled in by
    ~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, installed)

  (x11-base/xorg-drivers-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.19 required by (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge)
    >=x11-base/xorg-drivers-1.18 required by (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)
  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-ati-7.8.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nouveau-1.0.13:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)
 
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1540

PostPosted: Mon May 22, 2017 12:57 am    Post subject: Reply with quote

First off, using -9999 packages are NOT recommended to use ever, unless you have a specific need for it (and you end up being that you pick up the pieces), as those packages are development packages, so can change quite frequently to where we will be unable to assist you.

Code:
[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-9999)

This is saying you need newer version than xf86-video-virtualbox-5.1.14...
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12247

PostPosted: Mon May 22, 2017 1:01 am    Post subject: Reply with quote

The output does not say you need a systemd ebuild. It says you need a dbus with systemd enabled. Your use case probably should not need that, so there is something for us to solve. What package needs dbus with USE=systemd?
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1540

PostPosted: Mon May 22, 2017 1:04 am    Post subject: Reply with quote

As far as sys-apps/dbus goes, 1.10.18 is already marked stable for most arches; so you don't need keyword anything for this package. So what would be better is find out what is preventing portage from using the newer version of dbus... (note, you can always do emerge -1pv dbus and look at the messages and resolve the issue).
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Mon May 22, 2017 1:31 am    Post subject: Reply with quote

Here is some more info that could be important:
This is a Virtualboxbox guest OS
I installed app-emulation/virtualbox-guest-additions 5.0.32 to get X11 working
The guest addtion package installed x11-base/xorg-drivers-1.18-r1

@ct85711
I removed the entry from package.accept_keywords and uninstalled dbus
Code:
emerge -1pv sys-apps/dbus

These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild  N     ] sys-apps/dbus-1.10.18::gentoo  USE="X -debug -doc -elogind (-selinux) -static-libs (-systemd) {-test} -user-session" ABI_X86="(64) -32 (-x32)" 0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


@Hu
I don't see any package in that output with that USE flag. What is the invocation so I can get you that information?
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 370
Location: Earth

PostPosted: Mon May 22, 2017 11:06 am    Post subject: Re: no ebuilds to satisfy ">=sys-apps/dbus-1.9.8[sys Reply with quote

EugeneTheJeep wrote:
I'm installing GNOME 3.14 using GNOME/GNOME Without systemd guide [...]

For the record, the support thread for GNOME Without Systemd is here.

Please post there in the future (or at the very least in Unsupported Software if you think you might derail the thread).

EugeneTheJeep wrote:
Code:
All ebuilds that could satisfy ">=sys-apps/dbus-1.9.8[systemd]" have been masked.

One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.10.16-r1::gentoo (masked by: ~amd64 keyword)

Are you skipping steps? Per the documentation, after selecting your profile you must run and complete:

Code:
emerge --ask --update --deep --changed-use --with-bdeps=y @world

before you even proceed with:

Code:
emerge --ask --keep-going gnome

Please share the full emerge output starting from the emerge command (with and without the --tree option) that produced the dbus issue after you update @world (while fixing unrelated blockers).

Now, I will point out that:

1. The project overlays mask the systemd USE flag.

2. sys-apps/dbus-1.10.18 was stabilized for amd64 on 2017-05-03.

3. If you are running an OpenRC system nothing should be requiring systemd because a quick grep of portage shows that the only the following packages want dbus[systemd]:

Code:
sys-apps/systemd/systemd-226-r2.ebuild:PDEPEND=">=sys-apps/dbus-1.6.8-r1:0[systemd]
sys-apps/systemd/systemd-231.ebuild:PDEPEND=">=sys-apps/dbus-1.8.8:0[systemd]
sys-apps/systemd/systemd-232.ebuild:PDEPEND=">=sys-apps/dbus-1.8.8:0[systemd]
sys-apps/systemd/systemd-233-r1.ebuild:PDEPEND=">=sys-apps/dbus-1.9.8[systemd]
sys-apps/systemd/systemd-9999.ebuild:PDEPEND=">=sys-apps/dbus-1.9.8[systemd]

This indicates that provided you are synced up, the problem is either in your world file or in /etc/portage/* (which will override the bundled profiles).

If you download a recent stage3 tarball and do nothing but activate the project overlays, select a profile and run:

Code:
emerge --pretend --update --deep --changed-use --with-bdeps=y gnome

you will get clean emerge output. The key to resolving this is figuring out where you diverged from the defaults.
_________________
Dantrell B.
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Mon May 22, 2017 12:33 pm    Post subject: Reply with quote

@dantrell

Thanks for the reply. I was aware of the stickied support thread, and you were correct to surmise that I didn't want to derail it. (After perusing it I decided I didn't want to crap it up with newb questions, as it seemed like mostly advanced user and developer-level content). Maybe a mod can move this thread to unsupported software? Otherwise I can re-create there with an updated title, as the problem does indeed lie with a failed
Code:
emerge --ask --update --deep --changed-use --with-bdeps=y @world


The output is available on the second post of this thread or reposted here:
Code:

These are the packages that would be merged, in order:

Calculating dependencies 
 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

. ......... ..... done!
[ebuild     UD ] dev-libs/gobject-introspection-common-1.42.0::dantrell-gnome-3-14 [1.50.0::gentoo] 1,278 KiB
[ebuild     U  ] dev-libs/vala-common-0.36.3::dantrell-gnome [0.34.8::gentoo] 2,774 KiB
[ebuild  N     ] dev-libs/libunistring-0.9.7:0/2::dantrell-gnome  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 3,506 KiB
[ebuild   R    ] dev-libs/npth-1.3::dantrell-gnome [1.3::gentoo] USE="-static-libs" 0 KiB
[ebuild   R    ] dev-libs/openssl-1.0.2k::gentoo  USE="asm sslv3 tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5,185 KiB
[ebuild     U *] x11-base/xorg-drivers-9999::gentoo [1.18-r1::gentoo] INPUT_DEVICES="keyboard libinput mouse -acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="amdgpu dummy fbdev intel nouveau radeon radeonsi vesa -ast -epson (-fglrx) (-freedreno) (-geode) -glint -i915% -i965% -mga -nv -nvidia (-omap) -qxl -r128 -siliconmotion -tdfx (-tegra) -via -virtualbox -vmware (-voodoo) (-apm%) (-chips%) (-cirrus%) (-i128%) (-i740%) (-mach64%) (-neomagic%) (-rendition%) (-s3%) (-s3virge%) (-savage%) (-sisusb%) (-sunbw2%) (-suncg14%) (-suncg3%) (-suncg6%) (-sunffb%) (-sunleo%) (-suntcx%) (-tga%) (-trident%) (-tseng%)" 0 KiB
[ebuild     U  ] app-admin/eselect-1.4.9::dantrell-gnome [1.4.8::gentoo] USE="-doc -emacs (-multischema) -vim-syntax" 173 KiB
[ebuild   R    ] app-eselect/eselect-pinentry-0.7::dantrell-gnome [0.7::gentoo] 0 KiB
[ebuild   R    ] dev-lang/python-3.4.5:3.4/3.4m::gentoo  USE="gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened (-libressl) -sqlite* -tk -wininst" 0 KiB
[ebuild   R    ] dev-lang/python-2.7.12:2.7::gentoo  USE="gdbm ipv6 ncurses readline ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened (-libressl) -sqlite* -tk -wininst" 0 KiB
[ebuild   R    ] media-libs/freetype-2.8:2::gentoo  USE="X adobe-cff bzip2 cleartype_hinting png -bindist* -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] x11-libs/libxkbcommon-0.6.0::gentoo  USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 595 KiB
[ebuild  N     ] x11-libs/libXinerama-1.1.3::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 272 KiB
[ebuild   R    ] dev-util/gtk-doc-am-1.25-r1::dantrell-gnome [1.25-r1::gentoo] 658 KiB
[ebuild   R    ] dev-libs/boehm-gc-7.4.2::gentoo  USE="cxx threads* -static-libs" 0 KiB
[ebuild  N     ] x11-libs/libXfont2-2.0.1::gentoo  USE="bzip2 ipv6 truetype -doc -static-libs" 462 KiB
[ebuild   R    ] www-client/w3m-0.5.3-r9::gentoo  USE="X gpm nls ssl unicode -fbcon -gtk* -imlib (-libressl) -lynxkeymap -nntp -xface" L10N="-ja" 0 KiB
[ebuild   R    ] sys-devel/gettext-0.19.8.1::dantrell-gnome [0.19.8.1::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)" 19,243 KiB
[ebuild   R    ] dev-libs/libgpg-error-1.27-r1::dantrell-gnome [1.27-r1::gentoo] USE="nls -common-lisp -static-libs" ABI_X86="(64) -32 (-x32)" 795 KiB
[ebuild   R    ] dev-libs/libgcrypt-1.7.6:0/20::dantrell-gnome [1.7.6:0/20::gentoo] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 2,830 KiB
[ebuild   R    ] dev-libs/libassuan-2.4.3-r1::dantrell-gnome [2.4.3-r1::gentoo] USE="-static-libs" 0 KiB
[ebuild  N     ] net-dns/libidn2-0.16-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1,460 KiB
[ebuild     U  ] net-libs/gnutls-3.5.12:0/30::gentoo [3.3.26:0/0::gentoo] USE="cxx idn%* nls openssl seccomp%* sslv3%* tls-heartbeat%* zlib -dane -doc -examples -guile -openpgp% -pkcs11 -sslv2% -static-libs {-test} (-test-full) -tools% -valgrind% (-crywrap%*)" ABI_X86="(64) -32 (-x32)" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN" 7,044 KiB
[ebuild  N     ] sys-libs/libomp-3.9.1:0/3.9::gentoo  USE="-hwloc -ompt" ABI_X86="(64) -32 (-x32)" 1,984 KiB
[ebuild  N     ] sys-devel/clang-runtime-3.9.1::gentoo  USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] sys-devel/llvm-3.9.1-r1:0/3.9.1::gentoo  USE="clang* libffi ncurses sanitize static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc -gold -libedit (-lldb) -multitarget -ocaml -python {-test}" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 11,911 KiB
[ebuild  N     ] sys-devel/clang-3.9.1-r100:0/3.9.1::gentoo  USE="static-analyzer -debug -multitarget -python" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB
[ebuild   R    ] media-libs/mesa-13.0.5::gentoo  USE="classic dri3 egl gallium gbm gles2 llvm nettle nptl -bindist* -d3d9 -debug -gcrypt -gles1 (-libressl) -opencl -openmax -openssl -osmesa -pax_kernel -pic (-selinux) -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 -r100 -r200 -r300 -r600 (-vc4) -vmware" 0 KiB
[ebuild  N     ] virtual/opengl-7.0-r1::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     UD ] dev-util/gdbus-codegen-2.42.2::dantrell-gnome [2.50.3::gentoo] PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_6)" 6,839 KiB
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.29.0:5/5.29::gentoo  USE="-doc {-test}" 296 KiB
[ebuild  N     ] media-libs/glfw-3.2.1::gentoo  USE="-examples -wayland" 640 KiB
[ebuild     U  ] x11-base/xorg-server-1.19.2:0/1.19.2::gentoo [1.18.4:0/1.18.4::gentoo] USE="glamor ipv6 suid udev xorg -debug% -dmx -doc -kdrive* (-libressl) -minimal (-selinux) -static-libs (-systemd) -tslib -unwind -wayland -xephyr -xnest -xvfb" 5,830 KiB
[ebuild  rR    ] x11-drivers/xf86-input-mouse-1.9.2::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216::gentoo  USE="dri sna udev -debug -dri3 -tools -uxa -xvmc" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-input-keyboard-1.9.0::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0::gentoo  USE="glamor" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-ati-7.8.0::gentoo  USE="glamor udev" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-nouveau-1.0.13::gentoo  0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-dummy-0.3.8::gentoo  USE="-dga" 0 KiB
[ebuild  rR    ] x11-drivers/xf86-video-vesa-2.3.4::gentoo  0 KiB
[ebuild  r  UD ] dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome [2.50.3-r1:2/2::gentoo] USE="dbus (mime) xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[blocks b      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
[ebuild  N     ] gnome-base/dconf-0.22.0::dantrell-gnome  USE="X {-test}" 385 KiB
[ebuild     UD ] dev-libs/gobject-introspection-1.42.0-r1::dantrell-gnome-3-14 [1.50.0::gentoo] USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="(-python2_7%) (-python3_4%*) (-python3_5%)" PYTHON_TARGETS="python2_7 (-python3_4%*) (-python3_5%)" 0 KiB
[ebuild   R    ] dev-libs/libcroco-0.6.12-r1:0.6::dantrell-gnome [0.6.12-r1:0.6::gentoo] USE="{-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-libs/dbus-glib-0.102::gentoo  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 766 KiB
[ebuild     UD ] x11-libs/gdk-pixbuf-2.36.4:2::dantrell-gnome [2.36.6:2::gentoo] USE="X introspection jpeg tiff -debug -jpeg2k {-test}" ABI_X86="(64) -32 (-x32)" 5,038 KiB
[ebuild     UD ] dev-libs/atk-2.14.0::dantrell-gnome-3-14 [2.22.0::gentoo] USE="introspection nls {-test}" ABI_X86="(64) -32 (-x32)" 680 KiB
[ebuild   R    ] sys-fs/eudev-3.1.5::gentoo  USE="hwdb introspection* kmod -rule-generator (-selinux) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] app-text/poppler-0.54.0:0/67::dantrell-gnome [0.45.0:0/62::gentoo] USE="cairo cxx introspection jpeg jpeg2k lcms png tiff utils -cjk -curl -debug -doc -nss -qt4* -qt5 (-cairo-qt%)" 1,659 KiB
[ebuild     UD ] app-accessibility/at-spi2-core-2.14.1:2::dantrell-gnome-3-14 [2.22.1:2::gentoo] USE="X introspection" ABI_X86="(64) -32 (-x32)" 446 KiB
[ebuild     UD ] x11-libs/pango-1.36.8-r1::dantrell-gnome [1.40.5::gentoo] USE="X introspection {-test}" ABI_X86="(64) -32 (-x32)" 1,010 KiB
[ebuild     UD ] app-accessibility/at-spi2-atk-2.14.1:2::dantrell-gnome-3-14 [2.22.0:2::gentoo] USE="{-test}" ABI_X86="(64) -32 (-x32)" 275 KiB
[ebuild     UD ] dev-util/gtk-update-icon-cache-3.14.15::dantrell-gnome-3-14 [3.22.2::gentoo] 304 KiB
[ebuild  N     ] app-text/mupdf-1.11-r1:0/1.11::gentoo  USE="X curl opengl openssl -javascript (-libressl) -static -static-libs -vanilla" 39,215 KiB
[ebuild   R    ] gnome-base/librsvg-2.40.17:2::dantrell-gnome [2.40.17:2::gentoo] USE="introspection -tools -vala" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] dev-libs/libgudev-230-r1::gentoo  USE="introspection -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     UD ] x11-themes/adwaita-icon-theme-3.14.1-r2::dantrell-gnome-3-14 [3.22.0-r1::gentoo] USE="branding" 17,170 KiB
[ebuild  rR    ] x11-drivers/xf86-input-libinput-0.24.0::gentoo  0 KiB
[ebuild     UD ] dev-libs/libgusb-0.2.7::dantrell-gnome [0.2.9::gentoo] USE="introspection -static-libs -vala" ABI_X86="(64) -32 (-x32)" 270 KiB
[ebuild   R    ] app-text/ghostscript-gpl-9.20-r1::gentoo  USE="X cups dbus tiff -gtk* -idn -static-libs" L10N="-de -ja -ko -zh-CN -zh-TW" 0 KiB
[ebuild     U  ] net-print/cups-filters-1.12.0::dantrell-gnome [1.5.0::gentoo] USE="dbus foomatic jpeg ldap pdf%* png postscript%* tiff -perl -static-libs -zeroconf" 1,385 KiB
[ebuild   R    ] app-crypt/libsecret-0.18.5::dantrell-gnome [0.18.5::gentoo] USE="crypt introspection -debug {-test} -vala" 0 KiB
[ebuild     U  ] sys-auth/pambase-20150213-r1::dantrell-gnome [20150213::gentoo] USE="consolekit* cracklib gnome-keyring* nullok sha512 -debug -elogind% -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux) (-systemd)" 0 KiB
[ebuild   R    ] net-misc/openssh-7.3_p1-r7::gentoo  USE="X* hpn ldap* pam pie ssl -X509 -bindist* -debug -kerberos -ldns -libedit (-libressl) -livecd -sctp (-selinux) -skey -ssh1 -static {-test}" 0 KiB
[ebuild   R    ] sys-auth/polkit-0.113::gentoo  USE="introspection nls pam -examples -gtk* -jit -kde (-selinux) (-systemd) {-test}" 0 KiB
[ebuild     UD ] sys-auth/consolekit-0.4.6::dantrell-gnome [1.1.0-r1::gentoo] USE="acl pam policykit -debug -doc (-selinux) -systemd-units% {-test} (-cgroups%) (-pm-utils%)" 370 KiB
[ebuild     UD ] x11-misc/colord-1.2.12:0/2::dantrell-gnome [1.3.4:0/2::gentoo] USE="gusb introspection policykit udev -argyllcms -examples -extra-print-profiles -scanner (-systemd) -vala" ABI_X86="(64) -32 (-x32)" 1,187 KiB
[ebuild     UD ] x11-libs/gtk+-3.14.15:3/14::dantrell-gnome-3-14 [3.22.15:3/3::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -examples {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)" 15,524 KiB
[ebuild     UD ] app-crypt/gcr-3.14.0:0/1::dantrell-gnome-3-14 [3.20.0:0/1::gentoo] USE="gtk introspection -debug {-test} -vala*" 1,310 KiB
[ebuild   R    ] app-crypt/pinentry-0.9.7-r1::dantrell-gnome [0.9.7-r1::gentoo] USE="gnome-keyring ncurses -caps -emacs -gtk* -qt4* -qt5 -static" 0 KiB
[ebuild     U  ] app-crypt/gnupg-2.1.21::dantrell-gnome [2.1.20-r1::gentoo] USE="bzip2 gnutls ldap nls readline smartcard usb -doc (-selinux) -tofu -tools -wks-server" 6,322 KiB
[ebuild     UD ] gnome-base/gnome-keyring-3.14.0::dantrell-gnome-3-14 [3.20.0::gentoo] USE="caps filecaps pam ssh-agent (-selinux) {-test}" 1,145 KiB
[ebuild   R    ] gnome-base/libgnome-keyring-3.12.0::dantrell-gnome [3.12.0::gentoo] USE="introspection -debug {-test} -vala" 0 KiB
[ebuild     U  ] sys-apps/openrc-0.26.2::gentoo [0.24.2::gentoo] USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs" 0 KiB
[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-9999)

Total: 76 packages (10 upgrades, 17 downgrades, 14 new, 35 reinstalls), Size of downloads: 168,218 KiB
Conflict: 2 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.19:0/1.18.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed)
    ^                     ^^^^^^^^^^^^^^                                                                                         
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed) pulled in by
    ~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, installed)

  (x11-base/xorg-drivers-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-drivers-1.19 required by (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge)
    >=x11-base/xorg-drivers-1.18 required by (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/glib-2.42.2-r1:2/42::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libgudev-230-r1:0/0::gentoo, ebuild scheduled for merge)
  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-ati-7.8.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nouveau-1.0.13:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)



My Gentoo is a guest OS running on virtual box. I installed guest additions to get X.org up and running.

This is an outline of what I've done so far:
1. Prepped disk & set up file systems using MBR
2. downloaded & upacked stage3-amd64-20170504.tar.bz2
3. ran emerge-sync
4. selected profile default/linux/amd64/13.0/desktop/gnome
5. ran emerge --ask --update --deep --newuse @world (this took hours and ended up segfaulting on me. I didn't run it again because the handbook said it was optional for non-systemd profiles. This has also crashed my computer twice before on previous Gentoo build attempts [since deleted; this is a fresh build], yielding a Windows 10 BSOD CRITICAL STRUCTURE CORRUPTION win32kfull.sys, which I believe is due to an illegal memory access) The previous attempts I believe crashed due to not having enough memory resources allocated to the guest OS via VBox, and not having a swap partition or swap file.
6. Configured locale & timezone, then ran env-update && source /etc/profile && export PS1="(chroot) $PS1"
7. Installed kernel 4.9.16 sources & configured (using options recommended in amd64 manual, VirtualBox guide, & X.org guide)
8. Compiled & installed kernel
9. Performed the following mask to resolve package conflicts in app-emulation/virtualbox-guest-additions:
Code:
touch /etc/portage/package.mask/x11
nano -w /etc/portage/package.mask/x11
=x11-base/xorg-drivers-1.19:0/0

10. downgraded to kernel 4.4.52 due to a bug with guest additions where it won't compile with kernel 4.9
11. verified that startx runs successfully
12. installed layman using the Layman & GNOME without systemd guide

I'm very new to portage and Gentoo in general, so I can only provide my best educated guess as to why I somehow deviated from the defaults. Having said that, I'm pretty sure it has something to do with either installing app-emulation/virtualbox-guest-additions (which in turn installled the xorg server & xorg drivers that are causing conflicts), or it has something to do with the ran emerge --ask --update --deep --newuse @world in step 5 segfaulting.

Thanks again for the reply.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 370
Location: Earth

PostPosted: Mon May 22, 2017 12:49 pm    Post subject: Reply with quote

EugeneTheJeep wrote:
The output is available on the second post of this thread or reposted here [...]

That's not the emerge command that produced the dbus issue.

The blocker produced by your @world update is an unrelated issue that you need to resolve. Once that's cleared up and if the dbus issue persists, provide the requested information.

EugeneTheJeep wrote:
I didn't run it again because the handbook said it was optional for non-systemd profiles.

Note, as per the project documentation:

Code:
emerge --ask --update --deep --changed-use --with-bdeps=y @world

is not optional.
_________________
Dantrell B.
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Mon May 22, 2017 10:33 pm    Post subject: Reply with quote

My bad; that is definitely not the same command. I resolved & successfully ran

Code:
emerge --pretend --update --deep --changed-use --with-bdeps=y @world
emerge --ask --update --deep --changed-use --with-bdeps=y @world



And the output you're looking for is:
Code:
# emerge --pretend --update --deep --changed-use --with-bdeps=y gnome

These are the packages that would be merged, in order:

Calculating dependencies  .... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/gtk+:3

  (x11-libs/gtk+-3.14.15:3/14::dantrell-gnome-3-14, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-3.22.15:3/3::gentoo, installed) pulled in by
    >=x11-libs/gtk+-3.22.0:3[X,wayland?] required by (gnome-base/gnome-control-center-3.22.2-r1:2/2::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^                                                                                                             
    (and 3 more with the same problem)

x11-misc/colord:0

  (x11-misc/colord-1.2.12:0/2::dantrell-gnome, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-misc/colord-1.3.4:0/2::gentoo, installed) pulled in by
    >=x11-misc/colord-1.3.1:0= required by (gnome-extra/gnome-color-manager-3.22.2:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^^^^^                                                                                             

x11-base/xorg-server:0

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.7:0/1.18.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.1.18:0/0::gentoo, installed)
                              ^^^^^^^^^^                                                                                         
    (and 2 more with the same problem)

dev-libs/gobject-introspection:0

  (dev-libs/gobject-introspection-1.42.0-r1:0/0::dantrell-gnome-3-14, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-1.50.0:0/0::gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-1.46.0:= required by (dev-python/pygobject-3.22.0:3/3::gentoo, ebuild scheduled for merge)
    ^^                               ^^^^^^                                                                                     

dev-libs/gobject-introspection-common:0

  (dev-libs/gobject-introspection-common-1.42.0:0/0::dantrell-gnome-3-14, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-common-1.50.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-common-1.50.0 required by (dev-libs/gobject-introspection-1.50.0:0/0::gentoo, installed)
    ^^                                      ^^^^^^                                                                           

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-libs/gobject-introspection-1.50.0::gentoo
# required by dev-python/pygobject-3.22.0::gentoo
# required by app-admin/system-config-printer-1.5.7::dantrell-gnome
# required by gnome-base/gnome-control-center-3.22.2-r1::gentoo[cups]
# required by net-libs/gnome-online-accounts-3.22.5::gentoo[gnome]
# required by gnome-base/gvfs-1.30.4::gentoo[gnome-online-accounts]
# required by gnome-base/gnome-3.22.2::gentoo
# required by gnome (argument)
# /var/lib/layman/dantrell-gnome/profiles/targets/gnome/3.14/package.mask:
# Masked to freeze the state of GNOME
=dev-libs/gobject-introspection-common-1.50.0
# required by x11-libs/libnotify-0.7.7-r1::dantrell-gnome
# required by app-admin/system-config-printer-1.5.7::dantrell-gnome
# required by gnome-base/gnome-control-center-3.22.2-r1::gentoo[cups]
# required by net-libs/gnome-online-accounts-3.22.5::gentoo[gnome]
# required by gnome-base/gvfs-1.30.4::gentoo[gnome-online-accounts]
# required by gnome-base/gnome-3.22.2::gentoo
# required by gnome (argument)
# /var/lib/layman/dantrell-gnome/profiles/targets/gnome/3.14/package.mask:
# Masked to freeze the state of GNOME
=dev-libs/glib-2.52.2

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

!!! All ebuilds that could satisfy ">=sys-apps/dbus-1.9.8[systemd]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.10.16-r1::gentoo (masked by: ~amd64 keyword)

(dependency required by "sys-apps/systemd-233-r1::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-settings-daemon-3.22.2::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-session-3.22.3::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-control-center-3.22.2-r1::gentoo" [ebuild])
(dependency required by "net-libs/gnome-online-accounts-3.22.5::gentoo[gnome]" [ebuild])
(dependency required by "gnome-base/gvfs-1.30.4::gentoo[gnome-online-accounts]" [ebuild])
(dependency required by "gnome-base/gnome-3.22.2::gentoo" [ebuild])
(dependency required by "gnome" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 370
Location: Earth

PostPosted: Tue May 23, 2017 11:00 pm    Post subject: Reply with quote

EugeneTheJeep wrote:
And the output you're looking for is [...]

Please share the output of:

Code:
eselect profile list

Code:
emerge --info

Code:
emerge --search "%@^sys-apps.*systemd$"

_________________
Dantrell B.
Back to top
View user's profile Send private message
EugeneTheJeep
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2017
Posts: 101

PostPosted: Sat May 27, 2017 3:00 pm    Post subject: Reply with quote

Just wanted to update that I decided to go with KDE plasma because the overlays were a bit to complex for my current experience level. (I informed dantrell of this via pm a couple of days ago) I hate to leave a dangling thread.
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 675

PostPosted: Fri Jun 02, 2017 9:35 pm    Post subject: Reply with quote

EugeneTheJeep wrote:
This was the output of emerge --deep --with-bdeps=y --changed-use --update --ask --verbose @world :
Code:

[...snip...]
[ebuild     U *] x11-base/xorg-drivers-9999::gentoo [1.18-r1::gentoo] INPUT_DEVICES="keyboard libinput mouse -acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="amdgpu dummy fbdev intel nouveau radeon radeonsi vesa -ast -epson (-fglrx) (-freedreno) (-geode) -glint -i915% -i965% -mga -nv -nvidia (-omap) -qxl -r128 -siliconmotion -tdfx (-tegra) -via -virtualbox -vmware (-voodoo) (-apm%) (-chips%) (-cirrus%) (-i128%) (-i740%) (-mach64%) (-neomagic%) (-rendition%) (-s3%) (-s3virge%) (-savage%) (-sisusb%) (-sunbw2%) (-suncg14%) (-suncg3%) (-suncg6%) (-sunffb%) (-sunleo%) (-suntcx%) (-tga%) (-trident%) (-tseng%)" 0 KiB
[...snip...]
  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed) pulled in by
    <x11-base/xorg-server-1.19:0/1.18.4=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, installed)
    ^                     ^^^^^^^^^^^^^^                                                                                         
    (and 1 more with the same problem)
This is actually where your problem is, it probably has nothing to do with dbus or systemd. You need to set VIDEO_CARDS= and INPUT_DEVICES= in /etc/portage/make.conf to their appropriate values, and you shouldn't unmask xorg-drivers-9999. You may need to manually uninstall some of the extraneous xorg-drivers after removing their respective flags, such as xf86-video-virtualbox.

Note that you don't need INPUT_DEVICES="mouse keyboard". INPUT_DEVICES="libinput" is just fine.
Back to top
View user's profile Send private message
ZappingLinux
n00b
n00b


Joined: 13 Oct 2017
Posts: 46

PostPosted: Fri Oct 13, 2017 9:56 pm    Post subject: Reply with quote

Hey guys I hope you dont me poking my head in here. I am experiencing the same problem as the other guy. I followed the guide to the letter but still it tells me that the sys-apps/dbus package is required before I emerge gnome. I am actually installing this on another laptop so I cant copy any text I am afraid. As per the emerge --searcg "%@^sys-apps.*systemd $", it is not installed. I did run the emerge --ask --update --deep --changed-use --with-bdeps=y @world. Also the profile i have selected even before that is dantrell-gnome:default/and64/3.24. Again any help would be lovely!
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 370
Location: Earth

PostPosted: Sun Oct 15, 2017 7:28 am    Post subject: Reply with quote

I also hate to leave a dangling thread. So just for the record...

EugeneTheJeep wrote:
Just wanted to update that I decided to go with KDE plasma because the overlays were a bit to complex for my current experience level. (I informed dantrell of this via pm a couple of days ago) I hate to leave a dangling thread.

This was indeed the case.

ZappingLinux wrote:
Hey guys I hope you dont me poking my head in here. I am experiencing the same problem as the other guy.

And this was resolved here.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum