Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg Segmentation fault when using Touchpad
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Fri Aug 10, 2012 1:38 pm    Post subject: Xorg Segmentation fault when using Touchpad Reply with quote

I am trying to get my Arm board working with a 7" touchscreen, if i comment out the touchscreen InputDevice in xorg.conf then it will X will start and display xfce.
If I use the touch screen InputDevice X will crash.

Any ideas what I can try?

Code:

EM210 X11 # cat xorg.conf
section "ServerLayout"
   Identifier     "XFree86 Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Touchpad0" "CorePointer"
   Option      "OffTime" "100"
EndSection

Section "InputDevice"
   Identifier  "Touchpad0"
   Driver      "tslib"
   Option      "CorePointer"           "true"
        Option      "SendCoreEvents"        "true"
        Option      "Device"                "/dev/input/event1"
        Option      "Protocol"              "Auto"
        Option      "Width"                 "800"
        Option      "Height"                "480"
   Option      "EmulateRightButton"    "1"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   ModelName    "Monitor Model"
   DisplaySize 800 480
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "fbdev"
   Option  "fbdev" "/dev/fb0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
EndSection


Code:


EM210 X11 # startx
hostname: Host name lookup failure
xauth:  file /root/.serverauth.3000 does not exist


X.Org X Server 1.12.2
Release Date: 2012-05-29
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.9 armv7l Gentoo
Current Operating System: Linux EM210 2.6.32.9 #26 PREEMPT Mon Aug 6 12:09:36 BST 2012 armv7l
Kernel command line: console=ttySAC2,115200 noinitrd root=/dev/mmcblk0p1 init=/sbin/linuxrc
Build Date: 09 August 2012  11:16:20AM
 
Current version of pixman: 0.26.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 10 13:33:26 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Backtrace:

Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
^Cxinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: unexpected signal 2
EM210 X11 # dmesg -c
[ 2776.876656] s3cfb s3cfb: [fb2] already in FB_BLANK_NORMAL


Code:

EM210 X11 # cat /var/log/Xorg.0.log
[  2776.572]
X.Org X Server 1.12.2
Release Date: 2012-05-29
[  2776.573] X Protocol Version 11, Revision 0
[  2776.573] Build Operating System: Linux 2.6.32.9 armv7l Gentoo
[  2776.573] Current Operating System: Linux EM210 2.6.32.9 #26 PREEMPT Mon Aug 6 12:09:36 BST 2012 armv7l
[  2776.573] Kernel command line: console=ttySAC2,115200 noinitrd root=/dev/mmcblk0p1 init=/sbin/linuxrc
[  2776.573] Build Date: 09 August 2012  11:16:20AM
[  2776.573] 
[  2776.573] Current version of pixman: 0.26.0
[  2776.573]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  2776.573] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2776.575] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 10 13:33:26 2012
[  2776.575] (==) Using config file: "/etc/X11/xorg.conf"
[  2776.575] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2776.576] (==) ServerLayout "XFree86 Configured"
[  2776.576] (**) |-->Screen "Screen0" (0)
[  2776.576] (**) |   |-->Monitor "Monitor0"
[  2776.577] (**) |   |-->Device "Card0"
[  2776.577] (**) |-->Input Device "Touchpad0"
[  2776.577] (**) Option "OffTime" "100"
[  2776.577] (==) Automatically adding devices
[  2776.577] (==) Automatically enabling devices
[  2776.577] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  2776.577]    Entry deleted from font path.
[  2776.577] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  2776.577]    Entry deleted from font path.
[  2776.578] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  2776.578]    Entry deleted from font path.
[  2776.578] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  2776.578]    Entry deleted from font path.
[  2776.578] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  2776.578]    Entry deleted from font path.
[  2776.578] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  2776.578]    Entry deleted from font path.
[  2776.578] (==) FontPath set to:
   
[  2776.579] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2776.579] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2776.579] (II) Loader magic: 0x1a3cd0
[  2776.579] (II) Module ABI versions:
[  2776.579]    X.Org ANSI C Emulation: 0.4
[  2776.579]    X.Org Video Driver: 12.0
[  2776.579]    X.Org XInput driver : 16.0
[  2776.579]    X.Org Server Extension : 6.0
[  2776.579] (II) LoadModule: "extmod"
[  2776.580] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  2776.581] (II) Module extmod: vendor="X.Org Foundation"
[  2776.581]    compiled for 1.12.2, module version = 1.0.0
[  2776.581]    Module class: X.Org Server Extension
[  2776.581]    ABI class: X.Org Server Extension, version 6.0
[  2776.581] (II) Loading extension MIT-SCREEN-SAVER
[  2776.581] (II) Loading extension XFree86-VidModeExtension
[  2776.581] (II) Loading extension XFree86-DGA
[  2776.581] (II) Loading extension DPMS
[  2776.581] (II) Loading extension XVideo
[  2776.582] (II) Loading extension XVideo-MotionCompensation
[  2776.582] (II) Loading extension X-Resource
[  2776.582] (II) LoadModule: "dbe"
[  2776.582] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  2776.583] (II) Module dbe: vendor="X.Org Foundation"
[  2776.583]    compiled for 1.12.2, module version = 1.0.0
[  2776.583]    Module class: X.Org Server Extension
[  2776.583]    ABI class: X.Org Server Extension, version 6.0
[  2776.583] (II) Loading extension DOUBLE-BUFFER
[  2776.583] (II) LoadModule: "glx"
[  2776.583] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2776.584] (II) Module glx: vendor="X.Org Foundation"
[  2776.584]    compiled for 1.12.2, module version = 1.0.0
[  2776.584]    ABI class: X.Org Server Extension, version 6.0
[  2776.584] (==) AIGLX enabled
[  2776.584] (II) Loading extension GLX
[  2776.584] (II) LoadModule: "record"
[  2776.585] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  2776.585] (II) Module record: vendor="X.Org Foundation"
[  2776.585]    compiled for 1.12.2, module version = 1.13.0
[  2776.585]    Module class: X.Org Server Extension
[  2776.585]    ABI class: X.Org Server Extension, version 6.0
[  2776.585] (II) Loading extension RECORD
[  2776.586] (II) LoadModule: "dri"
[  2776.586] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  2776.587] (II) Module dri: vendor="X.Org Foundation"
[  2776.587]    compiled for 1.12.2, module version = 1.0.0
[  2776.587]    ABI class: X.Org Server Extension, version 6.0
[  2776.587] (II) Loading extension XFree86-DRI
[  2776.587] (II) LoadModule: "dri2"
[  2776.587] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  2776.588] (II) Module dri2: vendor="X.Org Foundation"
[  2776.588]    compiled for 1.12.2, module version = 1.2.0
[  2776.588]    ABI class: X.Org Server Extension, version 6.0
[  2776.588] (II) Loading extension DRI2
[  2776.588] (II) LoadModule: "fbdev"
[  2776.589] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  2776.589] (II) Module fbdev: vendor="X.Org Foundation"
[  2776.590]    compiled for 1.12.2, module version = 0.4.2
[  2776.590]    ABI class: X.Org Video Driver, version 12.0
[  2776.590] (II) LoadModule: "tslib"
[  2776.590] (II) Loading /usr/lib/xorg/modules/input/tslib_drv.so
[  2776.591] (II) Module tslib: vendor="X.Org Foundation"
[  2776.591]    compiled for 1.12.2, module version = 0.0.1
[  2776.591]    Module class: X.Org XInput Driver
[  2776.591]    ABI class: X.Org XInput driver, version 16.0
[  2776.591] (II) FBDEV: driver for framebuffer: fbdev
[  2776.591] (--) using VT number 7

[  2776.598] (WW) Falling back to old probe method for fbdev
[  2776.598] (II) Loading sub module "fbdevhw"
[  2776.598] (II) LoadModule: "fbdevhw"
[  2776.598] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  2776.599] (II) Module fbdevhw: vendor="X.Org Foundation"
[  2776.599]    compiled for 1.12.2, module version = 0.0.2
[  2776.599]    ABI class: X.Org Video Driver, version 12.0
[  2776.599] (II) FBDEV(0): using /dev/fb0
[  2776.599] (II) FBDEV(0): Creating default Display subsection in Screen section
   "Screen0" for depth/fbbpp 24/32
[  2776.600] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[  2776.600] (==) FBDEV(0): RGB weight 888
[  2776.600] (==) FBDEV(0): Default visual is TrueColor
[  2776.600] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[  2776.600] (II) FBDEV(0): hardware: s3cfb (video memory: 3000kB)
[  2776.600] (**) FBDEV(0): Option "fbdev" "/dev/fb0"
[  2776.600] (II) FBDEV(0): checking modes against framebuffer device...
[  2776.600] (II) FBDEV(0): checking modes against monitor...
[  2776.600] (--) FBDEV(0): Virtual size is 800x480 (pitch 800)
[  2776.600] (**) FBDEV(0):  Built-in mode "current": 38.8 MHz, 36.8 kHz, 70.0 Hz
[  2776.600] (II) FBDEV(0): Modeline "current"x0.0   38.81  800 816 846 1056  480 490 503 525 -hsync -vsync -csync (36.8 kHz b)
[  2776.600] (**) FBDEV(0): Display dimensions: (800, 480) mm
[  2776.601] (**) FBDEV(0): DPI set to (25, 25)
[  2776.601] (II) Loading sub module "fb"
[  2776.601] (II) LoadModule: "fb"
[  2776.601] (II) Loading /usr/lib/xorg/modules/libfb.so
[  2776.602] (II) Module fb: vendor="X.Org Foundation"
[  2776.602]    compiled for 1.12.2, module version = 1.0.0
[  2776.602]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2776.602] (**) FBDEV(0): using shadow framebuffer
[  2776.603] (II) Loading sub module "shadow"
[  2776.603] (II) LoadModule: "shadow"
[  2776.603] (II) Loading /usr/lib/xorg/modules/libshadow.so
[  2776.603] (II) Module shadow: vendor="X.Org Foundation"
[  2776.603]    compiled for 1.12.2, module version = 1.1.0
[  2776.603]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2776.603] (==) Depth 24 pixmap format is 32 bpp
[  2776.604] (==) FBDEV(0): Backing store disabled
[  2776.606] (==) FBDEV(0): DPMS enabled
[  2776.606] (==) RandR enabled
[  2776.606] (II) Initializing built-in extension Generic Event Extension
[  2776.606] (II) Initializing built-in extension SHAPE
[  2776.606] (II) Initializing built-in extension MIT-SHM
[  2776.607] (II) Initializing built-in extension XInputExtension
[  2776.607] (II) Initializing built-in extension XTEST
[  2776.607] (II) Initializing built-in extension BIG-REQUESTS
[  2776.607] (II) Initializing built-in extension SYNC
[  2776.607] (II) Initializing built-in extension XKEYBOARD
[  2776.607] (II) Initializing built-in extension XC-MISC
[  2776.607] (II) Initializing built-in extension XINERAMA
[  2776.607] (II) Initializing built-in extension XFIXES
[  2776.607] (II) Initializing built-in extension RENDER
[  2776.607] (II) Initializing built-in extension RANDR
[  2776.607] (II) Initializing built-in extension COMPOSITE
[  2776.607] (II) Initializing built-in extension DAMAGE
[  2776.647] (II) AIGLX: Screen 0 is not DRI2 capable
[  2776.647] (II) AIGLX: Screen 0 is not DRI capable
[  2776.667] (II) AIGLX: Loaded and initialized swrast
[  2776.667] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[  2776.785] (II) Using input driver 'tslib' for 'Touchpad0'
[  2776.785] (**) Option "SendCoreEvents" "true"
[  2776.785] (**) Option "CorePointer"
[  2776.786] (**) Touchpad0: always reports core events
[  2776.786] (**) Touchpad0: always reports core events
[  2776.786] (**) Option "Width" "800"
[  2776.786] (**) Option "Height" "480"
[  2776.786]
[  2776.786] Backtrace:
[  2776.787]
[  2776.787] Segmentation fault at address (nil)
[  2776.787]
Fatal server error:
[  2776.787] Caught signal 11 (Segmentation fault). Server aborting
[  2776.787]
[  2776.787]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  2776.787] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2776.787]
[  2776.801] Server terminated with error (1). Closing log file.
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Fri Aug 10, 2012 1:56 pm    Post subject: Reply with quote

Some more useful information about my system:

Code:

EM210 ~ # emerge --info
Portage 2.1.10.65 (default/linux/arm/10.0, gcc-4.5.3, glibc-2.14.1-r3, 2.6.32.9 armv7l)
=================================================================
System uname: Linux-2.6.32.9-armv7l-ARMv7_Processor_rev_2_-v7l-with-gentoo-2.1
Timestamp of tree: Wed, 08 Aug 2012 00:45:02 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv7a-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
CHOST="armv7a-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl arm berkdb bzip2 cli cracklib crypt cups cxx fortran gdbm gif gpm gudev iconv ipv6 javascript jpeg libnotify modules mudflap mysql ncurses nls nptl openmp pam pcre png pppd python readline session sqlite sqlite3 ssl svg tcpd thunar tslib unicode webgl xinerama zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="tslib evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="exynos fbdev omap omapfb dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Fri Aug 10, 2012 4:34 pm    Post subject: Reply with quote

GOOD NEWS!

To get my touch screen working I had to add export flags, I did this by creating a tslib.sh profile:

Code:

EM210 etc # cd profile.d/
EM210 profile.d # ls -l
total 4
-rw-r--r-- 1 root root 208 Aug 10 16:28 tslib.sh
EM210 profile.d # cat tslib.sh
export TSLIB_TSEVENTTYPE=INPUT
export TSLIB_CONSOLEDEVICE=none
export TSLIB_FBDEVICE=/dev/fb0
export TSLIB_TSDEVICE=/dev/input/event1
export TSLIB_CALIBFILE=/etc/pointercal
export TSLIB_CONFFILE=/etc/ts.conf
EM210 profile.d #


My touchscreen works with tslib, I am able to use ts_test and ts_calibrate however I have a new Xorg problem.
When I touch the screen after loading X it exits saying another instance took over. Leaving......

Quote:

/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/input/tslib_drv.so: undefined symbol: xf86XInputSetScreen
xfce4-session-Message: Got disconnected from D-Bus. Unless this happened during session shutdown, this is probably a bad thing.
xfsettingsd: Another instance took over. Leaving...
xfce4-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Thunar: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfwm4: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfsettingsd: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfdesktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
migrate: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xinit: connection to X server lost


Any ideas?


Last edited by Jono86 on Mon Aug 13, 2012 10:10 am; edited 1 time in total
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Aug 13, 2012 10:06 am    Post subject: Reply with quote

I have found out that xf86XInputSetScreen has been removed from xorg core and that xorg-input-tslib_0.0.6-7+b2 calls the removed function.
To resolve this I have to downgrade xorg-server.

Code:
emerge -av =x11-base/xorg-server-1.11.4-r1


Will update with my results, a new xorg-input-tslib will be required at a later date.
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Aug 13, 2012 2:27 pm    Post subject: Reply with quote

Touchscreen now works with xfce :)

I also needed to do the following to get everything working:

find all xorg modules required

Quote:

EM210 ~ # equery list *xf86*
* Searching for *xf86* ...
[IP-] [ ] x11-drivers/xf86-input-evdev-2.7.0:0
[IP-] [ ] x11-drivers/xf86-input-joystick-1.6.1:0
[IP-] [ ] x11-drivers/xf86-input-keyboard-1.6.1:0
[IP-] [ ] x11-drivers/xf86-input-mouse-1.7.2:0
[IP-] [ ] x11-drivers/xf86-input-mouse-0.0.6-r2:0
[IP-] [ ] x11-drivers/xf86-video-dummy-0.3.5-r1:0
[IP-] [ ] x11-drivers/xf86-video-fbdev-0.4.2:0
[IP-] [ ] x11-drivers/xf86-video-omapfb-0.1.1_p3:0
[IP-] [ ] x11-drivers/xf86-video-v4l-0.2.0:0
[IP-] [ ] x11-libs/libXxf86misc-1.0.3:0
[IP-] [ ] x11-libs/libXxf86vm-1.1.2:0
[IP-] [ ] x11-proto/xf86bigfontproto-1.2.0:0
[IP-] [ ] x11-proto/xf86dgaproto-2.1-r1:0
[IP-] [ ] x11-proto/xf86driproto-2.1.1:0
[IP-] [ ] x11-proto/xf86miscproto-0.9.3:0
[IP-] [ ] x11-proto/xf86rushproto-1.1.2-r1:0
[IP-] [ ] x11-proto/xf86vidmodeproto-2.3.1:0


emerge all packages
Code:
emerge -av xorg-drivers


Code:
emerge -av xf86-input-mouse xf86-input-mouse xf86-video-dummy xf86-video-fbdev xf86-video-omapfb xf86-video libXxf86misc libXxf86vm xf86bigfontproto xf86dgaproto xf86driproto xf86miscproto xf86rushproto xf86vidmodeproto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum