Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers hdmi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Kurogane
n00b
n00b


Joined: 23 May 2010
Posts: 39

PostPosted: Wed Aug 08, 2012 1:38 pm    Post subject: ati-drivers hdmi Reply with quote

I have problem with overscan in ATI, AMD Catalyst Control Centre doesn't save my overscanning setting after reboot, the underscan appears to be set to 10%, but in CCC, it reports it as 0. In order to bring it back to normal (no black bars), I have to move the slider to another spot and back and it fixes the issue. Restarting it again it back, even though CCC says it was 0, is very annoying I have to change back the overscanning setting each time I reboot my computer.

Catalyst 12.6
X Server 1.12.3

Xorg.0.log

http://pastebin.com/GQhJaHpP

xorg.config

Code:
#Section "Files"
#         ModulePath "/usr/lib64/xorg/modules"
#         ModulePath "/usr/lib64/opengl/xorg-x11/extensions/"
#EndSection
#Section "Extensions"
#         Option        "Composite"        "Enable"
#EndSection
#Section "ServerFlags"
#         Option        "AIGLX"            "On"
#EndSection

Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"

#       Modeline "1920x1080@60" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
        Identifier   "aticonfig-Monitor[0]-0"
#       ModeLine     "1920x1080_60.00" 173.0 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
#       Modeline "1920x1080@60" 182.28 1920 1952 2640 2672 1080 1102 1113 1135 -hsync +vsync
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "XAANoOffscreenPixmaps" "true"
#       Option      "TVOverscan" "on"
        BusID       "PCI:6:0:0"
        Option      "underscan"        "true"
EndSection

#Section "Files"
#         ModulePath "/usr/lib64/xorg/modules"
#         ModulePath "/usr/lib64/opengl/xorg-x11/extensions/"
#EndSection
#Section "Extensions"
#         Option        "Composite"        "Enable"
#EndSection
#Section "ServerFlags"
#         Option        "AIGLX"            "On"
#EndSection

Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"

#       Modeline "1920x1080@60" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
        Identifier   "aticonfig-Monitor[0]-0"
#       ModeLine     "1920x1080_60.00" 173.0 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
#       Modeline "1920x1080@60" 182.28 1920 1952 2640 2672 1080 1102 1113 1135 -hsync +vsync
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "XAANoOffscreenPixmaps" "true"
#       Option      "TVOverscan" "on"
        BusID       "PCI:6:0:0"
EndSection


#xrandr -q

Code:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 1920 x 1920
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 disconnected (normal left inverted right x axis y axis)
DFP5 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080      60.0*+   50.0     59.9     30.0     25.0     30.0 
   1776x1000      50.0     59.9     25.0     30.0 
   1680x1050      50.0     60.0 
   1400x1050      50.0     60.0 
   1600x900       50.0     60.0 
   1360x1024      50.0     60.0 
   1280x1024      50.0     75.0     60.0 
   1440x900       50.0     59.9 
   1280x960       50.0     75.0     60.0 
   1152x864       50.0     59.9     75.0 
   1280x768       50.0     75.0     60.0 
   1280x720       60.0     50.0     59.9 
   1024x768       50.0     75.0     70.1     60.0 
   1152x648       50.0     59.9 
   800x600        50.0     72.2     75.0     60.3     56.2 
   720x576        59.9     50.0 
   720x480        50.0     60.0     59.9 
   640x480        50.0     75.0     72.8     67.0     60.0     59.9 
DFP6 disconnected (normal left inverted right x axis y axis)
DFP7 disconnected (normal left inverted right x axis y axis)
CRT1 disconnected (normal left inverted right x axis y axis)
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 259

PostPosted: Wed Aug 08, 2012 5:09 pm    Post subject: Reply with quote

I have the exact problem too. Give this a try http://phoronix.com/forums/showthread.php?72618-Catalyst-keeps-resetting-overscan , and for further reference http://wiki.cchtml.com/index.php/Configuring

This seems to have hit a lot of people all at the same time, which is strange...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum