Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
General Pulseaudio (and M-audio delta 1010lt) problems
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 15 Aug 2002
Posts: 3197
Location: Gainesville, Florida

PostPosted: Tue Jul 31, 2012 8:31 pm    Post subject: General Pulseaudio (and M-audio delta 1010lt) problems Reply with quote

I recently changed my sound card to the delsta 1010lt (3 gentoo installs on this box), and all three have constant problems with sound and flash/youtube.

My new Ubuntu Studio partition seems to work fine. At least sound (recording, playback, and youtube flash videos for the great sound tutorials) work out of the box with this card.

After days of reading forums for many distros and trying every fix/configuration/flash and other sound apps versions that seemed relevant, disabling onboard sound in the bios, and referring to all Gentoo sound related guides, I've had unsatisfactory results. Sound was working fine on Gentoo and many other distros I run until recently.

I'm about convinced pulseaudio isn't currently capable of working normally with this card, and that's my main problem, so my questions are:

1. Why has pulseaudio apparently been newly added as a default to various packages? It's causing many weird problems for many users.

2. Not withstanding that "equery d pulseaudio" reports other apps need it (shown below), can I completely get rid of it (even if I wish to run a kde desktop) with the global -pulseaudio USE flag, and run an emerge -uDN @world? (-pulse audio is strongly recommended by audiodef in his Gentoo guide for the "Pro Audio Overlay, but he isn't running kde)

In other words, can I rebuild the following without pulseaudio support, and expect not to have any major issues, or for that matter any issues at all?
 gentoo-audio wrc # equery d pulseaudio
 * These packages depend on pulseaudio:
gnome-base/gnome-control-center-3.2.3 (>=media-sound/pulseaudio-0.9.16[glib])
gnome-base/gnome-settings-daemon-3.2.3 (>=media-sound/pulseaudio-0.9.16)
gnome-base/gnome-shell- (media-sound/pulseaudio)
gnome-extra/cinnamon-1.4 (media-sound/pulseaudio)
kde-base/kmix-4.8.4 (pulseaudio ? >=media-sound/pulseaudio-0.9.12)
kde-base/phonon-kde-4.8.4 (pulseaudio ? >=media-sound/pulseaudio-0.9.21[glib])
media-libs/libao-1.1.0-r1 (pulseaudio ? media-sound/pulseaudio)
media-libs/libcanberra-0.29 (pulseaudio ? >=media-sound/pulseaudio-0.9.11)
media-libs/libsdl-1.2.15-r2 (pulseaudio ? media-sound/pulseaudio)
media-libs/phonon-4.6.0-r1 (pulseaudio ? >=media-sound/pulseaudio-0.9.21[glib])
media-plugins/alsa-plugins-1.0.25-r1 (pulseaudio ? media-sound/pulseaudio)
media-sound/fluidsynth-1.1.5 (pulseaudio ? >=media-sound/pulseaudio-0.9.8)
media-sound/mpg123-1.14.3 (pulseaudio ? media-sound/pulseaudio)
media-video/ffmpeg-0.10.4 (pulseaudio ? media-sound/pulseaudio)
media-video/mplayer-1.1-r1 (pulseaudio ? media-sound/pulseaudio)
media-video/vlc-2.0.3 (pulseaudio ? >=media-sound/pulseaudio-0.9.22)

Any advice is greatly appreciated.

I'm trying to set up a really good Linux DAW, but at this point the only thing that is even looking plausible is the Ubuntu Studio, or AVLinux. Tried most other "audio" distros over the years, but never been happy.

I'm thinking of doing a fresh amd64 Gentoo install using Audiodef's new overlay and guide, but to be honest I've tried this before on Gentoo and other distros, and never managed to achieve a stable functioning setup that didn't consume most of my time dealing with OS and app problems rather than recording actual music.

In fact, I became so frustrated with linux sound that I finally ordered a windows 7 retail disk, installed it on this same box (on sdb1), and it's been a good experience so far. Only problem is the pro apps costs a small fortune, so I'm still on the quest for the linux pro audio setup.

Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.28-r5, gcc-8.3.0 kernel-4.20.12-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum