Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing Libreoffice without installing cups
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
atoussaint
n00b
n00b


Joined: 31 Jul 2012
Posts: 7

PostPosted: Tue Jul 31, 2012 3:32 pm    Post subject: installing Libreoffice without installing cups Reply with quote

Hello,

I am trying to install libreoffice on my netbook without having to install cups. The reasons are that I never plugged in a printer on this netbook; also, cups fail to compile at the moment and it never did work consistently after a month of use regardless of the version, the printers or the computers and finally, it was compiled with standard cflags (--march=native -mtune=native -O2 on gcc 4.5.3).

I have tried masking the cups ebuild and replacing it with lprng but ghostscript-gpl insist on having cups support regardless of what I do and I did disable the cups useflags in both make.conf as well as /etc/portage/package.use.

any advices?

Alain
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Tue Jul 31, 2012 6:15 pm    Post subject: Reply with quote

libreoffice requires cups a build time dependency - at runtime, it can be disabled via the useflag.

Or simply put, if you want to install libreoffice, you have to install cups, but it can be removed afterwards.
as alternative, you can use libreoffice-bin, which has a runtime option for cups, but save you the build time needed to install libreoffice, and the cups workaround.


personally, i would go the libreoffice-bin way, as libreoffice has quite a long built time - and probably even an longer on one a netbook.


V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Jul 31, 2012 9:15 pm    Post subject: Reply with quote

Alternatively, you can use a recent version of LO (that means probably one of the live versions, I guess at least 3.6.9999, I don't know which version other than -9999 has it implemented already).
Code:

09 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
Introduce proper cups useflag. Thanks to Dave Flogeras.

_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Wed Aug 01, 2012 4:52 pm    Post subject: Reply with quote

gorkypl wrote:
Alternatively, you can use a recent version of LO (that means probably one of the live versions, I guess at least 3.6.9999, I don't know which version other than -9999 has it implemented already).
Code:

09 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
Introduce proper cups useflag. Thanks to Dave Flogeras.
fair point. I just had another look at the ebuilds, and I can confirm, that 3.6.9999 already includes it.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
nvanwyen
n00b
n00b


Joined: 25 Jan 2014
Posts: 9

PostPosted: Wed May 07, 2014 4:30 pm    Post subject: Reply with quote

.
Well that was a good call, and it did get past the LibreOffice issue, but that just opened up a whole bunch of others that still needed Boost 1.52. I really appreciate everyone that helped and provided feedback (great community).

Code:
# emerge -pqv  =dev-libs/libixion-0.7.0 =dev-util/mdds-0.10.3 =dev-cpp/libcmis-0.3.1 =dev-cpp/libcmis-0.3.1 =dev-libs/boost-1.55.0-r1 app-office/libreoffice
[ebuild  N    ] dev-util/cppunit-1.13.1  USE="-doc -examples -static-libs"
[ebuild  N    ] sys-devel/ucpp-1.3.4  USE="-static-libs"
[ebuild     U ] dev-util/boost-build-1.55.0 [1.52.0-r1] USE="-examples -python {-test}"
[ebuild     U ] dev-libs/boost-1.55.0-r1 [1.52.0-r6] USE="nls threads -context% -debug -doc -icu -mpi -python -static-libs -tools" PYTHON_TARGETS="python2_7 python3_3 (-python2_6) -python3_2"
[ebuild     U ] dev-util/mdds-0.10.3 [0.8.1]
[ebuild     U ] dev-libs/libixion-0.7.0 [0.5.0] USE="-static-libs"
[ebuild  N    ] dev-perl/Archive-Zip-1.300.0
[ebuild   R   ] dev-cpp/libcmis-0.3.1  USE="-man -static-libs {-test}"
[ebuild  N    ] app-office/libreoffice-4.1.4.2  USE="bluetooth branding cups dbus gtk opengl vba webdav (-aqua) -debug -eds -gnome -gstreamer -gtk3 -java -jemalloc -kde -mysql -odk -postgres -telepathy {-test}" LIBREOFFICE_EXTENSIONS="presenter-minimizer -nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 python3_3"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-util/mdds:0

  (dev-util/mdds-0.10.3::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/mdds-0.10.3
    >=dev-util/mdds-0.10.1:= required by (dev-libs/libixion-0.7.0::gentoo, ebuild scheduled for merge)

  (dev-util/mdds-0.8.1::gentoo, installed) pulled in by
    =dev-util/mdds-0.8*:= required by (app-office/libreoffice-4.1.4.2::gentoo, ebuild scheduled for merge)

dev-libs/libixion:0

  (dev-libs/libixion-0.7.0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/libixion-0.7.0

  (dev-libs/libixion-0.5.0::gentoo, installed) pulled in by
    <dev-libs/libixion-0.7:= required by (dev-libs/liborcus-0.5.1::gentoo, installed)
    >=dev-libs/libixion-0.5.0:0/0.5= required by (dev-libs/liborcus-0.5.1::gentoo, installed)

dev-libs/boost:0

  (dev-libs/boost-1.52.0-r6::gentoo, installed) pulled in by
    >=dev-libs/boost-1.51.0:0/1.52= required by (dev-libs/liborcus-0.5.1::gentoo, installed)
    dev-libs/boost:0/1.52= required by (dev-libs/libixion-0.5.0::gentoo, installed)

  (dev-libs/boost-1.55.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/boost-1.55.0-r1



Maybe a whole different approach would be to just get Boost 1.55 (from boost.org), booststrap and compile it to the stage myself, then adjust my search paths accordingly as needed. However, that feels more like giving up.

.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum