Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo Forever: The diary of a returning Gentoo user
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message

Joined: 07 May 2011
Posts: 38

PostPosted: Mon Aug 20, 2012 12:35 am    Post subject: Reply with quote

rlmaers wrote:
mrmylanman wrote:
Yeah, I'd recommend using something with some more punch.

Because my laptop has UEFI (and I wanted to boot in UEFI mode), I ended up using an Archboot image on a USB stick in order to boot up in UEFI mode, and just did the installation from that live environment, since I don't need Gentoo specific commands until after it's in the chroot anyway. Worked out pretty well, whereas the minimal image isn't UEFI compatible (perhaps that's why your system isn't booting? I see you have some very modern parts in there)

Hope this helps!

Yeah, it might be an UEFI thing, but it seems to support legacy booting as well. Are there any benefits to UEFI boot in place of legacy?


Alright. So I've tried several things to get this thing to boot, the promising being unetbootin. As I wrote above, I got an error message saying there was no operating system on the boot device. I don't know if that's an issue with unetbootin or the system. To exclude the latter I updated BIOS, which is a good thing even though it didn't help. :D

As for now I'm following this guide. Problem is that I can't be arsed to figure out fdisk on Mac OS X, as I suspect it won't get the job done anyway. My solution is to download SysRescCD and boot that on my Macbook in order to format the drive on there.

I'm learning the hard way.

UEFI alone is usually a bit faster that needing to load a bios.efi first. You also don't need an external bootloader, the kernel (3.3 and later) can function as it's own boot-loader if you compile it with the EFI_STUB option (and a few other efi related options) It's what I had to end up doing.

I know the 12.04 Ubuntu liveUSB has UEFI support if you use the tool on the liveCD to make the liveUSB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Goto page Previous  1, 2
Page 2 of 2

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum