Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] install libmatheval - cannot create directory
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 17 Feb 2006
Posts: 120
Location: Tuscany, Italy

PostPosted: Tue Jul 31, 2012 9:20 am    Post subject: [SOLVED] install libmatheval - cannot create directory Reply with quote

Dear gentoo users,
I need to install libmatheval (it's not in the portage tree).

I downloaded it ( placed it in /usr/local.
Then didt ./configure and make. Everything fine, but when it comes to make install it fails.

I really have no clue. My system is up to date (I m posting emerge --info at bottom). I really need to install this package as it is required by a software I need for work.

Many thanks in advance

make install
Making install in doc
make[1]: Entering directory `/usr/local/libmatheval-1.1.8/doc'
make[2]: Entering directory `/usr/local/libmatheval-1.1.8/doc'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/info" || /bin/mkdir -p "/usr/local/share/info"
 /usr/bin/install -c -m 644 ./ '/usr/local/share/info'
 install-info --info-dir='/usr/local/share/info' '/usr/local/share/info/'
make[2]: Leaving directory `/usr/local/libmatheval-1.1.8/doc'
make[1]: Leaving directory `/usr/local/libmatheval-1.1.8/doc'
Making install in lib
make[1]: Entering directory `/usr/local/libmatheval-1.1.8/lib'
make[2]: Entering directory `/usr/local/libmatheval-1.1.8/lib'
test -z "/usr/local/lib" || /bin/mkdir -p "/usr/local/lib"
/bin/mkdir: cannot create directory `/usr/local/lib': File exists
make[2]: *** [install-libLTLIBRARIES] Error 1
make[2]: Leaving directory `/usr/local/libmatheval-1.1.8/lib'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/usr/local/libmatheval-1.1.8/lib'
make: *** [install-recursive] Error 1

emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.14.1-r3, 3.3.8-gentoo x86_64)
System uname: Linux-3.3.8-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Mon, 30 Jul 2012 08:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X \ a52 aac acl acpi alsa amd64 atlas audiofile avi berkdb bitmap-fonts blas bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups curl cxx dbus device-mapper doc dri dts dv dvd dvdr emacs emboss encode exif f77 fam ffmpeg firefox flac foomaticdb fortran gd gdbm gdu gif glut gpm gtk gtk2 iconv imagemagick ipv6 java jpeg lapack lcms ldap libnotify live lock mad mjpeg mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ntp ntponly ogg oggvorbis opengl openmp pam pango pcre pdf pdflib png policykit ppds pppd python qt3support qt4 readline sdl session slang spell sse sse2 ssl startup-notification svg symlink tcltk tcpd theora thunar tiff truetype truetype-fonts type1-fonts udev udisks unicode upower usb vorbis wmf wxwidgets x264 xcb xemacs xface xivd xml xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by ad_meis on Tue Jul 31, 2012 4:34 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Jul 31, 2012 10:04 am    Post subject: Reply with quote

You should make it in your home dir, and then install as root. Now the building dir is overlapping with the install dir.

Anyway, first record from google:

Grab it, rename to libmatheval-1.1.8.ebuild, create a local overlay and emerge in a regular way. Much cleaner and simpler solution :)
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 17 Feb 2006
Posts: 120
Location: Tuscany, Italy

PostPosted: Tue Jul 31, 2012 4:34 pm    Post subject: Reply with quote

creating the local overlay did the job
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum