Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ironically enough, urxvt isn't displaying unicode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
numberlessusername
n00b
n00b


Joined: 29 Dec 2011
Posts: 20

PostPosted: Tue Jul 31, 2012 4:36 am    Post subject: [SOLVED] ironically enough, urxvt isn't displaying unicode Reply with quote

or something? I can copypaste unicode characters into chromium just fine but they all appear as question marks in urxvt. xterm also shows them just fine. ☭☭☭

any ideas?


Last edited by numberlessusername on Wed Aug 01, 2012 4:20 am; edited 1 time in total
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Jul 31, 2012 7:32 am    Post subject: Reply with quote

How have you configured urxvt? Also please paste the result of 'emerge --info' and 'emerge -pqv rxvt-unicode'.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2928
Location: Germany

PostPosted: Tue Jul 31, 2012 11:56 am    Post subject: Reply with quote

It works for me but I set it to use an Unicode font in Xresources

Code:

URxvt*font:      -Misc-Fixed-Medium-R-Normal--18-120-100-100-C-90-ISO10646-1,\
         -Misc-Fixed-Medium-R-Normal-ja-18-120-100-100-C-180-ISO10646-1,\
         xft:Bitstream Cyberbit:pixelsize=18
Back to top
View user's profile Send private message
numberlessusername
n00b
n00b


Joined: 29 Dec 2011
Posts: 20

PostPosted: Tue Jul 31, 2012 5:01 pm    Post subject: Reply with quote

.Xdefaults (urxvt configuration)
emerge --info
emerge --pqv rxvt-unicode

I'll try changing the font, that might do it.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Jul 31, 2012 5:14 pm    Post subject: Reply with quote

Yes, the font would be also my guess. Notice that for some fonts you will need USE='xft'.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
numberlessusername
n00b
n00b


Joined: 29 Dec 2011
Posts: 20

PostPosted: Tue Jul 31, 2012 6:37 pm    Post subject: Reply with quote

well I reemerged rxvt-unicode with the xft flag and copypasted frostschutz's snippet into my file but unicode characters still aren't working.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Jul 31, 2012 7:29 pm    Post subject: Reply with quote

Have you installed the font that is mentioned in his config?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
numberlessusername
n00b
n00b


Joined: 29 Dec 2011
Posts: 20

PostPosted: Tue Jul 31, 2012 7:50 pm    Post subject: Reply with quote

yes I have
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Jul 31, 2012 8:13 pm    Post subject: Reply with quote

Uh, I am not sure he is using a font that you want.
Try starting with Terminus, as it is proved to work reliable.
Code:

URxvt.font:             xft:Terminus:pixelsize=14:antialias=false
URxvt.boldFont:         xft:Terminus:bold:pixelsize=14:antialias=false

_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
numberlessusername
n00b
n00b


Joined: 29 Dec 2011
Posts: 20

PostPosted: Tue Jul 31, 2012 8:27 pm    Post subject: Reply with quote

yeah I tried terminus, it still doesn't work. the thing that's confusing me most is why is it working in xterm but not urxvt
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2928
Location: Germany

PostPosted: Tue Jul 31, 2012 8:56 pm    Post subject: Reply with quote

did you start a new urxvt and load the new xresources before you did so?

(xrdb -load file)
Back to top
View user's profile Send private message
numberlessusername
n00b
n00b


Joined: 29 Dec 2011
Posts: 20

PostPosted: Tue Jul 31, 2012 9:08 pm    Post subject: Reply with quote

well I guess some unicode is showing now. things like ‽ and â work but ☭ doesn't, so I guess it's a font thing now. thanks! I just restarted the x server a bunch of times without changing anything and now it works.

EDIT: okay wait new realization

if I open urxvt normally through the window manager with meta+enter then unicode doesn't work. if I launch urxvt from a urxvt window, unicode will work in the upper one. ehhhh.

EDIT AGAIN: okay it works now but I'm not quite sure what I did.

ANOTHER EDIT: in another topic which I imagine had the same issue, they said to include "export LANG=en_US.UTF-8" in .xinitrc. I didn't have that but it sounds reasonable so if anyone with this issue finds this topic through the googlebox or whatever, they can try it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum