Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mplayer freezes after feh is used
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
nc-pv
n00b
n00b


Joined: 01 Oct 2012
Posts: 24
Location: FL, USA

PostPosted: Fri Jan 05, 2018 2:50 pm    Post subject: Mplayer freezes after feh is used Reply with quote

Hello,

I am running mplayer-1.3.0 remotely on a Gentoo Linux computer (4.1.43-gentoo-r1, x86_64):
Code:
mplayer -display :0.0 -slave -msglevel all=4 -input file=/tmp/mplayer_cmd /home/user/video.mkv


Where /tmp/mplayer_cmd is a named pipe created beforehand.

Config file ~/.mplayer/config:
Code:
vo=vdpau
vc=ffh264vdpau
fs=1


There is no display manager.

I need to pause playback and display a PNG image on the screen with Feh program.

Mplayer is paused like this:
Code:
echo -n -e 'pausing get_file_name\x0A' > /tmp/mplayer_cmd


Then, feh is called (and the picture appears on the screen)
Code:

DISPLAY=:0.0 feh /home/user/image.png


The problem comes when I need to stop feh and continue playback:

CTRL+C is pressed to stop feh. Feh process disappears, however, the image stays on the screen.

An attempt to resume playback fails - mplayer simply does not react, nor respond on any command:
Code:
echo -n -e 'get_file_name\x0A' > /tmp/mplayer_cmd


At the same time CPU usage of mplayer process goes to 100%.

What seems to make mplayer alive again is any keystroke (even pressing ALT button works). At which point mplayer resumes playback and responds to ALL commands that were sent to it while it was frozen. Using the keyboard to unpause the mplayer in first place does not cause this strange behavior. It only occurs when mplayer is commanded with slave protocol.

So, I am trying to understand what is this element that hangs and waits for a keystroke.

Does anybody have any idea what is going on?
_________________
Use GNU/Linux
Back to top
View user's profile Send private message
blopsalot
n00b
n00b


Joined: 28 Jan 2017
Posts: 74

PostPosted: Fri Jan 05, 2018 6:41 pm    Post subject: Reply with quote

mplayer is not quite abandoned, but 1.3.0 is almost 2 years old. you may want to try https://wiki.gentoo.org/wiki/Mpv
Back to top
View user's profile Send private message
nc-pv
n00b
n00b


Joined: 01 Oct 2012
Posts: 24
Location: FL, USA

PostPosted: Fri Jan 05, 2018 9:49 pm    Post subject: Reply with quote

Blopsalot,

Thank you for your response. First, I would like to see if I can make it work with mplayer.
_________________
Use GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum