Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox 54 not showing checkboxes/radios
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 217

PostPosted: Tue Jun 20, 2017 7:57 am    Post subject: Firefox 54 not showing checkboxes/radios Reply with quote

Newest firefox for me does not show any radios/checkboxes. Here is a very simple test.

Code:
1 <input type="radio"> 2 <input type="checkbox"> 3


For me it looks like this http://imgur.com/a/4IqLG

Code:
$ equery u firefox
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for www-client/firefox-54.0:
 U I
 - - bindist              : Disable official Firefox branding (icons, name) which are not
                            binary-redistributable according to upstream.
 + + custom-cflags        : Build with user-specified CFLAGS (unsupported)
 + + custom-optimization  : Build with user-specified compiler optimizations (-Os, -O0, -O1, -O2,
                            -O3) from CFLAGS (unsupported)
 + + dbus                 : Enable dbus support for anything that needs it (gpsd, gnomemeeting,
                            etc)
 - - debug                : Enable extra debug codepaths, like asserts and extra output. If you
                            want to get meaningful backtraces see
                            https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 + + gmp-autoupdate       : Allow Gecko Media Plugins (binary blobs) to be automatically downloaded
                            and kept up-to-date in user profiles
 - - hardened             : Activate default security enhancements for toolchain (gcc, glibc,
                            binutils)
 + + hwaccel              : Force-enable hardware-accelerated rendering (Mozilla bug 594876)
 - - jack                 : Add support for the JACK Audio Connection Kit
 + + jemalloc             : Enable or disable jemalloc
 + - jit                  : Enable just-in-time compilation for improved performance. May prevent
                            use of some PaX memory protection features in Gentoo Hardened.
 - - kde                  : Add support for KDE (K Desktop Environment)
 - - l10n_ru              : Russian
 - - nsplugin             : Enable support for NPAPI plugins other than flash
 - - pgo                  : Add support for profile-guided optimization using gcc-4.5, for faster
                            binaries. This option will double the compile time.
 + + pulseaudio           : Add support for PulseAudio sound server
 + + startup-notification : Enable application startup event feedback mechanism
 + + system-harfbuzz      : Use the system-wide media-libs/harfbuzz and media-gfx/graphite2 instead
                            of bundled.
 + + system-icu           : Use the system-wide dev-libs/icu instead of bundled.
 + + system-jpeg          : Use the system-wide media-libs/libjpeg-turbo instead of bundled.
 + + system-libevent      : Use the system-wide dev-libs/libevent instead of bundled.
 + + system-libvpx        : Use the system-wide media-libs/libvpx instead of bundled.
 + + system-sqlite        : Use the system-wide dev-db/sqlite installation with secure-delete
                            enabled
 - - test                 : Workaround to pull in packages needed to run with FEATURES=test.
                            Portage-2.1.2 handles this internally, so don't set it in
                            make.conf/package.use anymore


I did find this https://bugzilla.mozilla.org/show_bug.cgi?id=1373573 so it looks like a linux+gtk issue although I did not experience this until v54 and this is v52. Anyone else experiencing this?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7084
Location: ~Brussels - Belgique

PostPosted: Tue Jun 20, 2017 8:12 am    Post subject: Reply with quote

Hi,

Can you try to change your GTK+ theme? Some of them are not complete and the checkboxes are not shown.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 217

PostPosted: Wed Jun 21, 2017 6:28 pm    Post subject: Reply with quote

Tried a couple different gtk themes, no change. I'll have to dig deeper into this.
Back to top
View user's profile Send private message
Dekan
n00b
n00b


Joined: 30 May 2002
Posts: 6

PostPosted: Fri Jun 23, 2017 2:14 am    Post subject: Reply with quote

The GTK3 themes do affect things like renderings of checkboxes in about:preferences, but html form widgets on regular webpages seem to just be a border collapsed around nothing. A tiny capture of what a radio button looks like on my browser: http://imgur.com/a/sp04R

Everyone probably has their own little html radio button/checkbox test page, but in case not, I use: https://www.w3schools.com/html/tryit.asp?filename=tryhtml_form_radio
Back to top
View user's profile Send private message
Dekan
n00b
n00b


Joined: 30 May 2002
Posts: 6

PostPosted: Fri Jun 23, 2017 2:22 am    Post subject: Reply with quote

Well, I restarted with addons disabled and it the problem wasn't there anymore, so now it's just an isolation exercise.....
Back to top
View user's profile Send private message
Dekan
n00b
n00b


Joined: 30 May 2002
Posts: 6

PostPosted: Fri Jun 23, 2017 4:13 am    Post subject: Reply with quote

I noticed that Firefox 54 has this change:
Quote:
<input> elements of types checkbox and radio with -moz-appearance: none; set on them are now non-replaced elements, for compatibility with other browsers (bug 605985 https://bugzilla.mozilla.org/show_bug.cgi?id=605985).

I had a custom userContent.css that I had been using from http://www.jitblog.net/firefox-does-not-display-checkboxes-and-radio-buttons/

To solve the problem, in the section for
Code:
input[type="radio"]
I commented out
Code:
-moz-appearance: none !important;
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 217

PostPosted: Sat Jun 24, 2017 10:38 pm    Post subject: Reply with quote

The userContent.css was also the issue for me but it's wasn't a complete solution to my problem as the GTK dark themes were running havoc again. However I found this extension https://addons.mozilla.org/en-US/firefox/addon/text-contrast-for-dark-themes/ which is a much better solution. Other solutions can also be found here https://wiki.archlinux.org/index.php/Firefox#Unreadable_input_fields_with_dark_GTK.2B_themes
Back to top
View user's profile Send private message
DhruvSingh7278
n00b
n00b


Joined: 15 Jul 2017
Posts: 5

PostPosted: Thu Jul 27, 2017 7:29 am    Post subject: Reply with quote

1. Navigate to the Firefox profile folder location.

NOTE: The default profile is located in ~/.mozilla/firefox/xyz5abcd.default-1234123412345, where xyz5abcd.default-1234123412345 is generated by Firefox.
2. Create a folder called chrome if it does not exist.

3. Create a file called userContent.css in the chrome folder.

4. Open the userContent.css in a text editor and copy the following content. Modify according to your preference.

CSS
// path: /home/$USER/.mozilla/firefox/<RANDOM>.default/chrome/userContent.css
input {
border: 2px inset white;
background-color: white;
color: black;
-moz-appearance: none !important;
}

input[type="radio"],
input[type="checkbox"] {
border: 2px inset white !important;
background-color: white !important;
color: ThreeDFace !important;
-moz-appearance: none !important;
}

*|*::-moz-radio {
background-color: white;
-moz-appearance: none !important;
}

body {
background-color: white;
color: black;
display: block;
margin: 8px;
-moz-appearance: none !important;
}
5. Save and close the file.

6. Launch Firefox and verify the fix.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 10816

PostPosted: Fri Jul 28, 2017 1:44 am    Post subject: Reply with quote

DhruvSingh7278: if you read up thread, you will see that -moz-appearance:none is the problem, not the solution. Indeed, your instructions appear to be copied from the blog which gave Dekan the styles that ultimately conflicted with this Firefox change. Advocating use of the change he just told us broke it seems rather counterproductive.

Several users have raised concerns that you are not a new user, but rather a lurking profile spammer. If you are legitimately trying to help, please be more careful.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38264
Location: 56N 3W

PostPosted: Fri Jul 28, 2017 12:21 pm    Post subject: Reply with quote

Saundersx,

You need to build firefox with -O2 to fix the rendering issues.
The default is -Os, forced by the build system.

If your CFLAGS already contains -O2, then
Code:
USE=custom-optimization emerge firefox
will tell firefox to use it.
You may also need CXXFLAGS="${CXXFLAGS} -mno-avx" See www-client/firefox-53.0 failed startup cache generation
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum