Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Mon Oct 21, 2013 4:36 pm    Post subject: Reply with quote

Hi shiznix

Thanks for your reply, after my sync up:
Code:
emerge --sync && layman -S

i was stuck with lots of multi slot issues again. And udev blocking systemd and vice versa

Before I go on or even dare to reboot I should probably know hwo to go on with udev vs systemd. I tried going for systemd but udev keeps on being being pulled in so there is no way for me to switch to systemd easily. I can't identify why udev is being pulled in all the time.

I honestly do not care if I use systmd or udev but during my new use deep update world some packages started in pulling systemd... I am totally lost. Do I need to switch to systemd for my deep update new use to go through when using the unity-overlay? If yes, how to get rif of udev being pulled in. If no how to avoid systemd being pulled in...?

thansk for any suggestion.

EDIT1: Forget the udev vs. systemd outburst above ^^

Making sure that i consistently make use of udev i can't see at which point my systemd problem came into play...

Still also without this i have lots of blockers and multi slots:
Code:

[blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking gnome-base/gdm-3.8.4-r3)
[blocks B      ] x11-misc/notification-daemon ("x11-misc/notification-daemon" is blocking x11-misc/notify-osd-0.9.34)
[blocks B      ] x11-misc/notify-osd ("x11-misc/notify-osd" is blocking x11-misc/notification-daemon-0.5.0)
[blocks B      ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.38.1)
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.38.0)

Fetch instructions for dev-java/oracle-jre-bin-1.7.0.45:
 * Please download 'jre-7u45-linux-x64.tar.gz' from:
 * 'http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html'
 * and move it to '/usr/portage/distfiles'
 * Also download 'UnlimitedJCEPolicyJDK7.zip' from:
 * 'http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html'
 * and move it to '/usr/portage/distfiles'

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/pango:0

  (x11-libs/pango-1.30.1::gentoo, ebuild scheduled for merge) pulled in by
    <x11-libs/pango-1.31[X] required by (x11-libs/gtkglext-1.2.0-r1::gentoo, installed)

  (x11-libs/pango-1.34.1::gentoo, installed) pulled in by
    >=x11-libs/pango-1.32.4[introspection?] required by (x11-libs/gtk+-3.8.4_p0_p03::unity-gentoo, installed)
    (and 1 more with the same problem)

dev-libs/libxslt:0

  (dev-libs/libxslt-1.1.28-r1::gentoo, installed) pulled in by
    dev-libs/libxslt[python,python_targets_python2_7(-)?,python_single_target_python2_7(+)?] required by (unity-base/bamf-0.5.1_p0_p01-r1::unity-gentoo, installed)

  (dev-libs/libxslt-1.1.28-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
    ~net-libs/libsoup-2.38.1[introspection?] required by (net-libs/libsoup-gnome-2.38.1::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-2.42.2-r1::gentoo, installed) pulled in by
    >=net-libs/libsoup-2.42.0:2.4[introspection?] required by (dev-libs/libgdata-0.14.0::gentoo, installed)
    (and 4 more with the same problem)

app-admin/packagekit-base:0

  (app-admin/packagekit-base-0.7.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-admin/packagekit-base-0.7.4::gentoo, installed) pulled in by
    app-admin/packagekit-base[networkmanager,-nsplugin,policykit,udev] required by (unity-indicators/indicator-session-12.10.5_p0_p01::unity-gentoo, installed)

gnome-base/gnome-desktop:3

  (gnome-base/gnome-desktop-3.6.3::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-desktop-3.6.0.1:3/4=[introspection] required by (gnome-extra/gnome-tweak-tool-3.6.1-r1::gentoo, installed)
    gnome-base/gnome-desktop:3/4= required by (gnome-extra/gnome-color-manager-3.6.1::gentoo, installed)
    (and 6 more with the same problems)

  (gnome-base/gnome-desktop-3.8.4_p0_p01::unity-gentoo, installed) pulled in by
    >=gnome-base/gnome-desktop-3.7.90:3 required by (gnome-base/gnome-session-3.9.90_p0_p03::unity-gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

dev-libs/libgweather:2

  (dev-libs/libgweather-3.6.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgweather-3.5.1:2/3-1= required by (gnome-base/gnome-panel-3.6.2::gentoo, installed)

  (dev-libs/libgweather-3.8.2::gentoo, installed) pulled in by
    >=dev-libs/libgweather-3.5:2/3-3= required by (gnome-extra/evolution-data-server-3.8.5::gentoo, installed)

gnome-base/gvfs:0

  (gnome-base/gvfs-1.14.2::gentoo, installed) pulled in by
    gnome-base/gvfs[fuse] required by (app-backup/deja-dup-26.0_p0_p01::unity-gentoo, installed)

  (gnome-base/gvfs-1.14.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/udev:0

  (virtual/udev-200::gentoo, installed) pulled in by
    =virtual/udev-200[gudev] required by (media-gfx/shotwell-0.14.1::gentoo, installed)
    (and 34 more with the same problem)

  (virtual/udev-206-r3::gentoo, ebuild scheduled for merge) pulled in by
    virtual/udev[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/mesa-9.2.1_p1_p03::unity-gentoo, ebuild scheduled for merge)
    >=virtual/udev-206-r2 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problems)

sys-fs/udev:0

  (sys-fs/udev-204::gentoo, installed) pulled in by
    >=sys-fs/udev-200[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?] required by (virtual/udev-200::gentoo, installed)

  (sys-fs/udev-208::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-206-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] required by (virtual/udev-206-r3::gentoo, ebuild scheduled for merge)

sys-apps/kmod:0

  (sys-apps/kmod-13-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-apps/kmod-15::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/kmod-14 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)

sys-apps/hwids:0

  (sys-apps/hwids-20130915.1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/hwids-20130717-r1[udev] required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)

  (sys-apps/hwids-20130329::gentoo, installed) pulled in by
    <sys-apps/hwids-20130915[udev] required by (sys-fs/udev-204::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.38.0::unity-gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/totem-pl-parser-3.4.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/cheese-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.8.4_p0_p01::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.14.1_pre20130901::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/libsecret-0.15-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-3.2.6_p0_p01::unity-gentoo, installed)
    dev-libs/gobject-introspection required by (media-libs/memphis-0.2.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/totem-3.8.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/libgweather-3.6.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.36.0 required by (dev-libs/gjs-1.36.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.6.8::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-0.1.28::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.36.0 required by (dev-libs/libsignon-glib-1.10_p0_p01-r1::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (gnome-base/gnome-shell-3.6.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (app-editors/gedit-3.6.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/libgtop-2.28.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/rest-0.7.12::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.3 required by (media-gfx/eog-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.8.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.18.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/gtksourceview-3.6.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:= required by (dev-libs/libgee-0.10.5::gentoo, installed)
    dev-libs/gobject-introspection required by (dev-libs/libunity-webapps-2.5.0a_p0_p01-r3::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/clutter-gtk-1.4.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.38.1::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (gnome-extra/zeitgeist-0.9.14::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (dev-libs/folks-0.9.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.2-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/libgweather-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (dev-libs/libindicate-12.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.36 required by (unity-base/ubuntuone-control-panel-13.09_p0_p01::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-3.8.2_p0_p02::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.9 required by (app-admin/packagekit-base-0.7.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (app-cdr/brasero-3.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/clutter-gst-2.0.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-204::gentoo, installed)
    dev-libs/gobject-introspection required by (unity-base/bamf-0.5.1_p0_p01-r1::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.10.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (app-i18n/ibus-1.5.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.0::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (dev-libs/libdbusmenu-12.10.3a_p0_p02::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-farstream-0.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.4_p0_p03::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (dev-libs/libaccounts-glib-1.14_p0_p01::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.20 required by (dev-python/pygobject-3.2.2-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6:= required by (dev-libs/libgee-0.6.8::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.14.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-3.4.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (net-libs/gnome-online-accounts-3.8.4.1::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (net-libs/libsocialweb-0.25.21::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.7 required by (app-accessibility/caribou-0.4.11::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.8.0_p1_p05::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.12.2.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (sys-apps/accountsservice-0.6.29_p1_p08-r2::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.9::gentoo, installed)
    dev-libs/gobject-introspection required by (media-libs/libchamplain-0.12.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.6.3::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (net-dns/avahi-0.6.31-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.9 required by (app-admin/packagekit-base-0.7.4::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (x11-libs/mx-1.4.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-panel-3.6.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (media-libs/clutter-1.14.4-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/libgnomekbd-3.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (gnome-extra/sushi-3.8.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (net-im/telepathy-logger-0.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (x11-misc/lightdm-1.6.0_p0_p0201-r3::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-libs/colord-gtk-0.1.24::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.30.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.6.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.1-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.0_p1_p01-r1::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.0 required by (media-sound/rhythmbox-2.99.1_p0_p01-r1::unity-gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-wireless/gnome-bluetooth-3.8.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.3 required by (net-misc/networkmanager-0.9.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.20_p1_p01::unity-gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-util/glade-3.12.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.2.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-wm/mutter-3.8.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.10.2-r300::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (gnome-extra/evolution-data-server-3.8.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (gnome-base/gdm-3.8.4-r3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.38.1::gentoo, ebuild scheduled for merge)

  (x11-misc/notify-osd-0.9.34::gentoo, installed) pulled in by
    x11-misc/notify-osd required by @selected
    x11-misc/notify-osd required by (x11-themes/notify-osd-icons-0.7::gentoo, installed)

  (dev-lang/vala-0.16.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/vala:0.16 required by (unity-base/gnome-control-center-signon-0.1.6_p0_p0101::unity-gentoo, installed)
    dev-lang/vala:0.16 required by (app-backup/deja-dup-26.0_p0_p01::unity-gentoo, installed)

  (sys-apps/openrc-0.11.8::gentoo, installed) pulled in by
    sys-apps/openrc required by @system
    sys-apps/openrc:= required by (app-admin/openrc-settingsd-1.0.1::gentoo, ebuild scheduled for merge)
    sys-apps/openrc required by (virtual/service-manager-0::gentoo, ebuild scheduled for merge)
    sys-apps/openrc required by (dev-db/mysql-init-scripts-2.0_pre1-r3::gentoo, installed)

  (gnome-base/gdm-3.8.4-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gdm-3.5[introspection] required by (gnome-base/gnome-shell-3.6.3.1::gentoo, installed)
    gnome-base/gdm required by (unity-base/unity-meta-7.0.0-r2::unity-gentoo, installed)

  (dev-lang/vala-0.14.2-r2::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/vala:0.14[vapigen] required by (net-libs/gssdp-0.12.2.1::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.14[vapigen] required by (unity-indicators/indicator-sound-12.10.2_p0_p01::unity-gentoo, installed)

  (dev-lang/vala-0.18.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/vala:0.18 required by (media-libs/memphis-0.2.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (media-libs/libchamplain-0.12.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (dev-libs/libindicate-12.10.1::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (net-libs/telepathy-glib-0.20.1-r1::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.18[vapigen] required by (net-misc/networkmanager-0.9.8.2::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (gnome-base/librsvg-2.36.4-r1::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (gnome-base/libgnome-keyring-3.8.0::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (gnome-extra/evolution-data-server-3.8.5::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (unity-lenses/unity-lens-video-0.3.14_p0_p01-r1::unity-gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (app-crypt/libsecret-0.15-r1::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (dev-libs/folks-0.9.3::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (net-libs/libsocialweb-0.25.21::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (unity-lenses/unity-lens-music-6.8.1_p0_p01-r1::unity-gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (x11-misc/colord-0.1.28::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.18[vapigen] required by (net-libs/account-plugins-0.10_p0_p0101::unity-gentoo, installed)
    dev-lang/vala:0.18 required by (media-gfx/shotwell-0.14.1::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (app-i18n/ibus-1.5.2::gentoo, installed)
    dev-lang/vala:0.18[vapigen] required by (x11-libs/colord-gtk-0.1.24::gentoo, installed)

  (net-libs/libsoup-gnome-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
    net-libs/libsoup-gnome required by (unity-lenses/unity-lens-video-0.3.14_p0_p01-r1::unity-gentoo, installed)
    >=net-libs/libsoup-gnome-2.26.0 required by (gnome-base/gvfs-1.14.2::gentoo, ebuild scheduled for merge)
    >=net-libs/libsoup-gnome-2.30:2.4 required by (dev-libs/totem-pl-parser-3.4.5::gentoo, installed)
    >=net-libs/libsoup-gnome-2.25.1:2.4 required by (dev-libs/libgweather-3.6.2::gentoo, ebuild scheduled for merge)
    >=net-libs/libsoup-gnome-2.37.91:2.4[introspection?] (>=net-libs/libsoup-gnome-2.37.91:2.4[introspection]) required by (dev-libs/libgdata-0.14.0::gentoo, installed)
    net-libs/libsoup-gnome required by (media-sound/rhythmbox-2.99.1_p0_p01-r1::unity-gentoo, ebuild scheduled for merge)
    >=net-libs/libsoup-gnome-2.26.0 required by (gnome-base/gvfs-1.14.2::gentoo, installed)
    >=net-libs/libsoup-gnome-2.25.1:2.4 required by (net-libs/libsocialweb-0.25.21::gentoo, installed)
    net-libs/libsoup-gnome required by (unity-lenses/unity-lens-photos-1.0_p0_p01::unity-gentoo, installed)
    net-libs/libsoup-gnome:2.4 required by (media-libs/libchamplain-0.12.3::gentoo, installed)
    >=net-libs/libsoup-gnome-2.25.1:2.4 required by (net-libs/rest-0.7.12::gentoo, ebuild scheduled for merge)

  (x11-misc/notification-daemon-0.5.0::gentoo, ebuild scheduled for merge) pulled in by
    x11-misc/notification-daemon required by (gnome-base/gnome-fallback-3.6.2::unity-gentoo, installed)
    x11-misc/notification-daemon required by (virtual/notification-daemon-0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by sys-fs/udev-208
# required by virtual/udev-206-r3
# required by media-libs/mesa-9.2.1_p1_p03::unity-gentoo[gbm]
# required by x11-libs/cairo-1.12.14-r4[opengl]
# required by mail-client/thunderbird-17.0.9
# required by @selected
# required by @world (argument)
=sys-apps/hwids-20130915.1 ~amd64
# required by gnome-base/nautilus-3.8.2_p0_p02::unity-gentoo
# required by gnome-extra/sushi-3.8.1
=gnome-base/gnome-desktop-3.6.3 ~amd64
# required by gnome-base/gnome-control-center-3.6.3_p0_p2401::unity-gentoo
# required by unity-base/unity-7.1.2_p0_p01-r1::unity-gentoo
# required by unity-lenses/unity-lens-files-7.1.0_p0_p01-r2::unity-gentoo
# required by unity-lenses/unity-lens-meta-7.0.0::unity-gentoo[files]
# required by unity-base/unity-meta-7.0.0-r2::unity-gentoo
# required by @selected
# required by @world (argument)
=app-admin/openrc-settingsd-1.0.1 ~amd64
# required by sys-fs/udev-208[kmod]
# required by virtual/udev-206-r3
# required by media-libs/mesa-9.2.1_p1_p03::unity-gentoo[gbm]
# required by x11-libs/cairo-1.12.14-r4[opengl]
# required by mail-client/thunderbird-17.0.9
# required by @selected
# required by @world (argument)
=sys-apps/kmod-15 ~amd64
# required by gnome-base/gnome-core-apps-3.6.2
# required by unity-base/unity-meta-7.0.0-r2::unity-gentoo[gnome]
# required by @selected
# required by @world (argument)
=net-im/empathy-3.8.4_p1_p01 ~amd64
# required by media-libs/libcanberra-0.30-r1[udev,alsa]
# required by x11-misc/notification-daemon-0.5.0
# required by virtual/notification-daemon-0[-gnome]
# required by x11-libs/libnotify-0.7.5-r1
# required by mail-client/thunderbird-17.0.9[libnotify]
# required by @selected
# required by @world (argument)
=virtual/udev-206-r3 ~amd64
# required by virtual/udev-206-r3
# required by media-libs/mesa-9.2.1_p1_p03::unity-gentoo[gbm]
# required by x11-libs/cairo-1.12.14-r4[opengl]
# required by mail-client/thunderbird-17.0.9
# required by @selected
# required by @world (argument)
=sys-fs/udev-208 ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by net-libs/libsoup-gnome-2.38.1
# required by dev-libs/libgweather-3.6.2
# required by gnome-base/gnome-panel-3.6.2
# required by unity-indicators/indicator-applet-12.10.2_p0_p01::unity-gentoo
# required by unity-indicators/unity-indicators-meta-7.0.0-r1::unity-gentoo
# required by unity-base/unity-meta-7.0.0-r2::unity-gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/mymask:
=net-libs/libsoup-2.38.1
# required by gnome-base/nautilus-3.8.2_p0_p02::unity-gentoo
# required by gnome-extra/sushi-3.8.1
# /etc/portage/package.mask/unity-portage.pmask:
=gnome-base/gnome-desktop-3.6.3

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- x11-libs/gtk+-2.24.20_p1_p01::unity-gentoo (masked by: package.mask)
- sys-libs/db-5.1.29::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2012)
# Masked for testing

- gnome-base/gnome-panel-3.6.2::gentoo (masked by: package.mask)
- dev-libs/libgee-0.6.8::gentoo (masked by: package.mask)
- x11-libs/libwnck-2.31.0::gentoo (masked by: package.mask)
- x11-libs/vte-0.28.2-r206::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I am going to comfort the requested keyword and mask changes an see what's next

EDIT1: after satisfying the the requested changes I end uo here:
Code:
The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/nautilus-3.8.2_p0_p02::unity-gentoo
# required by gnome-extra/sushi-3.8.1
# /etc/portage/package.mask/unity-portage.pmask:
=gnome-base/gnome-desktop-3.6.3
root@zenbook [/usr/src/linux]# ll /etc/portage/package.mask/unity-portage.pmask
lrwxrwxrwx 1 root root 48 20. Okt  02:36 /etc/portage/package.mask/unity-portage.pmask -> /var/lib/layman/unity-gentoo/unity-portage.pmask


This gnome-3.6 stuff is masked by the /var/lib/layman/unity-gentoo/unity-portage.pmask and I think this is by intention? So what am I supposed to do here? however it seems to be required for sushi and nautlius 3.8??

Edit2:
stuck here
Code:

[blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking gnome-base/gdm-3.8.4-r3)

to resolve this i can set systemd -consolekit globally but that results in udev vs systemd again:
Code:

[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-204-r1)
[blocks B      ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking sys-apps/kmod-15)
[blocks B      ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.38.1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-204, sys-fs/udev-208)


okay, now switching to systemd was working unpromblematic however I am facing this last blocker now:
Code:

[ebuild  N    ~] unity-lenses/unity-lens-files-7.1.0_p0_p01-r2  USE="-debug"
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-204-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-208)

Fetch instructions for dev-java/oracle-jre-bin-1.7.0.45:
 * Please download 'jre-7u45-linux-x64.tar.gz' from:
 * 'http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html'
 * and move it to '/usr/portage/distfiles'
 * Also download 'UnlimitedJCEPolicyJDK7.zip' from:
 * 'http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html'
 * and move it to '/usr/portage/distfiles'

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-204-r1::gentoo, installed) pulled in by
    sys-apps/systemd required by (sys-apps/dbus-1.6.12::gentoo, installed)
    >=sys-apps/systemd-39 required by (media-sound/pulseaudio-2.1-r1::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (sys-auth/polkit-0.112::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186 required by (sys-apps/accountsservice-0.6.34_p0_p06::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.8.3_p0_p01-r3::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (net-misc/networkmanager-0.9.8.8::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (gnome-base/gvfs-1.16.3-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186[pam] required by (gnome-base/gdm-3.8.4-r3::gentoo, ebuild scheduled for merge)
    <sys-apps/systemd-205 required by (sys-apps/gentoo-systemd-integration-1::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.8.4-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (gnome-base/gnome-session-3.9.90_p0_p03::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-197 required by (sys-fs/udisks-2.1.0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44 required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-204-r1 required by (sys-apps/gentoo-systemd-integration-1::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.8.5_p0_p09::unity-gentoo, ebuild scheduled for merge)

  (sys-fs/udev-208::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-206-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] (>=sys-fs/udev-206-r2[abi_x86_64(-),gudev,introspection,kmod]) required by (virtual/udev-206-r3::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- media-libs/lcms-1.19::gentoo (masked by: package.mask)
- x11-libs/gtk+-2.24.20_p1_p01::unity-gentoo (masked by: package.mask)
- sys-libs/db-5.1.29::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2012)
# Masked for testing

- dev-libs/libgee-0.6.8::gentoo (masked by: package.mask)
- x11-libs/libwnck-2.31.0::gentoo (masked by: package.mask)
- x11-libs/vte-0.28.2-r206::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Any suggestions?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Oct 21, 2013 10:24 pm    Post subject: Reply with quote

noclear2000 wrote:
Hi shiznix

Thanks for your reply, after my sync up:
Code:
emerge --sync && layman -S

i was stuck with lots of multi slot issues again. And udev blocking systemd and vice versa

Before I go on or even dare to reboot I should probably know hwo to go on with udev vs systemd. I tried going for systemd but udev keeps on being being pulled in so there is no way for me to switch to systemd easily. I can't identify why udev is being pulled in all the time.

I honestly do not care if I use systmd or udev but during my new use deep update world some packages started in pulling systemd... I am totally lost. Do I need to switch to systemd for my deep update new use to go through when using the unity-overlay? If yes, how to get rif of udev being pulled in. If no how to avoid systemd being pulled in...?

thansk for any suggestion.

Yes you need to switch to systemd.
I mistakenly assumed you were already in a position to install Gnome 3.8 when using sushi-3.8, so apologies for the surprise that caused. :roll:
If you're still wanting to go forward with installation of Gnome 3.8 and Unity, you should first get your system working with systemd (see http://wiki.gentoo.org/wiki/Systemd).

I'll flag a news item in the overlay that covers the need for systemd, and it'll go something like this...
While systemd is not strictly needed for Gnome 3.8 to build, it is needed at runtime.
From http://wiki.gentoo.org/wiki/GNOME/3.8-upgrade-guide ...
Quote:
GNOME 3.8 requires systemd to be running to get it working properly, otherwise, you will get broken power management and multiseat handling, and also some more problems because upstream has moved away from the obsolete consolekit to logind (that needs systemd to be running to work).
It is highly recommended you get the system working with systemd before proceeding with the Unity desktop installation (see http://wiki.gentoo.org/wiki/Systemd).

If you need to roll back to openrc, simply 'layman -d unity-gentoo', set 'consolekit -systemd' USE flags globally and emerge -uDN world.
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Tue Oct 22, 2013 6:27 am    Post subject: Reply with quote

Hi shining.

After some googling I figured the Gnome 3.8 systems relationship myself.

I am switched and rebooted now. :-)

Still new use deep world ends up with systemd vs udev blocker as found in the code section of my previous post.

systemd -consolekit set globally. Udev not in world file. Any hints? Thanks!

EDIT1: setting -udev globally results in:
Code:

!!! The ebuild selected to satisfy "gnome-base/gvfs" has unmet requirements.
- gnome-base/gvfs-1.16.3-r1::gentoo USE="avahi bluetooth cdda fuse gnome-keyring gnome-online-accounts gtk http samba systemd -afp -archive -bluray -gdu -gphoto2 -ios -mtp -test -udev -udisks"

  The following REQUIRED_USE flag constraints are unsatisfied:
    cdda? ( udev ) systemd? ( udisks )

  The above constraints are a subset of the following complete expression:
    cdda? ( udev ) udisks? ( udev ) systemd? ( udisks )

(dependency required by "gnome-base/libgnome-2.32.1-r1" [installed])
(dependency required by "gnome-base/libgnomeui-2.24.5" [installed])
(dependency required by "dev-util/glade-3.8.3[gnome]" [installed])
(dependency required by "x11-libs/gtksourceview-2.10.5-r2[glade]" [installed])
(dependency required by "dev-python/pygtksourceview-2.10.1" [installed])
(dependency required by "dev-vcs/git-1.8.1.5-r1[python,gtk]" [installed])
(dependency required by "sys-devel/gettext-0.18.2[git]" [installed])
(dependency required by "x11-misc/colord-1.0.3" [ebuild])
(dependency required by "x11-libs/gtk+-3.8.4_p0_p03::unity-gentoo[colord]" [installed])
(dependency required by "gnome-base/gconf-3.2.6-r1[gtk]" [ebuild])

so udev is haunting me in its afterlife.. ;)
interssting enough the gconf-3.2.6-r1 form the last line is maked my unity-portate_saucy.pmask. The currently installed gnome-base/gconf-3.2.6_p0_p01 is no longer availble in the unity overlay...?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Tue Oct 22, 2013 9:20 am    Post subject: Reply with quote

noclear2000 wrote:
Hi shining.

After some googling I figured the Gnome 3.8 systems relationship myself.

I am switched and rebooted now. :-)

Still new use deep world ends up with systemd vs udev blocker as found in the code section of my previous post.

systemd -consolekit set globally. Udev not in world file. Any hints? Thanks!

EDIT1: setting -udev globally results in:
Code:

!!! The ebuild selected to satisfy "gnome-base/gvfs" has unmet requirements.
- gnome-base/gvfs-1.16.3-r1::gentoo USE="avahi bluetooth cdda fuse gnome-keyring gnome-online-accounts gtk http samba systemd -afp -archive -bluray -gdu -gphoto2 -ios -mtp -test -udev -udisks"

  The following REQUIRED_USE flag constraints are unsatisfied:
    cdda? ( udev ) systemd? ( udisks )

  The above constraints are a subset of the following complete expression:
    cdda? ( udev ) udisks? ( udev ) systemd? ( udisks )

(dependency required by "gnome-base/libgnome-2.32.1-r1" [installed])
(dependency required by "gnome-base/libgnomeui-2.24.5" [installed])
(dependency required by "dev-util/glade-3.8.3[gnome]" [installed])
(dependency required by "x11-libs/gtksourceview-2.10.5-r2[glade]" [installed])
(dependency required by "dev-python/pygtksourceview-2.10.1" [installed])
(dependency required by "dev-vcs/git-1.8.1.5-r1[python,gtk]" [installed])
(dependency required by "sys-devel/gettext-0.18.2[git]" [installed])
(dependency required by "x11-misc/colord-1.0.3" [ebuild])
(dependency required by "x11-libs/gtk+-3.8.4_p0_p03::unity-gentoo[colord]" [installed])
(dependency required by "gnome-base/gconf-3.2.6-r1[gtk]" [ebuild])

so udev is haunting me in its afterlife.. ;)
interssting enough the gconf-3.2.6-r1 form the last line is maked my unity-portate_saucy.pmask. The currently installed gnome-base/gconf-3.2.6_p0_p01 is no longer availble in the unity overlay...?

Nice!!
Much as it was forced, I'm actually warming to systemd in many respects :)

gnome-base/gconf has been reinstated for Saucy, so all you should need do is sync up for the fix (thanks for the report).

With regards to the udev problem, leave 'udev' USE flag enabled.
Systemd provides it's own udev implementation and this is handled by Gentoo's virtual/udev package.

If there's still a problem with 'udev' enabled, please provide a complete output from 'emerge -uDNpvt @world'.
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Tue Oct 22, 2013 10:12 am    Post subject: Reply with quote

Hi shiznix,

Sorry for adressing you as "shining" in my previous post! :o
This was the stupid keyboard app (auto correction) of my android phone :roll: (as I am stuck in the middle of xorg upgrade X won't start...)
Shining is only the unity-overlay. :lol:

BTW, thanks for all the effort you put into this overlay! I really appreciate this and all your replies to my posts. :D


shiznix wrote:
noclear2000 wrote:

After some googling I figured the Gnome 3.8 systems relationship myself.

I am switched and rebooted now. :-)

Nice!!
Much as it was forced, I'm actually warming to systemd in many respects :)

gnome-base/gconf has been reinstated for Saucy, so all you should need do is sync up for the fix (thanks for the report).

With regards to the udev problem, leave 'udev' USE flag enabled.
Systemd provides it's own udev implementation and this is handled by Gentoo's virtual/udev package.

If there's still a problem with 'udev' enabled, please provide a complete output from 'emerge -uDNpvt @world'.


The blazing fast boot of systemd is something I could also get used to. :) I first thought boot stopped in the middle (especially because of the kernel messages on the login prompt - the gentoo wiki deals with this. I will check that later.). :oops:

Now my update deep newuse is asking for >=gnome-extra/gnome-screensaver-3.8:
Code:
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=gnome-extra/gnome-screensaver-3.8".
(dependency required by "unity-indicators/indicator-session-12.10.5a_p0_p01-r7::unity-gentoo" [ebuild])
(dependency required by "unity-extra/unity-greeter-13.10.3_p0_p01::unity-gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

likewise
Code:
emerge -1av  unity-indicators/indicator-session
asks for ">=gnome-extra/gnome-screensaver-3.8"
Code:

root@zenbook [~]# grep gnome-screensaver /var/lib/layman/unity-gentoo/unity-indicators/indicator-session/indicator-session-12.10.5a_p0_p01-r7.ebuild
        >=gnome-extra/gnome-screensaver-3.8
root@zenbook [~]#


available (also via your overlay) is only 3.6.1_p0_p06 from your overlay:
Code:
[U] gnome-extra/gnome-screensaver
     Available versions:  [m]2.30.2-r1 [m]~3.6.1 (~)3.6.1_p0_p06^m[1] {branding debug doc libnotify opengl pam systemd KERNEL="linux"}
     Installed versions:  3.6.1_p0_p03^m[1](22:30:08 11.03.2013)(pam -debug -doc -systemd)
     Homepage:            http://live.gnome.org/GnomeScreensaver
     Description:         Replaces xscreensaver, integrating with and patched for the Unity desktop

[1] "unity-gentoo" /var/lib/layman/unity-gentoo


Did you maybe originally intend to provide a gnome-screensaver-3.8 package with your overlay and actually forgot to do so? Or do I need to find it elsewhere for my local overlay?

EDIT1:
i duplicated your indicator-session/indicator-session-12.10.5a_p0_p01-r7 to my local overlay as -r8 and modified it to requirey >= gnome-screensaver-3.6 only (as a dummy to see what is after that - just out of curiosity). BTW, on ftp.gnome.org i found no gnome.screensaver-3.8 source...?

So now I am back to udev blocker (with udev in global use as you suggested):
Code:

[ebuild  N    ~] unity-lenses/unity-lens-files-7.1.0_p0_p01-r2  USE="-debug"
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-204-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-208)

Fetch instructions for dev-java/oracle-jre-bin-1.7.0.45:
 * Please download 'jre-7u45-linux-x64.tar.gz' from:
 * 'http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html'
 * and move it to '/usr/portage/distfiles'
 * Also download 'UnlimitedJCEPolicyJDK7.zip' from:
 * 'http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html'
 * and move it to '/usr/portage/distfiles'

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-204-r1::gentoo, installed) pulled in by
    sys-apps/systemd required by (sys-apps/dbus-1.6.12::gentoo, installed)
    >=sys-apps/systemd-39 required by (media-sound/pulseaudio-2.1-r1::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (sys-auth/polkit-0.112::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-extra/gnome-screensaver-3.6.1_p0_p06::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186 required by (sys-apps/accountsservice-0.6.34_p0_p06::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.8.3_p0_p01-r3::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (net-misc/networkmanager-0.9.8.8::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (gnome-base/gvfs-1.16.3-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186[pam] required by (gnome-base/gdm-3.8.4-r3::gentoo, ebuild scheduled for merge)
    <sys-apps/systemd-205 required by (sys-apps/gentoo-systemd-integration-1::gentoo, installed)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.8.4-r1::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-183 required by (gnome-base/gnome-session-3.9.90_p0_p03::unity-gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-197 required by (sys-fs/udisks-2.1.0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-200 required by (sys-power/upower-0.9.21::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44 required by (x11-misc/colord-1.0.3::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-204-r1 required by (sys-apps/gentoo-systemd-integration-1::gentoo, installed)
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.8.5_p0_p09::unity-gentoo, ebuild scheduled for merge)

  (sys-fs/udev-208::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-206-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev?,introspection?,kmod?,selinux?,static-libs?] (>=sys-fs/udev-206-r2[abi_x86_64(-),gudev,introspection,kmod]) required by (virtual/udev-206-r3::gentoo, ebuild scheduled for merge)


EDIT2: Seems like udev stuff is coming from media-libs/mesa (media-libs/mesa-9.2.1_p1_p03::unity-gentoo)

EDIT 3:
equery d virtual/udev reaveals:
media-libs/mesa-9.2.1_p1_p03 (gbm ? virtual/udev[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?])

so:
USE -gbm for media-libs/mesa did the trick

for hwids pulling in udev a downgrade to a non-keywored version (sys-apps/hwids-20130329) from sys-apps/hwids-20130915.1 did the trick

+ kmod udev systemd: remove all masks/unmask/use/keyword specials
EDIT4:
Now I am facing this problem with perl/qt5:
Code:

dev-lang/perl:0

  (dev-lang/perl-5.12.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    <dev-lang/perl-5.16[-build] required by (dev-perl/TermReadKey-2.300.0::gentoo, installed)
    ~dev-lang/perl-5.12.4 required by (virtual/perl-Getopt-Long-2.380.0-r2::gentoo, installed)
    (and 79 more with the same problems)

  (dev-lang/perl-5.16.1::gentoo, installed) pulled in by
    >=dev-lang/perl-5.14 required by (dev-qt/qtdbus-5.1.1::qt, ebuild scheduled for merge)
    (and 1 more with the same problem)

Any suggestions?
EDIT5: worked around it, compiling again. 8)
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Wed Oct 23, 2013 7:49 am    Post subject: Reply with quote

Sorry for the double post. But the previous one gets quite lengthy and the issues described there are basically resolved besides
the gnome-screensaver-3.8 dependency of unity-indicators/indicator-session/indicator-session-12.10.5a_p0_p01-r7.ebuild

unity-base/unity-7.1.2_p0_p01-r1 fails due to some source code issue it seems?
Code:

In file included from /usr/include/zeitgeist-2.0/zeitgeist.h:12:0,
                 from /var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2+13.10.20131014.1/unity-shared/../unity-shared/ZeitgeistUtils.h:23,
                 from /var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2+13.10.20131014.1/unity-shared/DesktopApplicationManager.h:27,
                 from /var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2+13.10.20131014.1/unity-shared/DesktopApplicationManager.cpp:20:
/usr/include/zeitgeist-2.0/zeitgeist-datamodel.h:255:17: error: previous declaration of 'ZeitgeistEvent* zeitgeist_event_constructv_full(GType, const gchar*, const gchar*, const gchar*, const gchar*, __va_list_tag*)' [-fpermissive]
 ZeitgeistEvent* zeitgeist_event_constructv_full (GType object_type, const gchar* interpretation, const gchar* manifestation, const gchar* actor, const gchar* origin, va_list _vala_va_list);
                 ^
make[2]: *** [unity-shared/CMakeFiles/unity-shared.dir/DesktopApplicationManager.cpp.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2_p0_p01_build'
make[1]: *** [unity-shared/CMakeFiles/unity-shared.dir/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2_p0_p01_build'
make: *** [all] Error 2
 * ERROR: unity-base/unity-7.1.2_p0_p01-r1::unity-gentoo failed (compile phase):
 *   emake failed


and unity-extra/unity-tweak-tool-0.0.6 is blocking my world deep newuse update:
Code:

>>> Compiling source in /var/tmp/portage/unity-extra/unity-tweak-tool-0.0.6/work/unity-tweak-tool ...
 * python3_2: running distutils-r1_run_phase distutils-r1_python_compile
/usr/bin/python3.2 setup.py build

** (setup.py:16016): WARNING **: Could not open X display

(setup.py:16016): Gtk-CRITICAL **: _gtk_style_cascade_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(setup.py:16016): Gtk-CRITICAL **: _gtk_style_provider_private_lookup: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(setup.py:16016): Gtk-CRITICAL **: _gtk_css_lookup_resolve: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(setup.py:16016): Gtk-CRITICAL **: _gtk_css_rgba_value_get_rgba: assertion 'rgba->class == &GTK_CSS_VALUE_RGBA' failed

[...lots of those kind of messages...]

(setup.py:16016): Gtk-CRITICAL **: _gtk_css_array_value_get_n_values: assertion 'value != NULL' failed
/var/tmp/portage/unity-extra/unity-tweak-tool-0.0.6/temp/environment: line 1795: 16016 Segmentation fault      "${@}"
 * ERROR: unity-extra/unity-tweak-tool-0.0.6::unity-gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 3882:  Called distutils-r1_src_compile
 *   environment, line 1003:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_compile'
 *   environment, line  270:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 3563:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2904:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2902:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line  658:  Called distutils-r1_run_phase 'distutils-r1_python_compile'
 *   environment, line  992:  Called distutils-r1_python_compile
 *   environment, line  900:  Called esetup.py 'build'
 *   environment, line 1799:  Called die
 * The specific snippet of code:
 *       "${@}" || die


Some gtk issue. Tried compiling GTK stuff again and such but not sure which package. Any suggestion, please? Really stuck here.

EDIT1:

For lightdm with unity greeter to start I required to create a symlink
Code:

root@zenbook [/var/log/lightdm]# ll /etc/lightdm/lightdm-greeter-display-setup
lrwxrwxrwx 1 root root 50 23. Okt  10:57 /etc/lightdm/lightdm-greeter-display-setup -> /usr/libexec/lightdm/lightdm-greeter-display-setup

is this expected?
x11-misc/lightdm-1.8.2_p0_p01 places lightdm-greeter-display-setup here: /usr/libexec/lightdm/lightdm-greeter-display-setup
lightdm during startup searches it here: /etc/lightdm/lightdm-greeter-display-setup

Instead of a link this might also be confiigured..?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Oct 23, 2013 9:56 am    Post subject: Reply with quote

noclear2000 wrote:
Sorry for the double post. But the previous one gets quite lengthy and the issues described there are basically resolved besides
the gnome-screensaver-3.8 dependency of unity-indicators/indicator-session/indicator-session-12.10.5a_p0_p01-r7.ebuild

unity-base/unity-7.1.2_p0_p01-r1 fails due to some source code issue it seems?
Code:

In file included from /usr/include/zeitgeist-2.0/zeitgeist.h:12:0,
                 from /var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2+13.10.20131014.1/unity-shared/../unity-shared/ZeitgeistUtils.h:23,
                 from /var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2+13.10.20131014.1/unity-shared/DesktopApplicationManager.h:27,
                 from /var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2+13.10.20131014.1/unity-shared/DesktopApplicationManager.cpp:20:
/usr/include/zeitgeist-2.0/zeitgeist-datamodel.h:255:17: error: previous declaration of 'ZeitgeistEvent* zeitgeist_event_constructv_full(GType, const gchar*, const gchar*, const gchar*, const gchar*, __va_list_tag*)' [-fpermissive]
 ZeitgeistEvent* zeitgeist_event_constructv_full (GType object_type, const gchar* interpretation, const gchar* manifestation, const gchar* actor, const gchar* origin, va_list _vala_va_list);
                 ^
make[2]: *** [unity-shared/CMakeFiles/unity-shared.dir/DesktopApplicationManager.cpp.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2_p0_p01_build'
make[1]: *** [unity-shared/CMakeFiles/unity-shared.dir/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/unity-base/unity-7.1.2_p0_p01-r1/work/unity-7.1.2_p0_p01_build'
make: *** [all] Error 2
 * ERROR: unity-base/unity-7.1.2_p0_p01-r1::unity-gentoo failed (compile phase):
 *   emake failed

This is being tracked as Issue #59 (https://github.com/shiznix/unity-gentoo/issues/59)
Re-emerging zeitgeist may work, but you may also need to sync up the overlay so that >=dev-util/cmake-2.8.12 is not emerged (looks to have problems parsing cmake files).

noclear2000 wrote:
and unity-extra/unity-tweak-tool-0.0.6 is blocking my world deep newuse update:
Code:

>>> Compiling source in /var/tmp/portage/unity-extra/unity-tweak-tool-0.0.6/work/unity-tweak-tool ...
 * python3_2: running distutils-r1_run_phase distutils-r1_python_compile
/usr/bin/python3.2 setup.py build

** (setup.py:16016): WARNING **: Could not open X display

(setup.py:16016): Gtk-CRITICAL **: _gtk_style_cascade_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(setup.py:16016): Gtk-CRITICAL **: _gtk_style_provider_private_lookup: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(setup.py:16016): Gtk-CRITICAL **: _gtk_css_lookup_resolve: assertion 'GTK_IS_STYLE_PROVIDER_PRIVATE (provider)' failed

(setup.py:16016): Gtk-CRITICAL **: _gtk_css_rgba_value_get_rgba: assertion 'rgba->class == &GTK_CSS_VALUE_RGBA' failed

[...lots of those kind of messages...]

(setup.py:16016): Gtk-CRITICAL **: _gtk_css_array_value_get_n_values: assertion 'value != NULL' failed
/var/tmp/portage/unity-extra/unity-tweak-tool-0.0.6/temp/environment: line 1795: 16016 Segmentation fault      "${@}"
 * ERROR: unity-extra/unity-tweak-tool-0.0.6::unity-gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 3882:  Called distutils-r1_src_compile
 *   environment, line 1003:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_compile'
 *   environment, line  270:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 3563:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2904:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2902:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line  658:  Called distutils-r1_run_phase 'distutils-r1_python_compile'
 *   environment, line  992:  Called distutils-r1_python_compile
 *   environment, line  900:  Called esetup.py 'build'
 *   environment, line 1799:  Called die
 * The specific snippet of code:
 *       "${@}" || die


Some gtk issue. Tried compiling GTK stuff again and such but not sure which package. Any suggestion, please? Really stuck here.

I've seen this before and had me baffled for days because it's not really GTK that is the problem.
It's unity-tweak-tool/UnityTweakTool/section/spaghetti/gsettings.py doing a self check on the GSettings objects located in that file.
If it can't find any of them, it tries to open a PyGTK error dialog in the current xsession and fails badly when root can't connect to the X display.

At that time I'd thought it was just indicator-bluetooth that was causing the problem, but it looks like all packages that provide those objects should be added to unity-tweak-tool's DEPEND list.
The fix for this has been committed, so sync up and see if things improve ;)
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Wed Oct 23, 2013 10:03 am    Post subject: Reply with quote

Hi shiznix,

I tried zeitgeist re-emerge alrady yesterday before posting to no avail.

I have and stick with dev-util/cmake-2.8.10.2-r2. Okay for unity-base/unity? Won't compile... :(

What about the gnome-screensaver-3.8 dependency of unity-indicators/indicator-session/indicator-session-12.10.5a_p0_p01-r7.ebuild? Is it saneto fix it to depend on >=scrensaver-3.6? as i did to get past that problem...


For unity-tweak-tool: going to sync up right now. :) (and i was wondering why it tries to open up a X display for compilation... :D)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Oct 23, 2013 11:18 am    Post subject: Reply with quote

noclear2000 wrote:
Hi shiznix,

I tried zeitgeist re-emerge alrady yesterday before posting to no avail.

I have and stick with dev-util/cmake-2.8.10.2-r2. Okay for unity-base/unity? Won't compile... :(

What about the gnome-screensaver-3.8 dependency of unity-indicators/indicator-session/indicator-session-12.10.5a_p0_p01-r7.ebuild? Is it saneto fix it to depend on >=scrensaver-3.6? as i did to get past that problem...


For unity-tweak-tool: going to sync up right now. :) (and i was wondering why it tries to open up a X display for compilation... :D)

Fix committed for indicator-session and >=gnome-screensaver-3.6.

Continuing on with the unity-base/unity compile problem, I can't yet reproduce this but you're the second user with the exact same error.
What versions of dev-lang/vala do you have installed ?
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Wed Oct 23, 2013 11:37 am    Post subject: Reply with quote

shiznix wrote:

Continuing on with the unity-base/unity compile problem, I can't yet reproduce this but you're the second user with the exact same error.
What versions of dev-lang/vala do you have installed ?


vala-0.20.1 and vala-0.22.0 because vala <0.20 resulted in blockers:
Code:

[I] dev-lang/vala
     Available versions:
     (0.10) [m]0.10.4-r2
     (0.12) [m]0.12.1-r1
     (0.14) [m]0.14.2-r2
     (0.16) [m]0.16.1-r2
     (0.18) [m]0.18.1
     (0.20) (~)0.20.1
     (0.22) (~)0.22.0
       {test +vapigen}
     Installed versions:  0.20.1(0.20)(00:33:32 21.10.2013)(vapigen -test) 0.22.0(0.22)(13:22:11 20.10.2013)(vapigen -test)
     Homepage:            http://live.gnome.org/Vala
     Description:         Compiler for the GObject type system

And zeitgeist: gnome-extra/zeitgeist-0.9.14 USE="datahub fts icu introspection nls -downloads-monitor -extensions -plugins -sql-debug -telepathy" PYTHON_TARGETS="python2_7 -python2_6"

EDIT: As my upgrade is spanning several days already and I really want to go on doing the preserved rebuild and revdep-rebuild to have a reliable system with bash at least ;) i decided to carelessly tinker around with the unity-base/unity source code to make it at least compile an go on with the upgrade. This is probably not a "fix" however it compiles. Curious to see it in action (if any) when I am back from work today. :) BTW; vala generated codes looks pretty ugly. :cry:

EDIT2: Yeah! Finally done. Emerge deep new use world + @preserved-rebuild + depclean + revdep-rebuild finished. That should be a sane system now (besides my unity hack). I will report how it works. Probably I need to fiddle a little with services to be autostarted by systemd.

EDIT3: lightdm startup with unity greeter and later login didn't work out of the box. I had to create some directories and symlinks in order to resolve this (some problem with the ebuilds?):
Code:

ln -s /usr/libexec/lightdm/lightdm-greeter-display-setup /etc/lightdm/lightdm-greeter-display-setup
ln -s /usr/libexec/lightdm/Xsession /etc/lightdm/Xsession
mkdir -p /usr/share/lightdm/sessions /usr/share/lightdm/remote-sessions #and chown to lightdm)

Also WLAN connection with new version of NetworkManager didn't work:
Code:
wlan0: deauthenticating from 64:70:02:5c:2c:d6 by local choice (reason=3)

I had to set USE -dhcpcd dhclient (was the other way round) to make this work

My unity package source "hack" seems to work. I am posting this in front of a pretty usable system. :) Will see if I exhibit random runtime failure in future. Ctrl+S will be my friend the next days... ;)

Only a few small things too follow up and fine tune (cups/printing not working and some config file overwritten) but all in all a lengthy but successful upgrade. Thanks so much again shiznix for your overlay and support!

EDIT4: BTW; during last stage of update I found that app-accessibility/pocketsphinx-0.8 should depend on media-libs/libsamplerate but doesn't. Both are main portage tree ebuilds. Dumb question but where to report this? Do I file a bug?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Oct 25, 2013 11:29 am    Post subject: Reply with quote

noclear2000 wrote:
vala-0.20.1 and vala-0.22.0 because vala <0.20 resulted in blockers:
Code:

[I] dev-lang/vala
     Available versions:
     (0.10) [m]0.10.4-r2
     (0.12) [m]0.12.1-r1
     (0.14) [m]0.14.2-r2
     (0.16) [m]0.16.1-r2
     (0.18) [m]0.18.1
     (0.20) (~)0.20.1
     (0.22) (~)0.22.0
       {test +vapigen}
     Installed versions:  0.20.1(0.20)(00:33:32 21.10.2013)(vapigen -test) 0.22.0(0.22)(13:22:11 20.10.2013)(vapigen -test)
     Homepage:            http://live.gnome.org/Vala
     Description:         Compiler for the GObject type system

And zeitgeist: gnome-extra/zeitgeist-0.9.14 USE="datahub fts icu introspection nls -downloads-monitor -extensions -plugins -sql-debug -telepathy" PYTHON_TARGETS="python2_7 -python2_6"

EDIT: As my upgrade is spanning several days already and I really want to go on doing the preserved rebuild and revdep-rebuild to have a reliable system with bash at least ;) i decided to carelessly tinker around with the unity-base/unity source code to make it at least compile an go on with the upgrade. This is probably not a "fix" however it compiles. Curious to see it in action (if any) when I am back from work today. :) BTW; vala generated codes looks pretty ugly. :cry:

EDIT2: Yeah! Finally done. Emerge deep new use world + @preserved-rebuild + depclean + revdep-rebuild finished. That should be a sane system now (besides my unity hack). I will report how it works. Probably I need to fiddle a little with services to be autostarted by systemd.

EDIT3: lightdm startup with unity greeter and later login didn't work out of the box. I had to create some directories and symlinks in order to resolve this (some problem with the ebuilds?):
Code:

ln -s /usr/libexec/lightdm/lightdm-greeter-display-setup /etc/lightdm/lightdm-greeter-display-setup
ln -s /usr/libexec/lightdm/Xsession /etc/lightdm/Xsession
mkdir -p /usr/share/lightdm/sessions /usr/share/lightdm/remote-sessions #and chown to lightdm)

Also WLAN connection with new version of NetworkManager didn't work:
Code:
wlan0: deauthenticating from 64:70:02:5c:2c:d6 by local choice (reason=3)

I had to set USE -dhcpcd dhclient (was the other way round) to make this work

My unity package source "hack" seems to work. I am posting this in front of a pretty usable system. :) Will see if I exhibit random runtime failure in future. Ctrl+S will be my friend the next days... ;)

Only a few small things too follow up and fine tune (cups/printing not working and some config file overwritten) but all in all a lengthy but successful upgrade. Thanks so much again shiznix for your overlay and support!

EDIT4: BTW; during last stage of update I found that app-accessibility/pocketsphinx-0.8 should depend on media-libs/libsamplerate but doesn't. Both are main portage tree ebuilds. Dumb question but where to report this? Do I file a bug?

Great you finally got it working!! :)

I'm doing a clean Gentoo install in a VM to try and reproduce the unity compile failure as it relates to vala+zeitgeist...
Can you post what changes you made to have it compile ?

The lightdm greeter setup can be more easily achieved by doing 'eselect lightdm list' and 'eselect lightdm set <number>'.
But we should probably have the ebuild set unity-greeter as the default greeter.

We could add pocketsphinx to the overlay to tackle those two bugs (will check the libsamplerate DEPEND), it's automake bug has been open for some time now.
All main tree bugs go to bugs.gentoo.org

Happy unity-gentoo'ing!! ;)
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Fri Oct 25, 2013 12:47 pm    Post subject: Reply with quote

shiznix wrote:

Great you finally got it working!! :)

I'm doing a clean Gentoo install in a VM to try and reproduce the unity compile failure as it relates to vala+zeitgeist...
Can you post what changes you made to have it compile ?

The lightdm greeter setup can be more easily achieved by doing 'eselect lightdm list' and 'eselect lightdm set <number>'.
But we should probably have the ebuild set unity-greeter as the default greeter.

We could add pocketsphinx to the overlay to tackle those two bugs (will check the libsamplerate DEPEND), it's automake bug has been open for some time now.
All main tree bugs go to bugs.gentoo.org

Happy unity-gentoo'ing!! ;)

Thanks you. :)
Ah, I should look more into eselect stuff instead of doing symlinking myself. Thanks for the pointer.

I am struggling with quite some stuff both related to systemd and gnome/saucy (but i also manged to fix some) For example most stupid thing is that plugged in USB media is detected but not mounted (no icon on desktop). On manual mount icon occurs. Maybe it is even mounted but unmounted because I see some "<volume name> unmounted" notification directly after plugin.

I can't check that because I didn't manage to get some syslog working. I need to check that section in sytemd gentoo wiki article and see if systemd loggin or sticking with syslog-ng can be fixed (i knwo there is a section). Also teamviewer8d cannot be started with systemd? there is only an init-script I fear.

Regarding unity-base/unity-7.1.2_p0_p01-r1 I "patched" unity-shared/ZeitgeistUtils.h from:
Code:

/* Unfortunately valac-generated zeitgeist library contains invalid
definitions
 * that makes impossible for us to compile with -Werror -Wall, so we need to
 * workaround them.
 * Unfortunately using #pragma doesn't help much here as we can't limit the
 * errors to the header inclusion only, so it's better to use this way
in order
 * to be able to include zeitgeist in multiple places without ignoring
warnings.
 */

static ZeitgeistEvent* zeitgeist_event_constructv_full(GType
object_type, const gchar* interpretation, const gchar* manifestation,
const gchar* actor, const gchar* origin, va_list _vala_va_list)
{
  return nullptr;
}

to
Code:
/* Unfortunately valac-generated zeitgeist library contains invalid
definitions
 * that makes impossible for us to compile with -Werror -Wall, so we need to
 * workaround them.
 * Unfortunately using #pragma doesn't help much here as we can't limit the
 * errors to the header inclusion only, so it's better to use this way
in order
 * to be able to include zeitgeist in multiple places without ignoring
warnings.


static ZeitgeistEvent* zeitgeist_event_constructv_full(GType
object_type, const gchar* interpretation, const gchar* manifestation,
const gchar* actor, const gchar* origin, va_list _vala_va_list)
{
  return nullptr;
}
 */

[extended the comment to span (re-)definition of the zeitgeist_event_constructv_full method]
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Sun Oct 27, 2013 10:39 am    Post subject: Reply with quote

HI shiznix,


Do you have problems with your overlay or is it on my side?
Code:

*
 * Errors:
 * ------
 * Failed to sync overlay "unity-gentoo".
 * Error was: Syncing overlay "unity-gentoo" returned status 1!
 * db.sync()
 *

 * IMPORTANT: 3 news items need reading for repository 'unity-gentoo'.
 * Use eselect news to read news items.


 * CLI: Errors occurred processing action sync_all
 *
 * Errors:
 * ------
 * Failed to sync overlay "unity-gentoo".
 * Error was: Syncing overlay "unity-gentoo" returned status 1!
 * db.sync()
 *

Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Mon Oct 28, 2013 10:57 am    Post subject: Reply with quote

noclear2000 wrote:
HI shiznix,


Do you have problems with your overlay or is it on my side?
Code:

*
 * Errors:
 * ------
 * Failed to sync overlay "unity-gentoo".
 * Error was: Syncing overlay "unity-gentoo" returned status 1!
 * db.sync()
 *

 * IMPORTANT: 3 news items need reading for repository 'unity-gentoo'.
 * Use eselect news to read news items.


 * CLI: Errors occurred processing action sync_all
 *
 * Errors:
 * ------
 * Failed to sync overlay "unity-gentoo".
 * Error was: Syncing overlay "unity-gentoo" returned status 1!
 * db.sync()
 *



Do you have local changes inside of the repository otherwise layman(git) refuses to sync it.
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Mon Oct 28, 2013 7:04 pm    Post subject: Reply with quote

Hi renegart,

Thanks for the pointer!
Code:

cd /var/lib/layman/unity-gentoo
git reset --hard

did the trick. :D
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Mon Oct 28, 2013 8:14 pm    Post subject: Reply with quote

hi shiznix, all,


The update from gnome-extra/nm-applet-0.9.8.0_p1_p02-r1 to gnome-extra/nm-applet-0.9.8.0_p1_p05 sadly renders my wifi unusable. There are connections dropped roughly all 2 minutes.

Can you please let me know what the changes are? Also would you please be so kind to provide me with a copy of the old ebuild for my local overlay? That would be highly appreciated. A ultrabook bound to a network cable is somewhat awkward. :lol:

Thanks!
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Oct 28, 2013 9:27 pm    Post subject: Reply with quote

noclear2000 wrote:
hi shiznix, all,


The update from gnome-extra/nm-applet-0.9.8.0_p1_p02-r1 to gnome-extra/nm-applet-0.9.8.0_p1_p05 sadly renders my wifi unusable. There are connections dropped roughly all 2 minutes.

Can you please let me know what the changes are? Also would you please be so kind to provide me with a copy of the old ebuild for my local overlay? That would be highly appreciated. A ultrabook bound to a network cable is somewhat awkward. :lol:

Thanks!

Anything interesting in syslog regarding the connection drop ?
I've not personally experienced any problem with wifi connections and the latest nm-applet, though I would think if there is a problem with connections then networkmanager would most likely be the cause ?

If you need a copy of the old nm-applet ebuild (or any other ebuild) you can check the overlay's commit history at https://github.com/shiznix/unity-gentoo and browse the ebuilds at any point along the commit timeline.
A copy of the ebuild can be found here -> https://raw.github.com/shiznix/unity-gentoo/5b1f4edc4639762b37b1ce671781b09aee481b72/gnome-extra/nm-applet/nm-applet-0.9.8.0_p1_p02-r1.ebuild
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Wed Oct 30, 2013 4:23 pm    Post subject: Reply with quote

Not sure anymore if nm-applet is really the culprit (old version - same problem). Looks like the iwlwifi. Not sure what else changed. Sadly no message in dmesg/syslog. also the panel indicator shows no connection loss, but NFS gets unmounted and ongoing downloads go down to 0kb/s and a minute later all is up at 5-6 MB/s (my ISP contract maximum). so all in all it is not unity overlay related most likely. Sorry for the false alarm.
Back to top
View user's profile Send private message
-=GGW=- $ol!d $n4>|e
Veteran
Veteran


Joined: 12 Apr 2004
Posts: 1604
Location: USA

PostPosted: Wed Nov 20, 2013 3:41 am    Post subject: slot conflicts galore? Reply with quote

Hey! was excited when i saw this overlay, just tried installing though and i see a ton of conflicts :(

Code:

sudo emerge -av unity-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/gdk-pixbuf:2

  (x11-libs/gdk-pixbuf-2.28.2::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gdk-pixbuf-2.28.0:2 required by (gnome-base/gnome-core-libs-3.8.0::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/gdk-pixbuf-2.26.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/atk:0

  (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/atk-2.8 required by (gnome-base/gnome-core-libs-3.8.0::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

  (dev-libs/atk-2.6.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/pango:0

  (x11-libs/pango-1.30.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/pango-1.34.0 required by (gnome-base/gnome-core-libs-3.8.0::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-libs/openssl:0

  (dev-libs/openssl-1.0.1e-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/openssl-1.0.1e-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-0.9.8g[-bindist] required by (net-voip/telepathy-gabble-0.16.6::gentoo, ebuild scheduled for merge)
    >=dev-libs/openssl-0.9.8g[-bindist] required by (net-voip/telepathy-salut-0.8.1::gentoo, ebuild scheduled for merge)

dev-libs/libxslt:0

  (dev-libs/libxslt-1.1.28-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libxslt-1.1.28-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxslt[python,python_targets_python2_7(-)?,python_single_target_python2_7(+)?] required by (unity-base/bamf-0.5.1_p0_p01-r1::unity-gentoo, ebuild scheduled for merge)

dev-libs/protobuf:0

  (dev-libs/protobuf-2.4.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/protobuf[python] required by (unity-base/ubuntuone-storage-protocol-13.10_p0_p01::unity-gentoo, ebuild scheduled for merge)

  (dev-libs/protobuf-2.4.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.46::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libdrm-2.4.46-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libdrm-2.4.46[video_cards_freedreno?,video_cards_nouveau?,video_cards_vmware?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/mesa-9.2.1_p1_p03-r2::unity-gentoo, ebuild scheduled for merge)

dev-libs/soprano:0

  (dev-libs/soprano-2.9.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/soprano-2.9.3[dbus,raptor,redland,virtuoso] required by (kde-base/nepomuk-core-4.11.3::gentoo, ebuild scheduled for merge)

  (dev-libs/soprano-2.9.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "dev-qt/qtdbus:5".
(dependency required by "unity-base/hud-13.10.1_p0_p01-r11::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-7.1.2::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


emerge --info

Code:

emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde/systemd, gcc-4.7.3, glibc-2.15-r3, 3.10.17-gentoo x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:    16347204 total,  14266180 free
KiB Swap:     499708 total,    499708 free
Timestamp of tree: Wed, 20 Nov 2013 01:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo unity-gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write --quiet-build=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/unity-gentoo"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv icu ipv6 jpeg jpeg2k kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse3 ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zeitgeist zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="emu pc efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Wed Nov 20, 2013 6:56 am    Post subject: Reply with quote

If you mask the older versions where there is "no parents that aren't satisfied by other packages in this slot" it should most likely work.


Second problem is qt5 which can be resolved by adding the qt5 overlay.
Back to top
View user's profile Send private message
-=GGW=- $ol!d $n4>|e
Veteran
Veteran


Joined: 12 Apr 2004
Posts: 1604
Location: USA

PostPosted: Wed Nov 20, 2013 9:01 am    Post subject: Reply with quote

thanks for the quick response :) no dice though, tried unmasking older versions still wind up with this

Code:

sudo emerge unity-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!


[nomerge       ] unity-base/unity-meta-7.1.2::unity-gentoo  USE="chat cloud webapps xdm -accessibility -gnome -gnome-extras"
[nomerge       ]  net-im/empathy-3.8.4_p1_p02::unity-gentoo  USE="geoloc map spell v4l -debug -gnome -gnome-online-accounts {-test}"
[nomerge       ]   net-libs/account-plugins-0.11_p0_p01::unity-gentoo  USE="-debug"
[nomerge       ]    unity-base/gnome-control-center-signon-0.1.7_p0_p01-r1::unity-gentoo  USE="-debug"
[nomerge       ]     gnome-base/gnome-control-center-3.8.3_p0_p01-r3:2::unity-gentoo  USE="bluetooth colord cups gnome-online-accounts i18n socialweb -debug -kerberos -modemmanager -v4l" INPUT_DEVICES="-wacom"
[nomerge       ]      net-fs/samba-3.6.20  USE="acl aio client cups fam ldap netapi pam readline server smbclient winbind -addns -ads -avahi -caps -cluster -debug -dmapi -doc -examples -ldb -quota (-selinux) -smbsharemodes -swat -syslog"
[ebuild  N     ]       net-fs/cifs-utils-6.1-r1  USE="acl ads caps caps-ng -creds" 382 kB
[ebuild  N    ~]        net-fs/samba-3.6.20  USE="acl aio client cups fam ldap netapi pam readline server smbclient winbind -addns -ads -avahi -caps -cluster -debug -dmapi -doc -examples -ldb -quota (-selinux) -smbsharemodes -swat -syslog" 33,313 kB
[ebuild  N    ~] unity-base/unity-meta-7.1.2::unity-gentoo  USE="chat cloud webapps xdm -accessibility -gnome -gnome-extras" 0 kB
[ebuild  N    ~]  unity-lenses/unity-lens-meta-7.1.2::unity-gentoo  USE="applications files music photos video -friends -radio" 0 kB
[ebuild  N    ~]   unity-lenses/unity-lens-photos-1.0_p0_p01::unity-gentoo  PYTHON_TARGETS="python3_2 -python3_3" 76 kB
[ebuild  N    ~]  unity-base/gnome-control-center-unity-1.3_p0_p01-r1::unity-gentoo  USE="socialweb -debug" 77 kB
[ebuild  N    ~]  unity-indicators/unity-indicators-meta-7.1.2::unity-gentoo  USE="battery datetime session sound sync -paste -sensors -weather" 0 kB
[ebuild  N    ~]  x11-misc/webaccounts-browser-extension-0.5_p0_p01::unity-gentoo  USE="chromium firefox" 51 kB
[ebuild  N    ~]  net-im/empathy-3.8.4_p1_p02::unity-gentoo  USE="geoloc map spell v4l -debug -gnome -gnome-online-accounts {-test}" 4,822 kB
[ebuild  N    ~]  app-backup/deja-dup-27.3.1_p0_p01::unity-gentoo  USE="nautilus -debug" 806 kB
[ebuild  N    ~]  unity-extra/unity-tweak-tool-0.0.6::unity-gentoo  USE="nls" PYTHON_TARGETS="python3_2 -python3_3" 580 kB
[ebuild  N    ~]  unity-extra/unity-greeter-13.10.3_p0_p01::unity-gentoo  USE="branding nls -battery -debug -networkmanager" 496 kB
[nomerge       ] unity-lenses/unity-lens-photos-1.0_p0_p01::unity-gentoo  PYTHON_TARGETS="python3_2 -python3_3"
[ebuild  N    ~]  net-libs/account-plugins-0.11_p0_p01::unity-gentoo  USE="-debug" 21 kB
[ebuild  N    ~]   unity-base/gnome-control-center-signon-0.1.7_p0_p01-r1::unity-gentoo  USE="-debug" 124 kB
[nomerge       ] x11-misc/lightdm-1.8.2_p0_p01::unity-gentoo  USE="introspection qt4 -mir (-qt5)" LIGHTDM_GREETERS="unity -gtk -kde -razor"
[nomerge       ]  unity-extra/unity-greeter-13.10.3_p0_p01::unity-gentoo  USE="branding nls -battery -debug -networkmanager"
[ebuild  N    ~]   unity-indicators/indicator-datetime-13.10.0_p0_p01-r8::unity-gentoo  USE="-debug" 81 kB
[ebuild  N    ~]    gnome-base/gnome-control-center-3.8.3_p0_p01-r3:2::unity-gentoo  USE="bluetooth colord cups gnome-online-accounts i18n socialweb -debug -kerberos -modemmanager -v4l" INPUT_DEVICES="-wacom" 6,927 kB
[nomerge       ] unity-lenses/unity-lens-meta-7.1.2::unity-gentoo  USE="applications files music photos video -friends -radio"
[ebuild  N    ~]  unity-lenses/unity-lens-music-6.9.0_p0_p01-r4::unity-gentoo  60 kB
[ebuild  N    ~]   unity-base/rhythmbox-ubuntuone-13.10_p0_p01::unity-gentoo  PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 24 kB
[ebuild  N    ~]  unity-scopes/smart-scopes-0.1_p0_p01-r3::unity-gentoo  USE="{-test}" PYTHON_TARGETS="python3_2 -python3_3" 416 kB
[ebuild  N    ~]  unity-lenses/unity-lens-video-0.3.15_p0_p01-r3::unity-gentoo  41 kB
[ebuild  N    ~]  unity-scopes/unity-scope-home-6.8.2_p0_p01-r5::unity-gentoo  122 kB
[ebuild  N    ~]  unity-lenses/unity-lens-files-7.1.0_p0_p01-r2::unity-gentoo  USE="-debug" 52 kB
[ebuild  N    ~]   unity-lenses/unity-lens-applications-7.1.0_p0_p01-r4::unity-gentoo  USE="-debug" 77 kB
[ebuild  N    ~]    unity-base/unity-7.1.2_p0_p01-r2::unity-gentoo  USE="branding -debug -doc -pch {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 2,450 kB

Total: 24 packages (24 new), Size of downloads: 50,990 kB

 * Error: circular dependencies:

(net-fs/cifs-utils-6.1-r1::gentoo, ebuild scheduled for merge) depends on
 (net-fs/samba-3.6.20::gentoo, ebuild scheduled for merge) (buildtime)
  (net-fs/cifs-utils-6.1-r1::gentoo, ebuild scheduled for merge) (runtime)

It might be possible to break this cycle
by applying any of the following changes:
- net-fs/samba-3.6.20 (Change USE: -client)
- net-fs/cifs-utils-6.1-r1 (Change USE: -acl)

Note that this change can be reverted, once the package has been installed.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libxslt:0

  (dev-libs/libxslt-1.1.28-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libxslt-1.1.28-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxslt[python,python_targets_python2_7(-)?,python_single_target_python2_7(+)?] required by (unity-base/bamf-0.5.1_p0_p01-r1::unity-gentoo, ebuild scheduled for merge)

dev-libs/openssl:0

  (dev-libs/openssl-1.0.1e-r1::gentoo, installed) pulled in by
    >=dev-libs/openssl-0.9.6d:0[bindist=] required by (net-misc/openssh-5.9_p1-r4::gentoo, installed)

  (dev-libs/openssl-1.0.1e-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-0.9.8g[-bindist] required by (net-voip/telepathy-gabble-0.16.6::gentoo, ebuild scheduled for merge)
    >=dev-libs/openssl-0.9.8g[-bindist] required by (net-voip/telepathy-salut-0.8.1::gentoo, ebuild scheduled for merge)

x11-libs/libdrm:0

  (x11-libs/libdrm-2.4.46::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libdrm-2.4.46-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libdrm-2.4.46[video_cards_freedreno?,video_cards_nouveau?,video_cards_vmware?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/mesa-9.2.1_p1_p03-r2::unity-gentoo, ebuild scheduled for merge)

dev-lang/perl:0

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    <dev-lang/perl-5.16[-build] required by (dev-perl/File-BaseDir-0.30.0::gentoo, installed)
    ~dev-lang/perl-5.12.4 required by (virtual/perl-libnet-1.230.0::gentoo, installed)
    (and 51 more with the same problems)

  (dev-lang/perl-5.16.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/perl-5.14 required by (dev-qt/qtdbus-5.2.0_beta1::qt, ebuild scheduled for merge)
    (and 1 more with the same problem)

virtual/udev:0

  (virtual/udev-200::gentoo, installed) pulled in by
    =virtual/udev-200[hwdb(+)] required by (media-sound/pulseaudio-4.0::gentoo, ebuild scheduled for merge)
    (and 31 more with the same problem)

  (virtual/udev-206-r3::gentoo, ebuild scheduled for merge) pulled in by
    virtual/udev[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-libs/mesa-9.2.1_p1_p03-r2::unity-gentoo, ebuild scheduled for merge)
    >=virtual/udev-206-r2 required by (sys-fs/udev-208::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problems)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.3_p3_p02::unity-gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server[dmx] required by (unity-base/frame-2.5.0a_p0_p01::unity-gentoo, ebuild scheduled for merge)
    x11-base/xorg-server[dmx] required by (unity-base/unity-7.1.2_p0_p01-r2::unity-gentoo, ebuild scheduled for merge)
    x11-base/xorg-server[dmx] required by (unity-base/compiz-0.9.10_p0_p01-r7::unity-gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.14.3-r2::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-input-evdev-2.8.1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- gnome-extra/polkit-gnome-0.105::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Wed Nov 20, 2013 9:24 am    Post subject: Reply with quote

samba/cifs you could maybe solve by following portage recommendations (temporarily)

dev-libs/libxslt, no idea. I can look it up how it is for me once back home tonight or tomorrow (CET)
EDIT: dev-libs/libxslt-1.1.28-r1 USE="crypt python -debug -static-libs" PYTHON_TARGETS="python2_7 -python2_6"

USE: dev-libs/openssl -bindist, does this help?
EDIT: dev-libs/openssl-1.0.1e-r1 USE="(sse2) tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -static-libs {-test} -vanilla"

mask <x11-libs/libdrm-2.4.46-r1

perl, no idea. I can look it up how it is for me once back home tonight or tomorrow (CET), maybe you identify all 53 packages that depend on perl < 5.16 and check if there are new versions availbale that accept >=5.16.1...
EDIT: dev-lang/perl-5.16.1 USE="berkdb gdbm -debug -doc -ithreads"

udev, had a hard time with that one, too.... :D CAn look it up tonight also, btw are you on systemd already? If not you need to migrate to systemd.
EDIT:
sys-apps/systemd-207-r2 USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -openrc -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
virtual/udev-206-r3 USE="gudev introspection kmod (-selinux) -static-libs" ABI_X86="(64) -32 (-x32)" 0 kB




x11-base/xorg-server, USE dmx?, if you can live with a broken system (in terms of X input devices) during isntallation (which might take quite some days...) you could try unmerge xf86-inout-evdev or look out if there is a new version (that helps often) availbale that needs unmasking/keywording and mask x11-base/xorg-server-1.14.3-r2 or all xorg-servers from gentoo and make sure only one from overlay is pulled in
EDIT: x11-base/xorg-server-1.14.3_p3_p02::unity-gentoo USE="dmx ipv6 kdrive nptl suid udev xorg -doc -minimal -mir (-selinux) -static-libs -tslib -xnest -xvfb"
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Fri Nov 22, 2013 9:34 pm    Post subject: Reply with quote

Hi,
for me, the emerge doesn't work as well. I symlinked the mask, unmask and use files from the overlay but still get:
Code:
emerge -av unity-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/xapian:0

  (dev-libs/xapian-1.3.1-r1::gentoo, installed) pulled in by
    =dev-libs/xapian-1.3.1* required by (dev-libs/xapian-bindings-1.3.1::gentoo, ebuild scheduled for merge)

  (dev-libs/xapian-1.2.15::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/xapian-1.3 required by (unity-lenses/unity-lens-applications-7.1.0_p0_p01-r4::unity-gentoo, ebuild scheduled for merge)

gnome-base/gvfs:0

  (gnome-base/gvfs-1.16.3-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-base/gvfs-1.16.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    gnome-base/gvfs[fuse] required by (app-backup/deja-dup-27.3.1_p0_p01::unity-gentoo, ebuild scheduled for merge)

dev-libs/boost:0

  (dev-libs/boost-1.53.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.52.0-r6::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.52 required by (unity-base/compiz-0.9.10_p0_p01-r7::unity-gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by app-admin/packagekit-base-0.7.4
# required by app-admin/packagekit-qt4-0.7.4
# required by app-admin/packagekit-0.7.4[qt4]
# required by dev-libs/libunity-webapps-2.5.0a_p0_p01-r3::unity-gentoo
# required by x11-misc/unity-firefox-extension-2.4.8_p0_p01::unity-gentoo
# required by x11-misc/webaccounts-browser-extension-0.5_p0_p01::unity-gentoo[firefox]
# required by unity-base/unity-meta-7.1.2::unity-gentoo[webapps]
# required by unity-meta (argument)
# /etc/portage/package.mask/portage.pmask:
# >www-servers/apache-2.4
=sys-auth/consolekit-0.4.6

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

emerge: there are no ebuilds to satisfy "dev-qt/qtdbus:5".
(dependency required by "unity-base/hud-13.10.1_p0_p01-r11::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-7.1.2::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


Adding a qt5 aoverlay doesn't work either:

Code:
layman -a qt5

 * Adding overlay,...
 * Exception: Overlay "qt5" does not exist.

 * CLI: Errors occurred processing action add
 * Exception: Overlay "qt5" does not exist.

So, is the whole thing still alive?

Rüdiger
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Fri Nov 22, 2013 10:52 pm    Post subject: Reply with quote

Hallo Rüdiger,

Yes, I guess it is still alive however the initial merge is always a bit lengthy. At least that is how was for me.
I think the qt5 overlay is actually named "qt" only.

I would start by umasking consolekit as portage suggests.


gnome-base/gvfs add USE fuse

dev-libs/boost-1.53.0 is installed on your system however it seems you can downgrade to 1.52.0-r6 safly (check with equery d before anyways)

xapian: no idea ad hoc but maybe you can unmerge 1.3x if you manage to avoid installling xapian-bindings-1.3x. Maybe mask it to use binding 1.2x for xapian 1.2x.
If have xapian and xapian bindgs 1.2.14 installed for my unity installation.

Gruß,
T
Back to top
View user's profile Send private message
Bluemerlin
n00b
n00b


Joined: 13 Apr 2011
Posts: 2

PostPosted: Mon Nov 25, 2013 3:42 pm    Post subject: Reply with quote

I'm having an issue with emerging unity-meta in that nux requires <media-libs/glew-1.8 however 1.9 is in stable portage and the overlay.

Code:
emerge: there are no ebuilds to satisfy "<media-libs/glew-1.8".
(dependency required by "unity-base/nux-4.0.3_p0_p01::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-7.1.2_p0_p01-r3::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-7.1.2::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


What should I do?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 24, 25, 26  Next
Page 25 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum