Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
LightDM Keeps Restarting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cld71
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2005
Posts: 128

PostPosted: Sun Jul 08, 2012 6:24 pm    Post subject: LightDM Keeps Restarting Reply with quote

LightDM keeps restarting after running `/etc/init.d/xdm start`.
In the /var/log/lightdm/ I am getting this:
Code:
Session 3185 got 1 message(s) from PAM
[+1.68s] DEBUG: Prompt greeter with 1 message(s)
[+1.73s] DEBUG: Greeter closed communication channel
[+1.73s] DEBUG: Session 3166 exited with return value 4
[+1.73s] DEBUG: Greeter quit
[+1.73s] DEBUG: Failed to start greeter
[+1.73s] DEBUG: Stopping display
[+1.73s] DEBUG: Sending signal 15 to process 3158
[+1.90s] DEBUG: Process 3158 exited with return value 0
[+1.90s] DEBUG: X server stopped

I am using lightdm-gtk-greeter add on.
Back to top
View user's profile Send private message
cld71
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2005
Posts: 128

PostPosted: Sun Jul 08, 2012 6:56 pm    Post subject: Re: LightDM Keeps Restarting Reply with quote

cld71 wrote:
LightDM keeps restarting after running `/etc/init.d/xdm start`.
In the /var/log/lightdm/ I am getting this:
Code:
Session 3185 got 1 message(s) from PAM
[+1.68s] DEBUG: Prompt greeter with 1 message(s)
[+1.73s] DEBUG: Greeter closed communication channel
[+1.73s] DEBUG: Session 3166 exited with return value 4
[+1.73s] DEBUG: Greeter quit
[+1.73s] DEBUG: Failed to start greeter
[+1.73s] DEBUG: Stopping display
[+1.73s] DEBUG: Sending signal 15 to process 3158
[+1.90s] DEBUG: Process 3158 exited with return value 0
[+1.90s] DEBUG: X server stopped

I am using lightdm-gtk-greeter add on.

I think this is also a gnome problem.
Back to top
View user's profile Send private message
cld71
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2005
Posts: 128

PostPosted: Sun Jul 08, 2012 10:30 pm    Post subject: GTK+ 3.0 Illegal instruction Reply with quote

It is GTK+ 3.0 that isn't working.
When I execute gedit it gives me Illegal instruction.
I have done a revdep-rebuild and it says everything is ok.
Is there anyway to test what is wrong with GTK+ 3.0?
GTK+ 1.0 works fine.
Back to top
View user's profile Send private message
cld71
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jul 2005
Posts: 128

PostPosted: Mon Jul 09, 2012 1:42 am    Post subject: [solved] Reply with quote

Found the problem.
The problem was python 3.1 needed to be uninstalled and python needed to be updated.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum