Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keyboard is not working in GNOME
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Thu Jul 05, 2012 8:52 pm    Post subject: Keyboard is not working in GNOME Reply with quote

Hi, ALL,
I have a dual-boot laptop with Win7 and Gentoo. Everything was working properly until today.
Today I needed to boot Gentoo. It booted up OK, and I was able to login. On the console everything was working.

I issued "startx", GNOME started, but to my surprise keyboard was not responding to anything.
I closed GNOME going back to console and the keyboard was working again.

What am I missing?

Thank you.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Jul 05, 2012 9:08 pm    Post subject: Reply with quote

ONEEYEMAN,

When my keyboard and/or mouse doesn't respond I just
Code:
emerge -av1 $(qlist -I -C x11-drivers)
and that seems to take care of it

Good luck :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Jul 05, 2012 9:38 pm    Post subject: Reply with quote

Perhaps revdep-rebuild ?
If you pulled udev 186 (IMHO, it should have landed in package.mask for a week or two first), you just had an ABI break on libudev.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Fri Jul 06, 2012 4:46 am    Post subject: Reply with quote

BillWho wrote:

ONEEYEMAN,

When my keyboard and/or mouse doesn't respond I just
Code:
emerge -av1 $(qlist -I -C x11-drivers)
and that seems to take care of it

Good luck :wink:


Tried that without success.

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Fri Jul 06, 2012 4:49 am    Post subject: Reply with quote

VoidMage wrote:

Perhaps revdep-rebuild ?
If you pulled udev 186 (IMHO, it should have landed in package.mask for a week or two first), you just had an ABI break on libudev.


No, have udev-171-r6.
Currently running revdep-rebuild. Hopefullyu it will fix it.

Will report back.

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Fri Jul 06, 2012 6:05 am    Post subject: Reply with quote

Running "revdep-rebuild" didn't help.

Any other idea?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Fri Jul 06, 2012 6:52 am    Post subject: Reply with quote

Maybe this will give some tips:

Code:

[    74.219]
X.Org X Server 1.9.5
Release Date: 2011-03-17
[    74.220] X Protocol Version 11, Revision 0
[    74.220] Build Operating System: Linux 2.6.38-gentoo-r6 x86_64 Gentoo
[    74.220] Current Operating System: Linux IgorReinCloud 3.1.6-gentoo #2 SMP Tue Jan 24 02:23:33 PST 2012 x86_64
[    74.221] Kernel command line: root=/dev/sda7 resume=/dev/sda6
[    74.221] Build Date: 18 June 2011  11:41:10AM
[    74.221] 
[    74.221] Current version of pixman: 0.22.2
[    74.222]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    74.222] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    74.223] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul  5 23:23:48 2012
[    74.280] (==) Using config file: "/etc/X11/xorg.conf"
[    74.280] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    74.326] (==) ServerLayout "aticonfig Layout"
[    74.326] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    74.326] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    74.327] (**) |   |-->Device "aticonfig-Device[0]-0"
[    74.327] (**) Option "BlankTime" "10"
[    74.327] (**) Option "StandbyTime" "20"
[    74.327] (**) Option "SuspendTime" "30"
[    74.327] (**) Option "OffTime" "60"
[    74.327] (==) Automatically adding devices
[    74.327] (==) Automatically enabling devices
[    74.353] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[    74.353]    Entry deleted from font path.
[    74.353] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    74.353]    Entry deleted from font path.
[    74.353] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    74.353]    Entry deleted from font path.
[    74.353] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    74.353]    Entry deleted from font path.
[    74.353] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[    74.353]    Entry deleted from font path.
[    74.353] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[    74.353]    Entry deleted from font path.
[    74.353] (==) FontPath set to:
   
[    74.353] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    74.353] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    74.354] (II) Loader magic: 0x7ce140
[    74.354] (II) Module ABI versions:
[    74.354]    X.Org ANSI C Emulation: 0.4
[    74.354]    X.Org Video Driver: 8.0
[    74.354]    X.Org XInput driver : 11.0
[    74.354]    X.Org Server Extension : 4.0
[    74.356] (--) PCI:*(0:0:1:0) 1002:9802:1025:0520 rev 0, Mem @ 0xe0000000/268435456, 0xf0400000/262144, I/O @ 0x00004000/256
[    74.357] (II) Open ACPI successful (/var/run/acpid.socket)
[    74.357] (II) "extmod" will be loaded by default.
[    74.357] (II) "dbe" will be loaded by default.
[    74.357] (II) "glx" will be loaded by default.
[    74.357] (II) "record" will be loaded by default.
[    74.357] (II) "dri" will be loaded by default.
[    74.357] (II) "dri2" will be loaded by default.
[    74.357] (II) LoadModule: "extmod"
[    74.492] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[    74.519] (II) Module extmod: vendor="X.Org Foundation"
[    74.519]    compiled for 1.9.5, module version = 1.0.0
[    74.519]    Module class: X.Org Server Extension
[    74.519]    ABI class: X.Org Server Extension, version 4.0
[    74.519] (II) Loading extension MIT-SCREEN-SAVER
[    74.519] (II) Loading extension XFree86-VidModeExtension
[    74.519] (II) Loading extension XFree86-DGA
[    74.520] (II) Loading extension DPMS
[    74.520] (II) Loading extension XVideo
[    74.520] (II) Loading extension XVideo-MotionCompensation
[    74.520] (II) Loading extension X-Resource
[    74.520] (II) LoadModule: "dbe"
[    74.641] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[    74.674] (II) Module dbe: vendor="X.Org Foundation"
[    74.674]    compiled for 1.9.5, module version = 1.0.0
[    74.674]    Module class: X.Org Server Extension
[    74.674]    ABI class: X.Org Server Extension, version 4.0
[    74.674] (II) Loading extension DOUBLE-BUFFER
[    74.674] (II) LoadModule: "glx"
[    74.675] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    74.721] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    74.722]    compiled for 6.9.0, module version = 1.0.0
[    74.723] (II) Loading extension GLX
[    74.723] (II) LoadModule: "record"
[    74.723] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[    74.738] (II) Module record: vendor="X.Org Foundation"
[    74.738]    compiled for 1.9.5, module version = 1.13.0
[    74.738]    Module class: X.Org Server Extension
[    74.738]    ABI class: X.Org Server Extension, version 4.0
[    74.738] (II) Loading extension RECORD
[    74.738] (II) LoadModule: "dri"
[    74.739] (WW) Warning, couldn't open module dri
[    74.740] (II) UnloadModule: "dri"
[    74.740] (EE) Failed to load module "dri" (module does not exist, 0)
[    74.740] (II) LoadModule: "dri2"
[    74.741] (WW) Warning, couldn't open module dri2
[    74.741] (II) UnloadModule: "dri2"
[    74.741] (EE) Failed to load module "dri2" (module does not exist, 0)
[    74.741] (II) LoadModule: "fglrx"
[    74.741] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[    75.081] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
[    75.098]    compiled for 1.4.99.906, module version = 8.91.4
[    75.098]    Module class: X.Org Video Driver
[    75.099] (II) Loading sub module "fglrxdrm"
[    75.099] (II) LoadModule: "fglrxdrm"
[    75.099] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[    75.129] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
[    75.129]    compiled for 1.4.99.906, module version = 8.91.4
[    75.129] (II) ATI Proprietary Linux Driver Version Identifier:8.91.4
[    75.129] (II) ATI Proprietary Linux Driver Release Identifier: 8.911                               
[    75.129] (II) ATI Proprietary Linux Driver Build Date: Oct 25 2011 21:24:13
[    75.129] (--) using VT number 7

[    75.134] (WW) Falling back to old probe method for fglrx
[    75.249] (II) Loading PCS database from /etc/ati/amdpcsdb
[    75.294] (--) Chipset Supported AMD Graphics Processor (0x9802) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[    75.296] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[    75.297] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:0) found
[    75.297] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:2) found
[    75.297] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:21:3) found
[    75.299] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    75.306] (II) AMD Video driver is signed
[    75.306] (II) fglrx(0): pEnt->device->identifier=0xca4680
[    75.307] (II) fglrx(0): === [xdl_x760_atiddxPreInit] === begin
[    75.307] (II) Loading sub module "vgahw"
[    75.307] (II) LoadModule: "vgahw"
[    75.307] (II) Loading /usr/lib64/xorg/modules/libvgahw.so
[    75.315] (II) Module vgahw: vendor="X.Org Foundation"
[    75.315]    compiled for 1.9.5, module version = 0.1.0
[    75.315]    ABI class: X.Org Video Driver, version 8.0
[    75.315] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    75.315] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    75.315] (==) fglrx(0): Default visual is TrueColor
[    75.315] (**) fglrx(0): Option "DPMS" "true"
[    75.316] (==) fglrx(0): RGB weight 888
[    75.316] (II) fglrx(0): Using 8 bits per RGB
[    75.316] (==) fglrx(0): Buffer Tiling is ON
[    75.317] (II) Loading sub module "fglrxdrm"
[    75.317] (II) LoadModule: "fglrxdrm"
[    75.317] (II) Reloading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[    75.322] ukiDynamicMajor: found major device number 251
[    75.322] ukiDynamicMajor: found major device number 251
[    75.322] ukiOpenByBusid: Searching for BusID PCI:0:1:0
[    75.322] ukiOpenDevice: node name is /dev/ati/card0
[    75.322] ukiOpenDevice: open result is 10, (OK)
[    75.322] ukiOpenByBusid: ukiOpenMinor returns 10
[    75.323] ukiOpenByBusid: ukiGetBusid reports PCI:0:1:0
[    75.323] (==) fglrx(0): NoAccel = NO
[    75.323] (==) fglrx(0): ATI 2D Acceleration Architecture enabled
[    75.323] (--) fglrx(0): Chipset: "AMD Radeon HD 6300 series Graphics" (Chipset = 0x9802)
[    75.323] (--) fglrx(0): (PciSubVendor = 0x1025, PciSubDevice = 0x0520)
[    75.323] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
[    75.323] (--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
[    75.323] (--) fglrx(0): MMIO registers at 0xf0400000
[    75.323] (--) fglrx(0): I/O port at 0x00004000
[    75.323] (==) fglrx(0): ROM-BIOS at 0x000c0000
[    75.400] (II) fglrx(0): ATIF platform detected
[    75.401] (II) fglrx(0): AC Adapter is used
[    75.493] (II) fglrx(0): Primary V_BIOS segment is: 0xc000
[    75.559] (II) Loading sub module "vbe"
[    75.559] (II) LoadModule: "vbe"
[    75.559] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    75.576] (II) Module vbe: vendor="X.Org Foundation"
[    75.576]    compiled for 1.9.5, module version = 1.1.0
[    75.576]    ABI class: X.Org Video Driver, version 8.0
[    75.576] (II) fglrx(0): VESA BIOS detected
[    75.576] (II) fglrx(0): VESA VBE Version 3.0
[    75.576] (II) fglrx(0): VESA VBE Total Mem: 16384 kB
[    75.577] (II) fglrx(0): VESA VBE OEM: AMD ATOMBIOS
[    75.577] (II) fglrx(0): VESA VBE OEM Software Rev: 12.36
[    75.577] (II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2010, AMD Technologies Inc.
[    75.577] (II) fglrx(0): VESA VBE OEM Product: WRESTLER
[    75.577] (II) fglrx(0): VESA VBE OEM Product Rev: 01.00
[    75.595] (II) fglrx(0): ATI Video BIOS revision 9 or later detected
[    75.595] (--) fglrx(0): Video RAM: 262144 kByte, Type: DDR3
[    75.595] (II) fglrx(0): PCIE card detected
[    75.595] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
[    75.595] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[    75.604] (II) fglrx(0): Using adapter: 0:1.0.
[    76.555] (II) fglrx(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x10000000)
[    76.830] (II) fglrx(0): Interrupt handler installed at IRQ 42.
[    76.830] (II) fglrx(0): RandR 1.2 support is enabled!
[    76.830] (II) fglrx(0): RandR 1.2 rotation support is enabled!
[    76.830] (==) fglrx(0): Center Mode is disabled
[    76.830] (II) Loading sub module "fb"
[    76.830] (II) LoadModule: "fb"
[    76.830] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    76.850] (II) Module fb: vendor="X.Org Foundation"
[    76.850]    compiled for 1.9.5, module version = 1.0.0
[    76.850]    ABI class: X.Org ANSI C Emulation, version 0.4
[    76.850] (II) Loading sub module "ddc"
[    76.850] (II) LoadModule: "ddc"
[    76.850] (II) Module "ddc" already built-in
[    77.050] (II) fglrx(0): Finished Initialize PPLIB!
[    77.053] (II) fglrx(0): Output LVDS using monitor section aticonfig-Monitor[0]-0
[    77.053] (II) fglrx(0): Output DFP1 has no monitor section
[    77.053] (II) fglrx(0): Output CRT1 has no monitor section
[    77.054] (II) Loading sub module "ddc"
[    77.054] (II) LoadModule: "ddc"
[    77.054] (II) Module "ddc" already built-in
[    77.054] (II) fglrx(0): Connected Display0: LVDS
[    77.054] (II) fglrx(0): Display0 EDID data ---------------------------
[    77.054] (II) fglrx(0): Manufacturer: AUO  Model: 26ec  Serial#: 0
[    77.054] (II) fglrx(0): Year: 2009  Week: 1
[    77.054] (II) fglrx(0): EDID Version: 1.3
[    77.054] (II) fglrx(0): Digital Display Input
[    77.054] (II) fglrx(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[    77.054] (II) fglrx(0): Gamma: 2.20
[    77.054] (II) fglrx(0): No DPMS capabilities specified
[    77.054] (II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[    77.054] (II) fglrx(0): First detailed timing is preferred mode
[    77.054] (II) fglrx(0): redX: 0.577 redY: 0.333   greenX: 0.333 greenY: 0.554
[    77.054] (II) fglrx(0): blueX: 0.161 blueY: 0.144   whiteX: 0.313 whiteY: 0.329
[    77.054] (II) fglrx(0): Manufacturer's mask: 0
[    77.054] (II) fglrx(0): Supported detailed timing:
[    77.054] (II) fglrx(0): clock: 71.8 MHz   Image Size:  344 x 193 mm
[    77.054] (II) fglrx(0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1526 h_border: 0
[    77.054] (II) fglrx(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 784 v_border: 0
[    77.055] (II) fglrx(0): Unknown vendor-specific block f
[    77.055] (II) fglrx(0):  AUO
[    77.055] (II) fglrx(0):  B156XW02 V6
[    77.055] (II) fglrx(0): EDID (in hex):
[    77.055] (II) fglrx(0):    00ffffffffffff0006afec2600000000
[    77.055] (II) fglrx(0):    01130103802213780ad7759355558d29
[    77.055] (II) fglrx(0):    24505400000001010101010101010101
[    77.055] (II) fglrx(0):    0101010101010c1c56a0500010303020
[    77.055] (II) fglrx(0):    360058c1100000180000000f00000000
[    77.055] (II) fglrx(0):    00000000000000000020000000fe0041
[    77.055] (II) fglrx(0):    554f0a202020202020202020000000fe
[    77.055] (II) fglrx(0):    004231353658573032205636200a0065
[    77.055] (II) fglrx(0): End of Display0 EDID data --------------------
[    77.058] (II) fglrx(0): EDID for output LVDS
[    77.058] (II) fglrx(0): Manufacturer: AUO  Model: 26ec  Serial#: 0
[    77.058] (II) fglrx(0): Year: 2009  Week: 1
[    77.058] (II) fglrx(0): EDID Version: 1.3
[    77.058] (II) fglrx(0): Digital Display Input
[    77.058] (II) fglrx(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[    77.058] (II) fglrx(0): Gamma: 2.20
[    77.058] (II) fglrx(0): No DPMS capabilities specified
[    77.058] (II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[    77.058] (II) fglrx(0): First detailed timing is preferred mode
[    77.058] (II) fglrx(0): redX: 0.577 redY: 0.333   greenX: 0.333 greenY: 0.554
[    77.058] (II) fglrx(0): blueX: 0.161 blueY: 0.144   whiteX: 0.313 whiteY: 0.329
[    77.058] (II) fglrx(0): Manufacturer's mask: 0
[    77.058] (II) fglrx(0): Supported detailed timing:
[    77.058] (II) fglrx(0): clock: 71.8 MHz   Image Size:  344 x 193 mm
[    77.058] (II) fglrx(0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1526 h_border: 0
[    77.058] (II) fglrx(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 784 v_border: 0
[    77.058] (II) fglrx(0): Unknown vendor-specific block f
[    77.058] (II) fglrx(0):  AUO
[    77.058] (II) fglrx(0):  B156XW02 V6
[    77.058] (II) fglrx(0): EDID (in hex):
[    77.058] (II) fglrx(0):    00ffffffffffff0006afec2600000000
[    77.058] (II) fglrx(0):    01130103802213780ad7759355558d29
[    77.058] (II) fglrx(0):    24505400000001010101010101010101
[    77.058] (II) fglrx(0):    0101010101010c1c56a0500010303020
[    77.058] (II) fglrx(0):    360058c1100000180000000f00000000
[    77.059] (II) fglrx(0):    00000000000000000020000000fe0041
[    77.059] (II) fglrx(0):    554f0a202020202020202020000000fe
[    77.059] (II) fglrx(0):    004231353658573032205636200a0065
[    77.059] (II) fglrx(0): EDID vendor "AUO", prod id 9964
[    77.059] (II) fglrx(0): Printing DDC gathered Modelines:
[    77.059] (II) fglrx(0): Modeline "1366x768"x0.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Printing probed modes for output LVDS
[    77.059] (II) fglrx(0): Modeline "1366x768"x60.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "1360x768"x60.0   71.80  1360 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "1280x768"x60.0   71.80  1280 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "1280x720"x60.0   71.80  1280 1414 1446 1526  720 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "1024x768"x60.0   71.80  1024 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "1024x600"x60.0   71.80  1024 1414 1446 1526  600 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "800x600"x60.0   71.80  800 1414 1446 1526  600 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "800x480"x60.0   71.80  800 1414 1446 1526  480 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): Modeline "640x480"x60.0   71.80  640 1414 1446 1526  480 771 777 784 -hsync -vsync (47.1 kHz)
[    77.059] (II) fglrx(0): EDID for output DFP1
[    77.060] (II) fglrx(0): EDID for output CRT1
[    77.060] (II) fglrx(0): Output LVDS connected
[    77.060] (II) fglrx(0): Output DFP1 disconnected
[    77.060] (II) fglrx(0): Output CRT1 disconnected
[    77.060] (II) fglrx(0): Using exact sizes for initial modes
[    77.060] (II) fglrx(0): Output LVDS using initial mode 1366x768
[    77.060] (II) fglrx(0): Display dimensions: (340, 190) mm
[    77.060] (II) fglrx(0): DPI set to (102, 102)
[    77.060] (II) fglrx(0): Adapter AMD Radeon HD 6300 series Graphics has 2 configurable heads and 1 displays connected.
[    77.060] (==) fglrx(0):  PseudoColor visuals disabled
[    77.060] (II) Loading sub module "ramdac"
[    77.060] (II) LoadModule: "ramdac"
[    77.060] (II) Module "ramdac" already built-in
[    77.060] (==) fglrx(0): NoDRI = NO
[    77.060] (==) fglrx(0): Capabilities: 0x00000000
[    77.060] (==) fglrx(0): CapabilitiesEx: 0x00000000
[    77.061] (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
[    77.061] (==) fglrx(0): UseFastTLS=0
[    77.061] (==) fglrx(0): BlockSignalsOnLock=1
[    77.085] (--) Depth 24 pixmap format is 32 bpp
[    77.085] (II) Loading extension ATIFGLRXDRI
[    77.085] (II) fglrx(0): doing swlDriScreenInit
[    77.085] (II) fglrx(0): swlDriScreenInit for fglrx driver
[    77.086] ukiDynamicMajor: found major device number 251
[    77.086] ukiDynamicMajor: found major device number 251
[    77.086] ukiDynamicMajor: found major device number 251
[    77.086] ukiOpenByBusid: Searching for BusID PCI:0:1:0
[    77.086] ukiOpenDevice: node name is /dev/ati/card0
[    77.086] ukiOpenDevice: open result is 13, (OK)
[    77.086] ukiOpenByBusid: ukiOpenMinor returns 13
[    77.086] ukiOpenByBusid: ukiGetBusid reports PCI:0:1:0
[    77.086] (II) fglrx(0): [uki] DRM interface version 1.0
[    77.086] (II) fglrx(0): [uki] created "fglrx" driver at busid "PCI:0:1:0"
[    77.086] (II) fglrx(0): [uki] added 8192 byte SAREA at 0x2000
[    77.086] (II) fglrx(0): [uki] mapped SAREA 0x2000 to 0x7fcc7b8c5000
[    77.086] (II) fglrx(0): [uki] framebuffer handle = 0x3000
[    77.087] (II) fglrx(0): [uki] added 1 reserved context for kernel
[    77.087] (II) fglrx(0): swlDriScreenInit done
[    77.087] (II) fglrx(0): Kernel Module Version Information:
[    77.087] (II) fglrx(0):     Name: fglrx
[    77.087] (II) fglrx(0):     Version: 8.91.4
[    77.087] (II) fglrx(0):     Date: Oct 25 2011
[    77.087] (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
[    77.087] (II) fglrx(0): Kernel Module version matches driver.
[    77.087] (II) fglrx(0): Kernel Module Build Time Information:
[    77.087] (II) fglrx(0):     Build-Kernel UTS_RELEASE:        3.1.6-gentoo
[    77.087] (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
[    77.087] (II) fglrx(0):     Build-Kernel __SMP__:            yes
[    77.087] (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
[    77.087] (II) fglrx(0): [uki] register handle = 0x00004000
[    77.157] (II) fglrx(0): DRI initialization successfull
[    77.157] (II) fglrx(0): FBADPhys: 0xf00000000 FBMappedSize: 0x01004000
[    77.185] (==) fglrx(0): Backing store disabled
[    77.185] (II) Loading extension FGLRXEXTENSION
[    77.185] (**) fglrx(0): DPMS enabled
[    77.186] (II) fglrx(0): Initialized in-driver Xinerama extension
[    77.186] (**) fglrx(0): Textured Video is enabled.
[    77.186] (II) LoadModule: "glesx"
[    77.186] (II) Loading /usr/lib64/xorg/modules/glesx.so
[    77.377] (II) Module glesx: vendor="X.Org Foundation"
[    77.377]    compiled for 1.4.99.906, module version = 1.0.0
[    77.377] (II) Loading extension GLESX
[    77.377] (II) fglrx(0): GLESX enableFlags = 592
[    77.377] (II) fglrx(0): GLESX is enabled
[    77.377] (II) LoadModule: "amdxmm"
[    77.378] (II) Loading /usr/lib64/xorg/modules/amdxmm.so
[    77.398] (II) Module amdxmm: vendor="X.Org Foundation"
[    77.398]    compiled for 1.4.99.906, module version = 2.0.0
[    77.408] (II) Loading extension AMDXVOPL
[    77.408] (II) Loading extension AMDXVBA
[    77.408] [-     XMM_GLX] [I ]glesxXvInit Configureable RGBOutputColorRange
[    77.429] (II) fglrx(0): UVD feature is enabled(II) fglrx(0):
[    77.434] (II) fglrx(0): Enable composite support successfully
[    77.435] (WW) fglrx(0): Option "VendorName" is not used
[    77.435] (WW) fglrx(0): Option "ModelName" is not used
[    77.435] (II) fglrx(0): X context handle = 0x1
[    77.435] (II) fglrx(0): [DRI] installation complete
[    77.435] (==) fglrx(0): Silken mouse enabled
[    77.450] (==) fglrx(0): Using HW cursor of display infrastructure!
[    77.450] (II) fglrx(0): Disabling in-server RandR and enabling in-driver RandR 1.2.
[    77.451] (II) fglrx(0): 'LVDS LCD' ConnectorType, abstracted as 'Panel'
[    77.451] (II) fglrx(0): 'eDP LCD' ConnectorType, abstracted as 'Panel'
[    78.565] (WW) fglrx(0): Framebuffer compression is disabled by the driver: Video Ram = 262144 kByte
[    78.565] (--) RandR disabled
[    78.565] (II) Initializing built-in extension Generic Event Extension
[    78.565] (II) Initializing built-in extension SHAPE
[    78.565] (II) Initializing built-in extension MIT-SHM
[    78.565] (II) Initializing built-in extension XInputExtension
[    78.565] (II) Initializing built-in extension XTEST
[    78.565] (II) Initializing built-in extension BIG-REQUESTS
[    78.565] (II) Initializing built-in extension SYNC
[    78.565] (II) Initializing built-in extension XKEYBOARD
[    78.565] (II) Initializing built-in extension XC-MISC
[    78.565] (II) Initializing built-in extension XINERAMA
[    78.565] (II) Initializing built-in extension XFIXES
[    78.565] (II) Initializing built-in extension RENDER
[    78.565] (II) Initializing built-in extension RANDR
[    78.565] (II) Initializing built-in extension COMPOSITE
[    78.565] (II) Initializing built-in extension DAMAGE
[    78.570] ukiDynamicMajor: found major device number 251
[    78.570] ukiDynamicMajor: found major device number 251
[    78.570] ukiOpenByBusid: Searching for BusID PCI:0:1:0
[    78.570] ukiOpenDevice: node name is /dev/ati/card0
[    78.570] ukiOpenDevice: open result is 14, (OK)
[    78.570] ukiOpenByBusid: ukiOpenMinor returns 14
[    78.570] ukiOpenByBusid: ukiGetBusid reports PCI:0:1:0
[    80.035] (II) AIGLX: Loaded and initialized OpenGL driver(II) GLX: Initialized DRI GL provider for screen 0
[    80.168] (II) fglrx(0): Enable the clock gating!
[    80.169] (II) fglrx(0): Setting screen physical size to 361 x 203
[    80.585] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    80.585] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    80.585] (II) LoadModule: "evdev"
[    80.585] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    80.594] (II) Module evdev: vendor="X.Org Foundation"
[    80.594]    compiled for 1.9.5, module version = 2.6.0
[    80.594]    Module class: X.Org XInput Driver
[    80.594]    ABI class: X.Org XInput driver, version 11.0
[    80.594] (**) Power Button: always reports core events
[    80.594] (**) Power Button: Device: "/dev/input/event3"
[    80.594] (--) Power Button: Found keys
[    80.594] (II) Power Button: Configuring as keyboard
[    80.594] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    80.594] (**) Option "xkb_rules" "evdev"
[    80.594] (**) Option "xkb_model" "evdev"
[    80.594] (**) Option "xkb_layout" "us"
[    80.965] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    80.965] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    80.965] (**) Power Button: always reports core events
[    80.965] (**) Power Button: Device: "/dev/input/event0"
[    80.965] (--) Power Button: Found keys
[    80.965] (II) Power Button: Configuring as keyboard
[    80.966] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    80.966] (**) Option "xkb_rules" "evdev"
[    80.966] (**) Option "xkb_model" "evdev"
[    80.966] (**) Option "xkb_layout" "us"
[    80.968] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[    80.968] (II) No input driver/identifier specified (ignoring)
[    80.969] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    80.969] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    80.969] (**) Sleep Button: always reports core events
[    80.969] (**) Sleep Button: Device: "/dev/input/event1"
[    80.969] (--) Sleep Button: Found keys
[    80.969] (II) Sleep Button: Configuring as keyboard
[    80.969] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
[    80.969] (**) Option "xkb_rules" "evdev"
[    80.969] (**) Option "xkb_model" "evdev"
[    80.969] (**) Option "xkb_layout" "us"
[    80.973] (II) config/udev: Adding input device HD-Audio Generic HDMI/DP (/dev/input/event7)
[    80.973] (II) No input driver/identifier specified (ignoring)
[    80.984] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event8)
[    80.984] (II) No input driver/identifier specified (ignoring)
[    80.987] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[    80.987] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    80.987] (**) AT Translated Set 2 keyboard: always reports core events
[    80.987] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[    80.987] (--) AT Translated Set 2 keyboard: Found keys
[    80.988] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    80.988] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    80.988] (**) Option "xkb_rules" "evdev"
[    80.988] (**) Option "xkb_model" "evdev"
[    80.988] (**) Option "xkb_layout" "us"
[    80.989] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event6)
[    80.989] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    80.989] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    80.989] (II) LoadModule: "synaptics"
[    80.989] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    81.001] (II) Module synaptics: vendor="X.Org Foundation"
[    81.001]    compiled for 1.9.5, module version = 1.4.0
[    81.001]    Module class: X.Org XInput Driver
[    81.001]    ABI class: X.Org XInput driver, version 11.0
[    81.001] (**) Option "Device" "/dev/input/event6"
[    81.009] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5772
[    81.009] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 5086
[    81.009] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    81.009] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    81.009] (--) SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    81.017] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    81.017] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    81.025] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[    81.025] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    81.025] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    81.025] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.035
[    81.025] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    81.025] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    81.025] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    81.025] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    81.026] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    81.027] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    81.027] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    81.027] (**) Option "Device" "/dev/input/mouse0"
[    81.027] (--) SynPS/2 Synaptics TouchPad: invalid x-axis range.  defaulting to 1615 - 5685
[    81.027] (--) SynPS/2 Synaptics TouchPad: invalid y-axis range.  defaulting to 1729 - 4171
[    81.027] (--) SynPS/2 Synaptics TouchPad: invalid pressure range.  defaulting to 0 - 256
[    81.027] (--) SynPS/2 Synaptics TouchPad: invalid finger width range.  defaulting to 0 - 16
[    81.048] (EE) Query no Synaptics: 6003C8
[    81.048] (--) SynPS/2 Synaptics TouchPad: no supported touchpad found
[    81.048] (EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
[    81.056] (EE) PreInit returned NULL for "SynPS/2 Synaptics TouchPad"
[    81.057] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[    81.057] (II) No input driver/identifier specified (ignoring)
[    81.097] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
[    86.451] (II) fglrx(0): EDID vendor "AUO", prod id 9964
[    86.451] (II) fglrx(0): Printing DDC gathered Modelines:
[    86.451] (II) fglrx(0): Modeline "1366x768"x0.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    86.465] (II) fglrx(0): EDID vendor "AUO", prod id 9964
[    86.465] (II) fglrx(0): Printing DDC gathered Modelines:
[    86.465] (II) fglrx(0): Modeline "1366x768"x0.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    86.477] (II) fglrx(0): EDID vendor "AUO", prod id 9964
[    86.477] (II) fglrx(0): Printing DDC gathered Modelines:
[    86.477] (II) fglrx(0): Modeline "1366x768"x0.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[    93.251] (II) fglrx(0): EDID vendor "AUO", prod id 9964
[    93.251] (II) fglrx(0): Printing DDC gathered Modelines:
[    93.251] (II) fglrx(0): Modeline "1366x768"x0.0   71.80  1366 1414 1446 1526  768 771 777 784 -hsync -vsync (47.1 kHz)
[   157.216] (II) Power Button: Close
[   157.216] (II) UnloadModule: "evdev"
[   157.219] (II) Power Button: Close
[   157.219] (II) UnloadModule: "evdev"
[   157.223] (II) Sleep Button: Close
[   157.223] (II) UnloadModule: "evdev"
[   157.229] (II) AT Translated Set 2 keyboard: Close
[   157.229] (II) UnloadModule: "evdev"
[   157.245] (II) UnloadModule: "synaptics"
[   157.259] (II) fglrx(0): Shutdown CMMQS
[   157.260] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[   157.260] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7fcc7b8c5000
[   157.268] (II) fglrx(0): Interrupt handler Shutdown.


Thank you.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Jul 06, 2012 10:41 am    Post subject: Reply with quote

ONEEYEMAN wrote:
Code:
[    80.987] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[    80.987] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    80.987] (**) AT Translated Set 2 keyboard: always reports core events
[    80.987] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[    80.987] (--) AT Translated Set 2 keyboard: Found keys
[    80.988] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    80.988] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    80.988] (**) Option "xkb_rules" "evdev"
[    80.988] (**) Option "xkb_model" "evdev"
[    80.988] (**) Option "xkb_layout" "us"

According to this keyboard is present and correctly configured.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Fri Jul 06, 2012 10:50 am    Post subject: Reply with quote

ONEEYEMAN,

Is there anything relevant in ~/.xsession-errors :?:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
Splink
Apprentice
Apprentice


Joined: 09 Feb 2005
Posts: 295

PostPosted: Fri Jul 06, 2012 4:06 pm    Post subject: Reply with quote

if this works ok in console, have you tried re-pulling in xf86-input-mouse xf86-input-evdev xf86-input-keyboard?
_________________
It said "Requires Windows XP or better"
So I installed gentoo.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Fri Jul 06, 2012 7:46 pm    Post subject: Reply with quote

@Splink,
Yes, I did. See my reply above.

@BillWho,
This file is not present. I tried to run "startx" as my user, but looking at ~ there is no such file.

@VoidMage,
The symptoms are:
Run GNOME, start "Text Editor", start typing. Nothing will show up on screen.
Start "Terminal" and start typing. Nothing shows up on screen.

Any idea?

Thank you.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Fri Jul 06, 2012 10:11 pm    Post subject: Reply with quote

gnome use its own keyboard hook, passing over X.

look at the keyboard configuration in gnome system menu, you could choose a keyboard type in it.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Sun Jul 08, 2012 11:55 pm    Post subject: Reply with quote

krinn,
What do you mean? Keyboard is selected in that program. The keyboard layout is selected as well.

Thank you.

P.S.: Sorry for the long delay. Had to work in Windows... ;-)
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2789

PostPosted: Thu Jul 12, 2012 8:34 am    Post subject: Reply with quote

Just tried to boot Gentoo and check.
There is nothing in the System->Preferences->Keyboard applet.
Mouse is working perfectly, while keyboard does not.

Running revdep-rebuild as well as re-pulling drivers for X didn't help.

According to VoidMage keyboard is pulled in and correctly configured. Everything seems to be in order and yet it does not work.

Lucky me I don't need Linux as yet... ;-)

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum