Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox will NOT emerge and prevents total system upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 233

PostPosted: Tue Jul 03, 2012 3:24 pm    Post subject: Firefox will NOT emerge and prevents total system upgrade Reply with quote

Hey everyone. Ive been trying to update firefox for days now as well as perform a full system update to KDE 4.8.3 but for some strange reason, Firefox will not update and it is preventing me from being able to update my entire system. I really do need my firefox to be updated because I have a lot of bookmarks on it that I have to save. Here is the error message that I have been getting:


Code:



/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libxcb-util.so.0, needed by /usr/lib/libstartup-notification-1.so.0, not found (try
using -rpath or -rpath-link)
/usr/lib/libstartup-notification-1.so.0: undefined reference to `xcb_aux_get_screen'
collect2: ld returned 1 exit status
make[6]: *** [plugin-container] Error 1
make[6]: Leaving directory `/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10/obj-x86_64-unknown-linux-gnu/ipc/app'
make[5]: *** [tools] Error 2
make[5]: Leaving directory `/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10/obj-x86_64-unknown-linux-gnu/ipc'
make[4]: *** [tools_tier_platform] Error 2
make[4]: Leaving directory `/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10/obj-x86_64-unknown-linux-gnu'
make[3]: *** [tier_platform] Error 2
make[3]: Leaving directory `/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10/obj-x86_64-unknown-linux-gnu'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10/obj-x86_64-unknown-linux-gnu'
make[1]: *** [realbuild] Error 2
make[1]: Leaving directory `/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10'
make: *** [build] Error 2
emake failed
 * ERROR: www-client/firefox-10.0.5 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 6893:  Called die
 * The specific snippet of code:
 *           CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" MOZ_MAKE_FLAGS="${MAKEOPTS}" emake -f client.mk || die "emake failed";
 *
 * If you need support, post the output of `emerge --info '=www-client/firefox-10.0.5'`,
 * the complete build log and the output of `emerge -pqv '=www-client/firefox-10.0.5'`.
/usr/lib64/portage/bin/isolated-functions.sh: line 214: wait: `emake failed': not a pid or valid job spec
 * The complete build log is located at '/var/tmp/portage/www-client/firefox-10.0.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/firefox-10.0.5/temp/environment'.
 * Working directory: '/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10'
 * S: '/var/tmp/portage/www-client/firefox-10.0.5/work/mozilla-esr10'

>>> Failed to emerge www-client/firefox-10.0.5, Log file:



I already have libxcb installed

Code:
$ eix libxcb
[I] x11-libs/libxcb
     Available versions:  1.7 ~1.8 ~1.8-r1 1.8.1 {doc selinux static-libs}
     Installed versions:  1.8.1(21:53:38 06/27/12)(-doc -selinux -static-libs)
     Homepage:            http://xcb.freedesktop.org/
     Description:         X C-language Bindings library


but for some reason the system cannot find the required file! Does anyone know how to fix this issue? I greatly appreciate all help!!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue Jul 03, 2012 3:54 pm    Post subject: Reply with quote

:roll:
revdep-rebuild is your friend.
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1095
Location: Massachusetts USA

PostPosted: Tue Jul 03, 2012 5:06 pm    Post subject: Reply with quote

See https://forums.gentoo.org/viewtopic-p-7072368.html?sid=85cbfe8c593eeda70b9b58d187bd3fa9
Back to top
View user's profile Send private message
xsilentmurmurx
Apprentice
Apprentice


Joined: 23 Oct 2009
Posts: 233

PostPosted: Wed Jul 04, 2012 2:56 pm    Post subject: Reply with quote

Thank you my friends. It worked! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum