Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
help with new install [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 200
Location: Italia

PostPosted: Thu Jan 30, 2014 10:09 am    Post subject: help with new install [SOLVED] Reply with quote

Hi,
I'am doing a set-up of two identical machine with gentoo kernel x86_64-3.11.7-hardened-r1

I'm configuring the identical machines, but I have two different problems
on one:
Code:
* Messages for package app-portage/gentoolkit-0.3.0.8-r2:

 * ERROR: app-portage/gentoolkit-0.3.0.8-r2::gentoo failed (prepare phase):
 *   python_export: no impl nor EPYTHON
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3298:  Called distutils-r1_src_prepare
 *   environment, line 1045:  Called python_prepare_all
 *   environment, line 3146:  Called python_export_best
 *   environment, line 2943:  Called python_export '' 'EPYTHON' 'PYTHON'
 *   environment, line 2793:  Called die
 * The specific snippet of code:
 *               [[ -n ${impl} ]] || die "python_export: no impl nor EPYTHON"
 *
 * If you need support, post the output of `emerge --info '=app-portage/gentoolkit-0.3.0.8-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-portage/gentoolkit-0.3.0.8-r2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-portage/gentoolkit-0.3.0.8-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-portage/gentoolkit-0.3.0.8-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-portage/gentoolkit-0.3.0.8-r2/work/gentoolkit-0.3.0.8'
 * S: '/var/tmp/portage/app-portage/gentoolkit-0.3.0.8-r2/work/gentoolkit-0.3.0.8'



on the other:

Code:
/usr/lib64/portage/bin/phase-helpers.sh: ./configure: /bin/sh: bad interpreter: Permission denied
 * ERROR: dev-lang/swig-2.0.9::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line  93:  Called src_configure
 *        environment, line 140:  Called econf '--disable-ccache' '--with-pcre'
 *   phase-helpers.sh, line 577:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=dev-lang/swig-2.0.9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/swig-2.0.9::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-lang/swig-2.0.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/swig-2.0.9/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/swig-2.0.9/work/swig-2.0.9'
 * S: '/var/tmp/portage/dev-lang/swig-2.0.9/work/swig-2.0.9'

>>> Failed to emerge dev-lang/swig-2.0.9, Log file:

>>>  '/var/tmp/portage/dev-lang/swig-2.0.9/temp/build.log'

 * Messages for package dev-lang/swig-2.0.9:

 * ERROR: dev-lang/swig-2.0.9::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line  93:  Called src_configure
 *        environment, line 140:  Called econf '--disable-ccache' '--with-pcre'
 *   phase-helpers.sh, line 577:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=dev-lang/swig-2.0.9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/swig-2.0.9::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-lang/swig-2.0.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/swig-2.0.9/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/swig-2.0.9/work/swig-2.0.9'
 * S: '/var/tmp/portage/dev-lang/swig-2.0.9/work/swig-2.0.9'


any suggestion is highly appreciated, thank you,
Maurizio


Last edited by pigreco on Thu Jan 30, 2014 11:02 am; edited 1 time in total
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 200
Location: Italia

PostPosted: Thu Jan 30, 2014 10:46 am    Post subject: update Reply with quote

the problem about 'permission denied' on emerge was generated by GRSEC
Code:
grsec: From 192.168.1.2: denied untrusted exec (due to not being in trusted group and file in non-root-owned directory) of /var/tmp/portage/dev-lang/swig-2.0.9/work/swig-2.0.9/configure by /var/tmp/portage/dev-lang/swig-2.0.9/work/swig-2.0.9/configure[ebuild.sh:18149] uid/euid:250/250 gid/egid:250/250, parent /usr/lib64/portage/bin/ebuild.sh[ebuild.sh:18130] uid/euid:250/250 gid/egid:250/250


I solved is by add 'portage' to trusted group:
Code:
usermod -a -G wheel portage


this may cause security problems?

the problem
Code:
ERROR: app-portage/gentoolkit-0.3.0.8-r2::gentoo failed (prepare phase):
 *   python_export: no impl nor EPYTHON


was solved by:
Code:
ln -s /proc/self/fd /dev/fd




Maurizio
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum