Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Long delay at first login
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Wed Jun 27, 2012 12:23 pm    Post subject: Long delay at first login Reply with quote

I played a bit around with pam and other use-flags. Now i experience a long delay at the first login, no matter if its at KDM or via ssh from a remote machine. If I login via kdm, the login dialog disappears and and it takes a minute untill the splash screen appears, via ssh I see the first line of the remote hoste (was it "Last login .."?) and then the login process hangs for a minute.

After the delay everything coninues normally, also second logins don't show the delay.

I guess it's sth. like DNS lookups, wrong domian names, ... Something that causes a timout in the first place but is cached after that.

I would be happy if someone with more experience on that topic could give me some hints how to systematicalle track down the problem instead of the chaotically try&error method.
Back to top
View user's profile Send private message
anb.clarke
n00b
n00b


Joined: 05 Apr 2006
Posts: 31

PostPosted: Fri Jun 29, 2012 8:25 am    Post subject: Reply with quote

How is your network setup? Dhcpcd, static IP, networkmanager : it'd be easier to diagnose
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Jun 29, 2012 8:34 am    Post subject: Reply with quote

It's dhcpd with fallback to autoip. Here's /etc/conf.d/net:

Code:
config_eth0="dhcp"
fallback_etho="autoipd"
dns_domain_lo="local"
Back to top
View user's profile Send private message
anb.clarke
n00b
n00b


Joined: 05 Apr 2006
Posts: 31

PostPosted: Fri Jun 29, 2012 8:49 am    Post subject: Reply with quote

Personally, i''d try using a static IP first. If improvement occurs then you know your dhcp is failing - then return to dhcp and tweak:

get current IP
Code:
# ifconfig -a


sudo nano /etc/conf.d/net (my example : i'm behind a nat router)
Code:
# STATIC IP
# =========
config_eth0="192.168.0.10/24"
routes_eth0="default via 192.168.0.1"

# DNS DATA
# ========
dns_domain="local"
dns_servers="8.8.8.8 8.8.4.4"

Reboot and look for changes

Notice the typo...
===========================
config_eth0="dhcp"
fallback_etho="autoipd"
dns_domain_lo="local"
==>
config_eth0="dhcp"
fallback_eth0="autoipd"
dns_domain_lo="local"
===========================
Back to top
View user's profile Send private message
furanku
l33t
l33t


Joined: 08 May 2003
Posts: 902
Location: Hamburg, Germany

PostPosted: Fri Jun 29, 2012 10:53 am    Post subject: Reply with quote

Arrrrgh! :oops:

Thanks! Correcting that typo solved the problem. I still don't know how that caused the delay, since that was just a fallback option, but who cares, if it works!

Thanks, again!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum