Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keyboard not working in Xorg/Gnome!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
justinschw
n00b
n00b


Joined: 19 Jun 2012
Posts: 11

PostPosted: Tue Jun 19, 2012 4:46 am    Post subject: Keyboard not working in Xorg/Gnome! Reply with quote

Hi,

I recently installed the latest Gentoo with kernel 3.2.12 on my IBM Thinkpad T60. In make.conf, for the video card I set it to intel, and for the input devices I set it to "evdev synaptics", as instructed by this guide:

http://www.gentoo.org/doc/en/xorg-config.xml

When I run startx, I am able to use the touchpad mouse, but the keyboard does not respond. This is the case in both tvm and gnome. Is there any more information I need to provide? Any ideas on what could be causing this problem? I am confused and I haven't found anyone else who has the same problem as me. Is there something else I need to change when I configure the kernel? Will I have to reconfigure gnome or just the xorg-server after changing any options?

Thanks,
-Justin
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Jun 19, 2012 4:54 am    Post subject: Reply with quote

justinschw,

You can try
Code:
emerge -av1 $(qlist -I -C x11-drivers)

It will rebuild all the x11 drivers

Good luck :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
justinschw
n00b
n00b


Joined: 19 Jun 2012
Posts: 11

PostPosted: Tue Jun 19, 2012 5:39 am    Post subject: Reply with quote

I recompiled the drivers and it gave the same results. I even recompiled the kernel again and then the drivers and xorg-server, and it was still the same, mouse but no keyboard. What could cause this to happen?
Back to top
View user's profile Send private message
justinschw
n00b
n00b


Joined: 19 Jun 2012
Posts: 11

PostPosted: Tue Jun 19, 2012 5:47 am    Post subject: Reply with quote

Ok so I found out the evdev driver was not installed for some reason. I thought it was supposed to be installed automatically. I emerged it and now keyboard works OK in xorg.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum