Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdelibs-4.8.3 fails to install with unpack error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Almad
n00b
n00b


Joined: 29 Apr 2005
Posts: 17

PostPosted: Sun Jun 17, 2012 10:25 pm    Post subject: kdelibs-4.8.3 fails to install with unpack error Reply with quote

Hi,

when I try to upgrade to new kdelibs, ti fails with this error:

[code]
>>> Running ebuild phase killold as root:root...
>>> Starting builtin_killold
>>> Done builtin_killold
>>> Completed ebuild phase killold
>>> Running ebuild phases init saveenv as paludisbuild:paludisbuild...
>>> Starting builtin_init
>>> Done builtin_init
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases init saveenv
>>> Running ebuild phases loadenv setup saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_setup
>>> Done pkg_setup
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases loadenv setup saveenv
>>> Running ebuild phases loadenv unpack saveenv as paludisbuild:paludisbuild...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting src_unpack
>>> Unpacking kdelibs-4.8.3.tar.xz to /var/tmp/paludis/kde-base-kdelibs-4.8.3/work
xz -dc /usr/portage/distfiles/kdelibs-4.8.3.tar.xz | tar xf - --no-same-owner
Checking 'kde-runtime-4.8.3.tar.xz'... ok

Error:
* In program cave perform install --hooks --managed-output --output-exclusivity with-others =kde-base/kdelibs-4.8.3:4::gentoo --destination installed --replacing =kde-base/kdelibs-4.8.1-r2:4::installed --x-of-y 1 of 5:
* When installing 'kde-base/kdelibs-4.8.3:4::gentoo' replacing { 'kde-base/kdelibs-4.8.1-r2:4::installed' }:
* When running an ebuild command on 'kde-base/kdelibs-4.8.3:4::gentoo':
* Install failed for 'kde-base/kdelibs-4.8.3:4::gentoo' (paludis::ActionFailedError)

Output from installing kde-base/kdelibs-4.8.3:4::gentoo to ::installed replacing 4.8.1-r2:4::installed:

unpack: error: Couldn't unpack /usr/portage/distfiles/kdelibs-4.8.3.tar.xz: 141 0
unpack: making ebuild PID 10562 exit with error
die trap: exiting with error.

Failed install to / for kde-base/kdelibs-4.8.3:4::gentoo replacing 4.8.1-r2:4::installed
[/code]

However, when I try to unpack it separately, it is OK

[code]
namtar ~ # xz -dc /usr/portage/distfiles/kdelibs-4.8.3.tar.xz | tar xf - --no-same-owner
namtar ~ # echo $?
0
namtar ~ #
[/code]

Any idea what could cause this?

(using paludis 0.58.5)
Back to top
View user's profile Send private message
nyback
n00b
n00b


Joined: 27 Aug 2004
Posts: 30

PostPosted: Wed Jun 20, 2012 10:16 pm    Post subject: same same Reply with quote

Same problem for me....
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Jun 21, 2012 12:41 am    Post subject: Reply with quote

Almad,

It appears to failing because /usr/bin/xz is missing.

Is app-arch/xz-utils installed :?:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Thu Jun 21, 2012 6:21 am    Post subject: Re: kdelibs-4.8.3 fails to install with unpack error Reply with quote

Almad wrote:
(using paludis 0.58.5)

WHOOT?!?
Paludis is at 0.74.1 (in portage) ATM, And 0.74.0 fixes these kinds of error (by ignoring trailing garbage).
So the solution for your problem is to update paludis.

Also have a look at the bugtracker:
https://bugs.gentoo.org/show_bug.cgi?id=410861
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum