Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev and /dev/snd/seq permissions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
highland
n00b
n00b


Joined: 05 Nov 2008
Posts: 71

PostPosted: Sun Jun 17, 2012 10:06 am    Post subject: udev and /dev/snd/seq permissions Reply with quote

Hello

Installed fresh amd64 from current minimal/stage3.
My privileges for /dev/snd/seq are incorrect:
Code:

pluton ~ # ls -la /dev/snd/
total 0
drwxr-xr-x   3 root root      200 Jun 17  2012 .
drwxr-xr-x  15 root root     4340 Jun 17 11:58 ..
drwxr-xr-x   2 root root       60 Jun 17  2012 by-path
crw-rw----+  1 root audio 116,  6 Jun 17  2012 controlC0
crw-rw----+  1 root audio 116,  5 Jun 17  2012 hwC0D0
crw-rw----+  1 root audio 116,  4 Jun 17  2012 hwC0D1
crw-rw----+  1 root audio 116,  3 Jun 17 11:58 pcmC0D0c
crw-rw----+  1 root audio 116,  2 Jun 17 11:58 pcmC0D0p
crw-------   1 root root  116,  1 Jun 17  2012 seq
crw-rw----+  1 root audio 116, 33 Jun 17  2012 timer
pluton ~ # cat /etc/udev/
rules.d/   udev.conf 
pluton ~ # cat /etc/udev/rules.d/80-my.rules
# sound devices
KERNEL=="seq",     NAME="snd/%k", OWNER="root", GROUP="audio", MODE="0666"
KERNEL=="sequencer", NAME="sound/%k", SYMLINK+="%k", GROUP="audio", MODE="0666"
KERNEL=="sequencer[0-9]*", NAME="sound/%k", SYMLINK+="%k", GROUP="audio", MODE="0666"

SUBSYSTEM=="sound", GROUP="audio"
SUBSYSTEM=="snd", GROUP="audio"


I want /dev/snd/seq device be also in group audio. Udev working correctly, no errors with this configuration.
In previous (before number 80) rule file no strings relating to sound config ("snd" "seq" "sound")
Of course i've deleted the /dev/snd/seq and stopped started udev, but again it appears with incorrect group/priv

What is wrong with this config ?
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Jun 17, 2012 11:24 am    Post subject: Reply with quote

Perhaps this helps:
Code:
KERNEL=="seq", GROUP="audio", MODE="0660", OPTIONS+="static_node=snd/seq"
KERNEL=="timer", GROUP="audio", MODE="0660", OPTIONS+="static_node=snd/timer"
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun Jun 17, 2012 11:27 am    Post subject: Reply with quote

Well, if your udev is 171, there was a bug in it that affected snd/seq node.
Also, drop 'NAME=' parts of your rules - they won't work with any recent enough udev.
Back to top
View user's profile Send private message
highland
n00b
n00b


Joined: 05 Nov 2008
Posts: 71

PostPosted: Sun Jun 17, 2012 11:35 am    Post subject: Reply with quote

i used both your tips, and it's working right now!
thanks a lot !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum