Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Konsole visual glitch after KDE 4.8.3/Qt 4.8.1 updates
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Chris W
l33t
l33t


Joined: 25 Jun 2002
Posts: 972
Location: Brisbane, Australia

PostPosted: Wed May 30, 2012 2:32 am    Post subject: Konsole visual glitch after KDE 4.8.3/Qt 4.8.1 updates Reply with quote

I did the KDE 4.83 and Qt 4.8.1 updates the other day. Everything is working fine except for a small visual glitch that seems to have crept into konsole. Every now and then the line spacing of output is compressed and character descenders on one line are truncated by the next line. The effect seems to only last a line. As usual a picture is worth a thousand word: see the marked line here (at least until the image is dropped)

I wonder if anyone else has seen this and knows a remedy?

I'm on an up-to-date amd64 stable machine with the exception of the kernel which is 3.2 1-gentoo-r2
_________________
Cheers,
Chris W
"Common sense: The collection of prejudices acquired by age 18." -- Einstein
Back to top
View user's profile Send private message
PhaytalError
n00b
n00b


Joined: 17 May 2012
Posts: 46

PostPosted: Wed May 30, 2012 4:03 am    Post subject: Reply with quote

It looks like a font issue.

However to test if it's a config issue, remove your ~/.kde4 directory and restart KDE and see if that issue continues.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Wed May 30, 2012 6:00 am    Post subject: Reply with quote

Quote:
remove your ~/.kde4

No! There is way too much important data in it! renaming - OK. But the easiest way to check for config errors is to use a completely fresh testuser. (I have one user just for testing, where rm -rf ~/* does not hurt)

The problem now seems to be caused by those ´´ around bytesTotal - they cause the line to grow shifting it downwards. The font seems to be monospace just horizontally.
Take another monospace-font for a test. If you want, you also can ask konsole-developers (directly or via bugs.kde.org) to fix rendering for your specific font.
Back to top
View user's profile Send private message
Chris W
l33t
l33t


Joined: 25 Jun 2002
Posts: 972
Location: Brisbane, Australia

PostPosted: Wed May 30, 2012 6:20 am    Post subject: Reply with quote

Yeah, not silly enough to delete my kde config ;)

The font is Terminus and did not have this issue that I noticed prior to the update. A quick survey of a few other fonts doesn't show the problem (but they are horrible to use). There are later versions of this font in Portage, and the changes include some quote-related fixes, but it still seems to do this.

I'll have a look at it in more detail over the next few days.
_________________
Cheers,
Chris W
"Common sense: The collection of prejudices acquired by age 18." -- Einstein
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Wed May 30, 2012 7:20 am    Post subject: Reply with quote

I installed terminus-font and tested it - no issue using stable version + kde-4.8.3 + qt-4.8.2 (Use +quote and +quote).
But I don't like the font. I like dejavu-sans-mono much more ;)
Back to top
View user's profile Send private message
Chris W
l33t
l33t


Joined: 25 Jun 2002
Posts: 972
Location: Brisbane, Australia

PostPosted: Wed May 30, 2012 7:28 am    Post subject: Reply with quote

OK, so it could be the Qt version rather than a KDE "feature"
_________________
Cheers,
Chris W
"Common sense: The collection of prejudices acquired by age 18." -- Einstein
Back to top
View user's profile Send private message
hochl
n00b
n00b


Joined: 05 Dec 2003
Posts: 39

PostPosted: Tue Jun 05, 2012 4:15 pm    Post subject: Reply with quote

I have the same issue, but with the Fixed [Misc] font and on Debian Testing. I recently discovered that enabling bi-directional text rendering in konsole configuration fixes this glitch. Right click -> configure current profile -> Advanced -> Enable Bi-Directional text rendering.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum