Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
e2fsprogs-1.42 fails to emerge [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Zubziro
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 243
Location: Sweden

PostPosted: Thu May 24, 2012 7:44 pm    Post subject: e2fsprogs-1.42 fails to emerge [SOLVED] Reply with quote

Hi

I'm struggling to upgrade e2fsprogs-1.42 from e2fsprogs-1.41.14 and keep getting this error:

Code:
SUBST e2fsck.8
        SUBST e2fsck.conf.5
make[2]: Leaving directory `/var/tmp/portage/sys-fs/e2fsprogs-1.42/work/e2fsprogs-1.42/e2fsck'
making all in debugfs
make[2]: Entering directory `/var/tmp/portage/sys-fs/e2fsprogs-1.42/work/e2fsprogs-1.42/debugfs'
        MK_CMDS debug_cmds.c
/usr/bin/mk_cmds: line 51: /var/tmp/portage/._portage_reinstall_.c4HaWs/bin/ebuild-helpers/sed: No such file or directo$
        CC debug_cmds.c
debug_cmds.c:1:25: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ssu00001’
debug_cmds.c:5:1: warning: data definition has no type or storage class
debug_cmds.c:5:26: error: ‘ssu00001’ undeclared here (not in a function)
debug_cmds.c:5:1: warning: excess elements in scalar initializer
debug_cmds.c:5:1: warning: (near initialization for ‘ss_request_table’)
make[2]: *** [debug_cmds.o] Error 1


There isn't any "/var/tmp/portage/._portage_reinstall_.c4HaWs/bin/ebuild-helpers/sed" there

Anyone has an idea why this happening? All other packages compiles fine and system is up to date.

Thanks in advance


Last edited by Zubziro on Mon May 28, 2012 10:24 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9466

PostPosted: Fri May 25, 2012 2:03 am    Post subject: Reply with quote

What is the output of emerge --info sys-fs/e2fsprogs?
Back to top
View user's profile Send private message
Zubziro
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 243
Location: Sweden

PostPosted: Fri May 25, 2012 5:20 pm    Post subject: Reply with quote

Hu wrote:
What is the output of emerge --info sys-fs/e2fsprogs?


here it comes:

Code:

Portage 2.1.10.49 (default/linux/x86/10.0/server, gcc-4.5.3, glibc-2.14.1-r3, 2.6.38-gentoo-r6 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38-gentoo-r6-i686-VIA_C7-D_Processor_1500MHz-with-gentoo-2.1
Timestamp of tree: Thu, 24 May 2012 05:35:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1, 3.1.4-r3, 3.2.3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo poly-c
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 Oracle-BCLA-JavaSE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=c3-2 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandb$
CXXFLAGS="-march=c3-2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="sv_SE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/poly-c"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fam fortran gdbm gpm iconv modules mudflap ncurses nls nptl openmp pam pcre pppd readline session sse2 ssl tcpd truetype unicode x86 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp$
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-fs/e2fsprogs-1.41.14 was built with the following:
USE="nls"


/Thanks
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4893

PostPosted: Fri May 25, 2012 9:22 pm    Post subject: Reply with quote

Code:
head /usr/bin/mk_cmds
#!/bin/sh
#
#

datarootdir=/usr/share
DIR="${DIR-/usr/share/ss}"
SS_DIR="/var/tmp/portage/sys-libs/e2fsprogs-libs-1.42.1/work/e2fsprogs-libs-1.42.1/lib/ss"
AWK=gawk
SED=/bin/sed


And lookout specially your SED= line value, i suppose you have reinstall portage while building the 1.41.14 and sed location was recorded to that location, an invalid one now that portage remove that temp dir.
Back to top
View user's profile Send private message
Zubziro
Apprentice
Apprentice


Joined: 21 Sep 2005
Posts: 243
Location: Sweden

PostPosted: Mon May 28, 2012 10:25 am    Post subject: Reply with quote

krinn wrote:
Code:
head /usr/bin/mk_cmds
#!/bin/sh
#
#

datarootdir=/usr/share
DIR="${DIR-/usr/share/ss}"
SS_DIR="/var/tmp/portage/sys-libs/e2fsprogs-libs-1.42.1/work/e2fsprogs-libs-1.42.1/lib/ss"
AWK=gawk
SED=/bin/sed


And lookout specially your SED= line value, i suppose you have reinstall portage while building the 1.41.14 and sed location was recorded to that location, an invalid one now that portage remove that temp dir.


THANK YOU!

I changed SED path and its worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum