Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg-server install problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
slydini
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2002
Posts: 129
Location: Virginia Beach, VA

PostPosted: Thu May 17, 2012 1:20 am    Post subject: [SOLVED] xorg-server install problems Reply with quote

Just finished the xorg-server install from the guide using the nouveau driver for my Nvidia GeForce Ti 4600. This is a first time X setup and after reconfiguring the kernel and emerging xorg-server as in the guide, startx failes with the following. Everything was compiled into the kernel directly so there are not going to be any modules.

Code:
[    55.367] (EE) Failed to load module "vesa" (module does not exist, 0)
[    55.369] (EE) Failed to load module "fbdev" (module does not exist, 0)


Missing directory:
Code:

/etc/X11/xorg.conf.d


No idea where the xorg.conf file is and what happened. It's probably something simple but I just haven't done a gentoo install in a very long time.

I'm guessing somethings wrong with my kernel config so here it is: http://pastebin.com/KPFG1REi
_________________
_______________________________________
Oh how I love Linux, especially on gentoo.


Last edited by slydini on Thu May 17, 2012 2:40 am; edited 1 time in total
Back to top
View user's profile Send private message
Hello71
n00b
n00b


Joined: 17 May 2012
Posts: 35

PostPosted: Thu May 17, 2012 1:42 am    Post subject: Reply with quote

Are you sure you compiled the KMS module for your video card?
Back to top
View user's profile Send private message
slydini
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2002
Posts: 129
Location: Virginia Beach, VA

PostPosted: Thu May 17, 2012 1:59 am    Post subject: Reply with quote

I'm not sure, that's why I posted my video card info and the kernel config I used to get help on what to set for my video card.
_________________
_______________________________________
Oh how I love Linux, especially on gentoo.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Thu May 17, 2012 2:07 am    Post subject: Reply with quote

did you give xorg something to do? startx won't work unless it has something to display. Try X -retro. If I recall correctly the vesa and fbdev errors are harmless.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
slydini
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2002
Posts: 129
Location: Virginia Beach, VA

PostPosted: Thu May 17, 2012 2:16 am    Post subject: Reply with quote

Awesome, the X -retro worked. I'll have to read about that one. I haven't configured X in quite a while so I'm not up on all the new stuff. I always thought that any errors that were of the EE type were catastrophic in nature. So even though the X -retro thing works I still don't have the xorg.conf.d directory or know where the xorg.conf file is located. Thanks for all the help.

Edit: I just found the directory at /usr/share/X11/xorg.conf.d

That means the install guide is wrong then. It needs to be updated.
_________________
_______________________________________
Oh how I love Linux, especially on gentoo.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Thu May 17, 2012 2:28 am    Post subject: Reply with quote

since you are using the open source driver, you shouldn't need an xorg conf. Now all you need to do is install a window manager/desktop environment and you should be good.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
slydini
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2002
Posts: 129
Location: Virginia Beach, VA

PostPosted: Thu May 17, 2012 2:40 am    Post subject: Reply with quote

Thanks. I am emerging lxde-meta right now. Just one quick question, how come Crtl-Alt-BS doesn't kill the xserver anymore? What's the new way to kill it?
_________________
_______________________________________
Oh how I love Linux, especially on gentoo.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Thu May 17, 2012 2:44 am    Post subject: Reply with quote

Quote:
Just one quick question, how come Crtl-Alt-BS doesn't kill the xserver anymore?

The good idea fairy dropped by.
Quote:
What's the new way to kill it?

No. You can put it back or use ct+alt+F<#> to go to a console and kill it that way if you want. I am afraid I don't remember how to reconfigure X to take ctl+alt+bs command to kill it, but it does exist on the net.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
dwbowyer
Apprentice
Apprentice


Joined: 18 Apr 2008
Posts: 154

PostPosted: Thu May 17, 2012 8:31 am    Post subject: Reply with quote

From my xorg.conf
Code:

## Needed for AutoAddDevices "True" in Serverlayout section
#Section "InputClass"
#    Identifier "keyboard-all"
#    Option "XkbOptions" "terminate:ctrl_alt_bksp"
#    MatchIsKeyboard "on"
#EndSection

## Input devices, using until udev cleans up and not
## trying to load 3 keyboards and 2 mice
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option      "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Back to top
View user's profile Send private message
slydini
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2002
Posts: 129
Location: Virginia Beach, VA

PostPosted: Thu May 17, 2012 2:56 pm    Post subject: Thank you all for your help Reply with quote

Jeez, that should be a default in the config file. I just used the Ctrl-Alt-F1 then Ctrl-C'd the running command and that did the trick.

On another note, I have LXDE up and running now and vim is installed. Hopefully the midori browser will run without too much resources and this will have breathed life into an otherwise useless old computer. :)
_________________
_______________________________________
Oh how I love Linux, especially on gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum