Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved - in test] how to upgrade xfce4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 390
Location: Paris

PostPosted: Mon May 07, 2012 10:24 am    Post subject: [solved - in test] how to upgrade xfce4 Reply with quote

I recently noticed that xfce 4.10 is released. when I check my portage tree, xfce 4.10 ebuild file is laid aside xfce 4.8 in directory "/usr/portage/xfce-base/xfce4-meta"

but no matter what I tried such as running "emerge -uDN world" or "emerge -pv xfce-meta", it only find xfce 4.8, but not xfce 4.10. It seems that I should do something. please someone explains me. Thank you.


Last edited by pd1986 on Mon May 07, 2012 11:03 am; edited 1 time in total
Back to top
View user's profile Send private message
Woofie
Tux's lil' helper
Tux's lil' helper


Joined: 11 Sep 2010
Posts: 83
Location: Czech Rep.

PostPosted: Mon May 07, 2012 10:47 am    Post subject: Reply with quote

Hi, you should put
Code:

xfce-base/xfce4-meta ~(arch)

where arch is your architecture
into your /etc/portage/package.keywords because xfce4.10 is in testing before move to stable.
_________________
Sorry for my English. It's not my native language and I'm still learning it.
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 390
Location: Paris

PostPosted: Mon May 07, 2012 10:51 am    Post subject: Reply with quote

woofie wrote:
Hi, you should put
Code:

xfce-base/xfce4-meta ~(arch)

where arch is your architecture
into your /etc/portage/package.keywords because xfce4.10 is in testing before move to stable.

I thought it's stable.
I didn't add anything about xfce in this file. by the way, I only have package.accept_keywords, I think there is no difference.
It do worked when I mask 4.8 and unmask 4.10. but it returned more information about keywords and so on. so maybe that, xfce4.10 is not confirmed stable. In order not to destroy my system, I'll wait. Thanks.
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 390
Location: Paris

PostPosted: Mon May 07, 2012 10:57 am    Post subject: Reply with quote

woofie wrote:
Hi, you should put
Code:

xfce-base/xfce4-meta ~(arch)

where arch is your architecture
into your /etc/portage/package.keywords because xfce4.10 is in testing before move to stable.


One more question, is the configuration under 4.8 possible to migrate to 4.10?
Back to top
View user's profile Send private message
Woofie
Tux's lil' helper
Tux's lil' helper


Joined: 11 Sep 2010
Posts: 83
Location: Czech Rep.

PostPosted: Mon May 07, 2012 11:28 am    Post subject: Reply with quote

Thanks to point me to accept_keywords, it's a little bit change in portage lately as wrote here
https://forums.gentoo.org/viewtopic-t-920888-start-0.html

It should work with accept_keywords and keywords too, but accept_keywords replace keywords..
I think that it'll work with configuration from 4.8 with no problem.. but I'll upgrade it at the end of week when I'll have more free time to repair it if something break :)
_________________
Sorry for my English. It's not my native language and I'm still learning it.
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 390
Location: Paris

PostPosted: Mon May 07, 2012 11:37 am    Post subject: Reply with quote

woofie wrote:
Thanks to point me to accept_keywords, it's a little bit change in portage lately as wrote here
https://forums.gentoo.org/viewtopic-t-920888-start-0.html

It should work with accept_keywords and keywords too, but accept_keywords replace keywords..
I think that it'll work with configuration from 4.8 with no problem.. but I'll upgrade it at the end of week when I'll have more free time to repair it if something break :)



Thanks a lot for testing.
Back to top
View user's profile Send private message
Woofie
Tux's lil' helper
Tux's lil' helper


Joined: 11 Sep 2010
Posts: 83
Location: Czech Rep.

PostPosted: Thu May 10, 2012 11:28 am    Post subject: Reply with quote

I found some free time in the middle of the week and upgrade it today. After upgrade everything seams to working normal but several plugins in panel stop working, it was because I forgot to run revdep-rebuild. I run into another problem with moving items in xfce-panel but it was discuss here
https://forums.gentoo.org/viewtopic-p-7014216.html?sid=6b78e64afa00d841371ed15fa459b741

If you hit the hard blocks during update as I did
Code:

[blocks B      ] xfce-base/xfce-utils ("xfce-base/xfce-utils" is blocking xfce-base/xfce4-session-4.10.0, xfce-base/xfce4-appfinder-4.10.0)

just unmerge xfce-utils and run upgrade again.
_________________
Sorry for my English. It's not my native language and I'm still learning it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum