Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cups-1.5.2-r4: "waiting for printer to become ..." [Solved!]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 12 Aug 2003
Posts: 2478
Location: Silver City, NM

PostPosted: Mon Apr 30, 2012 1:47 am    Post subject: cups-1.5.2-r4: "waiting for printer to become ..." Reply with quote

Updating world brought in cups-1.5.2-r4. I updated the config files but didn't restart cupsd. Printing didn't work. Jobs were getting queued "waiting for printer to become available". I restarted cupsd and had the same problem.

So I downgraded back to cups-1.4.8-r1 which had been working fine yesterday. It didn't work either but it had a different problem. Whatever I try to print it errors out with a "document format not supported" error. Plain text, postscript, it doesn't matter.

So now I have no way to print. My printer is a standard HP LaserJet-1200 that connects via usb. I've tried with and without the usblp module loaded but that doesn't seem to make any difference. The http interface to cups always works fine.

Portage (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 2.6.36-gentoo-r8 x86_64)
                        System Settings
System uname: Linux-2.6.36-gentoo-r8-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.0.3
Timestamp of tree: Sun, 29 Apr 2012 18:30:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.4.6, 2.6.6-r2, 2.7.2-r3, 3.1.5, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.5, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo sunrise multimedia local
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL googleearth AdobeFlash-10.1 AdobeFlash-10 AdobeFlash-10.3 Oracle-BCLA-JavaSE google-chrome"
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/multimedia /usr/local/portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amarok amd64 bash-completion berkdb bluray branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdnav dvdr dvdread emboss emovix encode exif fam fbcon ffmpeg firefox flac fortran gdbm gdu gif glitz gmp gpm gtk iconv id3 ieee1394 imagemagick java jpeg kpathsea lcms libnotify libwww lirc lm_sensors logitech-mouse mad mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz ncurses nls nptl nptlonly nsplugin objc ogg opengl openmp pam pango pcre pdf plotutils png policykit ppds pppd python qt3support quicktime readline ruby sdl session sockets spell sse sse2 ssl startup-notification svg sysfs tcltk tcpd tetex tidy tiff tk truetype udev unicode usb vaapi vdpau vim-pager vim-syntax vorbis wxwidgets x264 xcb xcomposite xetex xine xinerama xml xmp xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" LIRC_DEVICES="mceusb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

net-print/cups-1.5.2-r4 was built with the following:
USE="X dbus filters gnutls java jpeg (multilib) pam png python ssl threads tiff usb -acl -avahi -debug -kerberos -ldap -perl -slp -static-libs -xinetd" LINGUAS="-da -de -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW"

Last edited by BitJam on Mon Apr 30, 2012 7:23 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 21 Sep 2011
Posts: 39

PostPosted: Mon Apr 30, 2012 7:10 am    Post subject: that's the lpusb driver Reply with quote


I had that same problem. For me (at least) it was the lpusb driver. CUPS 1.5 comes with its own usb support, which conflicts with the one I had built into my kernel. There are basically two options:

A) You remove the lpusb support from your kernel (or unload the module, where this applies)

B) you re-emerge CUPS without the USB use flag

So, ironically, to get CUPS working with USB you have to remove the USB use flag.

I chose option B by the way. Now everything works fine.

Back to top
View user's profile Send private message

Joined: 12 Aug 2003
Posts: 2478
Location: Silver City, NM

PostPosted: Mon Apr 30, 2012 7:24 am    Post subject: Reply with quote

That worked! Thank you.
Back to top
View user's profile Send private message

Joined: 17 Sep 2010
Posts: 464
Location: Frankfurt, Germany

PostPosted: Tue May 01, 2012 4:47 pm    Post subject: Reply with quote

Thanks, redmaniac, I had the same problem - and your posting saved my day.

I opened a bug in Bugzilla:
Back to top
View user's profile Send private message

Joined: 04 Jan 2004
Posts: 2370
Location: Netherlands

PostPosted: Tue May 01, 2012 5:30 pm    Post subject: Reply with quote

I added a comment to your bug report.
I went about it more rigorously by recompiling my kernel w/o usblp.
Had to reinstall my printer though.
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
Back to top
View user's profile Send private message

Joined: 15 Dec 2003
Posts: 339
Location: Around 2.4GHz

PostPosted: Sun May 13, 2012 10:29 am    Post subject: Reply with quote

Thanks! It works for me.
Linux Proud User: HP Pavilion 15-an002ns laptop (KDE Neon), Xiaomi Mi Air 12 (KDE Neon), Raspberry Pi 3 (Nextcloudpi), Docooler MS9 Pro (LibreElec)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum