Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
4559 port closed ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Fri Apr 27, 2012 2:59 am    Post subject: 4559 port closed ? Reply with quote

I just completed a fresh installation, installed hylafax (it is using port 4559) but I can not connect to the server on this machine from other local machines because the 4559 port is closed:
Code:
nmap -sS -O 10.0.0.161 -p4559

Starting Nmap 5.51 ( http://nmap.org ) at 2012-04-26 20:50 MDT
Nmap scan report for eden.inet (10.0.0.161)
Host is up (0.00020s latency).
PORT     STATE  SERVICE
4559/tcp closed hylafax


Why is the port closed? There is no firewall in between.
_________________
#Thelma
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Fri Apr 27, 2012 3:53 am    Post subject: Reply with quote

In the machine where hylafaxplus is running 4559 is only open for 127.0.0.1 but not for 10.0.0.161 (this is the eth0 IP on this machine).

Code:
nmap -sS -O 127.0.0.1 -p4559

Starting Nmap 5.51 ( http://nmap.org ) at 2012-04-26 21:46 MDT
Nmap scan report for localhost.localdomain (127.0.0.1)
Host is up (0.00013s latency).
PORT     STATE SERVICE
4559/tcp open  hylafax

nmap -sS -O 10.0.0.161 -p4559

Starting Nmap 5.51 ( http://nmap.org ) at 2012-04-26 21:46 MDT
Nmap scan report for eden.inet (10.0.0.161)
Host is up (0.00013s latency).
PORT     STATE  SERVICE
4559/tcp closed hylafax


Why?
_________________
#Thelma
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 552
Location: uk

PostPosted: Fri Apr 27, 2012 7:28 am    Post subject: Reply with quote

I would guess you need to configure hosts.hfaxd?

see
http://hylafax.sourceforge.net/man/hosts.hfaxd.php
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Fri Apr 27, 2012 12:54 pm    Post subject: Reply with quote

baaann wrote:
I would guess you need to configure hosts.hfaxd?

see
http://hylafax.sourceforge.net/man/hosts.hfaxd.php


No, my hosts.hfaxd file is correct:
Code:
     ^fd@:::ZGM....
     ^fax@:::CL6....
     localhost
     127.0.0.1
     10.10.0.*
     10.0.0.*
     192.168.*


The problem is with new hylafaxplus installation, it starts the "hfaxd" but the listen ports is only localhost and it should be on all ports:
Code:
lsof | grep hfaxd (old hylafax, the line below is correct)
hfaxd      3969       uucp    4u     IPv4               5939       0t0        TCP *:hylafax (LISTEN)

on hylafax+ it is (incorrect):
hfaxd      4988       uucp    3u     IPv4     916017      0t0        TCP localhost.localdomain:hylafax (LISTEN)

and it should be: "*:hylafax"
But I can not find it where to change it.

file: /usr/lib/fax/hfaxd.conf
does not contain any parameters how to define port for hfaxd

In Gentoo files in /etc/init.d/... are starting scripts and in /etc/conf.d/... are configuration scripts.
I've compared them both old hylafax and new hylafaxplus the files in both directories for both versions (old and new) are identical.
So it must be something else that is not correctly configured on Gentoo.
Lee Howard pointed me to:
http://hylafax.sourceforge.net/man/hfaxd.php
but it doesn't know where it is so it must be something specific to Gentoo :-/
_________________
#Thelma
Back to top
View user's profile Send private message
Arkhelion
Apprentice
Apprentice


Joined: 07 Sep 2010
Posts: 151
Location: France

PostPosted: Fri Apr 27, 2012 4:57 pm    Post subject: Reply with quote

In /etc/conf.d/hylafaxplus, you have :
Code:
faxbind="127.0.0.1"


That must be the culprit.
_________________
Arkhelion
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Fri Apr 27, 2012 6:54 pm    Post subject: Reply with quote

Arkhelion wrote:
In /etc/conf.d/hylafaxplus, you have :
Code:
faxbind="127.0.0.1"


That must be the culprit.


Yes, changing it to "*" did the trick but an old script "hylafax" (that was removed from portage) had
faxbind="127.0.0.1" as well and everything was working, port 4559 was open when you restart hylafax.
So there must have been some changes somewhere else.
_________________
#Thelma
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum