Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
urxvt only transparent at shading=100 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6335
Location: /usr/lib64/lv2

PostPosted: Sun Apr 22, 2012 1:30 am    Post subject: urxvt only transparent at shading=100 [SOLVED] Reply with quote

Would anyone know why urxvt is only transparent when shading=100? If it's 99, 101, or anything other than 100, there is no transparency at all.

Code:

*background: #000000
*foreground: #ffffff

URxvt*font:                     xft:Terminus:size=14

URxvt*urlLauncher:              firefox
URxvt*perl-ext-common:          default,matcher,tabbed
URxvt*urlLauncher:              /usr/bin/firefox
URxvt*matcher.button:           1

URxvt*scrollBar:                false

URxvt*transparent:              true
URxvt*shading:                  100

Xcursor*theme:                  Obsidian

_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.


Last edited by audiodef on Mon May 07, 2012 12:48 am; edited 1 time in total
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Mon Apr 23, 2012 1:37 pm    Post subject: Reply with quote

Strange. Maybe you could use true transparency instead?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6335
Location: /usr/lib64/lv2

PostPosted: Mon Apr 23, 2012 6:01 pm    Post subject: Reply with quote

I would, but I'm using Fluxbox and no compositor...
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Mon Apr 23, 2012 8:03 pm    Post subject: Reply with quote

You can give compton a try, I use it with awesome without problems.

I know it's not a solution to your question, but I have no problems with fake/true transparency so the only thing that comes to my mind is recommending the latter :)
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6335
Location: /usr/lib64/lv2

PostPosted: Mon Apr 23, 2012 8:42 pm    Post subject: Reply with quote

I'll check out compton. How much of a footprint does it have?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Tue Apr 24, 2012 10:46 am    Post subject: Reply with quote

Close to nothing, on my system urxvtd uses ten times more resources with one client spawned.

I run compton in background with 'compton -b', without any shadows or transitions (it can do them, though).
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Wed Apr 25, 2012 6:49 am    Post subject: Reply with quote

Dude, fluxbox can handle composite now. I think it was one of the two projects of the GSoC last year. It's even included in the main branch.

I just run xcompmgr while I've got the correct settings in my .Xdefaults, and that's it.
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Wed Apr 25, 2012 11:05 am    Post subject: Reply with quote

barul, you might want to know that compton is a fork of xcompmgr which does not have problems with memory leaks :)

Also unagi might be worth a try, though it seems that noone have made an ebuild yet.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
colo-des
n00b
n00b


Joined: 20 May 2011
Posts: 23

PostPosted: Sat Apr 28, 2012 9:02 pm    Post subject: Re: urxvt only transparent at shading=100 Reply with quote

$ equery uses rxvt-unicode
- - afterimage : Enable transparency support using media-libs/libafterimage (deprecated in 9.14)
+ + pixbuf : Enable transparency support using gtk's pixbuf

Disable afterimage and enable pixbuf in you /etc/portage/package.use

$ eix -Ic rxvt-unicode
[I] x11-terms/rxvt-unicode (9.15@12/04/12): rxvt clone with xft and unicode support

Regards
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6335
Location: /usr/lib64/lv2

PostPosted: Mon May 07, 2012 12:48 am    Post subject: Reply with quote

Wouldn't you know it - it all works after my last world update. No idea which package it was, but hey - it's working.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Wed May 09, 2012 8:42 am    Post subject: Reply with quote

Same problem here, just did an excruciating world update after several months.

Works with shading at 100 only.
I tried enabling pixbuf and reemerging gdk-pixbuf, no luck so far.

While reading the FAQ at /usr/share/doc/rxvt-unicode-9.15/README.FAQ.bz2 I tried the second mentioned method with -pixmap and that worked, including shading, setting it by -sh or in .Xdefaults did work.

However, that's just a workaround.

I think I'll just emerge -e world overnight, revdep-rebuld may have missed some libs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum