Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need help with emerging tigervnc with "server" USE flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
leonchik1976
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2010
Posts: 83

PostPosted: Fri Apr 20, 2012 9:45 am    Post subject: Need help with emerging tigervnc with "server" USE Reply with quote

when i try to emerge tigervnc with "server" USE flag, i have following error:

# USE=server emerge tigervnc -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild UD ] x11-base/xorg-server-1.11.2-r2 [1.12.0-r1] USE="doc kdrive nptl udev xorg -dmx -ipv6 -minimal -static-libs -tslib -xnest -xvfb (-selinux%)" 0 kB
[ebuild R ] net-misc/tigervnc-1.1.0-r3 USE="nptl opengl server* xorgmodule" 0 kB
[blocks B ] <x11-base/xorg-server-1.11.4 ("<x11-base/xorg-server-1.11.4" is blocking x11-libs/gtk+-3.4.1)

Total: 2 packages (1 downgrade, 1 reinstall), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(x11-base/xorg-server-1.11.2-r2::gentoo, ebuild scheduled for merge) pulled in by
x11-base/xorg-server required by (gnome-base/gdm-3.2.1.1-r2::gentoo, installed)
x11-base/xorg-server[-minimal] required by (x11-drivers/xf86-video-intel-2.18.0::gentoo, installed)
~x11-base/xorg-server-1.11.2 required by (net-misc/tigervnc-1.1.0-r3::gentoo, ebuild scheduled for merge)
x11-base/xorg-server[udev] required by (x11-drivers/xf86-input-evdev-2.7.0::gentoo, installed)
x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-evdev-2.7.0::gentoo, installed)
<x11-base/xorg-server-1.12.99 required by (x11-drivers/nvidia-drivers-295.40::gentoo, installed)
x11-base/xorg-server[-minimal] required by (x11-base/xorg-x11-7.4-r1::gentoo, installed)
x11-base/xorg-server required by @selected
x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-intel-2.18.0::gentoo, installed)

(x11-libs/gtk+-3.4.1::gentoo, installed) pulled in by
x11-libs/gtk+:3 required by (x11-misc/notification-daemon-0.7.4::gentoo, installed)
>=x11-libs/gtk+-3.1.10:3 required by (gnome-base/gnome-settings-daemon-3.2.3::gentoo, installed)
>=x11-libs/gtk+-2.90.0:3[introspection] required by (dev-libs/libgweather-3.2.1::gentoo, installed)
>=x11-libs/gtk+-3.1.6:3[introspection] required by (app-editors/gedit-3.2.6::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (app-cdr/brasero-3.4.0::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (app-accessibility/caribou-0.4.1-r1::gentoo, installed)
>=x11-libs/gtk+-3.1.13:3[introspection] required by (gnome-extra/gnome-documents-0.2.1::gentoo, installed)
>=x11-libs/gtk+-2.90:3 required by (gnome-base/gconf-3.2.5::gentoo, installed)
x11-libs/gtk+:3 required by (media-libs/libcanberra-0.28-r5::gentoo, installed)
x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
>=x11-libs/gtk+-2.91.1:3 required by (gnome-base/gdm-3.2.1.1-r2::gentoo, installed)
>=x11-libs/gtk+-2.91.1:3[introspection] required by (dev-libs/libpeas-1.2.0-r1::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (net-misc/vino-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.1.19:3 required by (gnome-base/gnome-control-center-3.2.2-r1::gentoo, installed)
>=x11-libs/gtk+-3.0:3[introspection] required by (app-editors/gedit-3.2.6::gentoo, installed)
>=x11-libs/gtk+-2.91.7:3[introspection] required by (media-video/totem-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.3.6:3[introspection,X] required by (media-gfx/eog-3.4.0::gentoo, installed)
>=x11-libs/gtk+-2.90:3[introspection] required by (media-libs/libchamplain-0.12.2::gentoo, installed)
>=x11-libs/gtk+-2.90.0:3[introspection] required by (dev-libs/libunique-3.0.2::gentoo, installed)
>=x11-libs/gtk+-2.91.7:3[introspection] required by (gnome-base/libgnomekbd-3.2.0-r1::gentoo, installed)
>=x11-libs/gtk+-3.1.6:3[introspection] required by (gnome-base/nautilus-3.2.1-r1::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (net-libs/gnome-online-accounts-3.2.1::gentoo, installed)
>=x11-libs/gtk+-2.91.4:3 required by (gnome-extra/nm-applet-0.9.4.1::gentoo, installed)
>=x11-libs/gtk+-2.90.0:3 required by (gnome-base/gnome-keyring-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0:3[introspection] required by (x11-libs/libwnck-3.2.1::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (gnome-extra/zenity-3.2.0::gentoo, installed)
>=x11-libs/gtk+-3.0:3[-aqua,introspection] required by (net-libs/webkit-gtk-1.8.0-r300::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (gnome-base/gnome-applets-3.2.1::gentoo, installed)
>=x11-libs/gtk+-2.91.3:3 required by (net-libs/gtk-vnc-0.5.0-r1::gentoo, installed)
>=x11-libs/gtk+-2.99.3:3 required by (gnome-extra/gnome-screensaver-3.4.1::gentoo, installed)
>=x11-libs/gtk+-2.90:3 required by (media-sound/sound-juicer-2.99.0_pre20111001::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (gnome-extra/sushi-0.2.1::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (gnome-extra/gucharmap-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0.2:3 required by (app-arch/file-roller-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0:3 required by (gnome-extra/evolution-data-server-3.2.3-r1::gentoo, installed)
>=x11-libs/gtk+-2.91.7:3[introspection] required by (x11-wm/mutter-3.2.2-r1::gentoo, installed)
>=x11-libs/gtk+-2.90.7:3 required by (gnome-base/libgdu-3.0.2::gentoo, installed)
>=x11-libs/gtk+-3.1.13:3[introspection] required by (app-accessibility/orca-3.2.2::gentoo, installed)
x11-libs/gtk+:3 required by (media-gfx/shotwell-0.12.1::gentoo, installed)
>=x11-libs/gtk+-3:3 required by (gnome-extra/mousetweaks-3.2.1-r10::gentoo, installed)
x11-libs/gtk+:3 required by (gnome-base/dconf-0.12.0::gentoo, installed)
>=x11-libs/gtk+-3.0:3 required by (gnome-extra/gnome-contacts-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.3.14:3 required by (x11-themes/gnome-themes-standard-3.4.1::gentoo, installed)
>=x11-libs/gtk+-2.90.0:3 required by (app-crypt/seahorse-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (app-misc/tracker-0.12.10::gentoo, installed)
x11-libs/gtk+:3 required by (gnome-extra/nautilus-tracker-tags-0.12.10::gentoo, installed)
x11-libs/gtk+:3 required by (x11-misc/xdg-user-dirs-gtk-0.9::gentoo, installed)
>=x11-libs/gtk+-3.4.0:3[X] required by (dev-cpp/gtkmm-3.4.0::gentoo, installed)
>=x11-libs/gtk+-3.0.2:3 required by (net-im/empathy-3.2.2::gentoo, installed)
x11-libs/gtk+:3[introspection] required by (gnome-base/gnome-applets-3.2.1::gentoo, installed)
>=x11-libs/gtk+-3.3.17:3[X] required by (x11-terms/gnome-terminal-3.4.0.1::gentoo, installed)
>=x11-libs/gtk+-3.3.14:3[introspection] required by (www-client/epiphany-3.4.0.1::gentoo, installed)
>=x11-libs/gtk+-2.91.3:3[introspection] required by (net-wireless/gnome-bluetooth-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (gnome-base/gnome-shell-3.2.2.1::gentoo, installed)
>=x11-libs/gtk+-2.90.7:3 required by (gnome-base/gnome-session-3.2.1-r1::gentoo, installed)
>=x11-libs/gtk+-3.0:3[X(+)] required by (gnome-extra/gnome-system-monitor-3.4.0::gentoo, installed)
>=x11-libs/gtk+-3.1.9:3[introspection] required by (x11-libs/vte-0.32.0::gentoo, installed)
>=x11-libs/gtk+-2.99.4:3[introspection] required by (media-video/cheese-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3:3[introspection] required by (media-libs/clutter-gtk-1.0.4::gentoo, installed)
>=x11-libs/gtk+-2.90.4:3 required by (net-analyzer/gnome-nettool-3.2.0::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (games-board/aisleriot-3.2.3.1::gentoo, installed)
>=x11-libs/gtk+-3.0.2:3 required by (mail-client/evolution-3.2.3::gentoo, installed)
>=x11-libs/gtk+-2.91.8:3 required by (gnome-extra/yelp-3.2.1::gentoo, installed)
>=x11-libs/gtk+-3.0:3[introspection] required by (x11-libs/gtksourceview-3.2.3::gentoo, installed)
>=x11-libs/gtk+-2.90:3[introspection] required by (gnome-extra/gnome-games-3.2.1-r1::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3 required by (gnome-extra/gconf-editor-3.0.1::gentoo, installed)
>=x11-libs/gtk+-3.2.1:3[cups] required by (gnome-base/gnome-core-libs-3.2.1::gentoo, installed)
>=x11-libs/gtk+-3:3 required by (gnome-extra/gcalctool-6.4.0::gentoo, installed)
>=x11-libs/gtk+-2.91.0:3 required by (media-libs/libgnome-media-profiles-3.0.0::gentoo, installed)
x11-libs/gtk+:3[introspection] required by (gnome-base/gnome-menus-3.2.0.1-r1::gentoo, installed)
>=x11-libs/gtk+-3.0.2:3[introspection] required by (app-text/evince-3.2.1-r1::gentoo, installed)
x11-libs/gtk+:3[introspection] required by (gnome-extra/gnome-tweak-tool-3.2.2-r2::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (gnome-extra/gnome-games-3.2.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.91.7:3 required by (gnome-extra/gnome-power-manager-3.2.1::gentoo, installed)
>=x11-libs/gtk+-2.99.3:3[introspection] required by (media-video/totem-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0.3:3 required by (net-misc/vinagre-3.2.2::gentoo, installed)
>=x11-libs/gtk+-3.0.2:3 required by (gnome-extra/gtkhtml-4.2.3::gentoo, installed)
>=x11-libs/gtk+-3.0.3:3 required by (gnome-extra/gnome-utils-3.2.1::gentoo, installed)
>=x11-libs/gtk+-3.0.0:3[introspection] required by (gnome-base/gnome-desktop-3.2.1::gentoo, installed)
>=x11-libs/gtk+-2.91.7:3[introspection] required by (gnome-extra/gnome-games-3.2.1-r1::gentoo, installed)
>=x11-libs/gtk+-3.0:3[introspection] required by (gnome-base/gnome-panel-3.2.1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Fri Apr 20, 2012 10:47 am    Post subject: Reply with quote

It's xorgmodule that's holding you back, not server. If you don't use the module, just deactivate the flag. If you do use the module, you can use my tigervnc-1.2.0 ebuild from this bug: https://bugs.gentoo.org/show_bug.cgi?id=410929
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum