Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdepimlibs-4.8.1 : emerge fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
marckn
n00b
n00b


Joined: 28 Apr 2006
Posts: 11

PostPosted: Sat Apr 07, 2012 9:54 am    Post subject: kdepimlibs-4.8.1 : emerge fails Reply with quote

Hi !
I tried to upgrade the system to the latest kde version that has been recently unmasked in portage. Everything went fine on my laptop but when I tried to upgrade my home pc I couldn't manage to emerge kdepimlibs-4.8.1.
I don't even know what's wrong with the emerge, every time I try to emerge kdepimlibs, it hangs at different points.
I thought to unmask the testing version of kdepimlibs, that is 4.8.2, but I changed my mind when I saw that in the dependencies it was going to install many other untested packages (and kdelibs too).

I asked google but found no answer, could you help me ?

Here are the info suggested by the emerge error message:


emerge -pqv =kde-base/kdepimlibs-4.8.1
[ebuild U ] kde-base/kdepimlibs-4.8.1 [4.7.4-r1] USE="handbook ldap semantic-desktop (-aqua) -debug -prison% -test"


emerge --info =kde-base/kdepimlibs-4.8.1
Code:

Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 3.2.12-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 07 Apr 2012 00:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=generic -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mtune=generic -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distcc distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo rsync://mirror.opteamax.de/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/"                                                                                                                                                                                   
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                                                             
MAKEOPTS="-j9"                                                                                                                                                                                                 
PKGDIR="/usr/portage/packages"                                                                                                                                                                                 
PORTAGE_CONFIGROOT="/"                                                                                                                                                                                         
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://nas.home.net/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



And these are the last sign of life by the emerge script:
Code:

[ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/abstractparser.o                                                                                                                             
Linking CXX shared library ../lib/libkcalcore.so                                                                                                                                                               
Linking CXX shared library ../lib/libkimap.so                                                                                                                                                                 
[ 32%] Built target kcalcore                                                                                                                                                                                   
CMakeFiles/kimap.dir/fetchjob.o: In function `KIMAP::FetchJob::handleResponse(KIMAP::Message const&)':
fetchjob.cpp:(.text+0xe9c): undefined reference to `KMime::Message::Message()'
fetchjob.cpp:(.text+0x1119): undefined reference to `KMime::Headers::Date::setDateTime(KDateTime const&)'
fetchjob.cpp:(.text+0x14e4): undefined reference to `KMime::Content::Content()'
fetchjob.cpp:(.text+0x1568): undefined reference to `KMime::Content::setHead(QByteArray const&)'
fetchjob.cpp:(.text+0x1604): undefined reference to `KMime::Content::setHead(QByteArray const&)'
fetchjob.cpp:(.text+0x164c): undefined reference to `KMime::CRLFtoLF(QByteArray const&)'
fetchjob.cpp:(.text+0x166a): undefined reference to `KMime::Content::setContent(QByteArray const&)'
fetchjob.cpp:(.text+0x1715): undefined reference to `KMime::Content::Content()'
fetchjob.cpp:(.text+0x1799): undefined reference to `KMime::Content::setBody(QByteArray const&)'
CMakeFiles/kimap.dir/fetchjob.o: In function `KIMAP::FetchJobPrivate::parseBodyStructure(QByteArray const&, int&, KMime::Content*)':
fetchjob.cpp:(.text+0x1bcb): undefined reference to `KMime::Content::contentType(bool)'
fetchjob.cpp:(.text+0x1bda): undefined reference to `KMime::Headers::ContentType::setMimeType(QByteArray const&)'
fetchjob.cpp:(.text+0x1c00): undefined reference to `KMime::Content::Content()'
fetchjob.cpp:(.text+0x1c1f): undefined reference to `KMime::Content::addContent(KMime::Content*, bool)'
fetchjob.cpp:(.text+0x1cf7): undefined reference to `KMime::Content::contentType(bool)'
fetchjob.cpp:(.text+0x1d06): undefined reference to `KMime::Headers::ContentType::setMimeType(QByteArray const&)'
fetchjob.cpp:(.text+0x1dd1): undefined reference to `KMime::Content::contentType(bool)'
fetchjob.cpp:(.text+0x1ddc): undefined reference to `KMime::Headers::ContentType::setBoundary(QByteArray const&)'
fetchjob.cpp:(.text+0x1e52): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x1e5f): undefined reference to `KMime::Headers::ContentDisposition::setDisposition(KMime::Headers::contentDisposition)'
fetchjob.cpp:(.text+0x1ea4): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x1eb1): undefined reference to `KMime::Headers::ContentDisposition::setDisposition(KMime::Headers::contentDisposition)'
CMakeFiles/kimap.dir/fetchjob.o: In function `KIMAP::FetchJobPrivate::parsePart(QByteArray const&, int&, KMime::Content*)':
fetchjob.cpp:(.text+0x2186): undefined reference to `KMime::Content::contentType(bool)'
fetchjob.cpp:(.text+0x2198): undefined reference to `KMime::Headers::ContentType::setMimeType(QByteArray const&)'
fetchjob.cpp:(.text+0x2236): undefined reference to `KMime::Content::contentDescription(bool)'
fetchjob.cpp:(.text+0x2377): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x2384): undefined reference to `KMime::Headers::ContentDisposition::setDisposition(KMime::Headers::contentDisposition)'
fetchjob.cpp:(.text+0x23c9): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x23d6): undefined reference to `KMime::Headers::ContentDisposition::setDisposition(KMime::Headers::contentDisposition)'
fetchjob.cpp:(.text+0x23ea): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x23f2): undefined reference to `KMime::Headers::ContentDisposition::disposition() const'
fetchjob.cpp:(.text+0x240b): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x2413): undefined reference to `KMime::Headers::ContentDisposition::disposition() const'
fetchjob.cpp:(.text+0x24fb): undefined reference to `KMime::Content::contentDisposition(bool)'
fetchjob.cpp:(.text+0x250a): undefined reference to `KMime::Headers::ContentDisposition::setFilename(QString const&)'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkimap.so.4.8.0] Error 1
make[1]: *** [kimap/CMakeFiles/kimap.dir/all] Error 2
Linking CXX shared library ../lib/libsyndication.so
[ 32%] Built target syndication                                                                                                                                                                               
make: *** [all] Error 2



Please, tell me if you need other info.
Thanks,
Marco
Back to top
View user's profile Send private message
dmoreno
n00b
n00b


Joined: 01 Feb 2004
Posts: 56

PostPosted: Sat Apr 07, 2012 3:20 pm    Post subject: Reply with quote

I run into a similar (but not the same) problem with kdepimlibs-4.8.1 and solved it by removing the ldap USE flag.
Does your build log show some errors related to ldap?
Back to top
View user's profile Send private message
marckn
n00b
n00b


Joined: 28 Apr 2006
Posts: 11

PostPosted: Sun Apr 08, 2012 12:52 am    Post subject: Reply with quote

Hello ! Thanks for the reply :)

I've just scanned my build log searching for the word "LDAP" but I didn't find any error about LDAP.
I tried anyway to unset the ldap use flag but it still does not compile the package.

Now it's a bit late in the night, tomorrow I'll try to search for any other errors in the log.
Back to top
View user's profile Send private message
marckn
n00b
n00b


Joined: 28 Apr 2006
Posts: 11

PostPosted: Wed Apr 11, 2012 11:02 am    Post subject: Reply with quote

tried to unmask kdepimlibs-4.8.2 but I'm still getting the same problem :cry:
When I finish my current work I'll try a clean install of kde.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum