Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] How to set language
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
conoscenza
Tux's lil' helper
Tux's lil' helper


Joined: 25 Dec 2011
Posts: 105
Location: Spinazzola (bt) | Brescia | Parma

PostPosted: Thu Apr 05, 2012 9:36 am    Post subject: [Solved] How to set language Reply with quote

Hi guys,
I've a problem. I can't set my language on gentoo with XFCE.

This is my locale.gen:
Quote:

localhost ~ # cat /etc/locale.gen
# /etc/locale.gen: list all of the locales you want to have on your system
#
# The format of each line:
# <locale> <charmap>
#
# Where <locale> is a locale located in /usr/share/i18n/locales/ and
# where <charmap> is a charmap located in /usr/share/i18n/charmaps/.
#
# All blank lines and lines starting with # are ignored.
#
# For the default list of supported combinations, see the file:
# /usr/share/i18n/SUPPORTED
#
# Whenever glibc is emerged, the locales listed here will be automatically
# rebuilt for you. After updating this file, you can simply run `locale-gen`
# yourself instead of re-emerging glibc.

#en_US ISO-8859-1
#en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
#fa_IR UTF-8
#fr_FR ISO-8859-1
#fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1
it_IT.UTF-8 UTF-8


but If I run:
locale-gen
my gui is in english language!

I would set it in italian language...

thank you


Last edited by conoscenza on Thu Apr 05, 2012 10:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Thu Apr 05, 2012 10:42 am    Post subject: Reply with quote

http://www.gentoo.org/doc/it/guide-localization.xml
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
GES
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 108
Location: Budapest, Hungary

PostPosted: Thu Apr 05, 2012 10:42 am    Post subject: Reply with quote

http://www.gentoo.org/doc/en/guide-localization.xml#doc_chap3
Back to top
View user's profile Send private message
conoscenza
Tux's lil' helper
Tux's lil' helper


Joined: 25 Dec 2011
Posts: 105
Location: Spinazzola (bt) | Brescia | Parma

PostPosted: Thu Apr 05, 2012 6:01 pm    Post subject: Reply with quote

I read doc, but I can't set it in italian.

Anyway I've a question:
my cat /etc/env.d/02locale is:
Quote:

LC_CTYPE=it_IT.UTF-8


I must put also:
Quote:

LANG="it_IT.UTF-8"
LC_COLLATE="C"


and after run:
env-update && source /etc/profile
and:
source ~/.bashrc
for my user account?


In the /etc/make.conf I've added:
LINGUAS="it"

and, from root:
Quote:

localhost ~ # locale
LANG=
LC_CTYPE=it_IT.UTF-8
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
localhost ~ # locale -a
C
POSIX
it_IT.utf8


from user:
Quote:

unknow@localhost ~/Desktop $ locale
LANG=
LC_CTYPE=it_IT.UTF-8
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
unknow@localhost ~/Desktop $ locale -a
C
POSIX
it_IT.utf8



I've tried to run:
export LANG="it_IT.UTF-8"
and after?
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 57
Location: Italy

PostPosted: Thu Apr 05, 2012 9:49 pm    Post subject: Reply with quote

What's the output under a terminal, not within xfce but after CTL-ALT-F1 for instance

After login try
Code:
~ $ man man


The reported manpage is english or italian?

If in italian, locale is OK, settings should be changed within xfce (No clue regarding xfce).

And after:
Quote:

In the /etc/make.conf I've added:
LINGUAS="it"

you need to
Code:
emerge -uavtDN world

Most likely that's the issue!

Ralf


Last edited by Helmering on Thu Apr 05, 2012 10:14 pm; edited 2 times in total
Back to top
View user's profile Send private message
conoscenza
Tux's lil' helper
Tux's lil' helper


Joined: 25 Dec 2011
Posts: 105
Location: Spinazzola (bt) | Brescia | Parma

PostPosted: Thu Apr 05, 2012 10:02 pm    Post subject: Reply with quote

Guys I resolved!

I done:
Quote:

echo "LANG="it_IT.UTF-8"" >> /etc/env.d/02locale
echo "LC_COLLATE="C"" >> /etc/env.d/02locale
env-update && source /etc/profile


and:
Quote:

source ~/.bashrc

this last from user account.

I restarted X11 and my layout is in italian! (I don't understand why export LANG="..." does not well)

Anyway:
which is the difference beetwen:
emerge -DNu world
and
emerge -avtDN @world
?
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 57
Location: Italy

PostPosted: Thu Apr 05, 2012 10:13 pm    Post subject: Reply with quote

conoscenza wrote:

Anyway:
which is the difference beetwen:
emerge -DNu world
and
emerge -avtDN @world
?


Fine that's working.
You are right regarding -u=update, what we want. Corrected in my post.

Ralf
Back to top
View user's profile Send private message
conoscenza
Tux's lil' helper
Tux's lil' helper


Joined: 25 Dec 2011
Posts: 105
Location: Spinazzola (bt) | Brescia | Parma

PostPosted: Thu Apr 05, 2012 11:42 pm    Post subject: Reply with quote

ok!

thanks to all!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum