Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -pv gnome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Wed Apr 04, 2012 4:22 am    Post subject: emerge -pv gnome Reply with quote

Code:
>=sys-fs/udev-182 required by (sys-auth/consolekit-0.4.5-r3::gento0,ebuild scheduled for emerge)
         (and 1 more with the same problems)

       (sys-fs/udev-171-r5::gentoo,installed ) pulled in by
           (no parents that aren't satisfied by other packages in this slot)

It may be possible bo solve this problem by using package.mask to preventtone of those packages from being selected.However,it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. If such a conflict exists in the dependencies of two dirrerent packages,them those packages can not be installed simultaneously.You may want to try a larger value of the --backtrack option ,such as  --backtrack=30,in order to see if that will  solve this conflict automatically

when I type the words "emerge -pv gnome " in the command line,the above situation emerges
iwhat should I do to solve this problem,please?
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Wed Apr 04, 2012 4:58 am    Post subject: Reply with quote

The problem is that consolekit requires udev-182, which is not installed. Your current version is udev-171-r5.

First you can try running emerge -avuND world to update everything and see if the message goes away if you are running the unstable branch, ie, ~amd64, ~x86, etc. Be aware that the new udev is not playing nicely with /usr on a separte partition without a initramfs. If you used genkernel or /usr is not a separate partition, you will not have a problem. After you complete the update, the block should go away.

you can try running emerge -pv --backtrack=30 gnome as per the portage output and see if that solves the problem.

If you are running on the stable branch, then you can proceed as follows, again be aware about the new quirk in udev above.
If the problem is not solved by these steps, then I would guess that the problem is that >=udev-182 are unstable and you are not running on the unstable branch. If you are not running on the unstable branch, then you will need to accept the keywords for udev to continue. Here is how to do that:
1) open the keywords file. You will need to create it if you have not already done so: nano -w /etc/portage/package.accept_keywords
2) add the line <=sys-fs/udev-182-r3 if you are running amd64. use r2 if you are on x86. Don't use the 182 version number because that will not install due to a bug.

note the inequality. You will want to only include the version that solves your problem and then return to the stable version as quickly as possible by not updating to newer unstable versions. Don't down grade important packages if you can help it. Some, like glibc and qt, will break your system.

In general, you want to avoid mixing branches like this if you can help it. When you do things tend to break.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Apr 04, 2012 5:00 am    Post subject: Reply with quote

unix like,

If you haven't done an update yet I would suggest doing so before installing gnome.
Code:
emerge -uavD @world

The message =sys-fs/udev-182 required by (sys-auth/consolekit-0.4.5-r3 is conflicting with the older version sys-fs/udev-171-r5.

If you already did an upgrade then try temporarily masking sys-fs/udev-182

Code:
echo "=sys-fs/udev-182" >> /etc/portage/package.mask


Good luck :wink:
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Wed Apr 04, 2012 6:17 am    Post subject: Reply with quote

when I emerge -avuND world
Code:
ERROR:sys-libs/zlib-1.2.6 failed (compile phase):
   (no error message)
Call stack
      ebuild.sh,line 85 : Called src_compile
   environment,line 2455:Called die
The specific snippet fo code:
                          emake || die
If you need support, post the output of 'emerge --info =sys-libs/zlib-1.2.6',
the compile build log is located at '/var/tmp/portage/sys-libs/zlib-1.2.7/temp/build.log',
The ebuild environment file si located at '/var/tmp/portage/sys-libs/zlib-1.2.6/temp/environment'.
S:'/var/tmp/portage/sys-libs/zlib-1.2.6/work/zlib-1.2.6'

Sorry,all of the methods you listed above does not work,by the way,
it is the first time that i have installed the gentoo(install-amd64-minimal) by referring to the gentoo handbook.
my cpu is intel corei3,even i don't know how to configure the file "make.conf",is there anything wrong with my contents of the file "make.conf"
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Apr 04, 2012 1:15 pm    Post subject: Reply with quote

unix like

My bad there with the mask :( This will correct it:

Code:
sed -i.bak 's/=sys-fs\/udev-182/=sys-fs\/udev-182-r2/' /etc/portage/package.mask


Quote:
i don't know how to configure the file "make.conf"

Paste back the contents of make.conf. Also, if you've made any changes to /etc/portage/package.mask (besides this one) and /etc/portage/package.use, include those too

One more thing - return the results of
Code:
eselect profile list|grep "*"
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Wed Apr 04, 2012 2:51 pm    Post subject: thanks Reply with quote

But new problems emerges,now I have to reinstall again.so bad! :(
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Wed Apr 04, 2012 3:05 pm    Post subject: Reply with quote

In general, re installing will NOT solve your problems. It will only give you the chance to make the same mistakes again. If you have not already re-installed, then post your /etc/make.conf and the output of eselect profile list
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Thu Apr 05, 2012 12:27 pm    Post subject: make.conf Reply with quote

Code:
CFLAGS="-02 -march=core2 -mtune=generic -pipe"
FEATURES="ccache"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="mmx sse sse2 nptl nptlonly -ipv6 -fortran unicode svg hal dbus -kde -qt4 -qt3 opengl mng python png policykit -arts -eds -esd consolekit ogg vorbis gnome gstreamer gtk firefox X pam mta ssl  pcre tcpd ncurses webkit sql declarative wallpapers handbook cups mplayer truetype new-login xorg nls static static-libs crypt gconf introspection xscreenaver xv xcomposite xinerama aiglx jpeg gif tiff pdf alsa mad vidix asf win32codecs dvd mp3 mp4 aac xvid nsplugin samba real -java  bzip2 udev gudev symlink sqlite spell xml fam threads kdeenablefinal rdesktop xa libkms python pulseaudio"

MAKEOPTS="-j2"
INPUT_DEVICES="vmmouse"
VIDEO_DEVICES="vmware"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/"
SYNC="rsync://rsync.asia.gentoo.org/gentoo-portage"
EMERGE_DEFAULT_OPTS="--autounmask=n
"
That is all of my 'make.conf'.is there any problem?
and when I type "emerge -pvuDN world",there are five blocks namely:kmod,module-init-tools,openrc,udev emered. what should I do for this?
by the way ,do you have QQ number?
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Apr 05, 2012 3:15 pm    Post subject: Reply with quote

unix like

What profile are you using?

Code:
eselect profile list|grep "*"

Also what desktop do you intend to use?

Depending on your profile, you may not need all those use flag settings in make.conf. Furthermore, if your profile has qt3 enabled, then it's not a good idea to disable it globally in make.conf. It would be better to disable it, for whatever reason, on an individual package basis in package.use.

Most emerge and compile errors can be attributed directly to use flag conflicts. It's good to get a handle on the use flags early-on otherwise you'll continue to have problems.

EDIT: Never mind the desktop question - you're emerging gnome and I was half asleep :oops:
You should set the profile to desktop/gnome. That will provide the necessary use flags for the gnome desktop :wink:
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Fri Apr 06, 2012 1:43 am    Post subject: Reply with quote

my desktop is gnome,and do I need to type ACCEPE_KEYWORDS="~amd6" into the file make.conf
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Fri Apr 06, 2012 4:21 am    Post subject: Reply with quote

You do not need ACCEPE_KEYWORDS="~amd6" in your make.conf
If you want the newest bleeding edge software and the bugs that come with it, then you can use it.
If you prefer stable packages with only the needed testing packages, add them to /etc/portage/package.accept_keywords (you will need to create this file)
entries look like this:
Code:
=sys-fs/udev-182-r3
this means "accept the testing version of udev, but only install version 182-r3. When a higher version is marked stable, use that one."

Generally you should avoid mixing software branches, but in this case it looks like you will need to.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Fri Apr 06, 2012 5:19 am    Post subject: Reply with quote

got it
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Fri Apr 06, 2012 5:39 am    Post subject: Reply with quote

Taking a close look at your make.conf use varable, it looks messy and chaotic. you can look up what flags do at http://www.gentoo.org/dyn/use-index.xml.

hal is dead and removed so your "hal" flag is useless. You set -kde and handbook, but handbook only generates entries for kde4 you also have kdeenablefinal, which is also kde specific. Most everything should be in the gnome profile. make.conf is best used for global fine tuning of your profile. python is listed twice. This is not really an issue, but it is a bit messy. The static and static-libs are not something you generally want to set. Do not set them unless you know what you are doing. For package specific flags, and I believe I see quite a few, you should set them on a per package basis in /etc/portage/package.use as they do different things in different packages.

Using a quick look at it, I think I would do this:

WANT="gtk firefox declarative cups mplayer pdf dvd samba"
DONTWANT="-kde -qt4 -qt3 -java"
USE="${WANT} ${DONTWANT}"

I included -java and samba here as they were set this way, but I would tend to reverse that and say java and -samba because everything uses java but unless you know what samba is, you will not be using it. I believe that the gnome profile would select just about everything else, except some of the media flags would should be controlled through package.use.

You can always go back and change your use settings of course. These are just a few random thoughts on your config.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Sat Apr 07, 2012 2:42 am    Post subject: Reply with quote

yeah,what you said makes sense,penguin!my make.conf file is not a bit messy but very very messy.Because when I install applications,I will add available VARS into USE according to the hints of screen,so it looks very chaotic.Luckily,before this I have finished the installation of gentoo including gnome finally,although my deed looks hurry and chaotic.But I am very happy and have the sense of achievement. It really take me many time just installing gnome!
Until I entered the gnome,did I found that I cann't use keyboard but mouse can,returned back to command line,both keyboadr and mouse are ok .I also did not find the grub.conf in /boot/grub.How do I solve the problems,please?


Last edited by unix like on Sat Apr 07, 2012 9:07 am; edited 1 time in total
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2630

PostPosted: Sat Apr 07, 2012 3:03 am    Post subject: Reply with quote

Ok, mouse and keyboard should be controlled by a driver in X11, so you should add this line to your make.conf:
Code:
INPUT_DEVICES="keyboard mouse evdev"

and run emerge -auvND world. Xorg should pick up the missing drivers. If not, then do it manually like this:
Code:
emerge -1 x11-drivers/xf86-input-evdev x11-drivers/xf86-input-keyboard x11-drivers/xf86-input-mouse


For your grub config file, make sure /boot is mounted if it is a separate partition. The config file should be located at /boot/grub/grub.conf
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
unix like
n00b
n00b


Joined: 04 Apr 2012
Posts: 16

PostPosted: Sat Apr 07, 2012 12:32 pm    Post subject: Reply with quote

Thank you for your advice.It's very very useful.I do as you said,it is totally right!
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Sat Apr 07, 2012 12:40 pm    Post subject: Reply with quote

Code:
INPUT_DEVICES="evdev"
should be enough
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum