Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RTL8188CE wireless card gives only low speeds.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Sun Apr 01, 2012 7:27 pm    Post subject: RTL8188CE wireless card gives only low speeds. Reply with quote

Hi!

I bought some time ago new wireless PCI-Express card "Asus PCE-N15 Wireless N PCIe" and I've been struggling getting it to work reliably. Usual symptoms are numerous disconnects and reconnects and speeds around 0.5 - 1.0Mbit, both up and down. My internet connection is 10Mbit up and 100Mbit down and the card reports always 300Mbit/s as the wlan speed.
This problem spans over several distros and is as such universal. I believe this is driver&kernel problem.

My desktop computer has access to two different wlan AP:s from different manufacturers. I have a Zydas USB-wlan-card as a backup device through with which I can use internet reliably. It supports g-channel and gives me 10Mbit up / 10Mbit down speeds when tested at www.speedtest.net .
I have several other computers which have no problems with up-to n-channel 300Mbit/s speeds.

My two APs are configured as follows:
Zyxel VSDL-modem NAT: 40Mhz N-only WPA2-PSK-AES for performance uses
D-Link DIR-615 bridge: b/g/n 20Mhz WPA2-PSK-AES for all legacy devices
Zyxel has NAT. D-Link is connected with Cat5-cable to Zyxel and serves as a bridge.

What has been done:
I have tested all current 3.x-series kernels up to (and now using) 3.4-rc1.
I found two patches from the bugzilla entry https://bugzilla.redhat.com/show_bug.cgi?id=770207 which improved the stability of connection, but didn't help with the speed.
Forcing the Zyxel-AP to use 20Mhz bandwith does not make any difference, except maximum speed.
The best configuration so far has been: 40Mhz, control sideband - "Upper". With that I get 10Mbit up / 4Mbit down from speedtest.net .
I have tried changing module options swenc, ips, swlps and fwlps and many combinations.
I have tried both in-kernel and latest official drivers from realtek.com.tw.

Any ideas how to debug this problem?
_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Sun Apr 01, 2012 7:34 pm    Post subject: Additional information Reply with quote

lspci -knnv
06:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8178] (rev 01)
Subsystem: ASUSTeK Computer Inc. Device [1043:84b6]
Flags: bus master, fast devsel, latency 0, IRQ 16
I/O ports at d800 [size=256]
Memory at feafc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 01-91-81-fe-ff-4c-e0-00
Kernel driver in use: rtl8192ce
Kernel modules: rtl8192ce

uname -a
Linux xxxxx 3.4.0-rc1 #1 SMP PREEMPT Sun Apr 1 15:06:10 EEST 2012 x86_64 AMD Phenom(tm) II X6 1100T Processor AuthenticAMD GNU/Linux

eix net-misc/networkmanager
[I] net-misc/networkmanager
Installed versions: 0.9.2.0-r2(11.13.51 05.01.2012)(avahi bluetooth connection-sharing dhclient gnutls introspection kernel_linux ppp resolvconf -dhcpcd -doc -nss -wimax)

Official realtek driver I tried:
rtl_92ce_92se_92de_linux_mac80211_0005.1230.2011

iwconfig wlan1
wlan1 IEEE 802.11bgn ESSID:"XXXXXXXXXXXX"
Mode:Managed Frequency:2.462 GHz Access Point: CC:5D:4E:7A:84:E7
Bit Rate=300 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=61/70 Signal level=-49 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:216 Missed beacon:0

The count "Invalid misc:" changes really often.
_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Mon Apr 02, 2012 6:56 pm    Post subject: Reply with quote

One "normal" usecase where the connection work for few minutes and then fails is like following:
Code:
Apr 02 21:40:40 [kernel] [95936.115479] wlan1: associated
Apr 02 21:40:43 [kernel] [95939.106087] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:43 [kernel] [95939.106220] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:44 [kernel] [95940.102148] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:44 [kernel] [95940.114107] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:45 [kernel] [95941.088184] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:45 [kernel] [95941.098126] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:46 [kernel] [95942.085189] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:46 [kernel] [95942.093163] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:47 [kernel] [95943.083171] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:47 [kernel] [95943.088164] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:48 [kernel] [95944.085168] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:48 [kernel] [95944.091150] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:49 [kernel] [95945.083179] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:49 [kernel] [95945.088146] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:51 [kernel] [95946.693310] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:40:51 [kernel] [95946.700283] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:41:02 [kernel] [95957.926797] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 7)
Apr 02 21:41:02 [kernel] [95957.962477] cfg80211: Calling CRDA to update world regulatory domain
Apr 02 21:41:03 [kernel] [95958.970263] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 02 21:41:03 [kernel] [95958.989719] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:41:03 [kernel] [95958.992141] wlan1: authenticated
Apr 02 21:41:03 [kernel] [95959.003229] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:41:03 [kernel] [95959.006611] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 02 21:41:03 [kernel] [95959.006620] wlan1: associated
Apr 02 21:41:03 [kernel] [95959.034245] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:41:03 [kernel] [95959.034394] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 02 21:48:46 [kernel] [96420.477350] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 7)
Apr 02 21:48:46 [kernel] [96420.507989] cfg80211: Calling CRDA to update world regulatory domain
Apr 02 21:48:47 [kernel] [96421.518361] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 02 21:48:47 [kernel] [96421.538258] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:48:47 [kernel] [96421.539793] wlan1: authenticated
Apr 02 21:48:47 [kernel] [96421.550743] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:48:47 [kernel] [96421.556453] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 02 21:48:47 [kernel] [96421.556462] wlan1: associated
Apr 02 21:48:55 [kernel] [96429.521660] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 15)
Apr 02 21:48:55 [kernel] [96429.546038] cfg80211: Calling CRDA to update world regulatory domain
Apr 02 21:48:56 [kernel] [96430.553229] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 02 21:48:56 [kernel] [96430.573091] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:48:56 [kernel] [96430.575447] wlan1: authenticated
Apr 02 21:48:56 [kernel] [96430.586554] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:48:56 [kernel] [96430.589919] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 02 21:48:56 [kernel] [96430.589922] wlan1: associated
Apr 02 21:49:02 [kernel] [96436.399069] wlan1: deauthenticating from cc:5d:XX:XX:XX:XX by local choice (reason=3)
Apr 02 21:49:02 [kernel] [96436.441202] cfg80211: Calling CRDA to update world regulatory domain
Apr 02 21:49:03 [kernel] [96437.457118] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 02 21:49:03 [kernel] [96437.477363] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:49:03 [kernel] [96437.481961] wlan1: authenticated
Apr 02 21:49:03 [kernel] [96437.492785] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:49:03 [kernel] [96437.496192] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 02 21:49:03 [kernel] [96437.496194] wlan1: associated
Apr 02 21:49:11 [kernel] [96445.461853] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 15)
Apr 02 21:49:11 [kernel] [96445.481044] cfg80211: Calling CRDA to update world regulatory domain
Apr 02 21:49:12 [kernel] [96446.488629] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 02 21:49:12 [kernel] [96446.508103] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:49:12 [kernel] [96446.510405] wlan1: authenticated
Apr 02 21:49:12 [kernel] [96446.520602] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:49:12 [kernel] [96446.528220] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 02 21:49:12 [kernel] [96446.528230] wlan1: associated
Apr 02 21:49:20 [kernel] [96454.489730] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 15)
Apr 02 21:49:20 [kernel] [96454.505934] cfg80211: Calling CRDA to update world regulatory domain
Apr 02 21:49:21 [kernel] [96455.513137] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 02 21:49:21 [kernel] [96455.532978] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:49:21 [kernel] [96455.534482] wlan1: authenticated
Apr 02 21:49:21 [kernel] [96455.545450] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 02 21:49:21 [kernel] [96455.548778] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 02 21:49:21 [kernel] [96455.548781] wlan1: associated
Apr 02 21:49:28 [kernel] [96462.121550] wlan1: deauthenticating from cc:5d:XX:XX:XX:XX by local choice (reason=3)
Apr 02 21:49:28 [kernel] [96462.156872] cfg80211: Calling CRDA to update world regulatory domain


Connection was somewhat working from 21:40:43 to 21:41:02 and from 21:41:03 to 21:48:46 after which it failed to reconnect until manually unloading and reloading the kernel modules.

Ping during the 21:41 - 21:48 timespace showed following:
Code:
--- 192.168.1.1 ping statistics ---
100 packets transmitted, 100 received, 0% packet loss, time 99131ms
rtt min/avg/max/mdev = 4.890/12.653/202.286/20.877 ms

As you can see the rtt should be around 4-5ms almost all the time.

I wonder if the WPA2-PSK-AES-encryption causes some problems?
_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Apr 02, 2012 8:13 pm    Post subject: Reply with quote

Code:
Apr 02 21:48:46 [kernel] [96420.507989] cfg80211: Calling CRDA to update world regulatory domain
This usually means only low transmit power, passive scanning and disabling of some other things. See if crda and wireless-regdb are installed properly. If you use wpa_supplicant, ensure that it is launched with -Dnl80211 (not -Dwext).

If it still does not work, you may have to set the regulatory domain manually.
Code:
# iw reg set <countrycode>
Back to top
View user's profile Send private message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Tue Apr 03, 2012 7:10 am    Post subject: Reply with quote

chithanh wrote:
Code:
Apr 02 21:48:46 [kernel] [96420.507989] cfg80211: Calling CRDA to update world regulatory domain
This usually means only low transmit power, passive scanning and disabling of some other things. See if crda and wireless-regdb are installed properly. If you use wpa_supplicant, ensure that it is launched with -Dnl80211 (not -Dwext).

If it still does not work, you may have to set the regulatory domain manually.
Code:
# iw reg set <countrycode>


Thank you for answering. I were wondering about that just yesterday and now I have the CRDA installed and 'iw reg set FI' executed. More testing will happen this evening when I'm back home from work.

I'm using NetworkManager and by checking the logs I doubt it could be the culprit.

Yet I doubt that is the reason why my connection is not working, because my another wlan card still connects flawlessly in 802.11g-mode.
_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Tue Apr 03, 2012 7:24 pm    Post subject: Reply with quote

Well well well. What a surprise. After fresh reboot the connection has been up 15 minutes.
After last try I reduced the bandwith from 40Mhz to 20Mhz.

Now I get following from iw dev wlan1 link:

Code:
Connected to cc:5d:4e:XX:XX:XX (on wlan1)
   SSID: XXXXXX
   freq: 2462
   RX: 354147 bytes (1420 packets)
   TX: 76240 bytes (500 packets)
   signal: -49 dBm
   tx bitrate: 144.4 MBit/s MCS 15 short GI

   bss flags:   short-preamble short-slot-time
   dtim period:   0
   beacon int:   100


Is that good?

www.speedtest.net gives me:
    Ping 32ms
    Download speed 5Mbps
    Upload speed 8.5Mbps


That is still less than what I get with ZyDas 802.11g USB-adapter (40ms/13Mbps/10Mbps). And very far away from the supposed 144Mbit/sec.
_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Tue Apr 03, 2012 7:36 pm    Post subject: Reply with quote

Testing the 40Mhz bandwith shows following:
Ping times do not vary.
40Mhz with Control Sideband: Lower gives 2Mbit/s down and 1Mbit/s up.
With Control Sideband: upper fives 4Mbit/s down and 4Mbit/s up.

So the control sideband-setting really matters. Yet actual speed is lower than with 20Mhz bandwith.

The Invalid Misc -count shown by iwconfig began changing. It resets whenever the connection deauthenticates.

The following is a repeating snippet showing what is going on when the bandwith is 40Mhz:
Code:
Apr 03 22:27:28 [kernel] [ 1814.170572] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 03 22:27:28 [kernel] [ 1814.170581] wlan1: associated
Apr 03 22:27:28 [kernel] [ 1814.201041] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:27:28 [kernel] [ 1814.201261] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:28:16 [kernel] [ 1862.010297] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 7)
Apr 03 22:28:16 [kernel] [ 1862.054218] cfg80211: Calling CRDA to update world regulatory domain
Apr 03 22:28:16 [kernel] [ 1862.065262] cfg80211: World regulatory domain updated:
Apr 03 22:28:16 [kernel] [ 1862.065269] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr 03 22:28:16 [kernel] [ 1862.065277] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:16 [kernel] [ 1862.065284] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:16 [kernel] [ 1862.065290] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:16 [kernel] [ 1862.065296] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:16 [kernel] [ 1862.065301] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:29 [kernel] [ 1874.850629] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 03 22:28:29 [kernel] [ 1874.870089] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:28:29 [kernel] [ 1874.887311] wlan1: authenticated
Apr 03 22:28:29 [kernel] [ 1874.898413] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:28:29 [kernel] [ 1874.903608] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 03 22:28:29 [kernel] [ 1874.903618] wlan1: associated
Apr 03 22:28:29 [kernel] [ 1874.932109] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:28:29 [kernel] [ 1874.932275] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:28:36 [kernel] [ 1881.230007] wlan1: deauthenticating from cc:5d:XX:XX:XX:XX by local choice (reason=3)
Apr 03 22:28:36 [kernel] [ 1881.280416] cfg80211: Calling CRDA to update world regulatory domain
Apr 03 22:28:36 [kernel] [ 1881.291388] cfg80211: World regulatory domain updated:
Apr 03 22:28:36 [kernel] [ 1881.291395] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr 03 22:28:36 [kernel] [ 1881.291403] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:36 [kernel] [ 1881.291410] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:36 [kernel] [ 1881.291416] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:36 [kernel] [ 1881.291422] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:36 [kernel] [ 1881.291428] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:28:37 [kernel] [ 1882.313774] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 03 22:28:37 [kernel] [ 1882.333496] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:28:37 [kernel] [ 1882.335837] wlan1: authenticated
Apr 03 22:28:37 [kernel] [ 1882.346987] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:28:37 [kernel] [ 1882.355873] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 03 22:28:37 [kernel] [ 1882.355876] wlan1: associated
Apr 03 22:28:37 [kernel] [ 1882.384503] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:28:37 [kernel] [ 1882.384678] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:29:47 [kernel] [ 1952.891246] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 7)
Apr 03 22:29:47 [kernel] [ 1952.919917] cfg80211: Calling CRDA to update world regulatory domain
Apr 03 22:29:47 [kernel] [ 1952.930976] cfg80211: World regulatory domain updated:
Apr 03 22:29:47 [kernel] [ 1952.930983] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr 03 22:29:47 [kernel] [ 1952.930991] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:29:47 [kernel] [ 1952.930998] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:29:47 [kernel] [ 1952.931004] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:29:47 [kernel] [ 1952.931010] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:29:47 [kernel] [ 1952.931016] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:29:48 [kernel] [ 1953.922538] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 03 22:29:48 [kernel] [ 1953.942179] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:29:48 [kernel] [ 1953.943696] wlan1: authenticated
Apr 03 22:29:48 [kernel] [ 1953.956662] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:29:48 [kernel] [ 1953.960128] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 03 22:29:48 [kernel] [ 1953.960131] wlan1: associated
Apr 03 22:29:48 [kernel] [ 1953.989398] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:29:48 [kernel] [ 1953.989580] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:31:28 [kernel] [ 2053.049019] wlan1: deauthenticated from cc:5d:XX:XX:XX:XX (Reason: 7)
Apr 03 22:31:28 [kernel] [ 2053.087722] cfg80211: Calling CRDA to update world regulatory domain
Apr 03 22:31:28 [kernel] [ 2053.098689] cfg80211: World regulatory domain updated:
Apr 03 22:31:28 [kernel] [ 2053.098695] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr 03 22:31:28 [kernel] [ 2053.098703] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:31:28 [kernel] [ 2053.098710] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:31:28 [kernel] [ 2053.098716] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:31:28 [kernel] [ 2053.098722] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:31:28 [kernel] [ 2053.098728] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Apr 03 22:31:29 [kernel] [ 2054.089182] wlan1: authenticate with cc:5d:XX:XX:XX:XX
Apr 03 22:31:29 [kernel] [ 2054.108975] wlan1: send auth to cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:31:29 [kernel] [ 2054.129629] wlan1: authenticated
Apr 03 22:31:29 [kernel] [ 2054.140371] wlan1: associate with cc:5d:XX:XX:XX:XX (try 1/3)
Apr 03 22:31:29 [kernel] [ 2054.156499] wlan1: RX AssocResp from cc:5d:XX:XX:XX:XX (capab=0x411 status=0 aid=1)
Apr 03 22:31:29 [kernel] [ 2054.156508] wlan1: associated
Apr 03 22:31:29 [kernel] [ 2054.185921] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption
Apr 03 22:31:29 [kernel] [ 2054.186007] rtlwifi:rtl_op_set_key():<0-0> not open hw encryption

_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Apr 04, 2012 12:46 am    Post subject: Reply with quote

Pallokala,

This might not apply to your card, but I had the same exact situation that you're exhibiting. This is the card I'm using: ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter [Ralink RT3072]
Although a cd was included with linux source, the driver is now included in the kernel. So I enabled it, setup wpa_supplicant and the appropriate configuration files.

When I connected I experienced the same situation - authenticating and deauthenticating. I went back to where I unpacked the source and checked the README file. There was a line that read IMPORTANT copy RT2870STA.dat to /etc/Wireless/RT2870STA. I created the directory, copied the file and that took care of the problem.

In short is there a file that's required for your card?

Hope this helps :wink:
Back to top
View user's profile Send private message
Pallokala
n00b
n00b


Joined: 09 Apr 2006
Posts: 47
Location: Finland

PostPosted: Thu Apr 05, 2012 8:07 pm    Post subject: Reply with quote

Thank you for the suggestion. I double checked the official drivers from Realtek and those didn't have any extra instructions. Also the firmware from linux-firmware is the same as the files from realteks driver package.

Well my problem became more interesting now that I actually managed to create kernel oops with this driver: https://bugzilla.kernel.org/show_bug.cgi?id=43044 .
I have some strange ideas to try out tomorrowish.
_________________
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"
Back to top
View user's profile Send private message
Misfit138
n00b
n00b


Joined: 25 Aug 2007
Posts: 9

PostPosted: Fri Jun 15, 2012 1:53 am    Post subject: Reply with quote

I can confirm nearly identical behavior with the rtl8192cu mainline driver and Edimax ew-7811un wireless adapter. I've been forced to use the downloadable Realtek drivers, which I got to compile following this tip on the Ubuntu bugtracker.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum