Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apache-2.4 complains about "User" entry
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3843
Location: Hamburg

PostPosted: Sun Apr 01, 2012 3:17 pm    Post subject: apache-2.4 complains about "User" entry Reply with quote

Code:
n22_uml ~ # /etc/init.d/apache2 start
 * Caching service dependencies ...                                                                     [ ok ]
 * apache2 has detected an error in your setup:
AH00526: Syntax error on line 149 of /etc/apache2/httpd.conf:
Invalid command 'User', perhaps misspelled or defined by a module not included in the server configuration
 * ERROR: apache2 failed to start
:-(
Back to top
View user's profile Send private message
philly_idle
n00b
n00b


Joined: 01 Apr 2012
Posts: 7

PostPosted: Sun Apr 01, 2012 3:35 pm    Post subject: Reply with quote

You need to load

Code:
LoadModule unixd_module modules/mod_unixd.so
LoadModule access_compat_module modules/mod_access_compat.so


to account for the first two error messages. The next one is about SSLMutex not existing anymore, but I'm working on it.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3843
Location: Hamburg

PostPosted: Sun Apr 01, 2012 4:09 pm    Post subject: Reply with quote

A great , with the 2 lines of you now I'm here :
Code:
n22_uml ~ # /etc/init.d/apache2 start
 * apache2 has detected an error in your setup:
[Sun Apr 01 18:08:30.281297 2012] [core:warn] [pid 992:tid 1078466160] AH00117: Ignoring deprecated use of DefaultType in line 8 of /etc/apache2/modules.d/00_mod_mime.conf.
AH00526: Syntax error on line 54 of /etc/apache2/modules.d/40_mod_ssl.conf:
SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?).
 * ERROR: apache2 failed to start
Back to top
View user's profile Send private message
JC99
l33t
l33t


Joined: 06 Aug 2003
Posts: 782
Location: Toronto

PostPosted: Mon Apr 02, 2012 2:54 am    Post subject: Reply with quote

I'm running into the same problem
Back to top
View user's profile Send private message
philly_idle
n00b
n00b


Joined: 01 Apr 2012
Posts: 7

PostPosted: Mon Apr 02, 2012 8:46 am    Post subject: Reply with quote

I think I almost figured it out. The problem is that the config files are obviously taken from apache-2.2. That is most visible by the use of SSLMutex, which simply doesn't exist in 2.4 anymore (see below).

You need to add to httpd.conf:
Code:
LoadModule unixd_module modules/mod_unixd.so
LoadModule access_compat_module modules/mod_access_compat.so


Also, I added to following to the <IfDefine SSL> section
Code:

LoadModule socache_shmcb_module modules/mod_socache_shmcb.so


Please note that you need to compile Apache with APACHE2_MODULES="access compat socache_shmcb".

Then in modules.d/40_mod_ssl.conf you need to replace SSLMutex file:/var/run/ssl_mutex with:
Code:
Mutex default ssl-cache

According to apache documentation, this should work:
Code:
Mutex file:/var/run/ssl_mutex ssl-cache

However, there appears to be a bug of some sort, resulting in an error when using the file: mutex. A similar bug existed some time ago on windows with apache-2.2.

Now, Apache should at least start but complaining about some Internal Server Error.

That's all i know right now, I never really concerned myself with apache that closely. I only figured that out in the last 24h or so.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3843
Location: Hamburg

PostPosted: Mon Apr 02, 2012 9:48 am    Post subject: Reply with quote

Code:
mkdir /var/run/ssl_mutex
helps
Back to top
View user's profile Send private message
philly_idle
n00b
n00b


Joined: 01 Apr 2012
Posts: 7

PostPosted: Mon Apr 02, 2012 10:06 am    Post subject: Reply with quote

toralf wrote:
Code:
mkdir /var/run/ssl_mutex
helps

Omg...thx.

I still got an internal server error. Does it work for you?
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3843
Location: Hamburg

PostPosted: Mon Apr 02, 2012 11:18 am    Post subject: Reply with quote

philly_idle wrote:
I still got an internal server error. Does it work for you?
Oh yes, FWIW I used "Mutex default ssl-cache".
Back to top
View user's profile Send private message
philly_idle
n00b
n00b


Joined: 01 Apr 2012
Posts: 7

PostPosted: Mon Apr 02, 2012 12:04 pm    Post subject: Reply with quote

That wasn't the problem. mod_auth{z,n}_core weren't loaded; now it works.
I'm basically building my configuration from scratch now. For those who are interested, i checked out the apache svn:
Code:
svn checkout http://svn.apache.org/repos/asf/httpd/httpd/branches/2.4.x httpd-2.4.x

using the examples at docs/conf as reference.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3843
Location: Hamburg

PostPosted: Mon Apr 02, 2012 12:18 pm    Post subject: Reply with quote

Yep, these lines were missing :
Code:
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_core_module modules/mod_authz_core.so
Back to top
View user's profile Send private message
JC99
l33t
l33t


Joined: 06 Aug 2003
Posts: 782
Location: Toronto

PostPosted: Mon Apr 02, 2012 4:50 pm    Post subject: Reply with quote

It's working, thanks! :)
Back to top
View user's profile Send private message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 93

PostPosted: Wed Apr 04, 2012 11:47 pm    Post subject: Reply with quote

this should go into the ebuild as a notice/default option
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3843
Location: Hamburg

PostPosted: Thu Apr 05, 2012 7:52 am    Post subject: Reply with quote

d-fens wrote:
this should go into the ebuild as a notice/default option
ofc, file a bug for that.
Back to top
View user's profile Send private message
Wuodan
n00b
n00b


Joined: 21 May 2012
Posts: 23

PostPosted: Mon Jul 23, 2012 1:20 pm    Post subject: Reply with quote

There is a bug for this:
www-servers/apache 2.4.1-r2 will not start with default conf

Thanks for all your input, my fix there should cover them.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum