Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201203-21 ] Asterisk: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Mar 28, 2012 12:26 pm    Post subject: [ GLSA 201203-21 ] Asterisk: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Asterisk: Multiple vulnerabilities (GLSA 201203-21)
Severity: high
Exploitable: remote
Date: March 28, 2012
Bug(s): #408431
ID: 201203-21

Synopsis

Multiple vulnerabilities have been found in Asterisk, the worst of
which may allow execution of arbitrary code.


Background

Asterisk is an open source telephony engine and toolkit.

Affected Packages

Package: net-misc/asterisk
Vulnerable: < 1.8.10.1
Unaffected: >= 1.8.10.1
Architectures: All supported architectures


Description

Two vulnerabilities have been found in Asterisk:
  • The "milliwatt_generate()" function in app_milliwatt.c is vulnerable
    to a stack overrun (AST-2012-002).
  • The "ast_parse_digest()" function in utils.c is vulnerable to a
    stack-based buffer overflow (AST-2012-003).


Impact

A remote unauthenticated attacker could execute arbitrary code or cause
a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Asterisk users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.10.1"
   


References


AST-2012-002


AST-2012-003

CVE-2012-1183
CVE-2012-1184
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum