Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Avidemux 2.6.x fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Eichhorn
n00b
n00b


Joined: 08 Jun 2011
Posts: 16

PostPosted: Sat May 02, 2015 9:19 am    Post subject: [Solved] Avidemux 2.6.x fails to compile Reply with quote

Good day,

I was trying to compile avidemux and got stuck on 2.6.8, 2.6.7 and 2.6.6 with the same error considering ffmpeg.
Here's the relevant part:
Code:
awk '/^@(verbatim)?include/ { printf "doc/fate.txt: doc/%s\n", $2 }' </var/tmp/portage/media-libs/avidemux-core-2.6.8/work/avidemux_2.6.8/buildCore/ffmpeg/source/doc/fate.texi >doc/fate.txt.d
makeinfo --force --no-headers -o doc/fate.txt /var/tmp/portage/media-libs/avidemux-core-2.6.8/work/avidemux_2.6.8/buildCore/ffmpeg/source/doc/fate.texi 2>/dev/null
make[3]: Leaving directory '/var/tmp/portage/media-libs/avidemux-core-2.6.8/work/avidemux_2.6.8/buildCore/ffmpeg/build'
CMakeFiles/libavcodec.dir/build.make:71: recipe for target 'ffmpeg/build/ffmpeg' failed
make[2]: *** [ffmpeg/build/ffmpeg] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-libs/avidemux-core-2.6.8/work/avidemux_2.6.8/buildCore'
CMakeFiles/Makefile2:94: recipe for target 'CMakeFiles/libavcodec.dir/all' failed
make[1]: *** [CMakeFiles/libavcodec.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-libs/avidemux-core-2.6.8/work/avidemux_2.6.8/buildCore'
Makefile:119: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: media-libs/avidemux-core-2.6.8::gentoo failed (compile phase):
 *   emake failed


Here's the whole log: https://bpaste.net/show/31d3bc32fc75

emerge --info '=media-libs/avidemux-core-2.6.8::gentoo':
Code:
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.2, glibc-2.20-r2, 4.0.1-celestia x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.0.1-celestia-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:    16341024 total,  12663860 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 02 May 2015 06:00:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.25 p1.1) 2.25
app-shells/bash:          4.3_p33-r2::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.3.5-r1::gentoo, 3.4.3::gentoo
dev-util/cmake:           3.2.1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.15::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25::gentoo
sys-devel/gcc:            4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.0::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

aidstu
    location: /var/lib/layman/aidstu
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7-avx -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes aes-ni alsa amd64 avx berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg lcms ldap libnotify libsamplerate mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit popcnt ppds qt3support qt4 readline sdl session spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vdpau vim vorbis vpx wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes aes-ni avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

emerge -pqv '=media-libs/avidemux-core-2.6.8::gentoo':
Code:
[ebuild  N    ] media-libs/avidemux-core-2.6.8  USE="nls sdl vdpau xv -debug (-system-ffmpeg) -vaapi" VIDEO_CARDS="-fglrx"


I've also tried with libav also and got the same error if I recall correctly.

There was a couple of threads on avidemux.org, and one of the solutions was to delete a line in admFFmpegBuild.cmake, but if I'm not mistaken it's extracted from the tarball during the compilation process. Can I simply unpack it, make the required changes and then repack it again or is there some kind of integrity check in place?
Here's the thread: http://avidemux.org/smuf/index.php?topic=16379.15


Last edited by Eichhorn on Fri May 08, 2015 10:24 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5100
Location: Saint Amant, Acadiana

PostPosted: Sat May 02, 2015 9:27 am    Post subject: Reply with quote

You can use ebuild to break emerge process down into steps. man ebuild
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Eichhorn
n00b
n00b


Joined: 08 Jun 2011
Posts: 16

PostPosted: Sat May 02, 2015 11:21 am    Post subject: Reply with quote

Most grateful, Jaglover. Everything works now.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2517
Location: Germany

PostPosted: Sat May 02, 2015 11:40 am    Post subject: Reply with quote

Probably is not compatible with =dev-util/cmake-3.2.1
Try it with =dev-util/cmake-3.1.0
See Bug 546516
Back to top
View user's profile Send private message
Eichhorn
n00b
n00b


Joined: 08 Jun 2011
Posts: 16

PostPosted: Fri May 08, 2015 10:24 am    Post subject: Reply with quote

Thank you, Josef.95. That solved the problem too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum