Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't emerge anything
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
scarecrowMTK
n00b
n00b


Joined: 17 Nov 2013
Posts: 3
Location: Monza

PostPosted: Wed Nov 20, 2013 4:26 pm    Post subject: Can't emerge anything Reply with quote

Hi, I dont know if this is the correct section,
but on my Gentoo2012 I cant emerge the most of the applications, it says

Code:


# emerge wine
!!! Repository 'gnome' is missing masters attribute in '/var/lib/layman/gnome/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'local' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies                   e * ERROR: www-client/seamonkey-2.14.1::gentoo failed (depend phase):
 *   python.eclass can not be used with python-r1 suite eclasses.
 *
 * Call stack:
 *                 ebuild.sh, line 545:  Called source '/usr/portage/www-client/seamonkey/seamonkey-2.14.1.ebuild'
 *   seamonkey-2.14.1.ebuild, line  29:  Called inherit 'check-reqs' 'flag-o-matic' 'toolchain-funcs' 'eutils' 'mozconfig-3' 'multilib' 'pax-utils' 'fdo-mime' 'autotools' 'mozextension' 'python' 'nsplugins' 'mozlinguas'
 *                 ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/python.eclass'
 *                 ebuild.sh, line  80:  Called source '/usr/portage/eclass/python.eclass'
 *             python.eclass, line  13:  Called die
 * The specific snippet of code:
 *      die 'python.eclass can not be used with python-r1 suite eclasses.'
 *
 * If you need support, post the output of `emerge --info '=www-client/seamonkey-2.14.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/seamonkey-2.14.1::gentoo'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/www-client/seamonkey-2.14.1/work/seamonkey-2.14.1'
     m * ERROR: sys-auth/polkit-kde-agent-0.99.0::gentoo failed (depend phase):
 *   EAPI=3 is not supported
 *
 * Call stack:
 *                        ebuild.sh, line 545:  Called source '/usr/portage/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.0.ebuild'
 *   polkit-kde-agent-0.99.0.ebuild, line  18:  Called inherit 'kde4-base'
 *                        ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/kde4-base.eclass'
 *                        ebuild.sh, line  80:  Called source '/usr/portage/eclass/kde4-base.eclass'
 *                 kde4-base.eclass, line  37:  Called inherit 'kde4-functions' 'toolchain-funcs' 'fdo-mime' 'flag-o-matic' 'gnome2-utils' 'base' 'virtualx' 'versionator' 'eutils' 'multilib'
 *                        ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/kde4-functions.eclass'
 *                        ebuild.sh, line  80:  Called source '/usr/portage/eclass/kde4-functions.eclass'
 *            kde4-functions.eclass, line  23:  Called die
 * The specific snippet of code:
 *      *) die "EAPI=${EAPI} is not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=sys-auth/polkit-kde-agent-0.99.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-auth/polkit-kde-agent-0.99.0::gentoo'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/sys-auth/polkit-kde-agent-0.99.0/work/polkit-kde-agent-0.99.0'
                 * ERROR: www-client/firefox-17.0.1::gentoo failed (depend phase):
 *   python.eclass can not be used with python-r1 suite eclasses.
 *
 * Call stack:
 *               ebuild.sh, line 545:  Called source '/usr/portage/www-client/firefox/firefox-17.0.1.ebuild'
 *   firefox-17.0.1.ebuild, line  33:  Called inherit 'check-reqs' 'flag-o-matic' 'toolchain-funcs' 'eutils' 'gnome2-utils' 'mozconfig-3' 'multilib' 'pax-utils' 'fdo-mime' 'autotools' 'python' 'virtualx' 'nsplugins' 'mozlinguas'
 *               ebuild.sh, line 277:  Called __qa_source '/usr/portage/eclass/python.eclass'
 *               ebuild.sh, line  80:  Called source '/usr/portage/eclass/python.eclass'
 *           python.eclass, line  13:  Called die
 * The specific snippet of code:
 *      die 'python.eclass can not be used with python-r1 suite eclasses.'
 *
 * If you need support, post the output of `emerge --info '=www-client/firefox-17.0.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/firefox-17.0.1::gentoo'`.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/www-client/firefox-17.0.1/work/firefox-17.0.1'
                       ... done!         

!!! All ebuilds that could satisfy "wine" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-emulation/wine-9999::gentoo (masked by: test in RESTRICT, missing keyword)
- app-emulation/wine-1.7.4::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.7.3::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.7.0::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.6::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.31::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.30::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.29::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.28::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.27::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.26::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.25::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.24::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.23-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.22::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.21::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.20::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.19::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.18::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.17::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.16-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.15-r2::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.14-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.13-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.12-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.11-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.10-r1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.9::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.8::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.7::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.6::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.5::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.4::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.3::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.2::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.5.0::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.4.1::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.4::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.3.28::gentoo (masked by: test in RESTRICT)
- app-emulation/wine-1.2.3::gentoo (masked by: test in RESTRICT)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I installed gentoo from the Gentoo-20121221-LiveDVD
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1404

PostPosted: Wed Nov 20, 2013 4:56 pm    Post subject: Reply with quote

Try:
Code:
# emerge --sync

Post output
Code:
emerge --info
for futher help.
Back to top
View user's profile Send private message
scarecrowMTK
n00b
n00b


Joined: 17 Nov 2013
Posts: 3
Location: Monza

PostPosted: Wed Nov 20, 2013 5:11 pm    Post subject: Reply with quote

emerge --info output
Code:

!!! Repository 'gnome' is missing masters attribute in '/var/lib/layman/gnome/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'local' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:

        default/linux/amd64/13.0/desktop

You may use the following command to upgrade:

        eselect profile set default/linux/amd64/13.0/desktop

!!! Repository 'gnome' is missing masters attribute in '/var/lib/layman/gnome/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'local' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
Portage 2.2.7 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.16.0, 3.6.8-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.6.8-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:     8146392 total,   4981812 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 20 Nov 2013 16:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p39
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.10.2
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.5
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 gnome mpd local
ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA @BINARY-REDISTRIBUTABLE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/gnome /var/lib/layman/mpd /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac accessibility acl acpi alsa amd64 atm avahi berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode exif fam fbcondecor firefox flac fortran gdbm gif gnome gnome-keyring gpm gtk iconv ipv6 jpeg kde lcms ldap libnotify livecd loop-aes mad mmx mng modules mpeg mudflap multilib nautilus ncurses nls nouveau nptl ogg opengl openmp pam pango pcre pdf png policykit portaudio ppds qt3support qt4 readline sdl semantic-desktop session socks5 spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vino vorbis wxwidgets xcb xml xv zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics virtualbox" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="af ar as ast az be bg bn bo br brx bs ca ca@valencia ca_XV cs csb cy da de dgo dz el en en_GB en_ZA eo es et eu fa fi fo fr fy ga gd gl gu gu_IN ha he hi hr hsb hu ia id is it ja ka kk km kn kn_IN ko kok ks ku lb lo lt lv mai mi mk ml mn mni mr ms mt my nb nds ne nl nn nr nso oc om or pa pa_IN pl pt pt_BR ro ru rw sa_IN sat sd se sh si sk sl sq sr ss st sv sw sw_TZ ta ta_IN te tg th tn tr ts tt ug uk uz ve ven vi wa xh zh_CN zh_HK zh_TW zu" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="i915 i965 r100 r200 r300 r600 qxl virtualbox nouveau glint intel mach64 mga neomagic nv r128 radeon savage tdfx trident vesa via vmware cirrus ast chips i128 imstt s3virge tseng v4l vermilion" XFCE_PLUGINS="menu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

Gentoo-20121221 / #

Back to top
View user's profile Send private message
olek
Apprentice
Apprentice


Joined: 22 Oct 2011
Posts: 173

PostPosted: Wed Nov 20, 2013 6:14 pm    Post subject: Reply with quote

you could start to follow what portage is telling you

Code:

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Code:

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:

        default/linux/amd64/13.0/desktop

You may use the following command to upgrade:

        eselect profile set default/linux/amd64/13.0/desktop

_________________
https://plaintext.blog
Back to top
View user's profile Send private message
scarecrowMTK
n00b
n00b


Joined: 17 Nov 2013
Posts: 3
Location: Monza

PostPosted: Wed Nov 20, 2013 7:57 pm    Post subject: Reply with quote

I will get another distro...javascript:emoticon(':?')
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum