Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge of dev-util/kbuild-0.1.9998_pre20110817 failed
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 26 Jun 2002
Posts: 35

PostPosted: Sat Mar 17, 2012 3:12 pm    Post subject: emerge of dev-util/kbuild-0.1.9998_pre20110817 failed Reply with quote

I'm having some issues emerging kbuild on amd64. I keep getting a pretty silly error: "gcc: argument to '-o' is missing". I've tried install subversion, as per a previous kbuild emerge issue, that I found, on the board.

Here is 'emerge --info':
Portage (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2 x86_64)
                        System Settings
System uname: Linux-3.2.1-gentoo-r2-x86_64-Intel-R-_Core-TM-_i5-2400_CPU_@_3.10GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 17 Mar 2012 13:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs distcc distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl aes-ni amd64 apng avx berkdb bzip2 caps cli cracklib crypt cxx dbus dlz dri drm fortran gdbm gpm gtk iconv ipv6 jpeg jpeg2k kerberos ldap mmx modules mudflap multilib ncurses nptl nptlonly openmp pam pcre pppd readline readlne session sna sse sse2 sse3 sse4_1 ssl ssse3 sysfs tcpd threads tiff unicode vim-syntax winbind xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Here is 'emerge -pqv':
[ebuild  N    ] dev-util/kbuild-0.1.9998_pre20110817

And, the build log is on pastebin, at

Thanks for any help!
- Alex
Back to top
View user's profile Send private message

Joined: 24 Mar 2012
Posts: 1

PostPosted: Sat Mar 24, 2012 3:46 am    Post subject: distcc is the problem Reply with quote

I don't know the why, but i know the who. I had the same problem, googled it and your post was the only thing i could find. i saw in your log that you also had distcc enabled, so I tried without and it worked with no issues. disable distcc from features and try again.

**UPDATE** careful here, i found the next two packages compile fine with distcc re-enabled, but not app-emulation/virtualbox-4.1.8. Also, remember when removing distcc from features to adjust your makeopts specifically the -jX setting. Pretty sure that's what just cause my system to melt down just now. Trying again with a sane -j setting.
Back to top
View user's profile Send private message

Joined: 26 Jun 2002
Posts: 35

PostPosted: Sat Mar 24, 2012 3:51 pm    Post subject: Reply with quote

Thanks, much for your help. I discovered this, myself, late last night, and it now compiles fine.

What's particularly odd is that this host is my distcc helper, only, for my other hosts. It only distccs to itself!

Anyway, much appreciated.

- Alex
Back to top
View user's profile Send private message

Joined: 24 Mar 2012
Posts: 46

PostPosted: Tue Feb 19, 2013 7:44 pm    Post subject: Reply with quote

Hopefully it is not too late to chime in here. I discovered that I had the same problem here today, with the help of this thread. This was on a distcc helper box with no other helpers specified. Upgraded my system and all installed ok except app-emulation/virtualbox ver 4.1.24. Repeatedly failed with the following error:

kmk: x86_64-pc-linux-gnu-gcc: argument to '-o' is missing

Disabled FEATURES="distcc" in /etc/portage/make.conf then I was able to complete the upgrade including virtualbox without any further hitches. So my question is: Is there a better long term solution, rather than having to disable distcc whenever a package fails to compile? Is there possibly something wrong with the way distcc is configured? I just recently started using distcc and configured according to the gentoo docs.

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum