Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome3.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
JR41
n00b
n00b


Joined: 16 Mar 2012
Posts: 6

PostPosted: Fri Mar 16, 2012 1:01 pm    Post subject: Gnome3.2 Reply with quote

Hi, I'm new to Gentoo (I'm moving from Fedora).

Just finshed my first install on X86_64, Kernel 3.2.1. I have installed Gnome 2.3 (emerge gnome), however I wish to install Gnome3, and could not find a way to emerge/migrate the the Gnome2 desktop to Gnome3.

Any help will be appreciated?

Thank you
Back to top
View user's profile Send private message
jtshs256
n00b
n00b


Joined: 25 Mar 2011
Posts: 17

PostPosted: Fri Mar 16, 2012 1:17 pm    Post subject: Reply with quote

First edit your make.conf:
Code:
ACCEPT_KEYWORDS="~amd64"

Then have a full upgrade:
Code:
emerge -avuDN world

And have a look at the official GNOME 3.2 Upgrade Guide:
http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-3.2-upgrade.xml
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Fri Mar 16, 2012 1:28 pm    Post subject: Reply with quote

jtshs256 wrote:
First edit your make.conf:
Code:
ACCEPT_KEYWORDS="~amd64"

PLEASE - NO! That's dangerous....

There is a reason why there is a sticky topic in the Desktop Environments-forum:
https://forums.gentoo.org/viewtopic-t-903280.html
Back to top
View user's profile Send private message
JR41
n00b
n00b


Joined: 16 Mar 2012
Posts: 6

PostPosted: Sun Mar 18, 2012 9:47 am    Post subject: Gnome3 Reply with quote

Thank you!

However why is the ~amd64 Keyword dangerous?
Back to top
View user's profile Send private message
Splink
Apprentice
Apprentice


Joined: 09 Feb 2005
Posts: 295

PostPosted: Sun Mar 18, 2012 9:54 am    Post subject: Reply with quote

the ~ marks packages that are not in mainstream release and are considered beta or still to be in testing or pre-production. So there may be a few packages in there which have not quite completed full testing or may have a few bugs still.

It is your own risk if you want to do that really - although many people do to get access to the latest things within the portage tree. There may be issues with other packages on the system which rely on other versions of gnome, and not supported on 3.2 on an ~amd64 keyword platform.

Best thing to do is if you have enough time, and the knowledge to fix your system is to just try it and see if it works.

Be aware that emerge -uaDv world updates may break quite a few things and you may need to install revdep-rebuild to sort out some of your backwards compatible application packages missing some dependencies.
_________________
It said "Requires Windows XP or better"
So I installed gentoo.
Back to top
View user's profile Send private message
JR41
n00b
n00b


Joined: 16 Mar 2012
Posts: 6

PostPosted: Sun Mar 18, 2012 10:02 am    Post subject: Gnome3.2 Reply with quote

Thank You! Now a few things make more sense!

On choosing my desktop environment, I "emerge gnome" , however I prefere Gnome3,2 after using it for a year on Fedora, 15&16.

Will there become an "emerge Gnome3" (4exmpl), At some later stage?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Sun Mar 18, 2012 10:06 am    Post subject: Re: Gnome3 Reply with quote

JR41 wrote:
However why is the ~amd64 Keyword dangerous?

It's not the keyword that is dangerous, it's when you set it globally. If you don't have the experience you should stick to stable:
ACCEPT_KEYWORDS="amd64"
If you think you need a package that is not yet stable in Gentoo, as gnome3, you should use /etc/portage/package.accept_keywords.
http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?part=3&chap=3
Also read 3.a, especially the warnings on stability and how to go back to stable branch!
Back to top
View user's profile Send private message
JR41
n00b
n00b


Joined: 16 Mar 2012
Posts: 6

PostPosted: Sun Mar 18, 2012 10:35 am    Post subject: Gnome3.2 Reply with quote

Thank You! :D
Back to top
View user's profile Send private message
Splink
Apprentice
Apprentice


Joined: 09 Feb 2005
Posts: 295

PostPosted: Sun Mar 18, 2012 10:44 am    Post subject: Reply with quote

Usage of accept_keywords is a good best practice and I suggest using this.

As for emerging gnome - if you just emerge gnome and you have set the keywords right then you will just pull in the latest one which is gnome-3.2.1 in my ports tree at the moment.

The best thing to do is read the masking documentation and then set your keywords for different packages in these locations, instead of cluttering up and complicating your make.conf.

make.conf is good for thing like alsa, and cups, and opengl etc because you have all of the hardware supported for that. But some applications have large package use options like mysql which could have a big big effect on your system if you have a shared mysql setup where some applications rely on certain versions of mysql.

Particularly coming from gnome 2 to version 3 where compiz was concerned, compiz has been left behind now and not being developed for 3, but it was part of my USE flags on make.conf, which led to some confusion around compiling some compiz settings in parts of gnome which were not supported in v3.

Just have a read and if there is anything you dont quite understand then im sure that some of us will help you out.
_________________
It said "Requires Windows XP or better"
So I installed gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum