Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why does my system want ~amd64 ncurses? [SOLVED?]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
freke
Apprentice
Apprentice


Joined: 23 Jan 2003
Posts: 276

PostPosted: Wed Aug 26, 2015 3:24 pm    Post subject: Why does my system want ~amd64 ncurses? [SOLVED?] Reply with quote

Doing my daily update I ran into this:
Code:
ns plugins # emerge -uvaDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ~] sys-libs/ncurses-5.9-r100:5::gentoo [5.9-r3:0::gentoo] USE="cxx unicode -ada -debug -gpm -profile -tinfo -trace" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-libs/openssl-1.0.2d::gentoo [1.0.1p::gentoo] USE="asm%* zlib -bindist -gmp -kerberos -rfc3779 -sctp% -static-libs {-test} -tls-heartbeat -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5172 KiB
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r100)

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 5172 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r3:0/0::gentoo, installed) pulled in by
    >=sys-libs/ncurses-5.2 required by (sys-kernel/gentoo-sources-4.0.5:4.0.5/4.0.5::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)
    sys-libs/ncurses:0= required by (app-crypt/pinentry-0.9.0:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-shells/bash-4.3_p39:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7[unicode?] (>=sys-libs/ncurses-5.7-r7[unicode]) required by (sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo, installed)

  (sys-libs/ncurses-5.9-r100:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/texinfo-5.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5 required by (sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
    sys-libs/ncurses:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-libs/ncurses:=[abi_x86_64(-)]) required by (dev-db/mariadb-10.0.21:0/18::gentoo, installed)
    >=sys-libs/ncurses-5.9-r1[unicode?] (>=sys-libs/ncurses-5.9-r1[unicode]) required by (app-editors/nano-2.3.6:0/0::gentoo, installed)
    sys-libs/ncurses required by (net-mail/mailutils-2.99.98:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5[unicode?] (>=sys-libs/ncurses-5.2-r5[unicode]) required by (dev-util/dialog-1.2.20150528:0/0::gentoo, installed)
    sys-libs/ncurses:5/5=[abi_x86_64(-)] required by (dev-db/mariadb-10.0.21:0/18::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-db/mariadb-10.0.21::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/ncurses-5.9-r100 ~amd64

Would you like to add these changes to your config files? [Yes/No]


I'm not really a fan of running ~amd64-keyword on my dns/dhcp/mail-server and I don't really get the emerge-ouput :S

The only ~amd64-packages on my system is:
Code:
=www-servers/apache-2.4.12-r1
=app-admin/apache-tools-2.4.12

=app-forensics/unhide-20130526

=mail-filter/opendmarc-1.3.0
=mail-filter/pypolicyd-spf-1.3.1


Neither of which is listed in the above.


Last edited by freke on Thu Aug 27, 2015 4:38 pm; edited 2 times in total
Back to top
View user's profile Send private message
leifbk
Guru
Guru


Joined: 05 Jan 2004
Posts: 344
Location: Bærum, Norway

PostPosted: Wed Aug 26, 2015 3:56 pm    Post subject: Reply with quote

Same here. I went over to bugs.gentoo.org to see if there was any new issues with ncurses. There's a couple of issues from this morning, not quite related to this problem, but there's a pungent smell of developer goofup here:

https://bugs.gentoo.org/show_bug.cgi?id=558800
https://bugs.gentoo.org/show_bug.cgi?id=428478
_________________
Grumpy old man
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 205
Location: Northern California

PostPosted: Wed Aug 26, 2015 4:02 pm    Post subject: Reply with quote

Same here.

I found that emerge was also reporting the same wrong change, which still blocked. I needed to add:

=sys-libs/ncurses-6.0

to my package.accept_keywords to allow the update to proceed.

I looked around, but couldn't figure out who was pulling in ncurses-6.
Back to top
View user's profile Send private message
dmoulding
n00b
n00b


Joined: 03 Jun 2014
Posts: 15

PostPosted: Wed Aug 26, 2015 4:15 pm    Post subject: Reply with quote

I ran into the same thing this morning. I'm pretty sure this is a mistake in the portage tree. My advice would be to skip your daily update for today and wait until this is resolved. I've seen this kind of thing in the past. Usually they get resolved pretty quickly (thank you Gentoo devs!)

Try again tomorrow. There's a good chance it may be resolved by then.
Back to top
View user's profile Send private message
GabrielYYZ
n00b
n00b


Joined: 03 May 2012
Posts: 24
Location: Dominican Republic

PostPosted: Wed Aug 26, 2015 4:53 pm    Post subject: Reply with quote

Same here, as well.

See here:

https://bugs.gentoo.org/show_bug.cgi?id=557472
https://github.com/gentoo/gentoo/commit/ec1cb36e722e62cf504f89ffdfc05ce87407ae3d
https://github.com/gentoo/gentoo/commit/bc763694f07e96137c03ff88643c4535ea645250
Back to top
View user's profile Send private message
charles17
Veteran
Veteran


Joined: 02 Mar 2008
Posts: 1695

PostPosted: Wed Aug 26, 2015 5:14 pm    Post subject: Reply with quote

And, https://gitweb.gentoo.org/repo/gentoo.git/commit/sys-libs/ncurses?id=051ad88caa127419c80d473021ab8909a2268789
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 205
Location: Northern California

PostPosted: Wed Aug 26, 2015 5:16 pm    Post subject: Reply with quote

This is typically what happens when the developers make a base-level change on their keyworded systems and don't check it out first on a stable system before plugging the change into the tree.

On the bright side, if you have time to spare, you can go with the change and get a preview of what future breakage, if any, is coming your way when stable is fixed and bumped to support the change.
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 319

PostPosted: Wed Aug 26, 2015 6:27 pm    Post subject: Reply with quote

Same issue here. I wanted to update my system today, so I did this:

Code:
emerge --update --deep --newuse @world  --exclude ncurses
Back to top
View user's profile Send private message
The_Great_Sephiroth
l33t
l33t


Joined: 03 Oct 2014
Posts: 802
Location: Fayetteville, NC, USA

PostPosted: Wed Aug 26, 2015 7:15 pm    Post subject: Testing ncurses required today? Reply with quote

I just did a sync and then tried updating the system set. For some reason, it wants to pull in the unstable version of ncurses. I cannot figure out why. Can somebody help me out here?
Code:

~ $ sudo emerge -avuND --with-bdeps=y --tree @system

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] kde-base/kdebase-startkde-4.11.19:4/4.11::gentoo  USE="wallpapers (-aqua)"
[nomerge       ]  kde-base/plasma-workspace-4.11.19:4/4.11::gentoo  USE="handbook kdepim python qalculate (-aqua) -debug -gps -json" PYTHON_TARGETS="python2_7"
[ebuild     U  ]   dev-libs/libdbusmenu-qt-0.9.3_pre20140619-r1::gentoo [0.9.2::gentoo] USE="qt4%* -debug -doc (-qt5) {-test}" ABI_X86="(64%*) -32% (-x32)" 46 KiB
[nomerge       ] app-cdr/k3b-2.0.3-r2:4::gentoo  USE="dvd encode ffmpeg flac handbook mad mp3 musepack sndfile taglib vcd vorbis (-aqua) -debug -emovix -libav -sox" LINGUAS="-ast -be -bg -bs -ca -ca@valencia -cs -csb -da -de -el -en_GB -eo -es -et -eu -fi -fr -ga -gl -he -hi -hne -hr -hu -is -it -ja -kk -km -ko -ku -lt -lv -mai -mr -ms -nb -nds -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -se -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW"
[ebuild   R    ]  media-video/ffmpeg-2.6.3:0/54.56.56::gentoo  USE="X aac aacplus alsa amr amrenc bzip2 cdio celt encode fontconfig gme gnutls gpl gsm hardcoded-tables iconv iec61883 ieee1394 jack jpeg2k libass libcaca lzma modplug mp3 network openal opengl openssl opus postproc samba sdl speex ssh theora threads truetype twolame v4l vaapi vdpau vorbis vpx wavpack webp x264 x265 xcb xvid zlib (-altivec) (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cpudetection -debug -doc -examples -faac -fdk -flite -frei0r -fribidi -ladspa -librtmp% -libsoxr -libv4l (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-neon) -oss -pic -pulseaudio -quvi -schroedinger -static-libs {-test} -zvbi (-rtmp%)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse4_2 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 0 KiB
[ebuild     U  ]   media-libs/libass-0.12.3:0/5::gentoo [0.11.2:0/5::gentoo] USE="enca fontconfig harfbuzz -static-libs" ABI_X86="(64) -32 (-x32)" 307 KiB
[nomerge       ] net-wireless/iw-3.17::gentoo
[ebuild     U  ]  dev-libs/libnl-3.2.26:3::gentoo [3.2.25:3::gentoo] USE="python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python3_3 -python3_4" 876 KiB
[nomerge       ] net-voip/linphone-3.6.1::gentoo  USE="gtk ipv6 libnotify ncurses nls sqlite ssl upnp video -assistant -doc -gsm-nonstandard -tools" LINGUAS="-cs -de -es -fr -he -hu -it -ja -nl -pl -pt_BR -ru -sr -sv -zh_CN"
[ebuild  NS   ~]  sys-libs/ncurses-5.9-r100:5::gentoo [5.9-r3:0::gentoo] USE="cxx gpm unicode -ada -debug -profile -tinfo -trace" ABI_X86="(64) -32 (-x32)" 0 KiB
[nomerge       ] app-office/kmymoney-4.7.1:4::gentoo  USE="calendar handbook hbci ofx quotes (-aqua) -debug -doc {-test}" LINGUAS="-bs -ca -ca@valencia -cs -da -de -el -en_GB -es -et -eu -fi -fr -gl -hu -it -kk -nds -nl -pl -pt -pt_BR -ro -ru -sv -uk -zh_TW"
[nomerge       ]  dev-perl/Finance-Quote-1.180.0::gentoo
[nomerge       ]   dev-perl/Crypt-SSLeay-0.640.0::gentoo  USE="{-test}"
[nomerge       ]    dev-perl/libwww-perl-6.50.0::gentoo  USE="ssl"
[nomerge       ]     dev-perl/LWP-Protocol-https-6.30.0-r1::gentoo
[nomerge       ]      dev-perl/IO-Socket-SSL-1.967.0::gentoo  USE="idn"
[ebuild     U  ]       dev-perl/Net-SSLeay-1.650.0-r1::gentoo [1.650.0::gentoo] 0 KiB
[ebuild     U  ]        dev-libs/openssl-1.0.2d::gentoo [1.0.1p::gentoo] USE="asm%* bindist gmp tls-heartbeat zlib -kerberos -rfc3779 -sctp% -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5,172 KiB
[nomerge       ] app-office/kmymoney-4.7.1:4::gentoo  USE="calendar handbook hbci ofx quotes (-aqua) -debug -doc {-test}" LINGUAS="-bs -ca -ca@valencia -cs -da -de -el -en_GB -es -et -eu -fi -fr -gl -hu -it -kk -nds -nl -pl -pt -pt_BR -ro -ru -sv -uk -zh_TW"
[nomerge       ]  net-libs/aqbanking-5.0.25::gentoo  USE="ofx -chipcard -debug -doc -examples -gtk"
[nomerge       ]   sys-devel/gettext-0.19.4::gentoo  USE="cxx emacs git ncurses nls openmp -acl -cvs -doc -java -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]    dev-vcs/git-2.4.6::gentoo  USE="blksha1 curl emacs gpg iconv nls pcre perl python threads webdav -cgi -cvs -doc -gnome-keyring -gtk -highlight -mediawiki (-ppcsha1) -subversion {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[nomerge       ]     dev-perl/Authen-SASL-2.160.0-r1::gentoo  USE="kerberos"
[nomerge       ]      dev-perl/GSSAPI-0.280.0-r1::gentoo  USE="{-test}"
[nomerge       ]       virtual/krb5-0-r1::gentoo  ABI_X86="(64) -32 (-x32)"
[nomerge       ]        app-crypt/mit-krb5-1.13.2::gentoo  USE="keyutils pkinit threads -doc -openldap (-selinux) {-test} -xinetd" ABI_X86="(64) -32 (-x32)"
[nomerge       ]         dev-libs/libverto-0.2.5-r1::gentoo  USE="libev threads -glib -libevent -static-libs -tevent" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ]          dev-libs/libev-4.19::gentoo [4.15-r1::gentoo] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 513 KiB
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r100)

Total: 8 packages (6 upgrades, 1 in new slot, 1 reinstall), Size of downloads: 6,911 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r3:0/0::gentoo, installed) pulled in by
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (sys-block/parted-3.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (app-crypt/pinentry-0.9.0:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r1[unicode?] (>=sys-libs/ncurses-5.9-r1[unicode]) required by (app-editors/nano-2.3.6:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (sys-apps/gptfdisk-0.8.10:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_64(-)]) required by (media-libs/aalib-1.4_rc5-r6:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/lame-3.99.5-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (dev-libs/libcdio-0.92:0/15::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (dev-db/unixODBC-2.3.2-r1:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-shells/bash-4.3_p39:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/texinfo-5.2:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_64(-)]) required by (sys-devel/llvm-3.5.0:0/3.5::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7[unicode?] (>=sys-libs/ncurses-5.7-r7[unicode]) required by (sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/alsa-utils-1.0.29:0.9/0.9::gentoo, installed)
    sys-libs/ncurses:0=[unicode] required by (media-video/vlc-2.1.5-r1:0/5-7::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (sys-libs/gpm-1.20.7-r2:0/0::gentoo, installed)

  (sys-libs/ncurses-5.9-r100:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2-r5[unicode?] (>=sys-libs/ncurses-5.2-r5[unicode]) required by (dev-util/dialog-1.2.20150528:0/0::gentoo, installed)
    sys-libs/ncurses required by (net-wireless/wpa_supplicant-2.4-r3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r3 required by (games-board/gnugo-3.9.1-r1:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-editors/emacs-24.5:24/24::gentoo, installed)
    sys-libs/ncurses required by (net-voip/linphone-3.6.1:0/0::gentoo, installed)
    sys-libs/ncurses:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-libs/ncurses:=[abi_x86_64(-)]) required by (dev-db/mariadb-10.0.21:0/18::gentoo, installed)
    sys-libs/ncurses required by (dev-java/libreadline-java-0.8.0-r3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5 required by (sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:5/5=[abi_x86_64(-)] required by (sys-devel/llvm-3.5.0:0/3.5::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (app-misc/screen-4.0.3-r6:0/0::gentoo, installed)
    sys-libs/ncurses:5/5=[abi_x86_64(-)] required by (dev-db/mariadb-10.0.21:0/18::gentoo, installed)
    sys-libs/ncurses:* required by (net-mail/mailutils-2.99.98:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (media-libs/libcaca-0.99_beta18-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (www-client/links-2.8-r1:2/2::gentoo, installed)
    sys-libs/ncurses required by (net-misc/telnet-bsd-1.2-r1:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-libs/slang-2.2.4-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-kernel/gentoo-sources-3.18.16:3.18.16/3.18.16::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (net-ftp/ftp-0.17-r7:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-text/hunspell-1.3.3:0/0::gentoo, installed)
    sys-libs/ncurses[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (sys-libs/ncurses[abi_x86_64(-)]) required by (dev-db/mariadb-10.0.21:0/18::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by sys-devel/llvm-3.5.0::gentoo
# required by media-libs/mesa-10.3.7-r1::gentoo
# required by x11-libs/cairo-1.14.2::gentoo[opengl]
# required by x11-libs/gtk+-2.24.28-r1::gentoo
# required by x11-misc/xscreensaver-5.32::gentoo
# required by kde-apps/kdeartwork-kscreensaver-4.14.3::gentoo[xscreensaver]
# required by kde-apps/kdeartwork-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/ncurses-5.9-r100 ~amd64

It appears as though Linphone wants it, but that makes no sense. Linphone is not being updated, should not be part of the system set, and has been on here for months just fine, and has weathered multiple updates without a hitch.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 3352
Location: Hamburg

PostPosted: Wed Aug 26, 2015 7:33 pm    Post subject: Reply with quote

Try -U too
Back to top
View user's profile Send private message
GabrielYYZ
n00b
n00b


Joined: 03 May 2012
Posts: 24
Location: Dominican Republic

PostPosted: Wed Aug 26, 2015 8:03 pm    Post subject: Reply with quote

See https://forums.gentoo.org/viewtopic-t-1027536.html for a temporary workaround.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 8887
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Aug 26, 2015 8:48 pm    Post subject: Reply with quote

Merged the above three posts.

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
grosgood
n00b
n00b


Joined: 01 Feb 2015
Posts: 18
Location: Brooklyn, NY

PostPosted: Wed Aug 26, 2015 11:45 pm    Post subject: Why does my system want ~amd64 ncurses? Reply with quote

I've read the bug report and looked at the revised ebuilds for packages now slotted for (0). These soft-block any sys-libs/ncurses ebuilds at or below 5.9-r4 so they won't continue (mis)using the old slot, (5). The new ebuild for what is now the libcurses library-only slot (5) has been pegged by fiat at version 5.9-r100, a gentoo version level much higher than r4 and far above the limit imposed by the soft block, or so it seems to me. So it perplexes me, then, why ncurses-6:0, whose ebuild soft-blocks ncurses packages at or below 5.9-r4, should block the slot (5) library-only package pegged at 5.9-r100. Regardless of the combination of fingers and toes I engage for counting, I always seem to get r100 > r4. Perhaps I have not quite yet mastered the interplay among prefix operators, atom versions, gentoo revision numbers, slot and subslot numbers and packages soft-masked for testing. There is a non-Euclidean geometry at work in there somewhere.
For those of us managing boxes pretty conservatively -- not, as a rule, accepting any unstable packages -- it seems that the actual source of emerge's upset is that the soft blocking rules do indeed preclude the only current stable package, sys-libs/ncurses-5.9-r3, for all the other ebuilds are marked unstable across the architectures. So why not a message from emerge of the sort: "There are currently no ebuilds available to satisfy your requirements"? I don't quite follow its choice of error message. There is indeed blocking going on, but it is (should be?) ncurses-5.9-r3 or so it seems to me, and not ncurses-5.9-r100, which appears to have been deliberately versioned so high as to get past the gate imposed by the other ebuilds in their RDEPEND rule settings.
As a practical matter, short term, jagdpanther's suggestion to just exclude ncurses got me though the day (thank you!), and, one hopes, one of the other ncurses ebuilds will stabilize soon and then the whole matter will moot itself. This has been one of the more interesting world updates.
_________________
Garry
Back to top
View user's profile Send private message
grosgood
n00b
n00b


Joined: 01 Feb 2015
Posts: 18
Location: Brooklyn, NY

PostPosted: Thu Aug 27, 2015 3:08 pm    Post subject: Why does my system want ~amd64 ncurses? Reply with quote

FYI

With a sync this AM, new ebuilds have come into addressing #558856: slot move of sys-devel/ncurses from 5 to 0 did not adjust vdb *DEPEND for ncurses atoms w/ subslot deps.

No unusual blocks are occurring; no requirement to accept unstable packages in the offing - this on a wholly stable box where soft-masked packages are not allowed. The condition which the OP observed yesterday, and seen here as well, is not recurring. It is a --quiet-build. Hopefully, others who hit this wall yesterday will have a better time of it on the next update.
_________________
Garry
Back to top
View user's profile Send private message
freke
Apprentice
Apprentice


Joined: 23 Jan 2003
Posts: 276

PostPosted: Thu Aug 27, 2015 4:21 pm    Post subject: Reply with quote

Today's sync seems to have fixed it for me as well (by upgrading in 5.9-r5 and pulling in a slotted 5.9-r99 it seems)...
Back to top
View user's profile Send private message
GabrielYYZ
n00b
n00b


Joined: 03 May 2012
Posts: 24
Location: Dominican Republic

PostPosted: Thu Aug 27, 2015 4:21 pm    Post subject: Re: Why does my system want ~amd64 ncurses? Reply with quote

grosgood wrote:
FYI

With a sync this AM, new ebuilds have come into addressing #558856: slot move of sys-devel/ncurses from 5 to 0 did not adjust vdb *DEPEND for ncurses atoms w/ subslot deps.

No unusual blocks are occurring; no requirement to accept unstable packages in the offing - this on a wholly stable box where soft-masked packages are not allowed. The condition which the OP observed yesterday, and seen here as well, is not recurring. It is a --quiet-build. Hopefully, others who hit this wall yesterday will have a better time of it on the next update.


I can confirm that this worked for me, as well.
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1405
Location: /mnt/Gentoo/Europe

PostPosted: Thu Aug 27, 2015 5:52 pm    Post subject: Reply with quote

What should I do? Looks like should be fine, but is not:

/etc/portage/package.mask
Code:
>www-client/opera-12.16_p1860-r1
>sci-astronomy/stellarium-0.12.4
#>sys-fs/udev-219
#>x11-drivers/nvidia-drivers-355.06
>media-libs/opencv-2.4.9
>sys-libs/ncurses-5.9-r4
=kde-apps/kdenlive-15.08.0
=sys-libs/ncurses-5.9-r101


Code:
#  emerge -uDN world               
Calculating dependencies... done!
[ebuild     U  ] net-firewall/iptables-1.4.21-r3 [1.4.21-r2]
[ebuild  NS   #] sys-libs/ncurses-5.9-r101 [5.9-r4] USE="gpm unicode -tinfo" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] app-arch/snappy-1.1.3 [1.1.2-r1]
[ebuild  NS    ] kde-apps/oxygen-icons-15.04.3 [4.14.3] USE="-debug -sources"
[uninstall     ] kde-apps/oxygen-icons-4.14.3
[blocks b      ] kde-apps/oxygen-icons:4 ("kde-apps/oxygen-icons:4" is blocking kde-apps/oxygen-icons-15.04.3)
[ebuild     U  ] kde-apps/kfmclient-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/knotify-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/libkonq-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdialog-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kcmshell-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kurifilter-plugins-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/zeroconf-ioslave-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kwalletd-15.08.0 [4.14.3-r2]
[ebuild     U  ] kde-apps/ktimezoned-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kpasswdserver-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/knewstuff-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/keditfiletype-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/renamedlg-plugins-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kfile-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kquitapp-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kmimetypefinder-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdebase-desktoptheme-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/attica-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kuiserver-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/ktraderclient-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdebase-menu-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kstart-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kglobalaccel-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kiconfinder-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdebase-menu-icons-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kioclient-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kreadconfig-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdenetwork-filesharing-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/keditbookmarks-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/plasma-apps-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdebase-data-15.08.0 [4.14.3-r1]
[ebuild     U  ] kde-apps/kdesu-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kfind-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/knetattach-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdebugdialog-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/krfb-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/konqueror-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/konq-plugins-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/plasma-runtime-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kimgio-15.08.0 [4.14.3]
[ebuild     U  ] sys-devel/gettext-0.19.5.1-r1 [0.19.5.1]
[ebuild     U  ] kde-apps/solid-runtime-15.08.0 [4.14.3]
[ebuild   R    ] kde-misc/kdiff3-0.9.98-r1  USE="kde* qt4* -qt5*"
[ebuild     U  ] kde-apps/phonon-kde-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/nsplugins-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kget-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kcontrol-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kdontchangethehostname-15.08.0 [4.14.3]
[ebuild     UD ] app-i18n/man-pages-pl-0.6 [20070628-r2]
[ebuild     U  ] kde-apps/drkonqi-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/kopete-15.08.0 [4.14.3-r1]
[ebuild     U  ] media-gfx/imagemagick-6.9.2.0 [6.9.1.8]
[ebuild     U  ] kde-apps/kdepasswd-15.08.0 [4.14.3]
[ebuild     U  ] app-emulation/wine-1.7.50 [1.7.47]
[ebuild     U  ] kde-apps/kdebase-kioslaves-15.08.0 [4.14.3]
[ebuild     U  ] kde-apps/krdc-15.08.0 [4.14.3]
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r101)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r4:0/0::gentoo, installed) pulled in by
    >=sys-libs/ncurses-5.2:0= required by (app-text/aspell-0.60.6.1-r2:0/0::gentoo, installed)
    sys-libs/ncurses:0=[unicode?] (sys-libs/ncurses:0=[unicode]) required by (www-client/lynx-2.8.9_pre6:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (sys-block/parted-3.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (x11-terms/xterm-319:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-devel/gettext-0.19.5.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/lame-3.99.5-r1:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.5:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (dev-libs/libcdio-0.93:0/15::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0=[unicode?] (>=sys-libs/ncurses-5.2-r2:0=[unicode]) required by (sys-apps/util-linux-2.26.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by (sys-apps/texinfo-6.0:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-2.7.10:2.7/2.7::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-3.4.3:3.4/3.4::gentoo, installed)
    sys-libs/ncurses:0=[unicode] required by (media-video/vlc-2.2.1:0/5-8::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by (sys-devel/gdb-7.9.1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (sys-apps/gptfdisk-1.0.0:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (media-video/mplayer-1.2_pre20150730:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-db/mysql-5.6.26-r1:0/18::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_32(-),abi_x86_64(-)]) required by (sys-libs/gpm-1.20.7-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-text/hunspell-1.3.3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/alsa-utils-1.0.29:0.9/0.9::gentoo, installed)
    sys-libs/ncurses:0= required by (app-crypt/pinentry-0.9.5:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.3.1-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_32(-),abi_x86_64(-)]) required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-),abi_x86_64(-)]) required by (sys-devel/llvm-3.6.2:0/3.6::gentoo, installed)
    sys-libs/ncurses:0= required by (dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2 required by (sys-kernel/gentoo-sources-4.1.6:4.1.6/4.1.6::gentoo, installed)
    sys-libs/ncurses:5/5=[unicode] required by (media-video/vlc-2.2.1:0/5-8::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:5/5=[unicode] required by (sys-apps/util-linux-2.26.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5 required by (games-roguelike/nethack-3.4.3-r4:0/0::gentoo, installed)
    sys-libs/ncurses:=[unicode] required by (dev-lang/ghc-7.10.2:0/7.10.2::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)] required by (games-roguelike/adom-1.1.1-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7[unicode?] (>=sys-libs/ncurses-5.7-r7[unicode]) required by (sys-process/procps-3.3.10-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5 required by (sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-479:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-shells/bash-4.3_p42:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:5/5= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:5/5= required by (sys-devel/gdb-7.9.1:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-libs/slang-2.3.0:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (dev-db/unixODBC-2.3.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5[unicode?] (>=sys-libs/ncurses-5.2-r5[unicode]) required by (dev-util/dialog-1.2.20150528:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-7.4.827:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.2:=[abi_x86_32(-),abi_x86_64(-)]) required by (app-emulation/wine-1.7.50:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.9-r3:5/5=[abi_x86_32(-),abi_x86_64(-)] required by (sys-devel/llvm-3.6.2:0/3.6::gentoo, installed)
    sys-libs/ncurses:5/5=[unicode] required by (www-client/lynx-2.8.9_pre6:0/0::gentoo, installed)
    sys-libs/ncurses:5/5=[unicode] required by (dev-lang/ghc-7.10.2:0/7.10.2::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:5/5= required by (x11-terms/xterm-319:0/0::gentoo, installed)
    sys-libs/ncurses:5/5= required by (dev-util/cmake-3.3.1-r1:0/0::gentoo, installed)
    sys-libs/ncurses required by (games-roguelike/stone-soup-0.16.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by (net-wireless/wpa_supplicant-2.4-r4:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:5/5= required by (sys-apps/texinfo-6.0:0/0::gentoo, installed)
    sys-libs/ncurses:5/5= required by (media-video/mplayer-1.2_pre20150730:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r7 required by (app-arch/dpkg-1.18.2:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-video/mplayer-1.2_pre20150730::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#>sys-fs/udev-219
#>x11-drivers/nvidia-drivers-355.06
=sys-libs/ncurses-5.9-r101

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
Back to top
View user's profile Send private message
FroL_Onn
n00b
n00b


Joined: 20 Oct 2013
Posts: 52

PostPosted: Thu Aug 27, 2015 7:16 pm    Post subject: Reply with quote

Xywa wrote:
What should I do? Looks like should be fine, but is not:

/etc/portage/package.mask
Code:
>www-client/opera-12.16_p1860-r1
>sci-astronomy/stellarium-0.12.4
#>sys-fs/udev-219
#>x11-drivers/nvidia-drivers-355.06
>media-libs/opencv-2.4.9
>sys-libs/ncurses-5.9-r4
=kde-apps/kdenlive-15.08.0
=sys-libs/ncurses-5.9-r101



It seems to me you should delete the last line from package.mask. Why did you add it there?
Then try `emerge --sync` and `emerge -NDuqa world` again. All blocks were resolved by devs...

Is it ok now?
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1405
Location: /mnt/Gentoo/Europe

PostPosted: Thu Aug 27, 2015 8:33 pm    Post subject: Reply with quote

FroL_Onn wrote:
It seems to me you should delete the last line from package.mask.


The same:
Code:
The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-video/mplayer-1.2_pre20150730::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#>sys-fs/udev-219
#>x11-drivers/nvidia-drivers-355.06
=sys-libs/ncurses-5.9-r101

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Thu Aug 27, 2015 8:46 pm    Post subject: Reply with quote

Quote:
>sys-libs/ncurses-5.9-r4
Did you delete this, too?
Back to top
View user's profile Send private message
GabrielYYZ
n00b
n00b


Joined: 03 May 2012
Posts: 24
Location: Dominican Republic

PostPosted: Thu Aug 27, 2015 8:47 pm    Post subject: Reply with quote

Xywa wrote:
What should I do? Looks like should be fine, but is not:

/etc/portage/package.mask
Code:
>www-client/opera-12.16_p1860-r1
>sci-astronomy/stellarium-0.12.4
#>sys-fs/udev-219
#>x11-drivers/nvidia-drivers-355.06
>media-libs/opencv-2.4.9
[b]>sys-libs/ncurses-5.9-r4[/b]
=kde-apps/kdenlive-15.08.0
=sys-libs/ncurses-5.9-r101



Remove the bold line and let portage work it out.

EDIT: never mind, it wasn't bold and buffon beat me to it, anyways. :P
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1405
Location: /mnt/Gentoo/Europe

PostPosted: Thu Aug 27, 2015 9:01 pm    Post subject: Reply with quote

Buffoon wrote:
Quote:
>sys-libs/ncurses-5.9-r4
Did you delete this, too?


No, some kind of old staff. Now is OK. Many thanks!
Back to top
View user's profile Send private message
grell
n00b
n00b


Joined: 02 Feb 2006
Posts: 12

PostPosted: Fri Aug 28, 2015 1:02 am    Post subject: Reply with quote

I am still having problems with ncurses. Here is the output of when I do a
Code:
emerge -NDuqa world
:
Quote:
make: *** [install] Error 2
make: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses'
* ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
* S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'

* Messages for package sys-libs/ncurses-6.0-r1:

* ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
* S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'

Here is my package.accept_keywords:
Quote:
# required by duke3d (argument)
=games-fps/duke3d-20040817-r2 **
media-video/miro ~amd64
# required by cs2d (argument)
=games-action/cs2d-0127 ~amd64
~sys-apps/attr-2.4.47
# required by games-fps/rtcw-1.41b::gentoo
# required by rtcw (argument)
=sys-libs/lib-compat-1.4.2-r1 ~amd64
# required by rtcw (argument)
=games-fps/rtcw-1.41b ~amd64
# required by dev-db/mariadb-10.0.21::gentoo
# required by virtual/mysql-5.6-r2::gentoo
# required by dev-qt/qtsql-4.8.6-r1::gentoo
# required by kde-apps/libkdcraw-4.14.3-r1::gentoo
# required by kde-apps/thumbnailers-4.14.3::gentoo
# required by kde-apps/kdegraphics-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
#=sys-libs/ncurses-5.9-r100 ~amd64
#=sys-libs/ncurses-6.0
# required by x11-terms/xterm-314::gentoo
# required by @selected
# required by @world (argument)
#=sys-libs/ncurses-6.0-r1 ~amd64
# required by x11-terms/xterm-314::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/ncurses-6.0-r1 ~amd64
Any more help would be appreciated as I cannot currently use ncurses based programs such as Vim.
Back to top
View user's profile Send private message
grimm26
Guru
Guru


Joined: 23 May 2004
Posts: 313
Location: Chicagoland, IL

PostPosted: Fri Aug 28, 2015 2:23 am    Post subject: Reply with quote

grell wrote:
I am still having problems with ncurses. Here is the output of when I do a
Code:
emerge -NDuqa world
:
Quote:
make: *** [install] Error 2
make: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses'
* ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
* S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'

* Messages for package sys-libs/ncurses-6.0-r1:

* ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
* S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'

Here is my package.accept_keywords:
Quote:
# required by duke3d (argument)
=games-fps/duke3d-20040817-r2 **
media-video/miro ~amd64
# required by cs2d (argument)
=games-action/cs2d-0127 ~amd64
~sys-apps/attr-2.4.47
# required by games-fps/rtcw-1.41b::gentoo
# required by rtcw (argument)
=sys-libs/lib-compat-1.4.2-r1 ~amd64
# required by rtcw (argument)
=games-fps/rtcw-1.41b ~amd64
# required by dev-db/mariadb-10.0.21::gentoo
# required by virtual/mysql-5.6-r2::gentoo
# required by dev-qt/qtsql-4.8.6-r1::gentoo
# required by kde-apps/libkdcraw-4.14.3-r1::gentoo
# required by kde-apps/thumbnailers-4.14.3::gentoo
# required by kde-apps/kdegraphics-meta-4.14.3::gentoo
# required by kde-base/kde-meta-4.14.3::gentoo
# required by @selected
# required by @world (argument)
#=sys-libs/ncurses-5.9-r100 ~amd64
#=sys-libs/ncurses-6.0
# required by x11-terms/xterm-314::gentoo
# required by @selected
# required by @world (argument)
#=sys-libs/ncurses-6.0-r1 ~amd64
# required by x11-terms/xterm-314::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/ncurses-6.0-r1 ~amd64
Any more help would be appreciated as I cannot currently use ncurses based programs such as Vim.


Have you tried it without the
Code:
=sys-libs/ncurses-6.0-r1 ~amd64
in your package.accept_keywords now?
_________________
"Blessed is he who finds happiness in his own foolishness, for he will always be happy".
Back to top
View user's profile Send private message
grell
n00b
n00b


Joined: 02 Feb 2006
Posts: 12

PostPosted: Fri Aug 28, 2015 3:23 am    Post subject: Reply with quote

If I comment out that last line and run
Code:
emerge -NDuqa world
I get this:
Quote:
[ebuild NS ] sys-libs/ncurses-6.0-r1 [6.0]

The following keyword changes are necessary to proceed:
(see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-terms/xterm-314::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/ncurses-6.0-r1 ~amd64

Would you like to add these changes to your config files? [Yes/No]
If I put that line back in and again run
Code:
emerge -NDuqa world
I get this:
Quote:
...
touch pc-files
make[1]: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses/misc'
Makefile:113: recipe for target 'install' failed
make: *** [install] Error 2
make: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses'
* ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
* S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'

* Messages for package sys-libs/ncurses-6.0-r1:

* ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
* S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'
same errors as before.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum