Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Can't install nvidia driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cristi92b
n00b
n00b


Joined: 26 Feb 2012
Posts: 29

PostPosted: Thu Mar 08, 2012 11:39 pm    Post subject: [SOLVED]Can't install nvidia driver Reply with quote

I used nouveau before and now I want to install nvidia driver, but I can not emerge nvidia-drivers, it says that nvidia-drivers are conflicting with rivafb. I reconfigured the kernel enabling only vesa framebuffer but I get the same error.

My graphic card is Nvidia GeForce G210


/var/tmp/portage/x11-drivers/nvidia-drivers-290.10/temp/build.log

Code:

 * Package:    x11-drivers/nvidia-drivers-290.10
 * Repository: gentoo
 * Maintainer: cardoe@gentoo.org jer@gentoo.org,spock@gentoo.org,xarthisius@gentoo.org
 * USE:        acpi amd64 elibc_glibc gtk kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.2.1-gentoo-r2/build
 * Found sources for kernel version:
 *     3.2.1-gentoo-r2
 * Checking for MTRR support ...
 [ ok ]
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-290.10.run to /var/tmp/portage/x11-drivers/nvidia-drivers-290.10/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-290.10/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-290.10/work ...
 * Applying 256.35-unified-arch.patch ...
 [ ok ]
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-290.10/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-290.10/work ...
 * Preparing nvidia module
make -j5 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.2.1-gentoo-r2/build CC=x86_64-pc-linux-gnu-gcc clean module
Your kernel was configured to include rivafb support!

The rivafb driver conflicts with the NVIDIA driver, please
reconfigure your kernel and *disable* rivafb support, then
try installing the NVIDIA kernel module again.

*** Failed rivafb sanity check. Bailing out! ***

make[1]: *** [build-sanity-checks] Error 1
make: *** [module] Error 2
emake failed
 * ERROR: x11-drivers/nvidia-drivers-290.10 failed (compile phase):
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=-m elf_x86_64  IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux       SYSOUT=/lib/modules/3.2.1-gentoo-r2/build CC=x86_64-pc-linux-gnu-gcc clean module
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 3695:  Called linux-mod_src_compile
 *   environment, line 2655:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CROSS_COMPILE=${CHOST}-                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *
 * If you need support, post the output of 'emerge --info =x11-drivers/nvidia-drivers-290.10',
 * the complete build log and the output of 'emerge -pqv =x11-drivers/nvidia-drivers-290.10'.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-290.10/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-290.10/temp/environment'.
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-290.10/work/'



/etc/make.conf

Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="mmx sse sse2 truetype exif udev vesa fbdev xvmc thunar session lock -gnome -kde -minimal -phonon dbus hal startup-notification extra kpathsea jadetex xml python fontconfig -doc -qt4 -cups X a52 aac aalib acpi ao apache2 apm bzip2 cairo cdr ctype cxx debug dts dvd dvdr emacs fastcgi ffmpeg gimp gpm gtk gzip ipv6 java java6 javascript jpeg jpeg2k latex lzma matroska mime mono mp3 mp4 multilib ncurses ogg opengl openal pdf png raw alsa syslog x264 zeroconf"
MAKEOPTS="-j5"
EMERGE_DEFAULT_OPTS="--autounmask-write"
GENTOO_MIRRORS="ftp://de-mirror.org/gentoo/ http://de-mirror.org/gentoo/ rsync://de-mirror.org/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo http://gentoo.mneisen.org/ http://mirror.netcologne.de/gentoo/ ftp://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/ rsync://mirror.opteamax.de/gentoo/ http://mirror.opteamax.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://ftp.join.uni-muenster.de/gentoo/ ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ rsync://ftp-stud.hs-esslingen.de/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.ipv6.uni-muenster.de/pub/linux/distributions/gentoo"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="nvidia"
ACCEPT_LICENSE="Oracle-BCLA-JavaSE"



/etc/X11/xorg.conf
Code:

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "dbe"
   #Load  "dri2"
   Load  "record"
   #Load  "dri"
   Load  "extmod"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "VideoKey"              # <i>
        #Option     "WrappedFB"             # [<bool>]
        #Option     "GLXVBlank"             # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "PageFlip"              # [<bool>]
   Identifier  "GeForce G210"
   Driver      "nvidia"
   VideoRam    65536
   BusID       "PCI:2:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection



EDIT:

I installed nvidia-drivers but now I can't modprobe nvidia.

EDIT:

I rebooted and it works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum