Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
localization on X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
madnbri
n00b
n00b


Joined: 10 Apr 2011
Posts: 69

PostPosted: Mon Mar 05, 2012 6:18 pm    Post subject: localization on X Reply with quote

Hi,
I used the X localization gentoo handbook: http://www.gentoo.org/doc/en/guide-localization.xml#doc_chap5.

My /etc/X11/xorg.conf:
...
Section "InputDevice"
Identifier "Keyboard0"
Driver "evdev"
Option "XkbLayout" "hu"
Option "XkbModel" "pc105"
#MatchIsKeyboard "on" - there is no option like this, I had to remove, because xserver couldn't start
EndSection
...

Code:
# cat /usr/src/linux/.config | grep EVDEV
CONFIG_INPUT_EVDEV=y
CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y


Keyboard layout is not "hu" of course (it is system default: "us"). Can somebody help?

P.S.: I had many problem with localization guide.

Regards,
m
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Mon Mar 05, 2012 8:22 pm    Post subject: Reply with quote

Try replacing "InputDevice" with "InputClass" and then also enable "MatchIsKeyboard".
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
madnbri
n00b
n00b


Joined: 10 Apr 2011
Posts: 69

PostPosted: Mon Mar 05, 2012 8:42 pm    Post subject: Reply with quote

avx wrote:
Try replacing "InputDevice" with "InputClass" and then also enable "MatchIsKeyboard".


Same error. X starting fails.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 778
Location: S.O. France

PostPosted: Mon Mar 05, 2012 9:22 pm    Post subject: Reply with quote

Try removing your xorg.conf and create a file

/etc/X11/xorg.conf.d/11-keymap.conf

Code:
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout"      "hu"
EndSection


If it doesn't work can you post your xorg.conf and xorg.0.log when it fail
Back to top
View user's profile Send private message
madnbri
n00b
n00b


Joined: 10 Apr 2011
Posts: 69

PostPosted: Mon Mar 05, 2012 9:34 pm    Post subject: Reply with quote

sebB wrote:
Try removing your xorg.conf and create a file

/etc/X11/xorg.conf.d/11-keymap.conf

Code:
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout"      "hu"
EndSection


If it doesn't work can you post your xorg.conf and xorg.0.log when it fail


Almost good!
terminal on X hasn't got hu keymap. It looks like xfce4-terminal, but ebuild name is another one. I won't merge another one, because I need small system (for example: gnome-terminal merges the half gnome).
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 778
Location: S.O. France

PostPosted: Mon Mar 05, 2012 10:26 pm    Post subject: Reply with quote

In /etc/conf.d/keymaps try keymap="hu101"
Back to top
View user's profile Send private message
madnbri
n00b
n00b


Joined: 10 Apr 2011
Posts: 69

PostPosted: Mon Mar 05, 2012 11:00 pm    Post subject: Reply with quote

sebB wrote:
In /etc/conf.d/keymaps try keymap="hu101"

Copletely wrong way.
  • This is qwerty variant of keyboard, and I have got qwertz.
  • /etc/conf.d/keymaps is used to set up console, and not terminal on X
Back to top
View user's profile Send private message
madnbri
n00b
n00b


Joined: 10 Apr 2011
Posts: 69

PostPosted: Mon Mar 05, 2012 11:58 pm    Post subject: Reply with quote

This is problem of X terminals.
I tried uxterm and worked fine (I don't like it), installed gnome-terminal and it is customizable (utf-8 is good choice), but not from command line options, only in menu of the window (strange - must do at every start). Is there a way to setup xfce4-terminal to keymapping UTF-8?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum