Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Libvirt 0.9 upgrade - win guest bloccato
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Alakhai
Apprentice
Apprentice


Joined: 16 Oct 2003
Posts: 151

PostPosted: Thu Feb 23, 2012 11:54 am    Post subject: Libvirt 0.9 upgrade - win guest bloccato Reply with quote

Ciao a tutti,
ho montato su un HP proliant DL580G5 gentoo a 64 bit, dotandolo di kernel hardned e di KVM.
E' un paio di anni che lo uso e devo dire che sono rimasto molto colpito dalle performance incredibili della macchina in combinazione con gentoo è veramente una cannonata.
Ci faccio girare diverse istanze di sistemi operativi, alcuni paravirtualizzati, altri non (vedi windows).

Ora quest'ultimo, dall'ultimo upgrade di libvirt ha smesso di partire, c'è qualche esperto che ha voglia di sbattersi per darmi una mano?

Intanto scrivo in dettaglio la problematica:
La macchina guest viene avviata ma andando a sbirciare con VNC nella macchina mi accorgo che rimane bloccata sulla schermata di boot ( per intenderci prima di far partire windows, " booting from hdd...")
_________________
Gentoo Linux 64Bit User
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Thu Feb 23, 2012 3:21 pm    Post subject: Reply with quote

hai provato a disabilitare temporaneamente grsecurity?
Back to top
View user's profile Send private message
Alakhai
Apprentice
Apprentice


Joined: 16 Oct 2003
Posts: 151

PostPosted: Thu Feb 23, 2012 3:27 pm    Post subject: Reply with quote

si la prima cosa che ho fatto è rifare un kernel senza la parte di sicurezza

cmq ho scoperto che creando una nuova macchina virtuale (usando gli stessi dischi) ma emulando il processore con QEMU senza KVM allora parte, ma ovviamente è lento da morire.

carico il modulo KVM-INTEL con i seguenti parametri:
flexpriority1 ept1 unrestricted_guest1 emulate_invalid_guest_state1 vpid1

di seguito le flag del mio processore, prese da /proc/cpuinfo

Code:

processor   : 7
vendor_id   : GenuineIntel
cpu family   : 6
model      : 15
model name   : Intel(R) Xeon(R) CPU           L7345  @ 1.86GHz
stepping   : 11
microcode   : 0xb3
cpu MHz      : 1866.592
cache size   : 4096 KB
physical id   : 2
siblings   : 4
core id      : 3
cpu cores   : 4
apicid      : 11
initial apicid   : 11
fpu      : yes
fpu_exception   : yes
cpuid level   : 10
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx tm2 ssse3 cx16 xtpr pdcm dca lahf_lm dts tpr_shadow vnmi flexpriority
bogomips   : 3733.52
clflush size   : 64
cache_alignment   : 64
address sizes   : 40 bits physical, 48 bits virtual
power management:


ho preso solo l'ultimo tanto sono tutti uguali
_________________
Gentoo Linux 64Bit User
Back to top
View user's profile Send private message
Alakhai
Apprentice
Apprentice


Joined: 16 Oct 2003
Posts: 151

PostPosted: Thu Feb 23, 2012 3:38 pm    Post subject: Reply with quote

inoltre, un altra macchina paravirtualizzata con gentoo si blocca quando la carico con più di un processore e con QEMU + KVM
oppure se carico il kernel con l'opzione nolapic in grub

windows con KVM non ne vuole sapere
_________________
Gentoo Linux 64Bit User
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum