Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iwlwifi problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
pavel.stratil
Tux's lil' helper
Tux's lil' helper


Joined: 23 Oct 2005
Posts: 134

PostPosted: Mon Feb 20, 2012 11:30 am    Post subject: iwlwifi problem Reply with quote

Hi all,

I'm having a problem with my 5300 AGN driver. I don't know the root cause as I have been updating too many things at once, but I suppose its a combined problem of kernel/ucode/userspace. All in all, NetworkManager says, that wifi is unavailable

Code:

# iwconfig
lo        no wireless extensions.

sit0      no wireless extensions.

teredo    no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.


and

Code:

$ dmesg | grep iwl
[   15.628307] iwlwifi 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   15.628318] iwlwifi 0000:0c:00.0: setting latency timer to 64
[   15.628349] iwlwifi 0000:0c:00.0: pci_resource_len = 0x00002000
[   15.628352] iwlwifi 0000:0c:00.0: pci_resource_base = ffffc90000674000
[   15.628356] iwlwifi 0000:0c:00.0: HW Revision ID = 0x0
[   15.628449] iwlwifi 0000:0c:00.0: irq 47 for MSI/MSI-X
[   15.628500] iwlwifi 0000:0c:00.0: Detected Intel(R) Ultimate N WiFi Link 5300 AGN, REV=0x24
[   15.628569] iwlwifi 0000:0c:00.0: L1 Enabled; Disabling L0S
[   15.648447] iwlwifi 0000:0c:00.0: device EEPROM VER=0x120, CALIB=0x4
[   15.648451] iwlwifi 0000:0c:00.0: Device SKU: 0Xf0
[   15.648467] iwlwifi 0000:0c:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[   15.806142] iwlwifi 0000:0c:00.0: RF_KILL bit toggled to disable radio.
[   15.887655] iwlwifi 0000:0c:00.0: loaded firmware version 8.83.5.1 build 33692
[   15.887996] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   24.612676] iwlwifi 0000:0c:00.0: Failed to run INIT ucode: -132
[   24.612761] iwlwifi 0000:0c:00.0: Unable to initialize device.
[   25.335081] iwlwifi 0000:0c:00.0: Failed to run INIT ucode: -132
[   25.335164] iwlwifi 0000:0c:00.0: Unable to initialize device.
[   25.354471] iwlwifi 0000:0c:00.0: Failed to run INIT ucode: -132
[   25.354554] iwlwifi 0000:0c:00.0: Unable to initialize device.
[   25.355022] iwlwifi 0000:0c:00.0: Failed to run INIT ucode: -132
[   25.355130] iwlwifi 0000:0c:00.0: Unable to initialize device.
[   25.610391] iwlwifi 0000:0c:00.0: Failed to run INIT ucode: -132
[   25.610474] iwlwifi 0000:0c:00.0: Unable to initialize device.



...


Code:

# uname -a
Linux vrrr 3.2.0-gentoo #2 SMP Sat Jan 7 09:46:12 CET 2012 x86_64 Intel(R) Core(TM)2 Duo CPU U9400 @ 1.40GHz GenuineIntel GNU/Linux


using latest ucode 8.83.5.1-1 (not in portage) - tried prev. versions initially, didnt work for. Any tips?
Thanks lots, Pavel
_________________
Senbonzakura
Back to top
View user's profile Send private message
geeksheik
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2003
Posts: 98
Location: Zürich, Switzerland

PostPosted: Mon Jun 11, 2012 8:36 am    Post subject: Reply with quote

Same problem here with the 5300. Any progress?
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Mon Jun 11, 2012 9:05 am    Post subject: Reply with quote

Why not try the 3.4 kernel?
_________________
fs/super.c: "Self-destruct in 5 seconds. Have a nice day...\n"
Back to top
View user's profile Send private message
geeksheik
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2003
Posts: 98
Location: Zürich, Switzerland

PostPosted: Mon Jun 11, 2012 9:16 am    Post subject: Reply with quote

It was the physical kill switch on the laptop. Duh. :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum