Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[install] AIUTO minimal-amd64-20120209 PRIMA INSTALLAZIONE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Wed Feb 15, 2012 8:46 pm    Post subject: [install] AIUTO minimal-amd64-20120209 PRIMA INSTALLAZIONE Reply with quote

Salve a tutti, mi sono piantato durante l'esecuzione di nano -w /mnt/gentoo/etc/make.conf :(

CHI mi leva dal fango :?:

ho eseguito la configurazione con successo della connessione con wifi

ho partizionato un disco come da guida

ho creato i filesystem di boot(EXT2) di root (EXT3) e di swap (TYPE 82)

ho montato: # mount /dev/sda3 /mnt/gentoo
# mkdir /mnt/gentoo/boot
# mount /dev/sda1 /mnt/gentoo/boot

ho scaricato lo stage3 per amd64-20120209 e scompattato: gentoo# tar xvjpf stage3-amd64-20120209*.tar.bz2

ho scaricato portage-latest e scompattato: gentoo# tar xvjf /mnt/gentoo/portage-latest.tar.bz2 -C /mnt/gentoo/usr

Sono parecchi giorni che cerco in giro ma non ho ben capito cosa devo metterci in MAKE.config

la guida dice che nel MAKE per prima cosa bisogna metterci il tipo di architettura.

[b] Ho un amd phenom 9950 x4 BE ho letto un pò in giro e aprendo

# nano -w /mnt/gentoo/etc/make.conf

ho impostato questa config presa da wikipedia: CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CXXFLAGS="${CFLAGS}"

Ho aperto il make.conf.example ma non ho capito molto.

Mi hanno regalato un libro LINUX PER NEGATI, non spiega molto però mi sono impegnato molto lenggendo le 417 pagine un qualche ora.

sono una 20 di giorni che scoprendo il mondo linux e mi piace un BOTTO!

ho provato ubuntu 11.10, si carino ma non è quello che voglio
ho provato anche Back Track 5 R1, molto bello, ma mi da molti conflitti hardware.

Ho trovato GENTOO e dato che non voglio essere più dipendente di windows colgo l'occasione per fare due cose insieme, installare GENTOO e apprendere il mondo linux!

Durante il caricamento del Kernel gentoo vedo a destra tutti gli asterischi VERDI eccetto uno ma non sò come rivederlo, credo non sia importantissimo, spero!

di seguito posto il mio hardware:

POWER Coler Master real power 700 W
MB asus M3A32-mvp deluxe wifi (atheros AR5007EG integrata)
CPU AMD Phenom X4 9950 BE (overclock a 3,09 Ghz)
RAM 4 Gb OCZ Gold DDR 2 800 Mhz
4 Gb PATRIOT DDR 2 800 Mhz
VGA Sapphire HD 4870 x2 2 Gb (gpu clock 840 mem 900) (chip R700) durante il caricamento segna verde
AUDIO Sound Blaster Audigy 2 ZS Pro quella con il pannello esterno durante il caricamento segna verde
CD/DVD RW LG lightscribe sata
LG Ide
HDD SSD OCZ AGIBILITY sata 2 60 Gb (win 7 ati ed.)
4 Maxtor 320 Gb sata
1 WDC 1 Tb sata

USB ESTERNO DVB-T stick N15 nilox (s/n 20NX01US00002)
ATI remote telecomando multi
Mouse Logitech G9X Laser
RAZER HYDRA pc gaming motion sensing controllers

POTETE AIUTARMI ???
_________________
Matteo
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Wed Feb 15, 2012 9:19 pm    Post subject: Reply with quote

ma perchè è tutto in grassetto?? :?

Quote:
ho creato i filesystem di boot(EXT2) di root (EXT3) e di swap (TYPE 82)


la partizione di boot non è obbligatoria, volendo potresti anche non farla. come filesystem c'è ext4 già da un po', sarebbe da preferire a ext3 :wink:

Quote:
Sono parecchi giorni che cerco in giro ma non ho ben capito cosa devo metterci in MAKE.config


make.conf non MAKE.config, ed è case sensitive, maiuscole e minuscole fanno la differenza :P

Quote:
ho impostato questa config presa da wikipedia:


8O ci sono fonti più adatte da seguire in questi casi: http://en.gentoo-wiki.com/wiki/Safe_Cflags

in ogni caso puoi utilizzare -march=native e toglierti la preoccupazione

Quote:
sono una 20 di giorni che scoprendo il mondo linux e mi piace un BOTTO!


se 20 giorni fa neanche conoscevi linux e ora vuoi installare gentoo... beh, hai la mia stima :lol:

Quote:
Durante il caricamento del Kernel gentoo vedo a destra tutti gli asterischi VERDI eccetto uno ma non sò come rivederlo, credo non sia importantissimo, spero!


i file di log si trovano in /var/log, per controllare/abilitare il log del processo di avvio controlla nel file /etc/rc.conf :wink:
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Wed Feb 15, 2012 10:33 pm    Post subject: Reply with quote

è qui dove devo rispondere?? :lol:spero di si!

scusa per grassetto, no lo faccio più :)

ok tolgo tutto di nuovo (questa è la 6 volta ) e sistemo come dici in ext4.

ho controllato rc.conf ma nn capisco quali sono i comandi che il nano mostra, non sò se sono informazioni quelle scritte o realmente comandi! Odio non conoscere le cose, nano lo da tre giorni. non riesco a trovare una guida che mi spieghi cosa/come/perchè possa fare.

es: sul nano ho letto che tutto quello che è scritto dopo il carattere # sono informazioni mentre ove nn c'è è un comando ..giusto?

ah, i comandi emerge / gcc mi dice : command not found ... perchè non li ho? eppure portage l'ho estratto come dice la guida!!!

cosa manco di eseguire correttamente?

GRAZIE ANCORA


[quote="k01"]ma perchè è tutto in grassetto?? :?



Quote:
ho creato i filesystem di boot(EXT2) di root (EXT3) e di swap (TYPE 82)


la partizione di boot non è obbligatoria, volendo potresti anche non farla. come filesystem c'è ext4 già da un po', sarebbe da preferire a ext3 :wink:

Quote:
Sono parecchi giorni che cerco in giro ma non ho ben capito cosa devo metterci in MAKE.config


make.conf non MAKE.config, ed è case sensitive, maiuscole e minuscole fanno la differenza :P

Quote:
ho impostato questa config presa da wikipedia:


8O ci sono fonti più adatte da seguire in questi casi: http://en.gentoo-wiki.com/wiki/Safe_Cflags

in ogni caso puoi utilizzare -march=native e toglierti la preoccupazione

Quote:
sono una 20 di giorni che scoprendo il mondo linux e mi piace un BOTTO!


se 20 giorni fa neanche conoscevi linux e ora vuoi installare gentoo... beh, hai la mia stima :lol:

Quote:
Durante il caricamento del Kernel gentoo vedo a destra tutti gli asterischi VERDI eccetto uno ma non sò come rivederlo, credo non sia importantissimo, spero!


i file di log si trovano in /var/log, per controllare/abilitare il log del processo di avvio controlla nel file /etc/rc.conf :wink:[/quote
_________________
Matteo
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Wed Feb 15, 2012 10:35 pm    Post subject: Re: [install] AIUTO minimal-amd64-20120209 PRIMA INSTALLAZIO Reply with quote

Farnamen wrote:
Salve a tutti, mi sono piantato durante l'esecuzione di nano -w /mnt/gentoo/etc/make.conf :(

CHI mi leva dal fango :?:

ho eseguito la configurazione con successo della connessione con wifi

ho partizionato un disco come da guida

ho creato i filesystem di boot(EXT2) di root (EXT3) e di swap (TYPE 82)

ho montato: # mount /dev/sda3 /mnt/gentoo
# mkdir /mnt/gentoo/boot
# mount /dev/sda1 /mnt/gentoo/boot

ho scaricato lo stage3 per amd64-20120209 e scompattato: gentoo# tar xvjpf stage3-amd64-20120209*.tar.bz2

ho scaricato portage-latest e scompattato: gentoo# tar xvjf /mnt/gentoo/portage-latest.tar.bz2 -C /mnt/gentoo/usr

Sono parecchi giorni che cerco in giro ma non ho ben capito cosa devo metterci in MAKE.config

la guida dice che nel MAKE per prima cosa bisogna metterci il tipo di architettura.

[b] Ho un amd phenom 9950 x4 BE ho letto un pò in giro e aprendo

# nano -w /mnt/gentoo/etc/make.conf

ho impostato questa config presa da wikipedia: CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CXXFLAGS="${CFLAGS}"

Ho aperto il make.conf.example ma non ho capito molto.

Mi hanno regalato un libro LINUX PER NEGATI, non spiega molto però mi sono impegnato molto lenggendo le 417 pagine un qualche ora.

sono una 20 di giorni che scoprendo il mondo linux e mi piace un BOTTO!

ho provato ubuntu 11.10, si carino ma non è quello che voglio
ho provato anche Back Track 5 R1, molto bello, ma mi da molti conflitti hardware.

Ho trovato GENTOO e dato che non voglio essere più dipendente di windows colgo l'occasione per fare due cose insieme, installare GENTOO e apprendere il mondo linux!

Durante il caricamento del Kernel gentoo vedo a destra tutti gli asterischi VERDI eccetto uno ma non sò come rivederlo, credo non sia importantissimo, spero!

di seguito posto il mio hardware:

POWER Coler Master real power 700 W
MB asus M3A32-mvp deluxe wifi (atheros AR5007EG integrata)
CPU AMD Phenom X4 9950 BE (overclock a 3,09 Ghz)
RAM 4 Gb OCZ Gold DDR 2 800 Mhz
4 Gb PATRIOT DDR 2 800 Mhz
VGA Sapphire HD 4870 x2 2 Gb (gpu clock 840 mem 900) (chip R700) durante il caricamento segna verde
AUDIO Sound Blaster Audigy 2 ZS Pro quella con il pannello esterno durante il caricamento segna verde
CD/DVD RW LG lightscribe sata
LG Ide
HDD SSD OCZ AGIBILITY sata 2 60 Gb (win 7 ati ed.)
4 Maxtor 320 Gb sata
1 WDC 1 Tb sata

USB ESTERNO DVB-T stick N15 nilox (s/n 20NX01US00002)
ATI remote telecomando multi
Mouse Logitech G9X Laser
RAZER HYDRA pc gaming motion sensing controllers

POTETE AIUTARMI ???



è qui dove devo rispondere?? :lol:spero di si!

scusa per grassetto, non lo faccio più :)

ok tolgo tutto di nuovo (questa è la 6 volta ) e sistemo come dici in ext4.

ho controllato rc.conf ma nn capisco quali sono i comandi che il nano mostra, non sò se sono informazioni quelle scritte o realmente comandi! Odio non conoscere le cose, nano lo da tre giorni. non riesco a trovare una guida che mi spieghi cosa/come/perchè possa fare.

es: sul nano ho letto che tutto quello che è scritto dopo il carattere # sono informazioni mentre ove nn c'è è un comando ..giusto?

ah, i comandi emerge / gcc mi dice : command not found ... perchè non li ho? eppure portage l'ho estratto come dice la guida!!!

cosa manco di eseguire correttamente?

GRAZIE ANCORA
_________________
Matteo
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Wed Feb 15, 2012 11:03 pm    Post subject: Reply with quote

Quote:
è qui dove devo rispondere?? :lol:spero di si!


mi sa che hai fatto un po' di confusione, doppio post in cui in uno ti sei autocitato :D

Quote:
ho controllato rc.conf ma nn capisco quali sono i comandi che il nano mostra,


non sono comandi, più che altro sono variabili con i loro valori. su linux la maggior parte delle configurazioni vengono scritte in un file di testo facilmente modificabile :wink:

Quote:
sul nano ho letto che tutto quello che è scritto dopo il carattere # sono informazioni mentre ove nn c'è è un comando ..giusto?


solitamente # si usa per i commenti, il resto non sono per forza comandi, possono essere anche variabili come detto prima, valori che vengono processati insomma. nano comunque è semplicemente un editor di testi, non un sito web o un manuale, sarebbe più giusto dire "con nano..." :)

Quote:
ah, i comandi emerge / gcc mi dice : command not found ... perchè non li ho? eppure portage l'ho estratto come dice la guida!!!


ma hai effettuato correttamente il chroot?
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Wed Feb 15, 2012 11:30 pm    Post subject: ma hai effettuato correttamente il chroot? Reply with quote

ho provato ma sensa successo perhè non mi riesce sistemare il mirror.

ora ho tutti su disco bianco, partiziono sdb1 ext4 bootabile e sdb2 la swap genero il filesystem ext4 e swap. cioè da fdisk non fa di già?? cmq seguo la guida...
scompatto di nuovo stage3 e portage
apro il make.conf:

sostituisco quello che avevo messo io come -march (ricontrollando sembra sia il comando giustote per la cpu)

cos'altro ci devo mettere?


ah durante il "boot" del cd dice rc_... non configured su rc.conf per ilresto però le lucine son tutte verdi :lol:

spero di non massacrarti con ste domande, se è troppo di peso non me la prendo a male se nn rispondi.

cmq grazie per la stima, mi stò veramente facendo male a imparare queste regole, mi sveglio alle 13 mangio lavoro 3 ore e poi fino alle 4-5 del mattino mi metto qui e cerco di imparare e andare avanti passetto per passetto... mia madre presto mi porterà in un centro dalla dipendenza dei pc :D :D :D
_________________
Matteo
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 3:05 am    Post subject: reinstallazione totale (ho perso il conto) Reply with quote

..allora

partizione

sdb1 boot 10 gb
sdb2 swap 5 gb

:arrow: estrazione stage3 amd 64 ok
:arrow: estrazione portage ok

:arrow: nano -w (-w cos'è) /etc/make.conf

CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CXXFLAGS="${CFLAGS}"

SYNC="rsync://rsync.gentoo.org/gentoo-portage"

PORTAGE_RSYNC_RETRIES="-1"

PORTAGE_RSYNC_EXTRA_OPTS="emerge --sync"

...salvataggio...

:arrow: #mirrorselect -i -o >> /mnt/gentoo/etc/make.conf

* downloading a list of mirrors...traceback (most recent call last):
File "/usr/sbin/mirrorselect", line 888, in <module>
main(sys.argv)

File "/usr/sbin/mirrorselect", line 875 in main
host = Extractor(MIRRORS_3_XML, options).host

File "/usr/sbin/mirrorselect", line 153, in __init__
host = self.getlist(parser, list_url)

File "/usr/sbin/mirrorselect", line 195, in getlist
parser.parser(urllib.urlopen(url).read())

File "/usr/lib64/python2.7/site-packages/mirrorselect/mirrorsparser3.py", line 37, in parse
for mirrorgroup in ET.XML/text):

File "usr/lib64/python2.7/xml/etree/ElementTree.py", line 1281, in XML
parser = XMLParser(target=TreeBuilder())

File "usr/lib64/python2.7/xml/etree/ElementTree.py", line 1447, in __init__
"No module named expat; use SimpleXMLTreeBuilder instead

:arrow: ImportError: No module named expat; use SimpleXMLTreeBuilder instead 8O DOH :!: :!:


WOOO ho scritto tutto a mano che fatica


ho provato anche la seconda

:arrow: #mirrorselect -i -r -o >> /mnt/gentoo/etc/make.conf

IDEM 8O 8O DOH :!: :!: DOH :!:



:evil: SONO FERMO A .6.a. al codice 1.1 : Utilizzo di mirrorselect per la variabile GENTOO_MIRRORS

:arrow: http://www.gentoo.org/doc/it/handbook/handbook-amd64.xml?part=1&chap=6

:roll: non ho fatto altro, non vorrei fare ulteriori danni e ripartire da capo di nuovo....



CE LA FAREMO....... :?: :?: :?: QUALCUNO HA :idea: :idea: :idea:


:cry: se ora non mi riposo mi sa che slero _-_
_________________
Matteo
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Feb 16, 2012 10:07 am    Post subject: Reply with quote

Quote:
cioè da fdisk non fa di già??


prova cfdisk, è più user friendly ;)

Quote:
ah durante il "boot" del cd dice rc_... non configured su rc.conf per ilresto però le lucine son tutte verdi


rispondendo non mi ero accordo che parlavi del live cd, io facevo riferimento al boot di un sistema già installato. degli errori durante il boot del livecd direi che puoi ampiamente fregartene

Quote:
sdb1 boot 10 gb
sdb2 swap 5 gb


??? se boot comprende anche la partizione di root allora sarebbe meglio qualche GB in più se vuoi un sistema desktop completo. se boot non comprende root e per quello c'è una sdb3 non elencata qui, allora 10 GB sono eccessivamente troppi per solo boot :lol:

Quote:
nano -w (-w cos'è) /etc/make.conf


dai nano -h e scoprilo da solo :wink: (non è per scortesia, ma almeno così impari ad usare gli help)
visto che è la tua prima installazione potresti lasciare la personalizzazione al minimo almeno per ora, quindi si chost, cflags e cxxflags, ma le varie opzioni per rsync le eviterei.

Quote:
#mirrorselect -i -o >> /mnt/gentoo/etc/make.conf


sembra esserci qualche problema con python, ma visto che si tratta ancora del livecd, direi che anche in questo caso puoi fregartene :P
se vuoi specificare dei mirror lo puoi fare anche a mano senza usare mirrorselect, sempre in make.conf basta che aggiungi questo (o i mirror che preferisci tu):

Code:
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ "


in generale comunque puoi utilizzare qualsiasi livecd che supporti il chroot per installare gentoo, se ti trovi più comodo puoi utilizzare un ambiente grafico e fare copia e incolla degli errori
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 12:30 pm    Post subject: Reply with quote

Buongiorno :)

conosco anche cfidsk, ma ho notato che quando andavo a creare una partizione, essa non partiva dal primo settore bens' da 2048 8O
e sicchè usa fdisk per spostare il tutto al primo settore.

EHEH, mi sono sbagliato non 10 gb per sdb1, sono 100 gb.

grazie per nano -h


Bene allora imposto subito il Codice:
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ "


(come faccio a citare una tua risposta) non sò che tasto è :)

citacione:
in generale comunque puoi utilizzare qualsiasi livecd che supporti il chroot per installare gentoo, se ti trovi più comodo puoi utilizzare un ambiente grafico e fare copia e incolla degli errori

per live cd che supporti il chroot cosa instendi per esempio?

es: mettiamo ubuntu 11.10 (la tiro lì)
posso in ambiente grafico aprire il terminale e fare tutto quello che dice la guida da lì :?: :?: :?:

Siccome sono collegato a internet tramite wifi handmade al mio vicino, e anche se ho il 90 % della potenza del segnale, io fino alle 23 non vado oltre i 50 kb/s
aspetta non è finita.
un altro vicino di casa ha sul proprio tetto un bel pò di apparati (sembra una centrale televisiva) , questi sembrano disturbare le freq. dei nostri telecomandi per gli splitter e quando entra un segnale troppo forte la centralina fancoil impazzisce e fa scattare tutto il quadro, ovviamente accade sempre quando scarico le iso _-_

ma vabene così! tanto ora mi mettono la linea (ho fatto il contratto fastweb a giugno)
ancora oggi aspetto i tecnici per portare il cavo

non mi scoraggio cmq...

OK mi butto a fare il chroot non dopo prima di aver settato il nano (mirror) e continuo

Grazie in anticipo e spero di risponderti senza riportare errori
_________________
Matteo
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Feb 16, 2012 1:49 pm    Post subject: Reply with quote

Quote:
(come faccio a citare una tua risposta) non sò che tasto è


Code:
[quote]messaggio da citare[/quote]


:wink:

Quote:
es: mettiamo ubuntu 11.10 (la tiro lì)
posso in ambiente grafico aprire il terminale e fare tutto quello che dice la guida da lì


si, a parte magari alcune cose specifiche di gentoo, come mirrorselect, ma una volta effettuato il chroot è uguale
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 2:08 pm    Post subject: Reply with quote

chroot effettuato così

# chroot /mnt/gentoo /bin/bash
# env-update
>> Regenerating /etc/ld.so.cache...
# source /etc/profile
# export PS1="(chroot) $PS1"


è normale che ora indica quuesto?

(chroot) tre quadretti bianchilivecd / #

ho fatto anche

# emerge --sync

ha scaricato un botto di cose e in fondo mi ha detto che ci sono 2 new items

sono altri agg.?

ho provato ad aprirli senza successo: devo imparare eselect.

mi sono fermato qui, devo andare a lavoro... ma se ora chiudo il pc come ritorno a questo step?

mi sento felice! è la prima volta che riesco a fare queste cose passo per passo con successo
senza aiuto ero sempre a mirror select! GRAZIE
_________________
Matteo
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Feb 16, 2012 2:18 pm    Post subject: Reply with quote

Quote:
# export PS1="(chroot) $PS1"


è normale che ora indica quuesto?

(chroot) tre quadretti bianchilivecd / #


quel comando è facoltativo, ti serve solo per distinguere l'ambiente chroot dagli altri. i 3 quadretti bianchi non sono molto normali, probabilmente qualche problema nella codica caratteri

Quote:
ha scaricato un botto di cose e in fondo mi ha detto che ci sono 2 new items

sono altri agg.?

ho provato ad aprirli senza successo: devo imparare eselect.


eselect news list per mostrare l'elenco, eselect news read X (dove X è un numero dell'elenco) per leggerle :wink:

Quote:
ma se ora chiudo il pc come ritorno a questo step?


rimonti la partizione, chroot e riprendi :wink:
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 6:20 pm    Post subject: Reply with quote

rieccoci :)

eselect dice che ho 2 read python 3.1 e --as-needed enable in default profiles

ci faccio la frittata stasera? :?

dopo la guida andando avanti mi chiede di impostare un profilo..

ne elenca molti

[1] default/linux/amd64/10.0 *
[2] default/linux/amd64/10.0/desktop
[3] default/linux/amd64/10.0/no-multilib
[4] default/linux/amd64/10.0/server
5 def----------------------------/selinux
6 def-----------------------------/desktop/gnome
7 def----------------------------/desktop/kde
8 hardened/linux/amd64/selinux
9 hardened/linux/amd64/no-multilib
10 hardened/linux/amd64/no-multilib/selinux


cosa consigli????

stavo provando con l'opzione kde e successivamente configurare le USE, ma al comando

# less /usr/portage/profiles/use.desc

bash: less: command not found

infatti se scrivo less dice lo stesso :cry:
dove sbaglio?
_________________
Matteo
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Feb 16, 2012 6:31 pm    Post subject: Reply with quote

dipende da quale ambiente desktop vuoi, kde per kde, gnome per gnome :D oppure se li vuoi entrambi o ambienti differenti seleziona il profilo desktop generico.

less è stato rimosso da system, quindi se lo vuoi usare devi prima installarlo, dai semplicemente emerge less :wink:
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 7:16 pm    Post subject: oh oh Reply with quote

ehmm....

ho installato less.....

il file use.desc comprendi quindi tutte le USE

quindi tecnicamente dovrei aprire il nano con make.config e iniziare a settare USE="?

qualcosa conosco esempio alsa 3dnow

c'è qualche maniera per capire cosa sono cosa fanno e come settarle?

credo che sia ovvio pensare che dovrò mettere un USE per la scheda video, audio (alsa giusto) insomma tutto l'harware. immagino anche il software? se setto USE="alsa" dovrò anche mettere il driver e il software di riferimento...

Come posso documentarmi???

CMQ è uno spettacolo, mi ci stò avventando come un barbone su un piatto di tordelli
e anche se smoccoleggio trovo che tutto questo è veramente interessante :lol: :lol:
_________________
Matteo
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Feb 16, 2012 7:25 pm    Post subject: Reply with quote

Per piacere edita i tuoi messaggi e sistemali.
Niente citazioni a casaccio, usa correttamente i tag, qui non siamo su fessbucc e neppure in chat, niente abbreviazioni.

Al posto di less ( certo che ultimamente le guide iniziano ad esser peggio che datate... :? ) ti consiglio
Code:
emerge euses gentoolkit
così avrai i comandi euses ed euse a disposizione (leggere la documentazione od almeno avviare con --help).
Oppure c'è sempre app-portage/ufed.

caveat: nonostante le stramaledizioni, che vanno al cielo copiose per questo, la use "doc" impostata globalmente crea una serie infinita di problemi.

Dato che sei alle prime armi abilita le use un poco alla volta (o meglio una alla volta). C'è un problema chiamato dipendenze circolari, nulla di irrisolvibile ma è meglio non abilitare cento use insieme.

Per l'inizio al settore 2048 dipende dal fatto che ora è questa l'impostazione di default. ( se ne è già parlato, cerca ... cerca ... :twisted: )

Il tuo profilo sicuramente sarà desktop scegli tu se sei scimmia o lucertola. (gnome/kde, se li metti tutti e due non la finirai mai di compilare)

Farnamen wrote:
smoccoleggio
... verso tipico ... almeno in questo ... :twisted:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Thu Feb 16, 2012 7:35 pm; edited 2 times in total
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 7:32 pm    Post subject: Reply with quote

ah dimenticavo


.... tra quanti anni vedrò il desktop grafico? :lol:
_________________
Matteo
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 9:04 pm    Post subject: Reply with quote

Quote:
Per piacere edita i tuoi messaggi e sistemali.
Niente citazioni a casaccio, usa correttamente i tag, qui non siamo su fessbucc e neppure in chat, niente abbreviazioni.


PERDONAMI è la prima volta che uso un forum, in effetti non si capisce molto nei miei messaggi, grazie :wink:

Quote:
Dato che sei alle prime armi abilita le use un poco alla volta (o meglio una alla volta). C'è un problema chiamato dipendenze circolari, nulla di irrisolvibile ma è meglio non abilitare cento use insieme


esempio

Code:
USE="alsa"


una volta salvato come faccio a sapere se funziona o se crea dipendenze?

non è ancora il momento di farlo avviare dall'Hardisk giusto?

NO, perchè se fosse così, resta il cursore intermittente fino in eterno :?



lo sò è come insegnare ad un cane di non abbaiare quando passano le persone davanti casa, è che questo mondo mi piace da morire e nonostante legga le giude, non c'è niente di meglio di una persona fisica, senza l'aiuto di k01 a quest'ora ero al passo
Code:
chroot



resto in attesa mentre cerco intanto la discussione sulla partenza
Code:
settore 2048


cmq ora la partizione
Code:
sdb1 boot ext4 100gb la ho impostata dal settore 1-13.....0


è grave?


e continuo a cercare per rendervi la vita meno complicata....
_________________
Matteo
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 152
Location: Osimo(AN)

PostPosted: Thu Feb 16, 2012 10:44 pm    Post subject: Reply with quote

Scusami se te lo dico, ma cominciare con Gentoo non mi sembra una scelta saggia.Ci sono moltissime altre distro con le quali ti puoi fare un po di esperienza, e dopo installare Gentoo da SOLO seguendo l'ottima documentazione.
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Thu Feb 16, 2012 11:36 pm    Post subject: Reply with quote

Quote:
Scusami se te lo dico, ma cominciare con Gentoo non mi sembra una scelta saggia.Ci sono moltissime altre distro con le quali ti puoi fare un po di esperienza, e dopo installare Gentoo da SOLO seguendo l'ottima documentazione.



Ciao Massimo, hai perfettamente ragione, è che sono alla deriva, ho provato "ubuntu" "backtrack 5 r1" ma non riesco a sistemare il mio HARDWARE, errori contro errori, anche seguendo le guide, riporto errori anche di altra natura. Ho pensato a Gentoo, così ho detto: istallando il sistema passo passo imparo e capisco ciò che digito e magari riesco anche a settare tutto l' HARDWARE....

NON MI CHIAMO CAPITAN SCHETTINO, AFFONDERO' CON LE MIE SCHEDE SE NECESSARIO :lol: :lol: :lol



ALTRIMENTI, che distro mi consigli?
_________________
Matteo
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Feb 17, 2012 9:58 am    Post subject: Reply with quote

Farnamen wrote:
PERDONAMI è la prima volta che uso un forum, in effetti non si capisce molto nei miei messaggi, grazie :wink:
Puoi sempre modificarli, quante volte vuoi. Fallo ed usa la funzione anteprima per vedere cosa ne esce fuori.
Farnamen wrote:
Code:
USE="alsa"
una volta salvato come faccio a sapere se funziona o se crea dipendenze?
le use attive con il profilo le puoi vedere tramite ufed o con emerge --info. Per vedere se ci sono problemi
Code:
emerge -aDNuv @world
è il comando che aggiorna il sistema, se attivare la use crea dipendenze circolari ti ritornerà un errore. Ed a qual punto o soprassiedi o chiedi lumi.
Per il momento puoi anche pensare di limitarti alle use impostate dal profilo (per inciso credo che alsa sia abilitata automaticamente dal profilo desktop/kde) ed andare avanti.
In un secondo tempo andrai a ricompilare quei pacchetti che impiegano le use che avrai modificato, e solo quelli.

Per il partizionamento non ti preoccupare, la geometria a cilindri è deprecata in favore di quella a settori ma non è il caso di darsi pena.

Nel frattempo installa il kernel e compilalo
Code:
emerge gentoo-sources ; genkernel all
per mettere mano alla configurazione c'è sempre tempo.
Se vuoi usare la configurazione del livecd usa questi comandi
Code:
zcat /proc/config.gz > /tmp/.kconfig
genkernel --config=/tmp/.kconfig all

rm /tmp/.kconfig
e non il comando indicato nella guida (sempre zcat ma "> /usr/qualcosa", è sbagliato.

Cerca il file make.conf.example e dagli uno sguardo (confrontalo anche con l'output di emerge --info)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Farnamen
n00b
n00b


Joined: 14 Feb 2012
Posts: 13
Location: ITALIA Toscana

PostPosted: Sat Feb 18, 2012 6:00 am    Post subject: Reply with quote

Scusa il ritardo ma dovevo riposare un pò, anche se nn ci riesco come si vede, sono le 7 !!!

WOOW ora si che inizio a capire!

datemi un paio di giorni e vi farò sapere.


MILLE GRAZIEEE!!
_________________
Matteo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum