Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kmail showing no folders
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Sat Feb 11, 2012 10:24 pm    Post subject: Kmail showing no folders Reply with quote

Hi there. Been awhile.

I'm trying to setup Kmail 4.8. I've had Kmail installed before, under KDE 3.5, and it worked fine, never had any issues. But this new version seems to have a clobbered configuration file. I setup 2 IMAP accounts with it. It successfully connected to the mail servers, but when you tell kmail to check the mail, it does nothing. No activity, nothing. It also shows no mail folders at all. No local folders, no IMAP folders, doesn't even show the IMAP accounts I've setup. So the first thing I'm trying to do is wipe the config, but I don't want to completely wipe my .kde folder. Where is the kmail config directory? I did a "rm -r .kde4*/share/apps/kmail*/*" but it made no visible difference. What's going on?
Back to top
View user's profile Send private message
Ormaaj
Guru
Guru


Joined: 28 Jan 2008
Posts: 319

PostPosted: Sun Feb 12, 2012 7:19 am    Post subject: Reply with quote

kmail has changed drastically since 3.5 due to Akonadi. Until very recently kmail has been essentially unusable. Since 4.7 or so it's kinda-sorta usable but is still very buggy. The KDE forums have a couple knowledgeable people and would probably be the best place to ask. The KDE wiki has a few mediocre articles on Akonadi configuration and troubleshooting. If you're having troubles with "folders" showing up, 90% chance it's Akonadi-related.

There are additional config files under ~/.local/share and ~/.config. Deleting them probably won't do much good. Testing under a new user seems the easiest way to ensure a clean configuration.
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Sun Feb 12, 2012 6:17 pm    Post subject: Reply with quote

Yeah, I did get the feeling that it was pretty ugly under the hood. I'm still not sure how it fits together. That makes me very sad, 4.8 and kmail is still very buggy. Lol, are there any alternatives for QT/KDE?
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Sun Feb 12, 2012 7:21 pm    Post subject: Reply with quote

Had the same(similar) problem, what worked for me, was to setup servers, close the app, log out and log in again. Weird, but well. Since then, I dropped KDE (again) anyway.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum