Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XEN] segfault at 0 ip (RESOLU)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Sat Feb 11, 2012 2:02 am    Post subject: [XEN] segfault at 0 ip (RESOLU) Reply with quote

Bonjour,

Je viens d'installer xen. Mon dom0 et l'application fonctionne correctement, cependant, j'ai un problème au démarrage de mon DomU.

Ce dernier est une image de mon système. J'ai fait un stage 5 de mon système dom0 que j'ai décompressé dans un fichier .img.

Voici l'erreur qui apparaît au démarrage :

Quote:
Started domain domU-xen (id=5)
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.1.6-gentoo (root@thess) (gcc version 4.5.3 (Gentoo 4.5.3-r1 p1.0, pie-0.4.5) ) #1 SMP Mon Jan 9 19:46:19 CET 2012
[ 0.000000] Command line: root=/dev/xvda1 ro xencons=tty
[ 0.000000] ACPI in unprivileged domain disabled
[ 0.000000] released 0 pages of unused memory
[ 0.000000] Set 0 page(s) to 1-1 mapping.
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] Xen: 0000000000000000 - 00000000000a0000 (usable)
[ 0.000000] Xen: 00000000000a0000 - 0000000000100000 (reserved)
[ 0.000000] Xen: 0000000000100000 - 0000000020800000 (usable)
[ 0.000000] NX (Execute Disable) protection: active
[ 0.000000] DMI not present or invalid.
[ 0.000000] No AGP bridge found
[ 0.000000] last_pfn = 0x20800 max_arch_pfn = 0x400000000
[ 0.000000] init_memory_mapping: 0000000000000000-0000000020800000
[ 0.000000] No NUMA configuration found
[ 0.000000] Faking a node at 0000000000000000-0000000020800000
[ 0.000000] Initmem setup node 0 0000000000000000-0000000020800000
[ 0.000000] NODE_DATA [000000001fffb000 - 000000001fffffff]
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0x00000010 -> 0x00001000
[ 0.000000] DMA32 0x00001000 -> 0x00100000
[ 0.000000] Normal empty
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[2] active PFN ranges
[ 0.000000] 0: 0x00000010 -> 0x000000a0
[ 0.000000] 0: 0x00000100 -> 0x00020800
[ 0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs
[ 0.000000] No local APIC present
[ 0.000000] APIC: disable apic facility
[ 0.000000] APIC: switched to apic NOOP
[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 0000000000100000
[ 0.000000] Allocating PCI resources starting at 20800000 (gap: 20800000:df800000)
[ 0.000000] Booting paravirtualized kernel on Xen
[ 0.000000] Xen version: 4.1.1 (preserve-AD)
[ 0.000000] setup_percpu: NR_CPUS:64 nr_cpumask_bits:64 nr_cpu_ids:1 nr_node_ids:1
[ 0.000000] PERCPU: Embedded 27 pages/cpu @ffff88001ffd5000 s78336 r8192 d24064 u110592
[ 0.000000] Built 1 zonelists in Node order, mobility grouping on. Total pages: 130923
[ 0.000000] Policy zone: DMA32
[ 0.000000] Kernel command line: root=/dev/xvda1 ro xencons=tty
[ 0.000000] PID hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.000000] Checking aperture...
[ 0.000000] No AGP bridge found
[ 0.000000] Memory: 498672k/532480k available (5715k kernel code, 448k absent, 33360k reserved, 5159k data, 656k init)
[ 0.000000] SLUB: Genslabs=15, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] Hierarchical RCU implementation.
[ 0.000000] NR_IRQS:4352 nr_irqs:256 16
[ 0.000000] Console: colour dummy device 80x25
[ 0.000000] console [tty0] enabled
[ 0.000000] console [hvc0] enabled
[ 0.000000] installing Xen timer for CPU 0
[ 0.000000] Detected 3007.004 MHz processor.
[ 0.000999] Calibrating delay loop (skipped), value calculated using timer frequency.. 6014.00 BogoMIPS (lpj=3007004)
[ 0.000999] pid_max: default: 32768 minimum: 301
[ 0.001119] Security Framework initialized
[ 0.001506] SELinux: Initializing.
[ 0.002135] Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
[ 0.002549] Inode-cache hash table entries: 32768 (order: 6, 262144 bytes)
[ 0.002640] Mount-cache hash table entries: 256
[ 0.002998] Initializing cgroup subsys cpuacct
[ 0.002999] Initializing cgroup subsys freezer
[ 0.003083] CPU: Physical Processor ID: 0
[ 0.003096] CPU: Processor Core ID: 0
[ 0.003128] SMP alternatives: switching to UP code
[ 0.006034] Freeing SMP alternatives: 12k freed
[ 0.006208] Performance Events: unsupported Netburst CPU model 6 no PMU driver, software events only.
[ 0.007542] Brought up 1 CPUs
[ 0.008030] Grant table initialized
[ 0.026962] RTC time: 165:165:165, date: 165/165/65
[ 0.027016] NET: Registered protocol family 16
[ 0.027183] kworker/u:0 used greatest stack depth: 6232 bytes left
[ 0.028268] kworker/u:0 used greatest stack depth: 5928 bytes left
[ 0.028859] PCI: setting up Xen PCI frontend stub
[ 0.056630] kworker/u:0 used greatest stack depth: 5848 bytes left
[ 0.059986] bio: create slab <bio-0> at 0
[ 0.060386] ACPI: Interpreter disabled.
[ 0.061837] xen/balloon: Initialising balloon driver.
[ 0.061853] last_pfn = 0x20800 max_arch_pfn = 0x400000000
[ 0.072130] xen-balloon: Initialising balloon driver.
[ 0.073149] vgaarb: loaded
[ 0.073689] SCSI subsystem initialized
[ 0.074504] usbcore: registered new interface driver usbfs
[ 0.074806] usbcore: registered new interface driver hub
[ 0.074982] usbcore: registered new device driver usb
[ 0.075768] Advanced Linux Sound Architecture Driver Version 1.0.24.
[ 0.075784] PCI: System does not support PCI
[ 0.075793] PCI: System does not support PCI
[ 0.076323] NetLabel: Initializing
[ 0.076336] NetLabel: domain hash size = 128
[ 0.076345] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.076373] NetLabel: unlabeled traffic allowed by default
[ 0.076390] Switching to clocksource xen
[ 0.076646] Switched to NOHz mode on CPU #0
[ 0.080683] kworker/u:0 used greatest stack depth: 5528 bytes left
[ 0.089418] pnp: PnP ACPI: disabled
[ 0.089685] NET: Registered protocol family 2
[ 0.089804] IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
[ 0.090298] TCP established hash table entries: 16384 (order: 6, 262144 bytes)
[ 0.090560] TCP bind hash table entries: 16384 (order: 6, 262144 bytes)
[ 0.090681] TCP: Hash tables configured (established 16384 bind 16384)
[ 0.090694] TCP reno registered
[ 0.090714] UDP hash table entries: 256 (order: 1, 8192 bytes)
[ 0.090739] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[ 0.091062] NET: Registered protocol family 1
[ 0.143776] RPC: Registered named UNIX socket transport module.
[ 0.143792] RPC: Registered udp transport module.
[ 0.143803] RPC: Registered tcp transport module.
[ 0.143815] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.144002] platform rtc_cmos: registered platform RTC device (no PNP device found)
[ 0.145000] microcode: CPU0 sig=0xf62, pf=0x4, revision=0xf
[ 0.145168] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[ 0.145874] audit: initializing netlink socket (disabled)
[ 0.145899] type=2000 audit(1328927892.240:1): initialized
[ 0.184732] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[ 0.193800] VFS: Disk quotas dquot_6.5.2
[ 0.193990] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[ 0.196679] msgmni has been set to 973
[ 0.198046] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.198065] io scheduler noop registered
[ 0.198068] io scheduler deadline registered
[ 0.198309] io scheduler cfq registered (default)
[ 0.198720] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.199943] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 0.201358] Non-volatile memory driver v1.3
[ 0.202160] uvesafb: failed to execute /sbin/v86d
[ 0.202172] uvesafb: make sure that the v86d helper is installed and executable
[ 0.202188] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[ 0.202201] uvesafb: vbe_init() failed with -22
[ 0.202215] uvesafb: probe of uvesafb.0 failed with error -22
[ 0.202734] Event-channel device installed.
[ 0.207288] brd: module loaded
[ 0.209681] loop: module loaded
[ 0.229440] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[ 0.229461] e1000: Copyright (c) 1999-2006 Intel Corporation.
[ 0.229576] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[ 0.229589] e100: Copyright(c) 1999-2006 Intel Corporation
[ 0.229805] sky2: driver version 1.29
[ 0.230026] Initialising Xen virtual ethernet driver.
[ 0.236199] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 0.236337] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 0.236500] uhci_hcd: USB Universal Host Controller Interface driver
[ 0.236746] usbcore: registered new interface driver usblp
[ 0.236759] Initializing USB Mass Storage driver...
[ 0.237345] usbcore: registered new interface driver usb-storage
[ 0.237360] USB Mass Storage support registered.
[ 0.237479] usbcore: registered new interface driver libusual
[ 0.238225] i8042: PNP: No PS/2 controller found. Probing ports directly.
[ 0.239064] i8042: No controller found
[ 0.239529] mousedev: PS/2 mouse device common for all mice
[ 0.280660] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
[ 0.280820] rtc_cmos: probe of rtc_cmos failed with error -38
[ 0.281619] lirc_dev: IR Remote Control driver registered, major 250
[ 0.281636] IR NEC protocol handler initialized
[ 0.281647] IR RC5(x) protocol handler initialized
[ 0.281659] IR RC6 protocol handler initialized
[ 0.281670] IR JVC protocol handler initialized
[ 0.281681] IR Sony protocol handler initialized
[ 0.281692] IR RC5 (streamzap) protocol handler initialized
[ 0.281703] IR MCE Keyboard/mouse protocol handler initialized
[ 0.281715] IR LIRC bridge handler initialized
[ 0.281726] Linux video capture interface: v2.00
[ 0.287211] device-mapper: ioctl: 4.21.0-ioctl (2011-07-06) initialised: dm-devel@redhat.com
[ 0.287917] EFI Variables Facility v0.08 2004-May-17
[ 0.295463] usbcore: registered new interface driver usbhid
[ 0.295485] usbhid: USB HID core driver
[ 0.296660] ALSA device list:
[ 0.296674] No soundcards found.
[ 0.296934] Netfilter messages via NETLINK v0.30.
[ 0.296978] nf_conntrack version 0.5.0 (3895 buckets, 15580 max)
[ 0.297535] ctnetlink v0.93: registering with nfnetlink.
[ 0.297811] IPv4 over IPv4 tunneling driver
[ 0.298760] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 0.298816] TCP cubic registered
[ 0.298826] Initializing XFRM netlink socket
[ 0.299508] NET: Registered protocol family 10
[ 0.300850] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 0.300936] IPv6 over IPv4 tunneling driver
[ 0.301933] NET: Registered protocol family 17
[ 0.301995] lib80211: common routines for IEEE802.11 drivers
[ 0.302037] Registering the dns_resolver key type
[ 0.302220] blkfront: xvda1: flush diskcache: enabled
[ 0.302595] registered taskstats version 1
[ 0.402181] XENBUS: Device with no driver: device/console/0
[ 0.402207] Magic number: 1:252:3141
[ 0.402288] console [netcon0] enabled
[ 0.402297] netconsole: network logging started
[ 0.402487] md: Waiting for all devices to be available before autodetect
[ 0.402502] md: If you don't use raid, use raid=noautodetect
[ 0.402935] md: Autodetecting RAID arrays.
[ 0.402949] md: Scanned 0 and added 0 devices.
[ 0.402960] md: autorun ...
[ 0.402969] md: ... autorun DONE.
[ 0.404029] kjournald starting. Commit interval 5 seconds
[ 0.404135] EXT3-fs (xvda1): mounted filesystem with writeback data mode
[ 0.404170] VFS: Mounted root (ext3 filesystem) readonly on device 202:1.
[ 0.404685] Freeing unused kernel memory: 656k freed
[ 0.405137] Write protecting the kernel read-only data: 10240k
[ 0.413796] Freeing unused kernel memory: 412k freed
[ 0.414946] Freeing unused kernel memory: 1076k freed
[ 1.079487] cat used greatest stack depth: 3952 bytes left
[ 1.088903] init-early.sh used greatest stack depth: 3680 bytes left
[ 2.153589] rc[880]: segfault at 0 ip 000000000040c928 sp 00007fff800711b0 error 4 in rc[400000+1c000]



J'ai cherché sur le net mais je n'ai rien trouvé. Auriez vous une idée pour résoudre ceci ?

Merci


Last edited by floc_12 on Sat Feb 11, 2012 10:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Sat Feb 11, 2012 10:26 pm    Post subject: Reply with quote

C'est bon, j'ai trouvé la réponse avec ce tuto : http://forums-web1.gentoo.org/viewtopic-t-885730-start-0.htm

Mercil
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum