Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wicd network connection does not work after kernel upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
wolfclaw
n00b
n00b


Joined: 14 Mar 2007
Posts: 31

PostPosted: Thu Dec 29, 2011 6:43 pm    Post subject: Wicd network connection does not work after kernel upgrade Reply with quote

Hi,

2 - 3 weeks ago I upgraded my kernel from version 3.0.7 to 3.1.1 using the oldconfig method as descriped in the kernel upgrade guide. Besides I also executed a world update. After I restarted my machine, no network connection could be provided any longer. I am using wicd for my network connections and I am still able to connect from my windows partition, thus I am relatively sure that the newtork card is no issue.

Below I paste the wicd log with debug mode enabled. Maybe also imported, both eth0 and wlan0 do not work:

Code:

2011/12/29 20:13:30 :: ---------------------------
2011/12/29 20:13:30 :: wicd initializing...
2011/12/29 20:13:30 :: ---------------------------
2011/12/29 20:13:30 :: wicd is version 1.7.1b2 565
2011/12/29 20:13:30 :: setting backend to external
2011/12/29 20:13:30 :: trying to load backend external
2011/12/29 20:13:30 :: successfully loaded backend external
2011/12/29 20:13:30 :: WARNING: No path found for dhclient
2011/12/29 20:13:30 :: WARNING: No path found for dhcpcd-bin
2011/12/29 20:13:30 :: WARNING: No path found for pump
2011/12/29 20:13:30 :: WARNING: No path found for udhcpc
2011/12/29 20:13:30 :: WARNING: No path found for ethtool
2011/12/29 20:13:30 :: WARNING: No path found for kdesu
2011/12/29 20:13:30 :: WARNING: No path found for ktsuss
2011/12/29 20:13:30 :: WARNING: No path found for ip
2011/12/29 20:13:30 :: WARNING: No path found for resolvconf
2011/12/29 20:13:30 :: trying to load backend external
2011/12/29 20:13:30 :: successfully loaded backend external
2011/12/29 20:13:30 :: WARNING: No path found for dhclient
2011/12/29 20:13:30 :: WARNING: No path found for dhcpcd-bin
2011/12/29 20:13:30 :: WARNING: No path found for pump
2011/12/29 20:13:30 :: WARNING: No path found for udhcpc
2011/12/29 20:13:30 :: WARNING: No path found for ethtool
2011/12/29 20:13:30 :: WARNING: No path found for kdesu
2011/12/29 20:13:30 :: WARNING: No path found for ktsuss
2011/12/29 20:13:30 :: WARNING: No path found for ip
2011/12/29 20:13:30 :: WARNING: No path found for resolvconf
2011/12/29 20:13:30 :: Automatically detected wireless interface wlan0
2011/12/29 20:13:30 :: setting wireless interface wlan0
2011/12/29 20:13:30 :: automatically detected wired interface eth0
2011/12/29 20:13:30 :: setting wired interface eth0
2011/12/29 20:13:30 :: setting wpa driver wext
2011/12/29 20:13:30 :: setting use global dns to False
2011/12/29 20:13:30 :: setting global dns
2011/12/29 20:13:30 :: global dns servers are None None None
2011/12/29 20:13:30 :: domain is None
2011/12/29 20:13:30 :: search domain is None
2011/12/29 20:13:30 :: setting automatically reconnect when connection drops True
2011/12/29 20:13:30 :: found wired_connect_mode in configuration 1
2011/12/29 20:13:31 :: found should_verify_ap in configuration 0
2011/12/29 20:13:31 :: Setting dhcp client to 0
2011/12/29 20:13:31 :: Wireless configuration file found...
2011/12/29 20:13:31 :: Wired configuration file found...
2011/12/29 20:13:31 :: chmoding configuration files 0600...
2011/12/29 20:13:31 :: chowning configuration files root:root...
2011/12/29 20:13:31 :: Using wireless interface...wlan0
2011/12/29 20:13:31 :: Using wired interface...eth0
2011/12/29 20:13:31 :: scanning start
2011/12/29 20:13:31 :: ifconfig wlan0 up
2011/12/29 20:13:31 :: iwlist wlan0 scan
2011/12/29 20:13:32 :: scanning done
2011/12/29 20:13:32 :: found 2 networks:
2011/12/29 20:13:32 :: found afterscript in configuration None
2011/12/29 20:13:32 :: found dhcphostname in configuration shakuras
2011/12/29 20:13:32 :: found ip in configuration None
2011/12/29 20:13:32 :: found use_dhcphostname in configuration 0
2011/12/29 20:13:32 :: found dns_domain in configuration None
2011/12/29 20:13:32 :: found gateway in configuration None
2011/12/29 20:13:32 :: found use_global_dns in configuration False
2011/12/29 20:13:32 :: found postdisconnectscript in configuration None
2011/12/29 20:13:32 :: found beforescript in configuration None
2011/12/29 20:13:32 :: found psk in configuration 39eee86f396c6f1f94bed4ce2ca10d0822e3aba953f7d58d5ed5625fc4ef719c
2011/12/29 20:13:32 :: found netmask in configuration None
2011/12/29 20:13:32 :: found key in configuration XXX_PASSWORD_XXX
2011/12/29 20:13:32 :: found usedhcphostname in configuration False
2011/12/29 20:13:32 :: found predisconnectscript in configuration None
2011/12/29 20:13:32 :: found enctype in configuration wpa
2011/12/29 20:13:32 :: found dns3 in configuration None
2011/12/29 20:13:32 :: found dns2 in configuration None
2011/12/29 20:13:32 :: found dns1 in configuration None
2011/12/29 20:13:32 :: found use_settings_globally in configuration False
2011/12/29 20:13:32 :: found use_static_dns in configuration False
2011/12/29 20:13:32 :: found automatic in configuration True
2011/12/29 20:13:32 :: found search_domain in configuration None
2011/12/29 20:13:32 :: found afterscript in configuration None
2011/12/29 20:13:32 :: found dhcphostname in configuration shakuras
2011/12/29 20:13:32 :: found postdisconnectscript in configuration None
2011/12/29 20:13:32 :: found use_dhcphostname in configuration 0
2011/12/29 20:13:32 :: found dns_domain in configuration None
2011/12/29 20:13:32 :: found gateway in configuration None
2011/12/29 20:13:32 :: found use_global_dns in configuration False
2011/12/29 20:13:32 :: found ip in configuration None
2011/12/29 20:13:32 :: found beforescript in configuration None
2011/12/29 20:13:32 :: found psk in configuration 52fdb98c98819b4839254c8fcd02306e14172946b77ddfbf5eefe8813ce827d1
2011/12/29 20:13:32 :: found netmask in configuration None
2011/12/29 20:13:32 :: found key in configuration XXX_PASSWORD_XXX
2011/12/29 20:13:32 :: found usedhcphostname in configuration False
2011/12/29 20:13:32 :: found predisconnectscript in configuration None
2011/12/29 20:13:32 :: found enctype in configuration wpa
2011/12/29 20:13:32 :: found dns3 in configuration None
2011/12/29 20:13:32 :: found dns2 in configuration None
2011/12/29 20:13:32 :: found dns1 in configuration None
2011/12/29 20:13:32 :: found use_settings_globally in configuration False
2011/12/29 20:13:32 :: found use_static_dns in configuration False
2011/12/29 20:13:32 :: found automatic in configuration False
2011/12/29 20:13:32 :: found search_domain in configuration None
2011/12/29 20:13:36 :: ifconfig eth0
2011/12/29 20:13:36 :: ifconfig wlan0
2011/12/29 20:13:36 :: iwconfig wlan0
2011/12/29 20:13:36 :: GetCurrentNetworkID: Returning -1, current network not found
2011/12/29 20:13:36 :: Autoconnecting...
2011/12/29 20:13:36 :: ifconfig eth0 up
2011/12/29 20:13:38 :: Starting wireless autoconnect...
2011/12/29 20:13:38 :: No wired connection present, attempting to autoconnect to wireless network
2011/12/29 20:13:38 :: scanning start
2011/12/29 20:13:38 :: ifconfig wlan0 up
2011/12/29 20:13:38 :: iwlist wlan0 scan
2011/12/29 20:13:39 :: scanning done
2011/12/29 20:13:39 :: found 2 networks:
2011/12/29 20:13:39 :: found afterscript in configuration None
2011/12/29 20:13:39 :: found dhcphostname in configuration shakuras
2011/12/29 20:13:39 :: found postdisconnectscript in configuration None
2011/12/29 20:13:39 :: found use_dhcphostname in configuration 0
2011/12/29 20:13:39 :: found dns_domain in configuration None
2011/12/29 20:13:39 :: found gateway in configuration None
2011/12/29 20:13:39 :: found use_global_dns in configuration False
2011/12/29 20:13:39 :: found ip in configuration None
2011/12/29 20:13:39 :: found beforescript in configuration None
2011/12/29 20:13:39 :: found psk in configuration 52fdb98c98819b4839254c8fcd02306e14172946b77ddfbf5eefe8813ce827d1
2011/12/29 20:13:39 :: found netmask in configuration None
2011/12/29 20:13:39 :: found key in configuration XXX_PASSWORD_XXX
2011/12/29 20:13:39 :: found usedhcphostname in configuration False
2011/12/29 20:13:39 :: found predisconnectscript in configuration None
2011/12/29 20:13:39 :: found enctype in configuration wpa
2011/12/29 20:13:39 :: found dns3 in configuration None
2011/12/29 20:13:39 :: found dns2 in configuration None
2011/12/29 20:13:39 :: found dns1 in configuration None
2011/12/29 20:13:39 :: found use_settings_globally in configuration False
2011/12/29 20:13:39 :: found use_static_dns in configuration False
2011/12/29 20:13:39 :: found automatic in configuration False
2011/12/29 20:13:39 :: found search_domain in configuration None
2011/12/29 20:13:39 :: found afterscript in configuration None
2011/12/29 20:13:39 :: found dhcphostname in configuration shakuras
2011/12/29 20:13:39 :: found ip in configuration None
2011/12/29 20:13:39 :: found use_dhcphostname in configuration 0
2011/12/29 20:13:39 :: found dns_domain in configuration None
2011/12/29 20:13:39 :: found gateway in configuration None
2011/12/29 20:13:39 :: found use_global_dns in configuration False
2011/12/29 20:13:39 :: found postdisconnectscript in configuration None
2011/12/29 20:13:39 :: found beforescript in configuration None
2011/12/29 20:13:39 :: found psk in configuration 39eee86f396c6f1f94bed4ce2ca10d0822e3aba953f7d58d5ed5625fc4ef719c
2011/12/29 20:13:39 :: found netmask in configuration None
2011/12/29 20:13:39 :: found key in configuration XXX_PASSWORD_XXX
2011/12/29 20:13:39 :: found usedhcphostname in configuration False
2011/12/29 20:13:39 :: found predisconnectscript in configuration None
2011/12/29 20:13:39 :: found enctype in configuration wpa
2011/12/29 20:13:39 :: found dns3 in configuration None
2011/12/29 20:13:39 :: found dns2 in configuration None
2011/12/29 20:13:39 :: found dns1 in configuration None
2011/12/29 20:13:39 :: found use_settings_globally in configuration False
2011/12/29 20:13:39 :: found use_static_dns in configuration False
2011/12/29 20:13:39 :: found automatic in configuration True
2011/12/29 20:13:39 :: found search_domain in configuration None
2011/12/29 20:13:39 :: BUERO has profile
2011/12/29 20:13:39 :: WOHUNG has profile
2011/12/29 20:13:39 :: trying to automatically connect to...WOHUNG
2011/12/29 20:13:39 :: Connecting to wireless network WOHUNG
2011/12/29 20:13:39 :: iwconfig wlan0
2011/12/29 20:13:39 :: /sbin/dhcpcd -k wlan0
2011/12/29 20:13:39 :: ifconfig wlan0 0.0.0.0
2011/12/29 20:13:39 :: /sbin/route del dev wlan0
2011/12/29 20:13:39 :: ifconfig wlan0 down
2011/12/29 20:13:39 :: ifconfig wlan0 up
2011/12/29 20:13:40 :: wpa_cli -i wlan0 terminate
2011/12/29 20:13:40 :: /sbin/dhcpcd -k eth0
2011/12/29 20:13:40 :: ifconfig eth0 0.0.0.0
2011/12/29 20:13:40 :: /sbin/route del dev eth0
2011/12/29 20:13:40 :: ifconfig eth0 down
2011/12/29 20:13:40 :: ifconfig eth0 up
2011/12/29 20:13:40 :: Putting interface down
2011/12/29 20:13:40 :: ifconfig wlan0 down
2011/12/29 20:13:40 :: Releasing DHCP leases...
2011/12/29 20:13:40 :: /sbin/dhcpcd -k wlan0
2011/12/29 20:13:40 :: Setting false IP...
2011/12/29 20:13:40 :: ifconfig wlan0 0.0.0.0
2011/12/29 20:13:40 :: Stopping wpa_supplicant
2011/12/29 20:13:40 :: wpa_cli -i wlan0 terminate
2011/12/29 20:13:40 :: Flushing the routing table...
2011/12/29 20:13:40 :: /sbin/route del dev wlan0
2011/12/29 20:13:40 :: iwconfig wlan0 mode managed
2011/12/29 20:13:40 :: Putting interface up...
2011/12/29 20:13:40 :: ifconfig wlan0 up
2011/12/29 20:13:42 :: enctype is wpa
2011/12/29 20:13:42 :: Generating psk...
2011/12/29 20:13:42 :: ['/usr/bin/wpa_passphrase', 'WOHUNG', 'XXX_PASSWORD_XXX']
2011/12/29 20:13:42 :: Attempting to authenticate...
2011/12/29 20:13:42 :: ['wpa_supplicant', '-B', '-i', 'wlan0', '-c', '/var/lib/wicd/configurations/004f622c9f48', '-D', 'wext']
2011/12/29 20:13:42 :: ['iwconfig', 'wlan0', 'essid', '--', 'WOHUNG']
2011/12/29 20:13:42 :: iwconfig wlan0 channel 11
2011/12/29 20:13:42 :: iwconfig wlan0 ap 00:4F:62:2C:9F:48
2011/12/29 20:13:42 :: WPA_CLI RESULT IS DISCONNECTED
2011/12/29 20:13:43 :: WPA_CLI RESULT IS DISCONNECTED
2011/12/29 20:13:44 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:45 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:46 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:46 :: iwconfig wlan0
2011/12/29 20:13:47 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:48 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:49 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:50 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:51 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:51 :: iwconfig wlan0
2011/12/29 20:13:52 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:53 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:54 :: WPA_CLI RESULT IS ASSOCIATING
2011/12/29 20:13:55 :: WPA_CLI RESULT IS COMPLETED
2011/12/29 20:13:55 :: Running DHCP with hostname shakuras
2011/12/29 20:13:55 :: /sbin/dhcpcd wlan0 -h shakuras
2011/12/29 20:13:55 :: dhcpcd[2367]: version 5.2.12 starting
2011/12/29 20:13:55 ::
2011/12/29 20:13:55 :: dhcpcd[2367]: wlan0: broadcasting for a lease
2011/12/29 20:13:55 ::
2011/12/29 20:13:56 :: dhcpcd[2367]: wlan0: offered 192.168.123.112 from 192.168.123.254 `ÿ'
2011/12/29 20:13:56 ::
2011/12/29 20:13:56 :: dhcpcd[2367]: wlan0: acknowledged 192.168.123.112 from 192.168.123.254 `ÿ'
2011/12/29 20:13:56 ::
2011/12/29 20:13:56 :: dhcpcd[2367]: wlan0: checking for 192.168.123.112
2011/12/29 20:13:56 ::
2011/12/29 20:13:56 :: iwconfig wlan0
2011/12/29 20:14:00 :: dhcpcd[2367]: wlan0: leased 192.168.123.112 for 7200 seconds
2011/12/29 20:14:00 ::
2011/12/29 20:14:01 :: dhcpcd[2381]: wlan0: wlan0: MTU set to 576
2011/12/29 20:14:01 ::
2011/12/29 20:14:01 :: dhcpcd[2367]: forked to background, child pid 2400
2011/12/29 20:14:01 ::
2011/12/29 20:14:01 ::
2011/12/29 20:14:01 :: DHCP connection successful
2011/12/29 20:14:01 :: not verifying
2011/12/29 20:14:01 :: Connecting thread exiting.
2011/12/29 20:14:01 :: ifconfig wlan0
2011/12/29 20:14:01 :: IP Address is: None
2011/12/29 20:14:01 :: Sending connection attempt result Success
2011/12/29 20:14:01 :: ifconfig eth0
2011/12/29 20:14:01 :: iwconfig wlan0
2011/12/29 20:14:01 :: Autoconnecting...
2011/12/29 20:14:01 :: Starting wireless autoconnect...
2011/12/29 20:14:01 :: No wired connection present, attempting to autoconnect to wireless network
2011/12/29 20:14:01 :: scanning start
2011/12/29 20:14:01 :: ifconfig wlan0 up
2011/12/29 20:14:01 :: iwlist wlan0 scan


Any hint is highly appreciated! Thanks in advance!

Greetings
Back to top
View user's profile Send private message
wolfclaw
n00b
n00b


Joined: 14 Mar 2007
Posts: 31

PostPosted: Mon Jan 02, 2012 9:35 am    Post subject: Reply with quote

No ideas? :-(
Back to top
View user's profile Send private message
Joseph K.
Guru
Guru


Joined: 07 Jun 2006
Posts: 422
Location: Sydney, Australia

PostPosted: Thu Feb 09, 2012 5:34 am    Post subject: Reply with quote

Try booting the 3.0.7 kernel again and see where the logs differ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum