Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[libxaw3d, font] Segmentation fault avec xfig et gv (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Wed Feb 08, 2012 11:23 am    Post subject: [libxaw3d, font] Segmentation fault avec xfig et gv (résolu) Reply with quote

Bonjour,

J'ai un problème de segfault sur deux programmes gv et xfig (peut êter plus). Quand je les lance, j'obtiens les erreurs suivantes:

Code:

$ xfig
Warning: Cannot convert string "7x13bold" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Segmentation fault


Code:

$ /usr/bin/gv
Warning: Cannot convert string "-*-Helvetica-Medium-R-Normal--*-140-*-*-P-*-ISO8859-1" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Segmentation fault


Dans mon dmesg, j'ai les lignes suivantes:
Code:

$ dmesg | tail
xfig[3958]: segfault at 8 ip 00007fb80320c648 sp 00007fff421f3c10 error 4 in libXaw3d.so.8.0[7fb8031f5000+50000]
gv[4271]: segfault at 8 ip 00007fa2bb28a74e sp 00007fff34b391a0 error 4 in libXaw3d.so.8.0[7fa2bb26e000+50000]



Un coup de gdb me donne le résultat suivant:
Code:

$ gdb xfig
GNU gdb (Gentoo 7.3.1 p2) 7.3.1
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/xfig...Reading symbols from /usr/lib64/debug/usr/bin/xfig.debug...done.
done.
(gdb) run
Starting program: /usr/bin/xfig
Warning: Cannot convert string "7x13bold" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font

Program received signal SIGSEGV, Segmentation fault.
GetGC (sink=0x865ea0) at AsciiSink.c:494
494     AsciiSink.c: No such file or directory.
        in AsciiSink.c


Est ce que quelqu'un a une idée pour résoudre le problème. Merci d'avance.

Bonne journée.

[tahiry]


Last edited by tahiry on Thu Feb 16, 2012 11:20 am; edited 1 time in total
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Wed Feb 08, 2012 12:53 pm    Post subject: Reply with quote

Je connais pas la libXaw3d, mais peut-être qu'un revdep-rebuild amènera à se recompilation…
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Wed Feb 08, 2012 3:31 pm    Post subject: Reply with quote

Non, ce n'est pas ça. Merci pour la réponse en tout cas.

Code:

$ revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 100% ]                 

 * Dynamic linking on your system is consistent... All done.


Bonne après midi.

[tahiry]
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8070
Location: ~Brussels - Belgique

PostPosted: Wed Feb 08, 2012 7:45 pm    Post subject: Reply with quote

Bonjour,

Quelles fontes as-tu activées ?
Code:
eselect fontconfig list

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Wed Feb 15, 2012 12:05 pm    Post subject: Reply with quote

XavierMiller wrote:
Bonjour,

Quelles fontes as-tu activées ?
Code:
eselect fontconfig list


Code:

$ eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf *
  [3]   10-sub-pixel-bgr.conf *
  [4]   10-sub-pixel-rgb.conf *
  [5]   10-sub-pixel-vbgr.conf *
  [6]   10-sub-pixel-vrgb.conf *
  [7]   10-unhinted.conf *
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans-mono.conf *
  [10]  20-unhint-small-dejavu-sans.conf *
  [11]  20-unhint-small-dejavu-serif.conf *
  [12]  20-unhint-small-vera.conf *
  [13]  25-unhint-nonlatin.conf *
  [14]  30-metric-aliases.conf *
  [15]  30-urw-aliases.conf *
  [16]  40-nonlatin.conf *
  [17]  42-luxi-mono.conf *
  [18]  45-latin.conf *
  [19]  49-sansserif.conf *
  [20]  50-user.conf *
  [21]  51-local.conf *
  [22]  57-dejavu-sans-mono.conf *
  [23]  57-dejavu-sans.conf *
  [24]  57-dejavu-serif.conf *
  [25]  60-latin.conf *
  [26]  60-liberation.conf *
  [27]  65-fonts-persian.conf *
  [28]  65-khmer.conf *
  [29]  65-nonlatin.conf *
  [30]  69-unifont.conf *
  [31]  70-no-bitmaps.conf *
  [32]  70-yes-bitmaps.conf *
  [33]  80-delicious.conf *
  [34]  90-synthetic.conf *
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8070
Location: ~Brussels - Belgique

PostPosted: Wed Feb 15, 2012 8:18 pm    Post subject: Reply with quote

Salut,

Jette un oeil là : https://forums.gentoo.org/viewtopic-t-813945.html
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Thu Feb 16, 2012 9:05 am    Post subject: Reply with quote

La solution proposée ne résoud pas le problème, mais je pense que le meme problème a été soulevé à la fin du post.

En tout cas, merci pour le lien.

[tahiry]
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Thu Feb 16, 2012 11:20 am    Post subject: Reply with quote

Bonjour,

En suivant les instructions de différents postes dont: https://forums.gentoo.org/viewtopic-t-739586.html

Je me suis aperçu que toutes les lignes de /etc/local.gen étaient commentées. Je ne sais pas exactement ce qui a résolu le problème du coup mais je pense que c'est un peu de tout.

Encore merci.

[tahiry]
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8070
Location: ~Brussels - Belgique

PostPosted: Thu Feb 16, 2012 1:05 pm    Post subject: Reply with quote

Oh, je n'y aurais même pas pensé !

Je suis content que tu aies pu trouver.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum