Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema ad emerge qt 4.8
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Meconiotronic
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2007
Posts: 99

PostPosted: Sat Feb 04, 2012 12:50 pm    Post subject: Problema ad emerge qt 4.8 Reply with quote

Eccomi qua a postare dopo ogni aggiornamento delle QT

Ogni volta mi si presentano problemi simili che non ho capito bene come risolvere:




Total: 28 packages (12 upgrades, 15 new, 1 in new slot), Size of downloads: 258,802 kB
Conflict: 18 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

(x11-libs/qt-script-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-script-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)

(x11-libs/qt-script-4.8.0::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-script-4.8.0[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

x11-libs/qt-core:4

(x11-libs/qt-core-4.8.0-r1::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-core-4.8.0[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-script-4.8.0::gentoo, ebuild scheduled for merge)
(and 9 more with the same problem)

(x11-libs/qt-core-4.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-core-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)
<x11-libs/qt-core-4.8.0 required by (kde-base/kstyles-4.7.4::gentoo, installed)
(and 4 more with the same problems)

x11-libs/qt-sql:4

(x11-libs/qt-sql-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-sql-4.7.4[aqua=,debug=,qt3support] required by (x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge)

(x11-libs/qt-sql-4.8.0::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-sql-4.8.0[aqua=,c++0x=,qpa=,debug=,qt3support=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

x11-libs/qt-dbus:4

(x11-libs/qt-dbus-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-dbus-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)

(x11-libs/qt-dbus-4.8.0::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-dbus-4.8.0[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-webkit-4.8.0::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

x11-libs/qt-gui:4

(x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge) pulled in by
<x11-libs/qt-gui-4.8.0 required by (kde-base/kstyles-4.7.4::gentoo, installed)
~x11-libs/qt-gui-4.7.4[aqua=,glib=,qt3support] required by (x11-libs/qt-core-4.7.4-r1::gentoo, ebuild scheduled for merge)
(and 1 more with the same problems)

(x11-libs/qt-gui-4.8.0-r1::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-gui-4.8.0[accessibility=,aqua=,c++0x=,qpa=,debug=,qt3support=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
(and 5 more with the same problem)

x11-libs/qt-qt3support:4

(x11-libs/qt-qt3support-4.8.0::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-qt3support-4.8.0[accessibility=,aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-declarative-4.8.0-r1::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(x11-libs/qt-qt3support-4.7.4::gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-qt3support-4.7.4[aqua=,debug=] required by (x11-libs/qt-gui-4.7.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



Ho rimosso tutte le vecchie ma continua a protestare, le ho smascherate, e fatto altre prove ma l'update mi conflitta sempre.

Mi serve una mano per favore.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Feb 04, 2012 1:15 pm    Post subject: Reply with quote

Usi kde? non vorrei sbagliare, ma dovresti smascherare anche kde-4.8.0.

Nel caso contrario, usa l'opzione -t e vedi chi continua a volere qt-4.7.4
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum